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Phoenix Architecture
Phoenix is based on a modular framework, which results in a flexible and robust application platform 
for future expansion, promotes interchangeability between major and minor system components, and 
permits development of new, specialized tools through the use of the Phoenix API (Application Pro-
gramming Interface). Contact Certara Support for information on contracting with Certara to use the 
API.

This type of architecture is called a plug-in architecture because you can add and remove plug-ins 
(referred to in Phoenix as operational objects) without affecting the core application. The Phoenix 
core application itself does not carry out any useful analytic tasks. It requires operational objects in 
order to perform any meaningful analysis. Each object provides a specific function. Descriptive statis-
tics, noncompartmental analysis, and linear mixed effects modeling are all operational objects created 
for use with the Phoenix platform. 

Phoenix allows you to work in an MDI (Multiple Document Interface) or an SDI (Single Document 
Interface) environment. Workflows, operational objects, and datasets can be opened in their own win-
dow separate from the main Phoenix interface, or you can choose to work completely within the 
Phoenix user interface.

When using Phoenix, you will create projects that consist of one or more workflows of connected 
operational objects. For details on these concepts see:

Projects
Phoenix workflows
Workflow template
Operational objects
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Projects
A Phoenix project is the workspace in which workflows, operational objects, and worksheets are com-
bined to perform an analysis. Phoenix projects contain the following items:

– Data folder for worksheets and other datasets
– Code folder for PML, ASCII, and NONMEM code
– Tables folder for HTML formatted tables
– BQL Rules folder for BQL rules
– Documents folder for binary objects not placed in the other folders
– Shortcuts for pointers to input data files that were imported as shortcuts
– Workflow object that is used to group operational objects

Two of the benefits of Phoenix projects is that they allow analysis work to be easily organized and 
saved. You can save projects as Phoenix project files (*.phxproj) locally or save them to a database, 
such as Integral. 

Phoenix projects are designed to be easily updated and shared, which allows for better data manage-
ment. A project file contains all the datasets, such as study data, that were imported into a project so 
project files can be exchanged between users without also having to exchange external data sources. 
Sharing Phoenix projects has two main advantages:

• multiple users can review the steps and processes used in an analysis
• the amount of time needed to validate the results of an analysis is decreased.

Phoenix project files might be rejected by some email servers since they are password protected, in 
which case the user will need to adjust permissions to allow the .phxproj files.

Phoenix does not automatically save projects. Users must choose to save the project. Phoenix 
also prompts users to save projects when the application is closed. By default, Phoenix project files 
are saved in your Documents folder in \Certara\Phoenix Projects.

Note: Certain operations in Phoenix may occasionally generate “out of memory” errors. Merging in large 
datasets, generating plots with a large number of pages or lattices, running covariate shotgun on 
an NLME model, and saving multiple projects on the close of Phoenix are some examples of 
cases where a user’s computer may not have enough free memory to complete the operation. 
Many times the error only results in the offending object not displaying properly, while the remain-
der of output is unaffected. 
To reduce the occurrence of memory errors while working with Phoenix: ensure that only the active 
Phoenix project is open; close any other applications that are open on the computer (email, web 
browsers, etc.); work with only relevant subsets of very large datasets so as not to carry around 
unused data in the workflow; create multiple plot or table objects to subset a large dataset. Of 
course, it is always a good working practice to save projects at regular intervals. 

See also:

Creating or opening a project
Closing a project
Saving a project
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For a brief, step-by-step example of using the Phoenix interface, see “Quick Tour of Phoenix”.

Creating or opening a project

To create a project in Phoenix

Click  (New Project icon) in the toolbar.

Or select File > New Project.

Or right-click an object in the Object Browser and select New > Project in the menu.

To open a saved Phoenix project
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Click  (Load Project icon) in the toolbar.

Or select the project from the bottom of the File menu, if it was one of the last five projects opened in 
Phoenix.

Or select File > Load Project, choose the project file (.phxproj) and click Open. 
(If the project file is in a different location, use the Load Project dialog to browse to the location. 

Or outside of Phoenix, double-click a Phoenix project file (.phxproj). 
By default, Phoenix project files are saved in your Documents folder in \Certara\Phoenix 
Projects.

Note: It is not recommended to open two conflicting projects since the re-serialization occasionally 
causes project corruption.

To restore a project from a backup file

Phoenix’s auto-backup feature was implemented to aid in recovering from corrupt projects. When 
saving a project, a backup project file (with an extension of .phxbackup) is created in the same 
directory as the project. This provides a recent “checkpoint” from which most of the work can be 
recovered in the event that a project becomes corrupt. Note that there is only one backup file 
maintained for a project, i.e., subsequent save operations overwrite the project’s backup file.

Right-click the <project_name>.phxbackup file in a file browser and select Properties.

On the General tab, change the extension from .phxbackup to .phxproj and the 
project_name (if the original project exists).and press OK. 

Press Yes in the confirmation popup to rename the file.

The backup file is saved as a project file and can be opened in Phoenix.
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Closing a project

Right-click the project in the Object Browser and select Close Project.

Or select File > Close Project.

Then, in the message dialog:

Click Yes to confirm that changes to the project should be saved and use the Save Project dialog 
to specify a directory and file name for the saved project. 

Or click No to not save changes. A warning message is displayed stating that all project changes 
will be lost if the project is not saved. Click Yes to close the project or No to keep it open.

Note: Should a Named User Server license become disconnected while there are still unsaved projects 
open, you must ensure that a license is retrieved before attempting to close Phoenix. Otherwise, 
there will be no ability to save the project, and all changes will be lost. 
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Saving a project

To save a project

Click  (Save Project icon) in the toolbar.

Or select File > Save Project.

Or type CTRL+S.

Or right-click a project in the Object Browser and select Save Project. 

If a project has not been previously saved, Phoenix displays the Save Project dialog.

Specify the directory in the Save Project dialog.

Specify a file name in the File name field.

Click Save to save the project.

To save a project under a new name

Select File > Save Project As.

Or right-click a project in the Object Browser and select Save Project As. 

Then, in the Save Project dialog, type a new file name in the File name field.

To save all open projects

Select File > Save All Projects.

If a project has not been previously saved, Phoenix displays the Save Project dialog. Type a new file 
name in the File name field.
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Phoenix workflows
There are two types of workflows: project and operational. The first type of workflow, the project 
workflow, refers to the series of steps needed to complete an analysis. This includes importing data, 
manipulating data, using model objects to analyze data, and saving or exporting the results. Project 
workflows contain the data, models, and other objects needed to complete an analysis, from data 
setup through reporting of results. 

The second type are “Operational objects”. The Workflow operational object is the root of all analysis 
work in Phoenix. It allows users to put together as many types of operational objects as needed to 
complete an analysis and, thereby, execute only a certain group of operational objects in a project. In 
a complex analysis that requires a large number of operational objects, Workflow objects provide a 
way of organizing various operational objects into larger, more complex functional units.

Workflow objects allow users to map data and code to operational objects in the workflow, and man-
age the flow of data between operational objects. Users can also access the Diagram tab through 
Workflow objects, which can be used to add operational objects, map data, and execute objects.

Figure 4-1. Root workflow with a locked sub-workflow

One or more Workflow objects can be inserted into a project like any other operational object. Multiple 
workflow objects can also be added to a project’s root Workflow object, with each subsequent Work-
flow object containing its own group of operational objects.

A Workflow operational object does not, itself, perform any sort of analysis. It is only used to group the 
other operational objects, such as NCA, NLME, or Convolution, that do perform the analyses. Once a 
Workflow object is set up with all of the objects required to complete a desired set of analysis opera-
tions, it can be saved as a template for later use (see “Workflow template” for more information).
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Locking and Unlocking a workflow
Locking a Workflow object protects it from modification, preserving the operational object settings and 
data flow between them.

To lock a workflow

Right-click the Workflow object or empty area in the Object Browser or Diagram and select Lock 
Workflow.

Then, in the Lock Workflow dialog, enter the password to be used to unlock the workflow (enter it a 
second time to confirm the password) and press Lock.

When a workflow is locked, a padlock  is added to the workflow icon. 

All unlocked objects within the workflow (and any nested workflows) will be locked with the same 
username/password. If any nested workflow is already locked, a message is displayed asking for con-
firmation to continue.

Note: Phoenix does not track passwords used to lock workflows. Therefore, if a password is forgotten, 
the workflow will need to be recreated.
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To unlock a workflow

Right-click a locked Workflow object or an empty area in the Object Browser or Diagram and select 
Unlock Workflow.

In the Unlock Workflow dialog, enter the password that was used to lock the workflow.

Use the Unlock Sub-Workflows checkbox to indicate if only the main workflow is to be unlocked 
(unchecked) or unlock all nested workflows as well (checked).

Press Unlock.

Note: Nested workflows within a locked workflow cannot be unlocked without first unlocking the outer 
workflow.

When a workflow is locked, it cannot be copied/pasted or saved as a template. However, an unlocked 
workflow that contains a nested, locked workflow can be copied/pasted or saved as a template (the 
password will still be required to unlock the nested workflow).

Locking a workflow also limits the functionality of operational objects within the workflow. The Setup, 
Verification, and Information tabs become unavailable, and the Options area becomes disabled. Add-
ing or removing operational objects from locked workflows is not allowed. New input data mappings 
are not allowed either; to re-use locked workflows, use Data Links and the Data Wizard to map data to 
the workflow before locking.
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Workflow template
A Workflow Template in Phoenix works like a template in Microsoft Word, it allows you to recreate the 
same steps over and over, and gives you a form or fields that can be used to automatically recreate a 
workflow to use with a new dataset.

Workflow Templates are .phxtmplt files that contain the specific configuration of each operational 
object in a workflow. Any pointers to results data are saved with the template (e.g., NCA Final Param-
eters worksheet), but not the original data input sources. (Note that older WinNonlin Template 
(*.wnlt) files can still be loaded into Phoenix, but are no longer created by Phoenix.)

Note: Workflow Template files do not contain any mappings or links to external data sources, which 
means templates do not have data mappings to external sources, or with any parameter settings 
in external scripts (e.g., scripts for connecting with third-party tools). This information must be 
remapped each time the template is used. The incorporation of Data Links in the workflow can 
streamline the process of connecting external data sources when a template is used.

By saving a workflow as a Workflow Template you can quickly reapply an analysis on new data. This 
allows a common analysis to be predefined for automated performance of repetitive analyses. Tem-
plates contain the specific configuration of each operational object in a workflow, but do not contain 
the original data input sources. 

Tip: Default templates can be shared with others by having an administrator set up the template pref-
erences file default_templates.binconfig, located in C:\Users\<user-
name>\AppData\Roaming\Certara\Phoenix\Configuration to point to a common 
location where the shared templates will be stored. Notifications can then be sent by the administrator 
with the configuration file, template files, and instructions on where to store the files. 

This section contains the following topics:

Saving and loading Workflow Templates
Workflows and Templates example

See also “Workflows and Templates example”.
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Saving and loading Workflow Templates
In situations where a particular workflow is commonly used, saving it as a Workflow Template allows 
you to simply load the template file rather than recreate the entire workflow every time. 

The default location for saved Workflow Templates is set through the Project Settings page of the 
Preferences dialog (Edit > Preferences, select General > Projects).

To save a workflow template

Select the Workflow object in the Object Browser or in the Diagram.

Click  (Save Workflow Template icon) in the Phoenix toolbar.

Or select File > Save Workflow Template in the Phoenix menu.

Or right-click the Workflow object or empty area in the Object Browser and select Save Workflow 
Template.

Or right-click an empty area in the Diagram and select Save Workflow Template.

In the Save Workflow Templates dialog, enter a name for the template file.

If you want to save the workflow’s history with the template file, uncheck the Clear History checkbox.

Click Save.
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To add a workflow template to the current workflow 

Select a project or any Workflow object in the Object Browser or in the Diagram:

Click  (Load Workflow Template icon) in the Phoenix toolbar.

Or select File > Load Workflow Template in the Phoenix menu.

Or right-click the Workflow object or empty area in the Object Browser and select Load Workflow 
Template.

Or right-click an empty area in the Diagram and select Load Workflow Template.

In the Load Workflow Templates dialog, select the template.

If desired, enter a suffix to append to the names of the imported objects.

Click Open.

Note: Workflow templates do not load internal worksheets with sort variables, since sorts usually indicate 
profile-specific data. Use an external worksheet or Data Links to optimize re-use of templates.
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Workflows and Templates example
The purpose of the example is to show Phoenix’s ability to create and reuse workflows. This example 
shows users how to create a workflow to perform an analysis, save the workflow as a template, and 
use the template to complete the same analysis using different data.

This example assumes that a drug company wants to create a generic form of a popular drug. The 
company wants to test two formulations of a compound in order to decide which formulation is closest 
in bioequivalence to the name brand drug. In this example users will create a workflow to test the first 
formulation, save the workflow as a template, and reuse the template to test the second formulation.

Data for this study were created using Certara’s Trial Simulator™.

The completed project (Templates.phxproj) is available for reference in …\Examples\Data 
and Plots.

Most Phoenix objects require the same basic steps for their use. However, there may be multiple 
paths to accomplishing a step (e.g., main menu, right-click menu, drag-and-drop, etc.). For simplicity, 
only one is listed here. 

Any object added to a project can be viewed in its own window by selecting the object in the Object 
Browser and double-clicking it or pressing ENTER. All instructions for setting up and executing an 
object are the same whether the object is viewed in its own window or in Phoenix’s viewing.

See also:

Phoenix workflows
Workflow template

Set up the workflow

A Workflow object is the part of the project that is used to contain and manage operational objects, 
similar to how the Data folder is used to contain and manage datasets.

Workflows can be set up to perform complex operational procedures using operational objects. A 
Workflow can be saved as a template file, which allows users to create complex operational proce-
dures once, and reuse and share them multiple times.

The advantage of a template is that it saves the configuration settings in each of the operational 
objects it contains. However, templates do not save mappings to external datasets. This means that a 
template can be created that can be easily reused with multiple datasets.

1. Create a project called Template.

2. Import the datasets.
From …\Examples\WinNonlin\Supporting files\, import:
GenericForm1.xls 
GenericForm2.xls 
Pococuranitol.xls 

3. Select the Has units row option for each worksheet (except the History worksheets), using the 
Right Arrow button to advance to the next preview screen.

4. Once you get to the last screen, click Finish.

Note: Datasets in XLS (Microsoft Excel Workbook) format are added to the Data folder as workbooks.

5. Rename the workflow as Parallel BE.
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Add Data Link objects

1. Drag the following worksheets from the Data folder to the display area:
Pococuranitol_data, Pococuranitol_dose, GenericForm1_data, and GenericForm1_dose.
This creates a Data Link object for each input dataset.

2. Execute the Parallel BE workflow object.

Later in the tutorial, you will switch the input datasets for two of the Data Link objects and then re-exe-
cute the workflow objects using the new datasets. Without the Data Link objects, you would have to 
redefine the input for each of the individual objects affected by the dataset change. 

Add BQL objects

BQL is an acronym for Below Quantifiable Limit. BQL rules are used to exclude values in a dataset 
that are too low to be useful in an analysis. See “BQL” for information.

1. Right-click the Parallel BE workflow object, select New > Data Management > BQL. 

2. Rename the BQL object as BQL Brand.

3. Insert a second BQL object named BQL Generic.

Create and map the BQL rule set

BQL rule sets are created and stored in the BQL Rules folder.

1. Right-click the BQL Rules folder, select New > Rule Set.

2. Type ERR under Nonnumeric Code.

3. Type 0 (zero) under Unconditional Substitution.

4. Check the Use When < LLOQ checkbox. 

5. In the Properties tab, check the Use Static LLOQ Value checkbox.

6. Type 0.01 in the LLOQ Value field.

7. Select the Parallel BE workflow in the Object Browser.

8. In the Diagram, for both BQL Brand and BQL Generic objects:


– Click the  button.
– Click the (+) symbol to expand Rule Sets.
– Drag the Rule Set from the BQL Rules folder to the BQL Rule Set input.
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Setup BQL objects

1. In the Diagram, expand Pococuranitol_data and the Results section.

2. Drag Data to BQL Brand > Inputs > Main. 
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3. Expand GenericForm1_data and the Results section.

4. Drag Data to BQL Generic > Inputs > Main.

5. Select the BQL Brand object in the Object Browser.

6. Map the data types in the Main Mappings panel as follows:
Subject to the Sort context.
Time to the Time context.
Concentration to the Concentration context.

Leave all other data types mapped to None.

7. In the Properties tab, type BrandConc_gt_0_01 as the Output Column Name.

8. Execute the object. 

9. Select the BQL Generic object.

10. Map the data types as follows:
Subject to the Sort context.
Time to the Time context.
Concentration to the Concentration context.

Leave all other data types mapped to None.

11. Type GenericConc_gt_0_01 as the Output Column Name.

12. Execute the object. 

Set up two Descriptive Statistics objects

1. Go to the Results tab of the BQL Brand object.

2. Right-click the Output worksheet, select Send To > Computation Tools > Descriptive Statis-
tics. 

A Descriptive Statistics object is inserted into the Parallel BE workflow. The columns in the Output 
worksheet are automatically mapped to the Descriptive Stat object’s Main Mappings panel. See 
“Descriptive Statistics” for more information.)

3. Rename the Descriptive Statistics object Descriptive Stats Brand.

4. Map the data types as follows:
Subject mapped to None.
Time to the Sort context.
BrandConc_gt_0_01 to the Summary context.

5. In the Options tab:
– Check the Confidence Intervals checkbox.
– Check the Number of SD Statistics checkbox.
Do not change the default value.

6. Execute the object. 

7. Go to the Results tab of the BQL Generic object.

8. Right-click the Output worksheet, select Send To > Computation Tools > Descriptive Statis-
tics. 

9. Rename the Descriptive Statistics object Descriptive Stats Generic. 
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10. Map the data types as follows:
Subject mapped to None.
Time to the Sort context.
GenericConc_gt_0_01 to the Summary context.

11. In the Options tab:
– Check the Confidence Intervals checkbox.
– Check the Number of SD Statistics checkbox.
Do not change the default value.

12. Execute the object. 

Plot the concentration values over time

In this example, XY Plot objects will be used to graphically look at the data. Refer to “Plotting” for 
information on other plot objects.

1. Go to the Results tab of the BQL Brand object.

2. Right-click the Output worksheet, select Send To > Plotting > XY Plot. 

3. Rename the XY Plot object XY Plot Brand vs Generic.

4. Map the data types as follows:
Subject to the Group context.
Time to the X context. 
BrandConc_gt_0_01 to the Y context. 

Add a second graph to the XY Plot object.

5. With Plot selected in the Options tab menu tree, click the Graphs tab.

6. Click Add.

A second XY Plot input named XY 1 Data is added to the Setup list.
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7. Map the Output worksheet from BQL Generic as input for the second graph:
   – Click the XY 1 Data object in the Setup panel.

   – In the XY 1 Data Mappings panel, click  (Select Source icon).
   – In the dialog, select the BQL Generic Output worksheet and click OK.

8. Map the data types as follows:
Subject to the Group context.
Time to the X context. 
GenericConc_gt_0_01 to the Y context.

9. Execute the object. 

Examine the output in the Results tab. The plot shows that the concentration values peak at different 
times for the two formulations. 

Plot the mean concentration values over time

1. Go to the Results tab of the Descriptive Stats Brand object.

2. Right-click the Statistics worksheet and select Send To > Plotting > XY Plot. 

3. Rename the XY Plot object XY Plot Mean Brand vs Generic.

4. Map the data types as follows:
Time to the X context.
Mean to the Y context.
SD to the Lower Error Bars and Upper Error Bars contexts.

Leave all other data types mapped to None.

Add a second graph to the XY Plot object.

5. With Plot selected in the Options tab menu tree, click the Graphs tab.

6. Click Add.

7. Click the XY 1 Data object in the Setup panel.

8. In the XY 1 Data Mappings panel, click the Select Source icon.

9. Select the Descriptive Stats Generic Statistics worksheet and click OK.

10. Map the data types as follows:
Time to the X context.
Mean to the Y context.
SD to the Lower Error Bars and Upper Error Bars contexts.

Leave all other data types mapped to None.

11. Execute the object.

The plot shows that the mean concentration values peak at very different times for the two formula-
tions.

The plot does not place the points close to the axes, it is hard to differentiate between the overlaid 
plots, and the plot does not have a title. Use the Options tab to change the X and Y axes ranges, 
change the plot colors, and add a title.

12. In the Options tab, select Plot and go to the Title tab.
– In the title field, type Brand and Generic Mean Concentration.
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13. Select Axes > X.
– In the Range area, select the Custom option button.
– Leave the Minimum field set to 0.
– In the Maximum field enter 60.

14. Select Axes > Y.
– In the Range area, select the Custom option button.
– In the Minimum field, enter 0.
– In the Maximum field enter 50.

15. Select Graphs > Mean vs Time (the first one in the list).
– In the Appearance tab, select Red from the Marker Color menu.
– In the Marker Border Color menu, select Red.
– In the Line Color menu, select Red.

The Descriptive Statistics Brand plot is now highlighted in red.

The plot is automatically updated to reflect the new axes ranges, plot colors, and the title. Note that 
the XY Plot object did not have to be re-executed.

Set up two noncompartmental analysis objects

Refer to “NCA” for more information on the NCA object.

1. Go to the Results tab for the BQL Brand object.

2. Right-click the Output worksheet, select Send To > NonCompartmental Analysis > NCA. 

3. Rename the NCA object NCA Brand. 

4. Map the data types as follows:
Subject to the Sort context.
Time to the Time context.
BrandConc_gt_0_01 to the Concentration context.
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In this example, one dose of 50 mg was administered at time zero. The Pococuranitol workbook has 
dosing data stored in the Pococuranitol_dose worksheet.

5. Select Dosing in the NCA Setup tab.

6. In the Mappings panel, click the Select Source icon.

7. Select the Pococuranitol_dose worksheet and click OK.

8. Map the data types as follows:
Subject to the Sort context. 
Dose to the Dose context. 
Time_of_Dose to the Time context.

9. Execute the object. 

10. Once the job finishes, go to the Results tab for the BQL Generic object.

11. Right-click the Output worksheet, select Send To > NonCompartmental Analysis > NCA. 

12. Rename the NCA object NCA Generic. 

13. Map the data types as follows:
Subject to the Sort context.
Time to the Time context.
GenericConc_gt_0_01 to the Concentration context.

In this example, one dose of 50 mg was administered at time zero. The GenericForm1 workbook has 
dosing data store in the GenericForm1_dose worksheet.

14. Select Dosing in the Setup tab.

15. In the Mappings panel, click the Select Source icon.

16. Select the GenericForm1_dose worksheet and click OK.

17. Map the data types as follows:
Subject to the Sort context.
Dose to the Dose context. 
Time_of_Dose to the Time context.

18. Execute the object.

Create the formulation dataset for the bioequivalence model

Combine the Final Parameters Pivoted worksheets from both NCA objects and use the combined out-
put in a bioequivalence model. The new column created by the Append Worksheets object will con-
tain the formulation information for the bioequivalence model.

1. Go to the Results tab for the NCA Brand object.

2. Right-click the Final Parameters Pivoted worksheet, select Send To > Data Management > 
Append Worksheets.

3. Map Subject, Cmax, and AUClast to the Source Column context.
Leave all other data types mapped to None. 

4. Click the Worksheet2 object in the Setup panel.

5. In the Worksheet 2 Mappings panel for the Append Worksheets object, click the Select Source 
icon.

6. Select NCA Generic Final Parameters Pivoted worksheet and click OK.
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7. Map Subject, Cmax, and AUClast to the Source Column context.
Leave all other data types mapped to None. 

8. Execute the object. 

Set up the first bioequivalence model

Refer to “Bioequivalence” for more information on the Bioequivalence object.

1. Right-click the Results worksheet for the Append Worksheets object, select Send To > Computa-
tion Tools > Bioequivalence.

2. Map the data types as follows:
Source to the Formulation context.
Subject mapped to None.
Cmax to the Dependent context.
AUClast to the Dependent context.

3. In the Model tab, select the Parallel/Other button.
This option sets the model to a parallel bioequivalence model.

Leave Reference Formulation set to NCA Brand.

4. Execute the object. 

Examine the output in the Results tab.

Create and add a template

The Parallel BE workflow looks like this:
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In Phoenix templates, any data mappings that are internal to the workflow are retained. For example, 
all expected output from the BQL objects, such as subject, time, and concentration, are retained in 
the NCA objects’ Main Mappings panel. Mappings that are external to the template, such as the BQL 
rules and the datasets used with the BQL objects are not retained.

1. Select the Parallel BE workflow.

2. Click  (Save Workflow Template icon) in the toolbar to save the workflow as a template.

3. In the dialog, enter the name as Parallel BE. 

4. Click Save.

The workflow is saved as a Workflow template file in the location set in the Preferences dialog (by 
default <default Project directory>/templates) and named Parallel BE.phxt-
mplt. 

5. Select Template in the Object Browser. 

6. Click  (Load Workflow Template icon) in the toolbar to load the template file. 

7. In the dialog, select Parallel BE.phxtmplt and click Open.

The template is added to the project as a second workflow. The second workflow is nested below the 
first one and named Parallel BE 1.

Note: All references to workflows and operational objects in this section of the example refer to the Par-
allel BE 1 workflow and the operational objects it contains.

Set up the objects in the template workflow

1. Map the rule sets for both BQL Brand and BQL Generic objects.
– In the Parallel BE 1 workflow object, expand the objects, if necessary.
– Drag Rule Set from the BQL Rules folder to the Rule Set input for both objects.

2. Drag the external data sources from the Data folder to the Data Link objects as follows:
GenericForm2_data to Inputs > Data for the GenericForm1_data object.
GenericForm2_dose to Inputs > Data for the GenericForm1_dose object.
Pococuranitol_data to Inputs > Data for the Pococuranitol_data object.
Pococuranitol_dose to Inputs > Data for the Pococuranitol_dose object.

3. Execute each object in the Parallel BE 1 workflow. 

4. Select the XY Plot Brand vs Generic object, select Output in the Results tab.

The plot shows that the concentration values peak at very different times in the two different study 
groups. The second generic formulation lasts longer and has much higher concentration values 
than the brand name formulation.

5. Select the XY Plot Mean Brand vs Generic object, select Output in the Results tab.

The plot shows that the mean concentration values peak at very different times in the two different 
study groups.

6. Examine the Bioequivalence output against the results from the first Bioequivalence object.

7. Right-click the project and select Close Project.

This concludes the Workflows and Templates example.



Operational objects

27

Operational objects
Phoenix analysis work is done using operational objects. An operational object contains a pointer to 
input data, a model, plot, or some other function, plus worksheet results, plot results, and text results. 
Examples of operational objects include data manipulation objects such as Column Transformation 
and Pivot Worksheet, models like Semicompartmental Modeling and PK Models, and plots like the XY 
Plot.

All operational objects can be inserted from the Insert menu, the Object toolbox, the Send To menu, 
and the workflow menu. They have user-defined settings and options that can be accessed in the 
Setup tab list and in the option tabs located beneath the Setup tab. Results in the form of worksheets, 
plots, and text, which are output from an executed operational object.

Operational objects use two types of data: external and internal.

An external data source for an operational object points to an imported dataset in the Data folder. 
The data is not contained in the object.

Internally generated data sources include worksheets created within Phoenix. These can be cre-
ated either by users or by executing an operational object to get output results (e.g., the Final 
Parameters worksheet from a model can be sent as input to a Descriptive Statistics object for fur-
ther analysis). These data are also not contained in the object.

This section contains information about the following topics:

Inserting operational objects
Using the Setup tab
Object settings
Renaming results
Using the Results tab

Inserting operational objects
Operational object menus in Phoenix are arranged by groups. There are several ways to insert an 
operational object, but the operational object menus are always grouped the same way. 

Insert an operational object in one of the following ways.

• Select a project or workflow in the Object Browser and then select the Insert > <Mouse Click> 
(object group) > (operational object) menu item.

• Select a workflow in the Object Browser. On the left side of the Diagram tab that is displayed, click 
the object button in the Object Toolbox.

• Right-click a workflow in the Object Browser and then select New > <Mouse Click> (object group) 
> (operational object) from the menu.
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• Right-click a data set in the Data folder or a results worksheet and then select Send To > <Mouse 
Click> (object group) > (operational object) from the menu.

The object is added to the project in the Object Browser and to the workflow Diagram tab. In addition, 
the inserted object is automatically opened in the right viewing panel. Each object’s default view is the 
Setup tab, which contains all the steps necessary to set up an object.

Note: Any object added to a project can be viewed in its own window by selecting the object in the 
Object Browser and double-clicking it or pressing the ENTER key. All instructions for setting up and 
executing an object are the same whether the object is viewed in its own window or in Phoenix’s 
viewing panel.

Plotting 

  Bar Plot ( )

  Box Plot ( )

  Column Plot ( )

  Histogram Plot ( )

  QQ Plot ( )

  Scatter Plot ( )

  XY Plot ( )

  X-Categorical XY Plot ( )

Computation Tools 

  Bioequivalence ( )

  Convolution ( )

  Crossover ( )

  Deconvolution ( )

  Descriptive Statistics ( )

  Linear Mixed Effects ( )

  Ratios and Differences ( )

NonCompartmental Analysis 

  NCA ( )

  NonParametric Superposition ( )

  Semicompartmental Modeling ( )

IVIVC 

  IVIVC ( )

  Levy Plot ( )

  Loo-Riegelman ( )

  Wagner-Nelson ( )
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Using the Setup tab
Every operational object has a Setup tab, which contains a list of items that must be specified before 
a model or other operational object can be executed. Each Setup tab has two common items: a panel 
used to map a dataset to an object’s input and a toolbar. Some operational objects contain an addi-
tional tab used to sort the input columns or the output columns. 

The following topics are discussed in this section:

Using the Setup tab toolbar
Entering data manually
Output Sort Order and Input Column Order tabs

Modeling 

  Maximum Likelihood Models ( )

  Maximum Likelihood Model Comparer ( )

  Least-Squares Regression Models interface 

      Dissolution Model ( )

      Indirect Response Model ( )

      Linear Model ( )

      Michaelis-Menten Model ( )

      PD Model ( )

      PK Model ( )

      PKPD Model ( )

      User ASCII Model ( )

Data Management 

  Append Worksheets ( )

  BQL ( )

  CDISC Data Preparer ( )

  Crossproduct Worksheets ( )

  Data Wizard ( )

  Enumerate Worksheets ( )

  Join Worksheets ( )

  Merge Worksheets ( )

  Pivot Worksheet ( )

  Rank Worksheet ( )

  Split Worksheet ( )

  Stacker ( )
Reporting 

  Reporter ( )

  Table ( )

External Software 

  NONMEM Shell ( )

  NONMEM Comparer ( )

  PsN Shell ( )

  R Shell ( )

  SAS Shell ( )

  SigmaPlot Shell ( )

System 

  Data Link ( )

  Workflow ( )
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Using the Setup tab toolbar
Each item in the Setup tab list contains a toolbar. The Setup tab toolbar allows users to select a data 
source, copy an internal worksheet to the Data folder, and view or delete the mapped data source.

Select source identifies an input data source for a Setup tab item.

Publish source copies an internal worksheet to the Data folder. (This button is only available for 
internal worksheets.) Displays the Select Object dialog. Select the Data folder or a worksheet in the 
Data folder in which to place the worksheet and click Select. Copying an internal worksheet to the 
Data folder converts the worksheet to an external source and automatically maps the column headers 
in the worksheet to the context associations.

Toggle source data panel displays the external source mapped to the Setup tab item. (This button is 
only available if a Setup tab list item has an external worksheet mapped to it.)

Remove source unmaps an external source worksheet from an operational object.

Load Object Settings displays the Load Object Settings dialog for selecting a saved settings file, in 
the default settings directory, to apply to the selected object.

Import Object Settings displays the Import Object Settings dialog for selecting a saved settings file, 
not in the default settings directory, to apply to the selected object.

Save Object Settings displays the Save Object Settings dialog for saving the current object settings 
to a file for later use.

The pull-down menu lists all of the saved settings files that are located in the default settings directory 
and pertain to the selected object type. Selecting one from the menu displays a confirmation dialog 
for applying the settings. Click Yes to load the settings.
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Entering data manually
Users do not have to use an external worksheet to provide input to operational objects. Internal work-
sheets can be used to enter the information necessary to set up an operational object.

Note: The primary data input for any operational object does not allow users to manually enter data.

1. Select an item in the Setup tab list other than the primary data input. 

2. Select the Use Internal Worksheet checkbox.

If the operational object uses sort keys, a dialog asks for the sort keys to use.

3. Check the boxes beside the sort keys to use and click OK.

4. Add the rows and columns of input data (refer to “Editing data values in worksheets”).
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Note: The Rebuild button in the mappings panel can be used to rebuild the worksheet, incorporating 
any changes that affect the contents of the worksheet.

When entering data manually into cells, there are a couple of features that can help with copying and 
moving values: “drag and fill” feature and “drag” feature.

To use the drag and fill feature to propagate values

1. Enter the value(s) to propagate.

2. Use the pointer to highlight those cells.

3. Place the pointer over the black square on the lower right side of the selection.
When the pointer changes shape, press the left mouse button and drag the selection down or 
across to fill the other cells.

In the image above, the same set of times when a dose is administered is being propagated to all 
subjects.
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To use the drag feature to move values

1. Enter the value(s).

2. Use the pointer to highlight the entire row(s). 

3. Place the pointer over the black square on the lower left side of the selection.
When the pointer changes shape, press the left mouse button to drag the selected row of values to 
the destination row.

Output Sort Order and Input Column Order tabs
Most operational objects have an Output Sort Order tab used to arrange results worksheets based on 
the sort keys mapped in the primary data input. The Output Sort Order tab is located beside the Map-
ping tab. 

1. Select the Output Sort Order tab.
Data types mapped to the object’s Sort context are listed.

2. Select a column name.

3. Click the Move Up or Move Down buttons to change the position of the columns.
Results worksheets are sorted based on the selections made in the Output Sort Order tab.

Plotting operational objects have an Input Column Order tab for sorting the input columns used to cre-
ate graphs. Users can select column headers mapped to different sorting contexts and specify how 
the points, bars, or lines are sorted in the output.
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1. Select the Input Column Order tab.

2. From the Context menu select the context to which the sort keys are mapped.
Plot objects have multiple sorting contexts, so the menu options are different for each plot object.

The data types mapped to the selected context are listed below the Context menu.

3. Select a sort key in the list, then use the > and < buttons to move it between lists. 
Use the >> and << buttons to move all sort keys between the lists.

4. Select a column name.

5. Click the Move Up or Move Down buttons to change the position of the columns.

Object settings
An Object Settings file contains all of the settings used with an operational object and has a .phx-
setting extension. The Object Settings file can be used to expedite future analysis of operational 
objects that are created to perform complex or specific functions. The file contains the specific config-
uration of an operational object, but does not contain the original data input sources. The configura-
tion in the file can be loaded into an operational object of the same type or it can be specified as the 
default configuration for that object type, so that the settings in the file are loaded when each new 
operational object of that type is added to a workflow. 

Note: Unlike other objects, the Data Wizard can contain many steps. Saving and loading object settings 
for Data Wizard objects includes settings for all steps, but input mappings for the first step only.



Operational objects

35

To save object settings

Once an object has the desired settings it can be saved to an Object Settings file. Settings files are 
saved to C:\Users\<username>\Documents\Certara\Phoenix Object Settings. 
See “To set object settings preferences for operational objects” for additional information.

1. With the object selected in the Object Browser, click  (Save Object Settings icon) in the 
Setup tab toolbar. Or right-click the object in the Object Browser or Diagram and select Save 
Object Settings.

2. In the dialog, enter a name for the file.

3. Check the Set as Default checkbox to use this settings file as the default settings when an object 
of the same type is inserted in Phoenix.

4. Click OK.
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To load object settings to an existing object

1. With the object selected, choose the settings file from the pull-down list in the Setup panel toolbar. 
Or right-click the object in the Object Browser or Diagram and select Load Object Settings.

Note: Selecting the No settings (system defaults) option ignores any user-specified settings and uses 
the Phoenix default settings.

2. In the dialog, select the settings file from the list available for the same operational object type.

3. Click OK.

A note about internal and external worksheet handling 

If an internal worksheet has one or more Sorts, then this indicates that the worksheet is data-specific 
and would not be applicable to other data, so it is not saved with the object settings. If there is no Sort 
in an internal worksheet (e.g., the same dosing or partial area was applied to all Sorts), then that inter-
nal worksheet is saved with the object settings and will be applied when those object settings are 
loaded. Thus, worksheets that do not allow for Sorts (e.g., NCA Parameter Names, NCA Units, and 
BQL Rules) will always be saved and loaded with object settings.
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External mapped worksheets have priority over internal worksheets. If an external worksheet is 
mapped as an auxiliary worksheet in an object (e.g., NCA Dosing worksheet) and the object settings 
that are loaded have an internal worksheet saved with them, the external worksheet and mappings 
will override.

To apply an imported object settings file

1. Click  (Import Object Settings icon) in the Setup toolbar or select File > Import.

2. In the file browser, navigate to and select the desired object settings file.
(The settings file must be for the same object type.)

3. In the dialog, enter a name for the settings file for use in Phoenix.

The settings are automatically loaded from the selected file and the settings file is managed by Phoe-
nix.
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To set object settings preferences for operational objects

1. Select Edit > Preferences. 

2. In the dialog, select Object Settings.

3. To specify the default settings for an operational object, select the object settings file to use as 
the default and click the Set Default button.

If only the default setting for an object is selected, the Set Default button will change to Clear 
Default. Clicking the Clear Default button returns to a state where none of the user-specified set-
tings are applied by default and the Phoenix default settings will be used for any new objects.

4. To delete object settings file(s) from the file system, select the file(s) and click Delete.

5. To import object settings file(s) that have been exported into the Settings directory, click Import or 
from the object’s Setup panel, click the Import icon in the toolbar (see “To load object settings to 
an existing object” for more information).

6. To export object settings file(s), select the file(s) and click Export. In the dialog, select the direc-
tory to which the files are to be exported and click OK.

Exported settings files can be shared with other users.

7. To rename object settings file(s), double-click the settings name and type the new name.
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Renaming results
Prior to the execution of an object, the name of the results worksheets, plots, and text files can be 
changed through the Diagram tab. 

1. Select the Workflow object to display the Diagram tab.

2. Click  to expand the desired object.

3. Click the (+) sign next to Results, Text Output, or Plots to expand the list of output items.

4. Right-click the item, and select Rename.

5. The name of the output item becomes editable and you can type in a new name.

Using the Results tab
The results of any operational object are located in the Results tab. There are four types of output cre-
ated by operational objects: 

Worksheets
Plots
Text files
Tables

Each type of output has its own set of options. 

The Results tab also contains a toolbar that allows users to group, save, and print the results.

Do not group lists the output alphabetically.
Group by type lists the output in grouped by type.
Group by executable lists the output grouped by operational object. Group by executable is only 
available in the workflow object’s Results tab.
Expand all results shows all results items in the list.
Collapse all results collapses results so only the group headings are visible.
Copy to Documents copies the selected item to the Data, Tables, or Documents folder.
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Export exports and saves the selected item.
Print sends the selected object to the printer.

An out-of-date result is shaded pink in the Object Browser. If the result is open in a separate window 
(by double-clicking the item in the Object Browser), the title bar will show “(Out of Date)” after the title. 
A result is considered out-of-date if some part of the operational object or its source data changes 
once the object is executed.

Worksheets
Result worksheets cannot be edited unless they are exported or copied to the Data folder. They are 
shaded gray to denote that they cannot be edited. 

To use a results worksheet as input

Right-click a worksheet in the Results tab and select Send To > (Object group) > (Operational 
object).

The operational object is added to the workflow and the result worksheet is mapped to it as the pri-
mary input data source. This is much simpler than exporting the worksheet or copying the worksheet 
to the Data folder.

To copy a result worksheet to the Data folder

Select the worksheet and click  (Copy to Data Folder icon) or right-click the worksheet and 
select Copy to Data Folder.

Note: When a Data Wizard result worksheet is copied to the Data folder, the History tab will also contain 
all of the history records from the source worksheet that was mapped into the Data Wizard. 

To save a worksheet

Select the worksheet and click  (Export icon) or right-click the worksheet and select Export.

In the dialog, select an export location and a file format and click Save.

To print a worksheet

Select the worksheet and click  (Print Results icon) or right-click the worksheet and select Print.

In the dialog, click OK to print the worksheet.

Plots
Result plots can be edited like any other plot object. Editing a plot does not mark an object as out-of-
date, because Phoenix automatically updates the object as the plot is edited.

To copy a plot to the Windows clipboard

Right-click the plot and select the image format to use when copying the plot to the clipboard: Copy 
high resolution image (vector) or Copy image (bitmap).
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To save a single plot to a file

Right-click the plot image and select Export.

In the dialog, select a location and a file type, then enter a name for the file.

In the Image Settings part of the dialog, make any changes to the size of the image and click Save. 

To export all plot images associated with a result plot

Select the result plot in the Results tab and click the Export icon.

In the dialog, select an export location and a file format, then click Save.

In the next dialog, make any changes to the size of the image and click OK. 

If there are multiple tabs of plots for the selected plot result, all of the plots in all of the tabs are 
exported as the selected file type. For example, if there are five tabs of plots in the results and the 
selected filetype is JPEG, five separate JPEG files are saved and named sequentially.

To print a plot

Select the plot and click the Print Results icon.

In the dialog, click Print to print the plot.

Text files
Result text files typically contain object settings and a plain text version of the worksheet output.

Note: Right-clicking a text file and using the Send To menu creates a new object, but does not map the 
text file to the object.

To copy a result text file to the Documents folder

Select the text file and click the Copy icon.

Or right-click the text file and select Copy to Documents.

To save a text file

Select the text file and click the Export icon.

Or right-click the text file and select Export.

Then, in the dialog, select an export location and a file format and click Save.

Note: For rtf file format, if the exported file contents do not appear to line up properly, change the font to 
Courier New 9pt.

To print a text file 

Select the text file and click the Print Results icon.

Or right-click the text file and select Print.

Then, in the dialog, click OK to print the text file.
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Tables

Note: Right-clicking a table and using the Send To menu creates a new object, but does not map the 
table to the object.

To copy a result table to the Tables folder

Select the table and click the Copy icon.

Or right-click the table and select Copy to Tables folder.

To save a table

Select the table and click the Export icon.

Or right-click the table and select Export.

Then, in the dialog, select an export location and click Save.

To print a table

Select the table and click the Print Results icon.

Or right-click the table and select Print.

Then, in the dialog, edit the page setup and click OK.

In the next dialog, click OK to print the table.
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Quick Tour of Phoenix
Using a number of the sample files provided with the Phoenix software, this tutorial introduces the 
steps to complete the following common tasks:

Start Phoenix and create a new project
Import a dataset
Create a plot
Create a table
Execute noncompartmental analysis
Perform pharmacokinetic modeling
Execute a bioequivalence model 

Most Phoenix objects require the same basic steps for their use. However, there may be multiple 
paths to accomplishing a step (e.g., main menu, right-click menu, drag-and-drop, etc.). For simplicity, 
only one is listed here. 

Note: Any object added to a project can be viewed in its own window by selecting the object in the Object 
Browser and double-clicking it or pressing ENTER. All instructions for setting up and executing an 
object are the same whether the object is viewed in its own window or in Phoenix’s viewing.

Start Phoenix and create a new project

1. Double-click the Phoenix icon ( ) on your desktop to start Phoenix.

2. Select File > New Project to create a new project. 
A new project is created in the Object Browser and is in edit mode for you to name. 

3. Name the new project by typing Quick Tour.

The left panel’s default view is the Object Browser, which contains the project, and the other folders 
and objects that are contained in the project. The right viewing panel’s default view is blank, unless 
one of the project folders or the workflow is selected. 

Import a dataset

The dataset Bguide1.dat will be used to test key Phoenix functions.

1. Select File > Import or click  (Import File icon).
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2. Navigate to <Phoenix_install_dir>\application\Examples\WinNonlin\Sup-
porting files.

3. Select the file Bguide1.dat and click Open.
The File Import Wizard is used to assign options for how the data are imported and presented.

No changes need to be made to the default options for this dataset.

4. Click Finish. 

The dataset is added to the project Data folder and the worksheet is displayed in the right viewing 
panel.
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Create a plot

1. Right-click Bguide1 in the Data folder and select Send To > Plotting > XY Plot from the menu.

An XY Plot object can also be added to a Workflow by selecting the Workflow object in the Object 
Browser and then selecting Insert > Plotting > XY Plot. Or by right-clicking the Workflow object, 
selecting New > Plotting > XY Plot, and then using the pointer to drag the Bguide1 worksheet 
from the Data folder to the XY Data Mappings panel.

The default view of an object is the Setup tab, which contains all the steps necessary to set up an 
object. 

2. Use the option buttons in the XY Data Mappings panel to map the data types to the contexts as fol-
lows:
Map Subject to the Group context.
Map Time to the X context.
Map Conc to the Y context.
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3. Click  (Execute icon) to execute the workflow. 

Now use the Bguide1 dataset to test the Table object and its summary statistics function.

Create a table

1. Right-click Bguide1 in the Data folder and select Send To > Reporting > Table.

2. In the Main Mappings panel, map the data types as follows:
Map Subject to the Stratification Row context.
Leave Time mapped to None.
Map Conc to the Data context.

3. In the Options tab below the Setup tab, select Table 1 - Column Summary by Row Stratification 
as the Table Type to use.



47

4. Check the Page Break on Row Stratification box.

5. Select the Statistics tab, which is also located below the Setup tab.

6. Click Select All to select all output statistics.

7. Execute the object.

The results are presented as three HTML tables in the Results tab. Compare the table for the DW 
subject in the Results tab to the table pictured below. 

Execute noncompartmental analysis

1. Select File > Load Project.

2. In the dialog, navigate to <Phoenix_install_dir>\application\Examples\Win-
Nonlin.

3. Select Multiple_Profiles.phxproj and click Open.

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This project contains: 
– A dataset worksheet (profiles)
– A worksheet of dosing information (Dosing published from NCA)
– An XY Plot object
– An NCA model object
– A Descriptive Statistics object
– A Data Wizard object
– An X-Categorical XY Plot object

4. Expand the workflow node.

5. Select the NCA model object in the Object Browser. 

6. Select items in the Setup tab list to explore the data mappings and option settings.

7. Execute the object.

Text output

The Core output contains the model settings and the same data as the worksheets, but presented in 
plain ASCII text. If there were errors in the model they would be listed here. Below is part of a Core 
output text file.

… 
Model: Plasma Data, Extravascular Administration 
Number of nonmissing observations:   12 
Dose time:      0.00 
Dose amount:      100.00 
Calculation method: Linear Trapezoidal with Linear Interpolation 
Weighting for lambda_z calculations: Uniform weighting 
Lambda_z method: Find best fit for lambda_z, Log regression 
Compute Concentrations at: 75 
 
Summary Table 
------------- 
 Time  Conc.  Pred. Residual    AUC         AUMC      Weight 
 min   ng/ml  ng/ml  ng/ml   min*ng/ml  min*min*ng/ml 
------------------------------------------------------------ 
  0.0000 0.0000                   0.0000       0.0000 
  5.000  340.3                     850.8        4254. 
  10.00  1914.                     6487.    5.636e+04 
  15.00  2069.                 1.644e+04    1.818e+05   1.000 
  20.00  1471.                 2.529e+04    3.329e+05   1.000 
  30.00  788.8                 3.659e+04    5.983e+05   1.000 
  45.00* 496.4  460.9  35.54   4.623e+04    9.434e+05   1.000 
  60.00* 372.8  357.2  15.63   5.275e+04    1.279e+06   1.000 
  90.00* 204.3  214.6 -10.33   6.141e+04    1.890e+06   1.000 
  120.0* 124.1  128.9 -4.852   6.633e+04    2.389e+06   1.000 
  180.0* 39.25  46.52 -7.266   7.123e+04    3.048e+06   1.000 
  240.0* 19.32  16.79  2.531   7.299e+04    3.389e+06   1.000 

The Settings file lists all the settings used to specify the noncompartmental analysis. Below is part of 
a Settings text file.

… 
  Sort: Subject, Form 
  Time: Time [min] 
  Concentration: Conc [ng/mL] 
  Carry: 
Dosing: (Internal) 
Slopes: (Internal) 
Partial Areas: (Internal) 
Therapeutic Response: <None> 
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Units: (Internal) 
Parameter Names: <None> 
… 
Plasma Model 
Title=Processing Multiple Profiles with Model 200 
Linear Trapezoidal Linear Interpolation 
Sparse=False 
Weighting=Uniform Weighting; 0 
Dose Type=Extravascular 
Dose Unit=ng 
Dose Normalization=None 
Compute Concentrations at: 75 

Output data

The NCA object creates several results worksheets including: Dosing Used, Exclusions, Final Param-
eters, Final Parameters Pivoted, Partial Areas, Plot Titles, Slopes Settings, and Summary Table. 
Selections from the Final Parameters and Summary Table worksheets are shown below.

Figure 8-1. Part of the Final Parameters worksheet
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Figure 8-2. Part of the Summary Table worksheet

A total of 12 pages of plots are generated; one for each of two formulations, for each of the six sub-
jects. The first two charts for subject one are shown below.

 

Figure 8-3. Plots for subject one, capsule and tablet formulation

Perform pharmacokinetic modeling

1. Select File > Load Project. 

2. In the dialog, navigate to <Phoenix_install_dir>\application\Examples\Win-
Nonlin.
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3. Select PK_Model.phxproj and click Open.

This project contains: 
– A dataset worksheet (study1)
– An XY Plot object
– A PK model object

4. Expand the workflow node.

5. Select the PK object in the Object Browser.

6. Select items in the Setup tab list to explore the model’s data mappings and option settings.

The imported PK Model object uses PK Model 3, which is a one-compartment model with 1st order 
absorption.

7. Execute the object.

Worksheet results

The PK Model object’s output worksheets partially include Condition Numbers, Diagnostics, Dosing 
Used, Final Parameters, Initial Estimates, Secondary Parameters, and Summary Table. The Final 
Parameters, Secondary Parameters, and Summary Table worksheets are shown below.

Figure 8-4. Final Parameters worksheet

Figure 8-5. Secondary Parameters worksheet
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Figure 8-6. Summary Table worksheet

Text output

The Core output text results include all model settings and iterations, including the output from the 
worksheets. Any model errors would be listed here. Below is part of the Core output text file.

… 
Listing of input commands 
 MODEL 3 
 NVAR 3 
 NPOI 1000 
 XNUM 2 
 YNUM 3 
 NCON 3 
 CONS 1,2,0 
 METH 2'Gauss-Newton (Levenberg and Hartley) 
 ITER 50 
 INIT 0.25,1.81,0.23 
 MISS '.' 
 DATA 'WINNLIN.DAT' 
 BEGIN 

The Settings file lists all the settings used to specify the noncompartmental analysis. Below is part of 
the Settings text file.

… 
Main: PK Model.Data.study1 
  Sort: Subject 
  Time: Time [hr] 
  Concentration: Conc [ng/mL] 
  Carry: 
Dosing: (Internal) 
Initial Estimates: (Internal) 
Units: (Internal) 
***** Other Parameters ***** 
… 
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PK 3-[PK] 
Gauss-Newton (Levenberg and Hartley) 
Convergence criteria of 0.0001 used during minimization process 
50 maximum iterations allowed during minimization process 

Plots

The plot results include Observed Y and Predicted Y vs X, Partial Derivatives Plot, Predicted Y vs 
Observed Y, Predicted Y vs X, Residual Y vs Predicted Y, and Residual Y vs X. Some plot results are 
shown below.

Figure 8-7. Observed Y and Predicted Y vs X

Figure 8-8. Predicted Y vs Observed Y



Phoenix Framework
User’s Guide

54

Figure 8-9. Residual Y vs X

Execute a bioequivalence model

1. Select the Quick Tour project in the Object Browser.

2. Select File > Import.

3. In the dialog, navigate to <Phoenix_install_dir>\application\Examples\Win-
Nonlin\Supporting files.

4. Select the file Seq2Per4.csv and click Open.
In the File Import Wizard dialog, click Finish. The dataset is added to the project Data folder.

5. Right-click the Seq2Per4 worksheet in the Data folder and select Send To > Computation Tools 
> Bioequivalence.
The Bioequivalence object is added to the workflow in the Object Browser and the following data 
types are automatically mapped to contexts.
– Sequence to the Sequence context
– Subject to the Subject context
– Period to the Period context
– Formulation to the Formulation context

6. In the Main Mappings panel, map AUC to the Dependent context.

7. In the Model tab (located below the Setup tab), ensure the following: 
– Crossover is selected as the Type of study
– Average is selected as the Type of Bioequivalence 
– R is selected as the Reference Formulation 
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8. Select the Fixed Effects tab, which is located below the Setup tab.

9. Ln(x) is automatically selected in the Dependent Variables Transformation menu. Do not 
change this setting.

10. Execute the object.

Output data

The bioequivalence model worksheet output partially includes Average Bioequivalence, Diagnostics, 
Final Fixed Parameters, Final and Initial Variance Parameters, Least Squares Means, and Sequential 
Tests. The Diagnostics, Final Variance Parameters, and Sequential Tests worksheets are shown 
below.

Figure 8-10. Average Bioequivalence worksheet
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Figure 8-11. Diagnostics worksheet

Figure 8-12. Final Variance Parameters worksheet

Figure 8-13. Sequential Tests worksheet

This concludes the Quick Tour of Phoenix.
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The Phoenix User Interface
The Phoenix interface lets users control and organize multiple projects, workflows, operational 
objects, and data sources. The following image highlights the major components of the interface.

Additional information is available for the following:

Main menu options
Toolbar buttons
Object Browser panel
Diagram tab
Setup and Results tabs
Verification tab
Information tab
History tab and Settings file
Phoenix log viewer
Phoenix hotkeys

For a brief walk-through of the Phoenix user interface, try the “Quick Tour of Phoenix”.



Phoenix Framework
User’s Guide

58

Note: The Phoenix interface is best rendered when there is no display scaling. If you are unable to select 
some buttons or tabs, or if parts of the interface overlap, try changing the scaling of text, applica-
tions, and other items to 100% (right-click on the Desktop and choose Display). A computer 
restart may be required to apply changes. 
To set the scaling only for the Phoenix application on a high DPI display, browse to the Phoenix 
installation folder (by default, C:\Program Files (x86)\Certara\Phoenix\appli-
cation), right-click on Phoenix.exe, select Properties menu item, and choose the Compat-
ibility tab. For Windows 7, select [x] on Disable display scaling on high DPI settings option. 
For Windows 8 or Windows 10, select [x] on Override high DPI scaling behavior. Scaling per-
formed by: option, and then select Application or System (Enhanced) in the drop-down menu. 
Then restart your computer to apply the changes.

Main menu options
The Phoenix main menu allows users to create and save projects, import datasets, export operational 
objects and worksheets, and connect to databases.

Note: All menu options are not always active and, therefore, are unavailable. Some options are only 
available when a user selects a certain part of the interface, such as a cell in a worksheet. For 
example, the Insert menu is only available when a project, workflow, or operational object is 
selected. The Send To menu is only available when a worksheet is selected. 

File: Create, load, save, and close projects, create worksheets, load and save templates, import and 
export data, and print results.

Edit: Undo and redo worksheet edits, cut, copy, paste, find, and sort data, insert and delete rows and 
columns, freeze panes, locate a cell by column/row number, edit worksheet in Excel, and access the 
Preferences dialog.

Insert: Add operational objects to a workflow. This menu is only available when a project, a workflow 
object, or an operational object is selected.

Send To: Send worksheets to an operational object. The Send To menu is only available when a 
worksheet is selected. 

Integral: Connect to Certara Integral, create and edit studies.

Watson: Import data from Watson LIMS into a Phoenix project as either a study Workbook or as a 
study in Integral.

Validation: Execute validation test packages, display results, and generate validation reports.

Window: View job status, display/undisplay the Object Browser, arrange open windows.

Help: Access the Phoenix Assistance Library, information about support, training, and the installed 
version of Phoenix, as well as view log files. 
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Toolbar buttons

Load Workflow Template and Save Workflow Template are only available when a workflow is 
selected. 

Cut, Copy, Paste, Freeze Panes, Insert Row, Insert Column, and Delete are only available when a 
cell in a worksheet is selected.

Verify Workflow, Execute, Remote Execute, and Stop Execution are only available when a work-
flow or operational object is selected.

Object Browser panel
The Object Browser displays all the operational objects inserted into a project or a workflow. 

The Object Browser contains the following items:

Project: All the operational objects inserted into a project. Also contains the Data and Library fold-
ers.

Data folder: Imported datasets and user-created worksheets and workbooks.

Code folder: Imported PML, legacy ASCII model code, NONMEM scripts, SAS scripts, and any 
imported text or rich text format (*.rtf) files.

Tables folder: Imported or internally created output tables.

BQL Rules folder: Rules for importing datasets with uselessly low concentration data.

Documents folder: Any binary objects that do not belong in the other folders.
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Shortcuts folder: Pointers to input data files that have been imported as shortcuts.

Workflow object: Any object that allows users to group operational object and nest workflows 
within a project.

Operational object: Any object that receives input, performs an operation, and produces results. 
An example is the NCA (noncompartmental analysis) object.

Select a folder object to display a list of the contents in the main panel area.

The objects in the tree can be re-ordered. Click and drag the item to the new location. The cursor will 
change to a blue arrow when it is possible to move the item to that location. Moving items to a differ-
ent workflow will require re-execution; however re-ordering within a workflow will not require re-exe-
cution. Items cannot be moved after a workflow, as it is not possible to determine if the user intends to 
place it at the end of the workflow or after it. Consequently, move the workflow instead.

The Object Browser toolbar contains icons for the following:

Show Sources shows which data is mapped to an operational object.

Show Dependents shows all objects which depend on the selected object for data input.

Expand all expands all of the nodes in the Object Browser.

Collapse all collapses all of the nodes in the Object Browser.

See Using the Object Browser for more information.

Diagram tab
Part of the Properties tab, the Diagram tab is only available when a Workflow object is selected in the 
Object Browser. Use the Diagram tab to visualize the flow of data between objects in your workflow. 

Right-clicking in an open area of the diagram display area presents a menu with the following options:

Verify Workflow: Check if an executable object can be run.

Execute: Execute an object or workflow locally, depending on which is selected in the Object 
Browser.

Lock/Unlock Workflow: Enter the username and password to lock/unlock the workflow. (Note 
that passwords must be recorded by users as they are not maintained by Phoenix. If a password 
is lost, the workflow will need to be recreated.)



61

Insert: Add an object to the workflow.

Load Workflow Template: Adds a new workflow to the project along with the operational objects 
and settings that were saved within the Workflow Template.

Save Workflow Template: Save a workflow as a Workflow Template, in order to reapply an anal-
ysis on new data. 

Paste: Add the object from the clipboard to the diagram.

Connect External Sources to Data Links: Create a data link object for every worksheet coming 
into the workflow. 

Disconnect External Data Links: Remove data link objects from the workflow.

Copy Diagram to Clipboard: Place a copy of the diagram on the clipboard.

The Diagram tab contains the operational objects in a workflow, color-coded as shown in the following 
image.

The Object Toolbox allows users to insert objects into a project by clicking the buttons in Object Tool-
box. The objects in the Object Toolbox are grouped in the same way as they are in the Insert menu.
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Setup and Results tabs
The Setup and Results tabs are sub-tabs of the Properties tab.

The Setup tab is the default view of any newly inserted operational object. This tab contains a list of 
the panels and options tabs that are used to set up the object. Through the Setup tab, users can map 
datasets and other worksheets to an object. 

The Results tab displays the results of an executed object grouped by type. Result types are text, 
worksheets, and graphs.

The toolbar contains icons that perform the following functions:

Do not group lists results in alphabetical order.
Group by type organizes the results in three groups: tables, plots, and text output.
Group by executable groups the results of each executable together.
Expand all results expands all of the groups to make all results visible in the list (use when 
results are grouped).
Collapse all results displays only the groupings, hiding the list of individual results.
Copy to Data Folder copies results to the Data folder.
Export exports the results.
Print prints the results.

The Results tab of all Phoenix objects allows filtering. The filtering is not case sensitive and when a fil-
tering string is entered, only results containing that string within their name are displayed in the 
Results tab. The filter persists until the object is closed or the filter is changed.

The list of results can also be simplified by collapsing/expanding the groups (i.e., results types) using 

the chevrons next to the group name.  
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A plot can be viewed and modified in its own window by selecting it in the Results list and double-
clicking it or pressing ENTER. 

Re-execute the object by clicking  (Re-execute Plot icon) in the toolbar of that separate window.

Verification tab
Part of the Properties tab, the Verification sub-tab displays operational object status and execution 
error messages.

 (Verify icon) in the main menu verifies that the selected operational object can be executed. 

Phoenix displays a popup indicating the success or failure of verification. The Verification tab will 
also indicate the verification results. If there is a failure, options in the operational object that need to 
be specified or any other problems will be listed in the Error Message column.
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Information tab
The Information tab displays information about a selected object. Depending on the object selected, 
the following information may be available: the name, date created, status, Phoenix version used to 
create the object, Phoenix version used when last saved, the last date executed, and the last date 
saved. When a project is selected, the tab also includes the full path of the source file. 

All Information tabs have two editable fields: the Name and the Description fields.

1. Select any item in the Object Browser. 

2. Select the Information tab at the bottom of the right viewing panel.

3. To edit the item’s name, type a new name in the Name field.

4. Add a description of the item in the Description text box.

The bottom portion of the tab lists any children of the selected item. The object type and creation time 
of each child is also listed. Children can be deleted from this list by selecting them and using either 
the Delete key or the right-click menu Delete option. If any of the selected children cannot be deleted, 
then pressing the Delete key will do nothing and the right-click menu Delete option will be disabled. 
Deleting a child from this list also removes them from the Object Browser. 
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History tab and Settings file
Phoenix provides two methods to track data analyses and manipulation. Operational objects, except 
for plot objects, create a text file called Settings that lists the options selected at the time of an object’s 
last execution. The Settings files are located in the Results tab.

Every item in the Object Browser also has a history worksheet that tracks changes made to that item. 
The history worksheet for each item is located on the History tab. Information recorded for each action 
includes a timestamp, the user who performed the action, the name of the action, and a description. 
Although the automatically recorded information cannot be edited, notes can be added using the 
Annotation field (double-click in the cell or click in the cell and press the F2 key).

 

The automatic history worksheet entries cannot be edited.

The events that the history worksheet records change depending on the item. The list below shows 
the events recorded in the History tab for each item.

Projects: creation, name change

Data folder: creation

Workbooks: creation, name change, copy and paste

Worksheets: creation, name change, column and row creation and deletion, cell value changes, 
copy and paste, column data type changes, and column unit changes, skipped worksheets on 
import, opening (including path and filename), fill-down event (including source and destination 
cell ranges). Worksheets that are copied from an operational object’s results contain all the his-
tory information from that object.

Code folder: creation

Code files: creation, name change, copy and paste

Tables folder: creation

HTML tables: creation, name change, copy and paste

BQL Rules folder: creation

BQL rules: creation, name change, copy and paste

Documents folder: creation

Document files: Varies based on the type of object imported.

Workflow object: creation, execution, name change, copy and paste, copy from template

Operational object: creation, execution, name change, copy and paste, copy from template

The date-time values recorded in the History tab are Coordinated Universal Time and are displayed 
with the “UTC” designation to indicate the time zone. This standard time is implemented in the History 
tab to prevent confusion if Phoenix projects are shared across time zones. There is no option in Phoe-
nix for the user to change the time zone used for recording times in the History worksheet. Settings, 
NCA, and modeling core text outputs will use the local time and timezone designation of the machine 
where Phoenix is installed; these do not conflict with the times in the History tab since the time zone 
being utilized is clearly indicated in each case.
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Phoenix log viewer
Phoenix creates several log files that are primarily useful for network administrators and customer 
support. These files are accessed using the Help > View Log menu item. Use the buttons above the 
list to show/hide log entries of different severity. By default, entries for all levels of severity are dis-
played. The total number of entries for the different severity levels are reported at the bottom of the 
window. 

Phoenix hotkeys
F1: Help
F2: Rename an object
F3: Find next
F7: Execute
F8: Validate
F9: Edit in Excel
Shift+F7: Execute all objects in workflow
Ctrl+N: New project
Ctrl+R: Close project
Ctrl+L: Open project
Ctrl+S: Save project
Ctrl+W: Save workflow template
Ctrl+P: Print
Ctrl+I: Import
Ctrl+E: Export
Ctrl+F: Find
Ctrl+H: Replace
Ctrl+J: View jobs
Ctrl+O: Orphan model
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How To Do Common Tasks
The following is a list of several basic tasks that are required by a large number of the Phoenix mod-
ules. Becoming familiar with these tasks will help reduce the time spent setting up projects.

Using the Object Browser
Importing Data
Data Mapping
Working with Worksheets
Using the Units Builder
Printing
Exporting
Executing Objects and Workflows
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Using the Object Browser
The following topics are discussed in this section:

Showing sources
Showing dependents
Send To menu
Copying/Pasting Data folder items
Copying/Pasting a workflow object
Moving a workflow object
Deleting items
Exporting a workflow
Comparing or refreshing a dataset

Showing sources

1. Click  (Show Sources icon) to display the source worksheets for each workflow and opera-
tional object.

2. Click the (+) sign next to Sources to view the source worksheets for an object. 
Source worksheets include imported datasets and user-created datasets.

3. Select a worksheet to view it in the right viewing panel. 
The worksheet is displayed in the Grid tab, with the Columns tab below.

Right-click an item in the Sources list and select Find Object in Browser to automatically go to that 
item in the Object Browser.

Source worksheets can be edited like any other worksheet. If a worksheet or part of a worksheet is 
shaded gray, it cannot be edited. Be aware that editing a source worksheet that is used by an exe-
cuted operational object marks the object, its results, and the workflow as out-of-date. Also, if multiple 
operational objects use the same worksheet, then changing the worksheet affects all of those objects, 
not just the selected one.
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Showing dependents

1. Click  (Show Dependents icon) to display dependent objects for each worksheet in the Data 
folder.

2. Click the (+) sign next to Dependents to view the dependent object list.

3. Select an object in the dependent object list to display it in the right viewing panel. 
Selecting a workflow object displays the Diagram tab for that workflow.

Right-click an item in the Dependents list and select Find Object in Browser to automatically go to 
that item in the Object Browser.

Note: Only dependents of final output are shown, dependents of intermediate or secondary results are 
not listed.
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Send To menu
The Send To menu is used to insert an operational object, automatically mapping the selected data-
set to it.

1. Right-click a dataset in the Data folder, select Send To > <object group> > <object>. 
For example, right-click a worksheet and select Send To > Plotting > Column Plot.

2. If there are multiple workflow objects, select the one in which to add the new object.
The object is added to the workflow, with the dataset is automatically mapped to its main input.

The Send To menu is accessible from any dataset in the Data folder and from any results worksheet. 

Items other than datasets can be sent to operational objects. Code and scripts in the Code folder can 
be sent to the User ASCII Model, NONMEM Shell, SAS Shell and SigmaPlot Shell operational 
objects. The Maximum Likelihood models, however, does not allow users to send a code file to be 
mapped to the object, because the Maximum Likelihood Models object always defaults to the built-in 
model, and not the text model.

BQL rules in the BQL Rules folder can be sent to a BQL object by right-clicking a rule set and select-
ing Send To > Data Management > BQL.

Copying/Pasting Data folder items
Right-click a worksheet, workbook, or subfolder in the Data folder and select Copy.
Or select the item and type Ctrl+C. 

Right-click the Data folder or a Data subfolder and select Paste. 
Or select the folder and type Ctrl+V. 

A duplicate of the worksheet, workbook or subfolder and its contents will be added to the folder or 
subfolder with “Copy of” prepended to the name.
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Copying/Pasting a workflow object
Right-click a Workflow in the Object Browser and select Copy.
Or select the Workflow and type Ctrl+C. 

Right-click the target Workflow and select Paste.
Or select the target Workflow and type Ctrl+V. 

A duplicate of the object will be added at the bottom of the list of workflow objects with “Copy of” pre-
pended to the name.

When pasting an object using Ctrl+V, Phoenix identifies an appropriate parent for the copied object. 
For instance, if a Workflow object is copied and then an executable (not a Workflow) is selected, typ-
ing Ctrl+V will paste a copy of the Workflow object into the parent executable’s Workflow. If another 
location is selected, such as the Data folder, a copy of the Workflow object will be pasted in the root 
Workflow. (Similarly, copying a worksheet and trying to paste it into an executable with Ctrl+V will 
paste the worksheet into the Data folder.)

Caution: When copying and pasting objects, auto-mapping can take place. For example, a parameter work-
sheet with a Lower or Upper column can be unexpectedly mapped when pasting in an NLME 
model. It is a good idea to check mappings after pasting a copied object. 

Moving a workflow object
Click and drag the object from one Workflow to another Workflow

Deleting items
Right-click an item in the Object Browser and select Delete.
Or select an item in the Object Browser and press the Delete key.

Click Yes in the confirmation dialog.

Since only one item can be selected at a time in the Object Browser, only one item can be deleted at 
a time. If there are multiple items that need to be deleted, use the Information tab. See “Information 
tab”.

Exporting a workflow
Phoenix can export all of the objects within a Workflow with one click. This option, called Dependen-
cies, is intended to share work with users that might not have Phoenix. It provides a .xml summary 
that displays information about the Phoenix objects in the Workflow and the results. To use this func-
tionality:

• Right-click a Workflow object and select Dependencies. 

• In the dialog, navigate to an empty folder.
All of the Workflow output will be exported to this location. 
(Plot results containing more than 100 chart tabs will only output the first 100 tabs.) 

• Enter a file name and select Save.
Exporting all objects in a Workflow may take a while, depending on the number of objects. 

• In the next dialog, select Yes to open a browser window and view a summary.
All objects are listed, including links to all results for each object. 
Select No to return to the main Phoenix window.
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Note: Exporting a Workflow in this manner is not a substitute for saving Phoenix projects as .phxproj 
files. Files exported via the Dependencies option cannot be imported back into Phoenix as a 
Workflow.

Comparing or refreshing a dataset
Datasets in ASCII format, meaning those with .csv and .dat extensions, can be compared to the 
original dataset and updated from the original file.

To compare imported and original dataset

Right-click an ASCII dataset in the Data folder and select Check State. 

Phoenix compares the imported version with the original version and tells the user if the datasets 
match. 

To refresh a dataset

Right-click an ASCII dataset in the Data folder and select Refresh from Source.

The dataset is synchronized with the original dataset.
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Importing Data
When a data is imported into Phoenix, whatever changes are made to those data only affects the data 
that is imported into Phoenix. The actual file that contains the data is not affected.

This means that any changes made to datasets imported into Phoenix are not reflected in the dataset 
that is saved on a hard drive or other storage media. Users can make as many changes as they want 
to a dataset in Phoenix without changing the original dataset.

What types of data does Phoenix use?

Imported datasets such as worksheets and workbooks.
User-created worksheets and workbooks.
Worksheets that are the results of operational objects.

How is data used in Phoenix?

The Data folder contains all the imported or created datasets that are used in a project.
All datasets used in a workflow are contained internally within Phoenix.
Changes made to imported datasets do not change the original dataset.
Data must be mapped to an operational object before it can be used.

This section contains information on:

Importing files
Importing datasets

Note: Computer accuracy for numeric data is limited to about 14 significant digits. This can cause two 
unique numbers with more than 14 significant digits to be treated as the same number. If the num-
ber represents an identifier, set the column type to text to preserve the full ID. The situation for 
actual numerical data needs to be handled carefully. As an example, using the NCA Slopes Selec-
tor when the time data has more than 14 significant digits, and two points differ at the 14th digit 
(e.g., 240.333333333333 and 240.333333333334), one point appears selected for the time range 
but it is not used in the Slopes Selector. Furthermore, the point representing a number, such as 
240.333333333333, is selectable in the Slopes Selector and can show as the End Time for a user-
specified range, but will not be used in the slope calculation, causing Lambda_Z_Lower and 
Lambda_Z_Upper in the output to be off by 1e-14. One workaround is to click on Slopes and paste 
the full number. Another possibility is, prior to NCA, to round the time data so it has 14 significant 
digits or fewer (use a custom transformation in the Data Wizard with a formula such as 
round(time,10) or roundsig(time,14)). 

Importing files

To import files

Click  (Import File icon) in the Phoenix toolbar.

Or select the File > Import menu option.
Or press CTRL+I. 
Or right-click the Data Folder in the Object Browser and select Import.

Navigate to and select the file(s) to import in the dialog.
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To import files as shortcuts

Select File > Custom Import > File Shortcut.

To import all files within a folder

Select File > Custom Import > Import Folder. All files and sub-folders within the selected folder will 
be imported into the Documents folder, with the directory structure maintained.

Supported file types
Phoenix can import several file types beyond what are officially supported and displays different 
import options depending on the file type selected. Some files have no import options. Supported files 
types are listed below.

ASCII Data (*.csv;*.dat): Displays the File Import Wizard dialog.

BQL Rule Set (*.phxruleset): Adds new BQL rule set to the BQL Rules folder.

Enhanced Meta File (*.emf): Imported in the Documents folder.

Excel 97–2003 Workbook (*.xls): Displays the File Import Wizard.

Excel Workbook (*.xlsx): Displays the File Import Wizard.

Image File (*.bmp,*.gif,*.jpeg,*.jpg,*.png): Imported in the Documents folder.

Phoenix Projects (*.phxproj): Can only be loaded using the import function if a project is already 
open in Phoenix. No import options.

SAS Transport Files (*.xpt): Imported into the Data folder. (Phoenix supports SAS Transport For-
mat (XPORT) Version 5.)

Text (*.bat,*.ctl,*.mdl,*.mod,*.r,*.sas,*.ssc,*.tdl,*.txt,*.vbs): Imported into the Code folder. 

Windows Meta File (*.wmf): Imported into the Documents folder.

Extensionless files are placed in the Code folder. Files imported as shortcuts are placed in the Short-
cuts folder.

Note: The following legacy file formats are no longer supported: .lib, .pwo, .pmo, .pto, .pco, .bql, .tdf, 
.xml, .lml, .cmd, .ivc, .map, .wsp, .pws. Files of these types can still be imported into a project 
using Pheonix32.exe and then save the project. The saved project is then ready for use in either 
32- or 64-bit Phoenix.

Importing datasets
Phoenix can import datasets in several different file formats. During the import process, a copy of the 
data is created. The original dataset file, no matter where it is located, is not altered by Phoenix in any 
way.

The maximum worksheet size Phoenix can import depends on the amount of RAM in the computer 
running Phoenix.

The following topics are discussed in this section:

Using the File Import Wizard dialog
Custom imports
See “ODBC” and “Watson Import Object” for data importing options.
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Note: When subject IDs with many digits are imported (e.g., 100010901), they are changed upon import 
to G8 format by default (e.g., 1.0001090E-08), even if they are imported as text. Using the G9 for-
mat preserves the subject ID digits. See “To specify a Microsoft .NET format string” for more infor-
mation on numeric formats.

Using the File Import Wizard dialog
The File Import Wizard dialog contains several options that allow users to determine how a dataset is 
imported into Phoenix. The File Import Wizard dialog is used to import .csv, .dat. .xls, or .xlsx files.

File(s) to Import: Lists the file or files that are being imported. Select a file in the list to view the 
options for that file.(Clear the checkbox to not import a particular item.)

Has header row: Check this box to indicate that a worksheet contains column headers.

Has units row: Check this box to indicate that a worksheet contains unit information for the col-
umn headers.

Has units in column header: Check this box to indicate that at least one of the columns in the 
worksheet has units included in the header. If checked, any characters that are after an under-
score (_), within brackets ({}), or within square brackets ([]) in the source file will be considered as 
units for the column. 

Treat consecutive delimiters as one: Check this box to have Phoenix treat two spaces, for 
example, as one space.

Field delimiter: Select the option buttons to indicate how the fields in a dataset are separated: by 
semi-colon, comma, space, tab, or a custom delimiter.
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Missing value: If the dataset has a specific entry for instances where the value is missing, type 
that entry in this field. Any cells that match that entry will be left blank when they are imported. For 
example, a dataset may contain the word “None” in cells where a value is not available. Typing 
None in the Missing value field will import cells that contain the word “None” as a blank cell.

Start at row: Type the row number where importing is to start. The default value is 1.

Number of Rows to Import: Type the total number of rows in the dataset that are to be imported. 

Worksheet Preview tab: Displays a preview of the data being imported based on the currently 
selected options. (Only the first 20 rows of a worksheet are previewed.)

File Contents tab: Displays the raw file contents. (Only the first 20 rows of a worksheet are 
shown in this tab.)

Column Options tab: Provides options to specify the data type of a column (Numeric or Text) 
and indicate any columns of data to ignore during the import (check the boxes in the Ignore col-
umn).

Click Finish to import the file and display it in the viewing panel. Click Cancel to cancel the file import.

Note: Numeric columns can switch to text if there is any non-numeric data in a cell. So, if there is an 
extra row in an input dataset containing text, it will cause entire columns to be treated as text. if 
this happens, change the column type to numeric.

Custom imports
Phoenix file imports are controlled by the file extension. Phoenix uses the file extension to determine 
where to place the file and its components, if any. The Custom Import menu allows users to force a 
file to be imported as a binary, ASCII, or text file, without regard to the file extension.

The Custom Import menu is useful for importing file types that are recognized by Phoenix, but do not 
contain data that is usable by Phoenix. For example, a user might want to attach an Excel table to a 
project. By selecting File > Custom Import > Binary File the Excel file is placed in the Documents 
folder, and not in the Data folder.

Additionally, the Custom Import menu allows users to import data for use with any of the third party 
objects (e.g., R, SAS, PsN, etc.) as a shortcut. 

• To import a binary file, select File > Custom Import > Binary File.
Files are placed it in a Documents sub-folder named after the imported file’s extension. For exam-
ple, an imported .jpg file is placed in Documents/jpg. These files cannot be viewed or used 
in Phoenix. The Binary File custom import is best used to keep files in a project that are associ-
ated with a project, but are not used directly in a project.

• To import an ASCII file, select File > Custom Import > ASCII Data.
Files are placed in the Data folder.

• To import a text file, select File > Custom Import > Plain Text.
Files are placed in the Code folder.

• To import a shortcut object, select File > Custom Import > File Shortcut.
A shortcut object containing meta information about the selected file is added to the Shortcuts 
folder.
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Data Mapping
Data mapping is the process of associating a dataset with an operational object so that objects can 
use the data in an analysis or other function. Data mapping in Phoenix is as simple as dragging a 
dataset from the Data folder to an object’s input, or using the Select Object dialog to select a dataset.

There are multiple types of data mapping in Phoenix: 

• Mapping a dataset to an operational object: Datasets can be mapped to the different panels in an 
object’s Setup list, or they can be mapped to an object’s inputs in the Diagram tab.

• Mapping results to an operational object

• Mapping context associations: Context mapping is the process of linking a specific column in a 
dataset to a specific context in an operational object, such as Time or Concentration.

Phoenix can complete context mappings if a column header in a worksheet matches the context 
name in an operational object. The Global Contexts and Context Association panels in the Prefer-
ences dialog can be used to automatically associate columns in a dataset with contexts in an opera-
tional object. For example, Phoenix can be set to map a concentration column named conc to an 
operational object’s concentration context. 

Mapping a dataset to an operational object
Every operational object includes a data input panel in the Setup tab that is used to identify how input 
variables are used in an operational object.

Most primary data input panels contain two tabs: the Mapping tab (where dataset columns are 
mapped to an object’s inputs) and a sort order tab (allows users to sort dataset columns). The Table, 
NONMEM, PsN, R, SAS, and SigmaPlot objects only have a Mappings panel.

Users can map a dataset or other worksheet to almost any item in the Setup tab list using the instruc-
tions listed below. Note that the R and SAS Shell objects must have a script mapped to them before 
their inputs are defined. The PsN Shell object must have at least one model mapped to it before the 
input can be defined.

To map a dataset using the data mappings panel

In the data mappings panel, click  (Show Sources icon). 

In the dialog, click the (+) sign next to the Data folder. 

Select a dataset and click Select.

Or use the pointer to drag a dataset from the Data folder to the Mappings panel.

To map a dataset using the Diagram tab

Select the Workflow object in the Object Browser.

In the Diagram tab, click  to expand the object box.

Click the (+) sign next to Inputs.

Drag the dataset from the Data folder to the primary data input.

The line between the External Sources box and the object box represents the data mapping.
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To map a dataset using the “Send To” menu option

Select the object in the Object Browser to return to the Setup tab.

Right-click an imported worksheet and select Send To > <object group> > <operational object>. 

The Send To command inserts the new object into the Workflow with the right-clicked worksheet 
already mapped as the input source. 

Mapping results to an operational object
The results worksheet of any operational object can also be mapped to another operational object.

To map results from the Setup tab

Click  (Select Source icon) in the operational object’s Setup tab.

In the dialog, click the (+) signs to expand the menu tree.

Select the results worksheet and click Select.

To map results from the worksheet

Right-click a results worksheet and select Send To > <object group> > <operational object>. 

Mapping context associations
Context associations are inputs to an operational object. Contexts that must have data mapped to 
them so the object can perform its function are shaded orange. Most items in an operational object’s 
Setup list have a Mappings panel that allows users to match columns in a dataset to inputs in an oper-
ational object.

Column headers in the dataset are displayed on the left side and context associations for the opera-
tional object are displayed across the top.

Figure 13-1. Context associations for NCA model 200

Select the option button to connect the input dataset column containing the data (row) to the corre-
sponding context (column).

Repeat for each item in the Setup tab list that requires mapping data to inputs.
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Working with Worksheets
This section includes information on the following topics:

Creating a worksheet or workbook
Adding columns to a worksheet
Editing an existing column
Adding and deleting rows in a worksheet
Moving cell values in a worksheet
Editing data values in worksheets
Replacing a cell value with a new value
Undoing and redoing actions
Changing the display format of numerical values
Finding a cell value in a worksheet
Sorting a worksheet
Using Edit in Excel

There are also a number of operational objects designed specifically for modifying worksheets. See 
“Worksheet-Related Objects”.

Creating a worksheet or workbook

To create a worksheet

Select File > New Worksheet  (New Worksheet icon).

Or right-click the Data folder and select New > Worksheet.

A new worksheet is added to the Data folder. 

To rename the worksheet

Select the worksheet and press the F2 key.
Or single-clicking the worksheet name a second time.
Or right-clicking the worksheet and selecting Rename. 

Type a name for the new worksheet.

To create a workbook

Right-click the Data folder and select New > Workbook. 

Click the (+) sign next to the workbook to view the worksheets it contains. 

To add more worksheets to a workbook, right-click a workbook and select New > Worksheet.

Adding columns to a worksheet
With the worksheet displayed, click Add under the Columns box in the Columns tab.
Or right-click in the worksheet itself and select Insert Column from the menu.

In the dialog, select the Numeric or Text option buttons to set the data type for the new column.
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Type a name for the new column in the Column Name field and click OK.

After a column is added to the Columns box its properties can still be edited.

Numeric versus text 

Numeric-type columns are considered by Phoenix to contain only numeric values, and the application 
treats the values in a numeric column as numeric data. A numeric column contains only numeric val-
ues or substitution values such as those applied by BQL rules. 

Text-type columns in Phoenix can contain mixed numeric and text values. Some important consider-
ations regarding Text-type columns include:

Any beginning and trailing spaces in text columns are trimmed in Phoenix worksheets. 

Preceding “0”s will be lost in the case of numeric subject identifiers that start with “0”s.

Columns with numbers as purely text will sort differently than numeric columns.

Very large integers will lose precision due to rounding of significant digits when they exceed pre-
cision capacity (approximately 14 digits); 

Limitations on column names 

Limitations on column names are necessary in Phoenix because certain characters can cause opera-
tional objects to either work incorrectly or not recognize a column in a worksheet.

Use only alphanumeric characters and underscores.

No spaces. Spaces are converted to underscores.

Start with a letter. Column names that start with a number have an underscore added to the 
beginning of the column name.

Any invalid characters are automatically converted to an underscore. For example, if a user types 
the column name 1 Conc%, Phoenix automatically converts it to _1_Conc_.

Editing an existing column
To change the column header, click the name in the Columns box to make it editable and type the 
new name.

To remove a column, select a column header in the Columns box and click Remove below the Col-
umns box.
Or right-click the cell or column header in the worksheet itself and select Delete from the menu. In the 
confirmation dialog, click the Selected Column(s) option button and click OK.

Note that columns cannot be deleted from a worksheet that is mapped to an operational object.
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To change the order of the columns, select a column in the Columns box and click the Up Arrow and 
Down Arrow buttons beside the Column box to move the column up and down.

To change a column’s data type, click Change beside Data Type to display the Change Column 
Type dialog and select the type.

Caution: Changing a column from text to numeric deletes any non-numeric values in the column.

To add units to a column header, type the unit in the Unit field or click Units Builder to open the 
Units Builder dialog. See “Using the Units Builder”.

Adding and deleting rows in a worksheet
Right-click in the worksheet and select Insert Row from the menu.

If a cell is selected, the row is inserted above the selected cell. If multiple rows are selected, the same 
number of rows will be inserted above the first selected row.

To delete a row, right-click a cell in the row and select Delete from the menu. In the dialog, select the 
Selected Row(s) option button and click OK.

To move rows, select the contiguous rows, move the cursor over the lower right corner of the selected 
block of rows and, when the cursor changes to a four-arrow sign, drag the block of rows to the new 
location.

Note: A row-paste operation will only appear in the history when the data to be copied is selected by 
highlighting the individual cells and pasted by selecting the destination row number. If the data is 
copied by selecting a row number or pasted by selecting the destination cells, the history entry will 
not be created. 

Moving cell values in a worksheet
Use the pointer to select a horizontal or vertical range of cells in a worksheet.

Select Cut, Copy, Paste from the right-click menu, Edit menu, or in the toolbar.

Cut moves the values in the cells to the clipboard.

Copy copies the values in the cells to the clipboard.

Paste pastes the values in the clipboard into cells, starting with the currently selected cell.

Or move the cursor over the lower right corner of the selected block of cells and, when the cursor 
changes to a four-arrow sign, drag the block of cells to the new location.
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Editing data values in worksheets
Click in a cell and edit the content directly in the cell or in the field above the worksheet.

If you want the same value in multiple adjacent cells, enter that value in the first cell and then drag the 
lower right corner of the selection box until the block of desired cells is selected. When you release 
the mouse button all of the selected cells will have the entered value.

Note: If you are unexpectedly unable to edit a cell value, try double-clicking in the cell or selecting the 
cell and then using the field above the worksheet to enter the data. 

Replacing a cell value with a new value
Select Edit > Replace.

In the Find field, type the text or number to be replaced. 

In the Replace With field, type the text or number to replace the search value entered in the Find 
field. 

Check the Replace All box to replace all instances of the value in the Find field. Unchecking the 
Replace All box only replaces the first instance of the search value.

Undoing and redoing actions
Select Edit > Undo to undo the last worksheet action. 

Select Edit > Redo to redo the last worksheet action.

Note: The Undo and Redo functions have no effect on any part of Phoenix other than worksheets.

Changing the display format of numerical values
The numeric display format is only used to control how data is displayed. All operational objects use 
the raw data that is displayed in the Value Display bar, i.e., full precision is used in all calculations 
regardless of the display format.

Phoenix uses Microsoft .NET format strings to display numerical values in a worksheet. 

To specify a Microsoft .NET format string

Select the Custom option button in the Columns tab.

Enter a format string in the field. The following lists some examples. The default is G8.
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General format (e.g., G, G4, G8): Enter G in the Custom field to display the values in the cells in 
fixed-point or scientific notation, depending on the length of the number and the specified preci-
sion. Users can change the precision specifier after G to any whole number from one to 99. Any 
numerical value longer than the specified precision value is displayed in scientific notation. If no 
precision value is specified, then every number in the column is displayed without regard to signif-
icant digits or decimal places.

Exponential (e.g., E, E4, E8): Enter E in the Custom field to display the values in the cells in sci-
entific notation. Users can change the precision specifier after E to any whole number from one to 
99. If no precision value is specified, then six decimal places are used to display every number in 
the column.

Fixed (e.g., F, F4, F8): Enter F in the Custom field to display the values in the cells in real num-
bers. The F format determines how many decimal places are displayed. Users can change the 
precision specifier after F to any whole number from one to 99. If no precision value is specified, 
then two decimal places are used to display every number in the column.

To specify the number of decimal places

Users can set the number of required and optional decimal places to make sure that all values in a 
cell are represented and not altered. The number of required and optional decimal places needed to 
do this depends on the values in the column cells.

Select the Numeric option button.

In the Required Decimals box, select or type the number of required decimal places. 

In the Optional Decimals box, select or type the number of optional decimal places.

Check the Use Thousands Separator box to place a comma between every third integer.

If a cell contains less than the specified number of required decimals, then zeros are appended to the 
end of the value. For optional decimals, no zeroes are appended. On the other hand, if a cell contains 
more decimal values than the number specified, then the values are truncated. The actual value is not 
changed in the cell, only the displayed value is changed.

Date and time formats
The time column in a worksheet is typically in numeric format. Phoenix also allows users to create 
worksheets that contain the date and time values in text format.

MM/dd/yyyy (8/22/2006)
dddd, dd MMMM yyyy (Tuesday, 22 August 2006)
dddd, dd MMMM yyyy HH:mm (Tuesday, 22 August 2006 06:30)
dddd, dd MMMM yyyy hh:mm tt (Tuesday, 22 August 2006 06:30 AM)
dddd, dd MMMM yyyy H:mm (Tuesday, 22 August 2006 6:30)
dddd, dd MMMM yyyy h:mm tt (Tuesday, 22 August 2006 6:30 AM)
dddd, dd MMMM yyyy HH:mm:ss (Tuesday, 22 August 2006 06:30:07)
MM/dd/yyyy HH:mm (8/22/2006 6:30)
MM/dd/yyyy hh:mm tt (8/22/2006 6:30)
MM/dd/yyyy H:mm (8/22/2006 6:30)
MM/dd/yyyy h:mm tt (8/22/2006 6:30)
MM/dd/yyyy h:mm tt (8/22/2006 6:30)
MM/dd/yyyy h:mm tt (8/22/2006 6:30)
MM/dd/yyyy HH:mm:ss (8/22/2006 6:30)
MMMM dd (22-Aug)
yyyy'-'MM'-'dd'T'HH':'mm':'ss.fffffffK (2006-08-22T06:30:07.7199222-04:00)
ddd, dd MMM yyyy HH':'mm':'ss 'GMT' (Tue, 22 Aug 2006 06:30:07 GMT)
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yyyy'-'MM'-'dd'T'HH':'mm':'ss (2006-08-22T06:30:07)
HH:mm (6:30)
hh:mm tt (6:30 AM)
H:mm (6:30)
h:mm tt (6:30 AM)
HH:mm:ss (6:30:07)
yyyy'-'MM'-'dd HH':'mm':'ss'Z' (2006-08-22 06:30:07Z)
dddd, dd MMMM yyyy HH:mm:ss (Tuesday, 22 August 2006 06:30:07)
yyyy MMMM (2006 August)

Finding a cell value in a worksheet

To find a cell by column and row

With a worksheet displayed, select Edit > Go To.

In the dialog, use the Column menu to select the column in which the cell is located.

In the Row Number field, type the row number in which the cell is located.

Click OK to select the corresponding cell and scroll to that location in the worksheet.

To find a cell by its value

Select Edit > Find.

In the dialog, type the number or text to search for in the Find field.

For numerical values, use the Tolerance field to enter a tolerance value. Numeric values that are +/- 
the tolerance of the search value are considered to match the search value.

For text or text and numbers, check the Case Sensitive checkbox to search for text that matches the 
capitalization of the search value.

In the Search Area, select the Entire Dataset, Column, or Current Selection option button to define 
the search range.

If the Column option button is selected, use the menu to select which column is searched.

In the Operation area, select one of the operator checkboxes to find values equal to, less than, 
greater than the search value. Multiple checkboxes can be selected to create additional operators.

= (equal to the search value)
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< (less than the search value)

<= (less than or equal to the search value)

> (greater than the search value)

>= (greater than or equal to the search value)

<> (not equal to the search value)

Sorting a worksheet
Worksheet columns can be sorted in ascending or descending order, and the sorted column position 
can be further ordered in the Sort Worksheet dialog.

Any worksheet, including imported datasets and the results of an analysis can be sorted. Sorting a 
worksheet has two different effects, depending on the type of worksheet that is sorted.

• Sorting a source worksheet, creates a permanent change in the way the worksheet is 
ordered. It affects all operational objects that use that worksheet so they are marked as out-
of-date.

• Sorting a results worksheet only changes the order in which the data is displayed. If users 
want to make permanent changes to the way a results worksheet is sorted, then that work-
sheet can be copied to the Data folder or mapped to a Column Transformation object.

To sort a worksheet

Click the Sort Worksheet  (Sort Worksheet icon) button that is located above every worksheet.

Or select Edit > Sort Worksheet. 

In the dialog, click the Sort Direction arrow next to a column name to select a sort direction. Sort 
direction options include Ascending (increasing) or Descending (decreasing). Changing the sort 
direction changes the column order in the dialog, but does not change the sort order in the work-
sheet.

Select a sorted column in the dialog and move it up or down in the list by clicking the Up and Down 
arrow buttons.
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When finished, click OK to apply the changes and close the dialog, or click Apply to apply the 
changes and leave the dialog open.

Click Clear Sort to clear all specified sort orders.

Note: If a column has no specified sort direction, then the column order cannot be changed in this dialog. 
However, the column order can still be changed in the Columns tab.

Using Edit in Excel
If Microsoft Excel is installed, users can edit worksheets and HTML tables in Excel and re-import the 
edited worksheet or table into Phoenix. Excel can be used to enter formulas into worksheets or 
change the formatting of HTML tables.

The following topics are discussed in this section:

Editing a worksheet with Microsoft Excel
Editing an HTML table in Microsoft Excel

Note: Copying and pasting from Phoenix to Excel might not retain the same number of digits or trailing 
zeros, since the tools could have different column formats. An alternative method is to send the 
data to a Table object and create a table with the specified number of decimals or significant fig-
ures for each table column. Then right-click the Table and select Copy to Tables folder. Select 
the copied table in the Tables folder and right-click to select Edit in Excel, which will open the data 
in Excel with preserved formatting. 

Editing a worksheet with Microsoft Excel
If a worksheet has no dependents, which means it is not mapped or connected to an operational 
object, and it is located in the Data folder, then it can be edited in Excel. In order to edit a Phoenix 
object's result worksheet in Excel, it first must be copied to the Data folder by right-clicking the work-
sheet and selecting Copy to Data Folder.

In the Object Browser, select a worksheet in the Data folder.

Select Edit > Edit in Excel.
Or right-click the worksheet and select Edit in Excel.

A dialog is displayed warning that all editing done in Excel is logged as a single, generic audit entry.

Click OK to open the worksheet in Excel.

Edit the worksheet using the Excel tools. 

Note: While a worksheet is being edited in Excel, it cannot be mapped to any operational object.

When finished editing, save the worksheet in Excel using File > Save and close Excel. 
Be sure to save the worksheet before closing Excel, or all changes will be lost.

Caution: Because of the way Phoenix handles its interactions with Excel, users cannot use the Save As 
option in Excel to save the worksheet with a different name or to a different location. The Save 
option must be used. If the worksheet name or file location is changed, the Excel edits cannot be 
imported into Phoenix.
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In the dialog, click Yes to apply the changes.
An entry is written in the worksheet’s History tab noting that it was edited in Excel.

In the next dialog, click Yes to save formulas in the worksheet. 
The worksheet is no longer editable in Phoenix, but it can be edited in Excel and the worksheet can 
still be used with operational objects.
If formulas are not saved, only the formula results are saved, and the worksheet can be edited in 
Phoenix. However, the formulas will not be available the next time the worksheet is edited in Excel.

In addition to editing the data in a worksheet, users can edit the units associated with each column. If 
a worksheet has a units row, edit the units in that row. If a worksheet does not have a units row, enter-
ing units adds the units to a row in the worksheet, but not the column headers.

When the worksheet is open in Excel, it is stored in a temp directory located at C:\Users\<user 
name>\AppData\Local\Temp\Phoenix. The temp directory’s name starts with PhxExcel_, 
followed by a unique identifier.

Note: For worksheets edited in Excel, with formulas saved, if the Refresh from Source option in the 
edited right-click menu is used, the worksheet is empty. To get the data back, use the Edit in 
Excel option again, make a change to the dataset and then save the changes back to Phoenix, the 
worksheet will be restored.

Editing an HTML table in Microsoft Excel
The Table object in Phoenix creates tables in HTML format. To edit a table in Excel, it first must be 
copied to the Table folder by right-clicking the table output and selecting Copy to Tables Folder. 

In the Object Browser, select a worksheet in the Table folder.

Select Edit > Edit in Excel.
Or right-click the worksheet and select Edit in Excel.

When finished editing in Excel, select File > Save As and change the filename. 
Excel cannot publish to the same file that is being edited.

In the Save as type menu, make sure that Web Page (*.htm;*.html) is selected.

Click Publish.

In the next dialog, click Publish.

Close Excel without saving. 

When asked to apply the changes to the table, click Yes.
An entry is written in the table’s History tab noting that it was edited in Excel.

In the next dialog, select the renamed HTML file and click Open. 
The HTML file’s name is the same one entered in Excel.

The HTML table in the Tables folder now contains the edits made in Excel.

When the table is open in Excel, it is stored as a temp file which, by default, is located in 
C:\Users\<username>\AppData\Local\Temp\Phoenix. 

Rules for editing worksheets and HTML tables in Excel:

• Only worksheets and HTML tables in the can be edited in Excel.

• Worksheet format edits (fonts, shading, etc.) are not saved when saving back to Phoenix.
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• HTML table format edits are saved when saving back to Phoenix and the user chooses to apply 
the changes.

• Only formatting available in standard Phoenix tables are supported. For non-standard tables, the 
HTML is passed to Excel as is.

• Multiple worksheets and HTML tables can be edited at once.

• If a text value is added to a Numeric-type column, then the column is changed to a Text-type 
when the changes are applied in Phoenix.

• The edited worksheet and table will match any changes that Excel automatically makes to those 
files.

• Formulas cannot be edited in Phoenix. If a worksheet contains formulas and the formulas are 
saved when the worksheet is imported back into Phoenix, then the worksheet can no longer be 
edited in Phoenix.

• Worksheets that cannot be edited in Phoenix are shaded gray.

• Detailed edits made in Excel are not recorded in the worksheet’s or table’s history tab. The His-
tory tab only records a single edit entry named “Object Edited in Excel.”
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Using the Units Builder
This section includes information on the following topics:

Adding new units
Converting existing units
Changing units without conversion
Removing units
Converting between grams (g) and moles (mol)
Valid units and prefixes in Phoenix

Phoenix recognizes certain units as valid, which means Phoenix can convert those units and their 
associated values. Invalid units can still be added but cannot be converted. Invalid units are placed 
inside curly brackets. For example, {mmHg} is an invalid unit and that is denoted by the curly brack-
ets. When unsure of the unit abbreviations recognized by Phoenix, use the Units Builder dialog.

Note: Avoid using spaces in the units, as they are considered invalid characters, even though the Units 
Builder does not flag them with curly braces.

With a worksheet displayed, click Units Builder in the Columns tab.

Note: Conversions involving “deca” should be avoided as they will generate incorrect results due to a 
defect in a third party product.

Invalid, or nonstandard units are carried throughout any operation, such as descriptive statistics, but 
not used in any calculations. For a list of valid units and prefixes, see “Valid units and prefixes in 
Phoenix”.

Adding new units
In the Units Builder dialog, type the units in the New Units field and click OK.
Or 

In the Time menu, select a time unit and click Add to add the unit to the New Units field.

In the Mass prefix menu, select a mass prefix.

In the Mass unit menu, select a mass unit.

Click Add to add the mass unit to the New Units field.
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In the Volume prefix menu, select a volume prefix.

In the Volume unit menu, select a volume unit.

Click Add to add the volume unit to the New Units field.

To add an operator to a unit, click one of the operator buttons.

 (multiplication)      (square)     (division)

Click OK to add the unit to the column header.

Invalid units are displayed in red text in the New Units field. If an invalid unit is specified, Phoenix dis-
plays a warning message asking if you wish to continue. Clicking Yes adds the unit.

When importing a dataset with units, be sure the Has units row checkbox is checked in the Import 
dialog to display the units in the column headers. Otherwise, the units are displayed in the first row, 
since units are stored in a row in a worksheet. 

When exporting a dataset with units, be sure the Output units checkbox is checked in the Export 
dialog. Otherwise, the units are not saved in the exported dataset.

Converting existing units
If a unit can be converted, the Convert Units option button is automatically selected. (Invalid units 
cannot be converted, and must be cleared before new units can be added.)

Type the new unit in the New Units field and click OK. 

The new unit is added to the column header and the values in the selected column are automatically 
converted.

Note: Units cannot be converted using the Unit Components menus. Selecting a unit from these menus 
only appends the selected unit to the existing unit. It does not convert them.

If Phoenix cannot convert a unit and its values, a warning message is displayed if you would like to 
set the unit anyway. Clicking Yes sets the unit.

Changing units without conversion
In the Units Builder dialog, select the Specify Units option button. 
(The Convert Units option button is selected by default if a column already has units.)

In the New Units field, type the new unit.
Or use the Unit Components menus and the operator buttons to enter the unit.

Click OK.

The unit is changed without converting the values in the column.

Removing units

Note: Only use the Clear Units button if want to change the unit label without changing the numbers, as 
clearing the units makes Phoenix “forget” the original unit.

In the Units Builder dialog, click Clear Units and then click OK.

The unit is removed from the column header.
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Converting between grams (g) and moles (mol)
Select the column that contains units in grams (g) or moles (mol).

Click Units Builder.

In the Units Builder dialog, type mol in the New Units field if the values are in grams or (mass 
prefix)g if the values are in moles (mol).

In the Molecular weight field, type the molecular weight and click OK.

The new unit is added to the column header and all values in the selected column are automatically 
converted.

Valid units and prefixes in Phoenix
Valid units and prefixes for time include: hour [h], hour [hr], day [day], minute [min], second [sec], sec-
ond [s], millisecond [ms], microsecond [us], nanosecond [ns], week [week], month [month], year [year]

Valid units and prefixes for mass include: gram [g], mol [mol], pound [lb], IU [IU], femto [f], pico [p], 
nano [n], micro [u], milli [m], centi [c], deci [d], deca [dk], kilo [k]

Valid units and prefixes for volume include: liter [L], femto [f], pico [p], nano [n], micro [u], milli [m], 
centi [c], deci [d], deca [dk], kilo [k]
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Printing
The results of any executed operational object can be printed. Phoenix can also print worksheets, text 
files of any format, .rtf files, .map files, .lib files, .mdl files, and HTML tables. 

Note: The only items in the Documents folder that can be printed are text files. Any other files imported 
into the Documents folder, including types that Phoenix can print, are not printable if they are in the 
Documents folder.

Printing object results
Select the Results tab of any executed operational object.

Select any text or plot object in the Results tab.

Click  (Print Results icon).

In the Print dialog, select a printer, the number of pages and copies to print, and click OK.

Printing items in the Object Browser
Not all objects in the Object Browser can be printed. For example, workbooks and most objects in the 
Documents folder cannot be printed. 

If an item cannot be printed, the Print and Print Preview options in the File menu are disabled.

To set up a page for printing

Select File > Page Setup.

The Page Setup dialog has several tabs containing setup options for headers, footers, page orienta-
tion, margins and other options that are relevant for a particular type of object.

To set up plot printing

Select the Plots tab.

To specify how multiple charts are to appear on a printed page, check the Multiple charts per page 
box and choose a predefined layout from the pull-down menu.
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Specify the orientation of the charts on the page as either Portrait or Landscape.

Enter the size of each page margin (in inches).

To set up worksheet printing

Select the Worksheets tab.

Select the Layout sub-tab.

Specify the orientation of the data on the page as Portrait or Landscape.

Enter the size of each page margin (in inches).

Select the Header sub-tab.

In the Header field, enter codes for information to include in the header in the order they should 
appear.

Codes supported for formatting headers and footers include:

&D (Date)
&N (Total number of pages)
&P (Current page number)
&T (Time)
&O (Object name)

The options on the Footer tab can be set in the same manner as described for the Header tab.
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Note: The options on the DME Plot Tables tab and the NONMEM Plot Tables tab are identical to those in 
the Worksheets Layout tab.

To print single objects

Select an object in the Data, Code, Tables, or Documents folders.

Select File > Print.
Or type CTRL+P. 

To print multiple objects

Select File > Print All. 

In the dialog, click Print to print all printable items in the Object Browser
This includes the results of any executed operational object, any internal worksheets created by oper-
ational objects, and any imported and user-created files.

Or 

Uncheck the Select all Objects box and check/uncheck the boxes beside each item to include or 
exclude it in the print job and then click Print.

Click Options in the dialog.

Check the Multiple charts per page box to print multiple charts per page.

Click the chart layout menu to select how many charts to print down and across each page.

Click OK.
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Exporting
Objects that Phoenix can export using File > Export or the Export icon include workflows, opera-
tional objects, workbooks, worksheets, text objects, BQL rules, plots, and HTML tables.

A separate Word Export tool allows users to export worksheets, HTML tables, plots, and text objects 
to Microsoft Word. See Exporting to Microsoft Word.

Exporting an object
With an object selected for export, choose File > Export or click the Export icon. 
If an object cannot be exported the Export button is unavailable.

In the dialog, use the Save in menu to select a directory.

Type a file name in the File name field or accept the default.

Use the Save as type menu to select the file format for the exported file.

For more details, see:

Workbooks and worksheets
HTML tables
BQL rule sets
Text objects
Plots

Workbooks and worksheets

Workbooks in the Data folder are only exported as Excel files (.xls or .xlsx). Worksheets in the 
Data folder and in the Results tab can be exported as the following file types:

Excel 97-2003 Workbook (*.xls)
Excel Workbook (*.xlsx)
SAS Transport Format (XPORT) Version 5 (*.xpt)
Text (Comma delimited) (*.csv)
Text (Space delimited (*.dat)
Text (Tab delimited) (*.txt)

Caution: To export output in the Results tab, click the Export icon in the Results tab toolbar. Otherwise, the 
selected operational object is exported, and not the results.
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To set options for Excel export

Exporting a worksheet or workbook as an Excel file displays the Excel Export Options dialog.

Check the Output column headers box to save the column headers in the Excel file.

Check the Output units box to save column units in the Excel file.

Type a value in the MissingValue field to have that value inserted in any blank cells in the worksheet.

Click OK to save the worksheet or workbook as an Excel file or click Cancel to cancel the export.

Worksheets saved as an Excel file have their history worksheet saved with them. 

Caution: Only the Excel export format supports saving the history worksheet with the dataset.

To set up for SAS export

Exporting a worksheet as a SAS Transport File displays the Rename Columns dialog.

Enter information in the table that is appropriate for the data being exported:

Column Name: The column name in Phoenix; it cannot be changed.

SAS Variable: Enter the name of the SAS variable or use the default (limited to eight characters).

SAS Label: Enter the SAS column label header or use the default name (limited to 40 charac-
ters).

Include: Set to True to include or False to exclude the column.

Precision Type: Set the precision type to either Significant Digits or Decimal Places.

Precision: Enter the number of significant digits or decimal places or use the default value. 
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Data Type: Select the data type as Numeric or Text, or leave it set to Auto to export the column 
as it is in Phoenix.

Data Set Name: Enter a name for the data set. 
This name is internal to SAS and independent of the actual file name.

To save the SAS export settings in the Documents folder, click Save Settings.
The settings are saved as a text file and named after the dataset name.

To load the SAS export settings from the Documents folder, click Load Settings. 
In the dialog, select an SAS export settings file in the Documents folder and click Select.

Click OK to save the worksheet as an SAS Transport File.

To set up a text export

Exporting a worksheet as a text (comma, space, or tab delimited) file displays the Data Export 
Options dialog.

Figure 17-1. Data Export Options dialog for a .csv, .dat, or .txt data file

Check the Output column headers box to include column headers in the worksheet.

Check the Output units box to include column units in the worksheet.

Check the Use cell formatting box to preserve custom cell formatting in the worksheet.

Type the value in the MissingValue field that is to be inserted in any blank cells in the worksheet.

Select one of the Delimiter option buttons to choose how to separate values in the worksheet.

By default, .csv files use a comma to separate values, .dat files use a space to separate val-
ues, and .txt files use a tab to separate values.

Check the Ignore box beside a column name to exclude that column in the output file.

Click OK to save the worksheet as a .csv, .dat, or .txt file.
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HTML tables
Select an HTML table in the Tables folder. 

Export the selected table. 

The table is exported as an HTML file.

BQL rule sets
Select a rule set in the BQL folder.

Export the rule set. 

The rule set is exported as a .phxruleset file.

Text objects
Text objects in the Code folder, the Documents folder, and in the Results tab are exported as the fol-
lowing file types:

RTF File (*.rtf)
Text File (*.txt)

Caution: To export output in the Results tab, click the Export icon in the Results tab toolbar. Otherwise, the 
selected operational object is exported, and not the results.

Plots
Plots in the Results tab are exported as the following file types:

Bitmap (*.bmp)
Enhanced Meta File (*.emf)
GIF (*.gif)
JPEG (*.jpg)
PNG (*.png)
Tiff (*

Caution: To export output in the Results tab, click the Export icon in the Results tab toolbar. Otherwise, the 
selected operational object is exported, and not the results.



Exporting

101

To set up image export

Exporting a plot as an image file displays the Export dialog with the following additional options.

Check the Keep aspect ratio box to keep the original ratio of width to height as adjustments are 
made.

Click Reset to return the settings to the original values.

Adjustments to the image can be made based on pixels or print. 

For pixel adjustments, use the Resolution pull-down to specify the dpi setting. 

For print adjustments, select the units to use from the Units pull-down.

Make the desired changes to the Width and/or Height values. 
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Exporting to Microsoft Word
The Word Export tool allows users to export items, such as external and internal source worksheets, 
code files, images, results worksheets, results text, plots, Information tab text, and History work-
sheets, to a Word file.

To set up an export to a Word file

Select File > Word Export.

In the dialog, click the (+) signs next to Data, Code, or Workflow to expand each list.

Check the checkbox beside the project name to select all exportable items.
Or check the checkbox next to individual items to include them in the Word document.

Click Export to export the selected items to a Word document.

Click Options to display the Word Export Options dialog.

In the Document tab:

Choose the page orientation by selecting the Portrait or Landscape option button.

Check the Add source line to object box (the default) to include a source line stating the project, 
workflow, and object used to create each exported item.

In the Charts tab:

Check the Multiple charts per page box to export more than one plot per page.

In the Down and Across menus, select the number of rows of plots (Down) and columns of plots 
(Across) to display per page.

Check the Add page break box to add a blank page between each plot or grouping of multiple 
plots.

Check the Include both linear and log charts box to export linear and logarithmic Y-axes ver-
sions of plots.
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Check the Start chart numbers at box to numerically label the charts. For example, Figure 1, 
Figure 2, etc. In the field, type the first number to use when labeling exported plots. The default is 
one.

In the Chart Format area, select the Export chart as metafile or Export chart as bitmap option 
button to choose the chart output format.

In the Workbooks tab:

Check the Start table numbers at box to numerically label the worksheets. For example, Table 1, 
Table 2, etc. In the field type the first number to use when labeling exported worksheets. The 
default is one. This option is ignored when exporting HTML tables created in Phoenix.

Check the Heading rows repeat box to have the worksheet column headers repeat on every 
new page.

Click Finished when all options are specified.

Click the checkbox of a particular type of object in the Object Types to Select list to select/deselect 
all objects of the specified type.

Click Export to export all selected items. The Word document is displayed when the export is fin-
ished.
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Executing Objects and Workflows
Individual objects in a workflow can be executed as well as an entire workflow. In many cases, the 
execution can be done locally or remotely. (See “RPS” for details on setting up Phoenix to use RPS 
for executing remotely.)

Note: Depending on the types of objects that make up the Workflow, executing the Workflow may some-
times fail if one object tries to start before another object, whose results are needed as input, fin-
ishes. In such cases, try executing the objects separately.

To execute an object

Select that object in the Object Browser and click the Execute icon or the Execute Remotely icon in 
the toolbar.

Or right-click an object in the Object Browser or in the Diagram and select Execute from the right-click 
menu.

Or with the object selected, right-click an empty space in the Object Browser or in the Diagram and 
select Execute from the right-click menu.

To execute an entire workflow

Select the workflow in the Object Browser or in the Diagram and click the Execute icon or the Exe-
cute Remotely icon in the toolbar.

Or right-click a workflow item in the Object Browser or in the Diagram and select Execute from the 
right-click menu.

Or with the workflow selected, right-click an empty space in the Object Browser or in the Diagram and 
select Execute from the right-click menu.
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BQL
Data analysis, tabulation, plotting, and summarization are problematic when the data contain concen-
trations that fall below the lower limit of quantification (LLOQ) of the assay. The LLOQ is the concen-
tration whose lower bound (of variability in the assay) includes zero. An analyte may be detectable 
below this concentration even though it is not quantifiable.The BQL object allows users to define rule 
sets to filter out unusable data in a dataset using a BQL (Below Quantifiable Limit) rule set.

Standard laboratory procedures can require that such data be reported as a character string rather 
than a numerical value. Representing such a concentration as zero is not always appropriate, as 
doing so can introduce a statistical bias or misrepresentation in some analyses. Different substitution 
rules are required depending on the intended use of the data, and substitution rules vary between 
companies and departments. As a result, it may be necessary to perform a custom transformation of 
the BQL column in your dataset. Refer to the “Data Wizard” section, specifically the “Example custom 
functions” has several example functions used for BQL columns.

The BQL object is used to create useful datasets by substituting different non-numerical codes for 
concentration levels too low to be used in an analysis.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Data Management > BQL. 
Or Main menu: Insert > Data Management > BQL.
Or right-click menu for a worksheet: Send To > Data Management > BQL.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

This section contains information about the following:

User interface description
General BQL rules
BQL output

User interface description
Main Mappings panel
Rule Set panel

Main Mappings panel
Use the Main Mappings panel to identify how input variables are used in a BQL object. Required input 
is highlighted orange in the interface.

None: Data types mapped to this context are not included in any analysis or output.
Sort: Categorical variable(s) identifying individual data profiles, such as subject ID and treatment 
in a crossover study. A separate computation is done for each unique combination of sort variable 
values.
Time: Nominal time or actual time (time that a study dose or observation actually happened) col-
lection points in a study.
Concentration: Drug concentration values in the blood.
Status Code: (Optional) Column containing the non-numeric status codes associated with each 
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datum in the Concentration column; determines transformation of the concentration values.
LLOQ: (Optional) Column containing the lower limit of quantification (LLOQ) associated with each 
measurement in the concentration variable.
Carry Along: Variables that are not required for the current analysis, but are copied and included 
in the output dataset.

Rule Set panel
The Rule Set panel allows users to map a BQL rule set to the BQL object, or define their own BQL 
rules using the internal BQL Rule Set worksheet. See “General BQL rules” for more information on 
BQL rules.

There are two ways to create a BQL rule set: create a rule set in Rule Set panel in the BQL object or 
in the BQL Rules folder.

Use the Rule Set panel
Select the Rule Set panel in the Setup tab.
Check the Use internal BQL Rule Set box.
Users can now define their own rule set as an internal worksheet in the Rule Set panel.

Use the BQL Rules folder
Select the BQL Rules folder in the Object Browser.
Right-click BQL Rules and select New > Rule Set. (Adds a new rule set to the BQL Rules folder.)
Rename the rule set or leave the default name.

Define a rule set

Note: The steps and interface used to define a BQL rule set are the same whether the BQL Rules folder 
or the Rule Set panel is used.

Enter the following information to define the rules:

Nonnumeric Code: Status code to be transformed.

Unconditional Substitution: If the transformation is the same regardless of whether the status 
code occurs before or after Tmax, or is repeated, this is the value to which the status code is 
transformed. An unconditional substitution is the same as a REPLACE ALL function within the 
column mapped to Concentration.
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
For conditional substitutions, where the transformation depends on the status code’s position 
relative to Tmax and whether or not the code is repeated in consecutive observations, then leave 
the cell in the Unconditional Substitution column blank and enter values in the subsequent four 
columns.

Conditional substitutions are based on being able to identify a Tmax (time when the maximum 
concentration is observed within a profile) and its corresponding concentration (Cmax). The first 
four parts of a conditional substitution need to be defined, but the fifth substitution is optional and 
not applied if left empty. The tool always sorts by the variable mapped to Time before applying the 
rule to the column mapped to Concentration:

Before Tmax: Value for any status code that occurs before Tmax.

After Tmax: Value to use for any status code that occurs after Tmax and is not followed, nor pre-
ceded, by the same status code (i.e., the value is isolated).

First of consecutive after Tmax: Value for any status code that occurs after Tmax and is fol-
lowed, but not preceded, by the same status code (i.e., this value is assigned to the first of those 
contiguous observations).

After First of Consecutive after Tmax: Value for any status code that occurs after Tmax and is 
preceded by the same status code (i.e., this value is assigned to all status codes except the first 
of those contiguous observations).

All Entries After 2 Consecutive after Tmax [Optional]: Value for any status code that occurs 
after Tmax and is preceded by two identical observations (i.e., the value assigned to all trailing 
observations (status codes or values) except the first and second of those contiguous observa-
tions). This substitution is optional and should be left blank if one does not wish to apply it.

Any entry that is not equal to the non-numeric code breaks the consecutive assessment including 
blank and missing values. These should be removed prior to applying conditional substitutions if 
the consecutive rule should ignore them. 

Tmax is considered the maximum value in the column concentration within unique combinations 
of sort variables (typically subject). If there is more than one Tmax within a profile, the first Tmax 
is used for the conditional substitution. Note that the tool automatically sorts by the sort variables 
and then by the column mapped to TIME.

Conditional substitution rules are only applied if there is at least one numerical value in the col-
umn mapped to concentration. For example, if all the values within a profile are equal the non-
numeric code (e.g. BQL) then the resulting column will present blank data for the profile. How-
ever, if there is an unconditional substitution beforehand then the results will present the original 
values in the column mapped to concentration (e.g., BQL).

Use When < LLOQ: Check to indicate that, when numeric values less than the LLOQ are 
encountered, those values are transformed as though they contained the status code.

This checkbox can be used with conditional and unconditional substitutions, but an LLOQ needs 
to be defined either by entering a static value in the rule or by mapping a column with these val-
ues to the LLOQ column. 

Only one non-numeric code can be assigned to Use When < LLOQ. When selected, the tool will 
compare concentrations values to the LLOQ for each row, and if the value is less than the LLOQ 
then it treats it as if it has been recorded as the non-numeric code and thus, the same rules as the 
non-numeric code will be applied to that number. For example, if the unconditional substitution is 
that BQL non-numeric code should be set to zero, the LLOQ is static to 0.5 and the Use When < 
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LLOQ is checked, any concentration equal to BQL and any concentration less than 0.5 will be set 
to zero.

If a profile has concentration values but all of those are < LLOQ a conditional substitution will con-
sider the first value in the concentration column to be tmax and the substitution will take place 
based on this assessment. In other words, the first concentration will be set to substitution for first 
consecutive and the following concentrations will be set to the value for the after first consecutive.

Set to LLOQ and censor: Check to set the resulting concentration cell to the LLOQ value (the 
static value or the value from the LLOQ mapped column). A column named CObsBQL is created 
in the output.

This substitution is mutually exclusive from the other existing substitutions (conditional and 
unconditional) therefore only one type of substitution can be used for each rule. If the option to 
Set to LLOQ and censor is selected for a nonnumeric code it sets that resulting concentration 
cell to the LLOQ value (the static value or the value from the LLOQ mapped column) and creates 
an additional column: CObsBQL. 

The cell that is modified by the censoring substitution (i.e. set to LLOQ value) gets a correspond-
ing value of one for CObsBQL, if no substitution took place then a value of zero is assigned to 
CObsBQL. The values assigned to the censored column CObsBQL are either zero or one. If the 
option of Use When < LLOQ is checked in conjunction with the censoring substitution then any 
numeric value less than LLOQ is set to the LLOQ value and the censoring flag is set to one. 

This option is designed to integrate with Maximum Likelihood models. A resulting worksheet of a 
BQL object with a censored column CObsBQL can be used as the input for a Maximum Likeli-
hood model with the option BQL?. If BQL? is selected, a column can be mapped to the 
CObsBQL context in the Main Mappings panel. This column can contain two categories of val-
ues: non-zero (censored) or zero (non-censored). If a concentration value is marked as censored 
(CObsBQL<>0), it means that the true value of the observation is unknown but it is not greater 
than the observed value (e.g., LLOQ) and then the cumulative distribution function for the nor-
mally distributed error is used to calculate the likelihood. If a concentration value is flagged as 
non-censored, then the probability density function is used to calculate the likelihood.

Note: Maximum Likelihood models with censored data (BQL? option) use the log of the probabilities 
between 0 and the censored number in the log likelihoods. If the censoring numbers are very 
small, the loglikelihood might overflow, resulting in a Fortran error. This seems to be more often 
the case when using multiplicative error models. If the error occurs, try increasing the BQL value if 
possible or change error types.

Check the Use Static LLOQ Value box to set a fixed LLOQ value.

In the LLOQ Value field, type the LLOQ value.

Note: When a static LLOQ value is specified the static value is always used, even if a dataset column is 
mapped to the LLOQ context in the BQL object.

Additional status codes can be entered under Non-numeric Code. Each new status code that is 
entered creates a new row in the rule set. To remove a row, left-click the row number to select the 
entire row and press the Delete key.

Syntax for the rules: The status rules are not case-sensitive. The values entered can include num-
bers, operators, and the variable LLOQ, if an LLOQ value or data column is assigned.
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General BQL rules
• A rule in a rule set can only do a conditional substitution or an unconditional substitution, not both.

• If a rule set has rules for the same exact non-numeric value, then the last rule is applied.

• A rule set can list several non-numeric codes with different substitution rules. These rules are 
considered independent of each other. For example, if the rule set states to substitute concentra-
tions equal to < LLOQ and set them to BQL, and then another rule within the same rule set indi-
cates to take all BQL values and set them to zero, concentrations of < LLOQ are shown as BQL 
and not zero, regardless of the order of the rules.

• The BQL object provides the option to map a column with the LLOQ values or to enter a static 
LLOQ value within the rule set. If both options are used the static option takes precedence over 
the mapped LLOQ column. 

• A numeric value is allowed to be entered as a non-numeric code. The tool will search for the exact 
value with the exact precision before a substitution takes place. The search will take place in the 
column mapped to Concentration unless the Status Code option is selected. In that case the 
search will take place in the column mapped to the Status Code instead.

• A rule that resides within the folder BQL Rules can be used in a BQL object or several BQL 
objects. An internal rule resides within a given BQL object and cannot be used by another object. 
If the rules are the same there is no difference in the results if an external or internal rule is used.

Common substitution rules
• Substitutions are either unconditional or conditional.

• The nonnumeric code column must contain non-numeric values.

• Only one column can apply rules for the below LLOQ concentration.

Some common substitution rules for BQL samples are presented in the table below.

The substitution rules are typically defined in standard operating procedures or method sheets for a 
given company or department. The rules can become more complex when a user wishes to make a 
distinction between concentrations that are below the quantification limit (BQL) and below the detec-
tion limit (BDL). In general, a substitution rule is defined by the list of possible non-numeric represen-
tations for concentration and the values to be substituted for each. One possible substitution rule for 
PK analyses is presented below:



Phoenix Framework
User’s Guide

112

The BQL object transforms observation values from non-numeric status codes to number values for 
use in analyses and plots. It can also convert unusable concentration values to non-numeric status 
codes. The BQL object creates a new worksheet based on an existing one, by copying over selected 
columns.

It transforms values in the input worksheet as specified by user-defined rules. Numeric concentration 
data and the non-numeric concentration status codes can be in the same or different columns in the 
dataset. 

The BQL object also stores information about the lower limit of quantification (LLOQ) for one or more 
sampling assays. Users can specify an LLOQ and the new column header into which it is placed, or 
identify an existing column containing the LLOQ for each observed concentration. The LLOQ, if any, 
can be used to define how status codes are transformed.

BQL output
The BQL object generates one worksheet and one text file.

Output: The worksheet with the updated concentration column.
Settings: The input worksheet used and the options selected.
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CDISC Data Preparer
The CDISC Data Preparer object produces analysis ready datasets (SAMPLE and DOSE) in Phoenix, 
using CDISC formatted dataset inputs of either SDTM (Study Data Tabulation Model) or SEND (Stan-
dard for Exchange of Nonclinical Data). 

• CDISC SDTM is a unified way of transmitting information in drug studies with precise column 
names and a common file format. CDISC Data Preparer produces output in the STDM format 
that is compliant with the standards in the SDTM Implementation Guide 3.1.1. 

• CDISC SEND is an implementation of SDTM for nonclinical studies and specifies a consistent 
format for presenting and exchanging nonclinical data. The CDISC Data Preparer produces 
output in the SEND format that is compliant with the standards in the SEND Implementation 
Guide 3.0. 

For further information, please visit the Clinical Data Interchange Standards Consortium Web site at 
www.cdisc.org.

CDISC input datasets must have the following domains in order for the CDISC Data Preparer object 
to generate a PK dataset:

DM: Demographic information; one row per subject
PC: PK concentrations data, one record per concentration per analyte
EX: Exposure, one record per constant dosing interval per subject

The input dataset can also include Finding domains such as:

EG: ECG tests
LB: Laboratory tests
PE: Physical examinations
QS: Questionnaire
SC: Subject characteristics
VS: Vital signs
MB: Microbiology specimens
PP: Pharmacokinetics parameters

Findings domains can contain time-dependent data, but the times do not necessarily match the times 
of the samples or treatments. The CDISC Data Preparer object uses processing rules to locate data 
corresponding to the time of data collection.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Data Management > CDISC Data Preparer. 
Main menu: Insert > Data Management > CDISC Data Preparer.
Right-click menu for a worksheet: Send To > Data Management > CDISC Data Preparer.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Additional information is available for the following topics:

User interface description
Results

See also “CDISC Data Preparer Example”.

http://www.cdisc.org/
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User interface description
Demographics panel
Exposure panel
PK Findings panel
Other Findings panel
Options tab
Exposure tab
PK Findings tab
Other Findings tab

Note: Required Mappings are highlighted in orange.

Demographics panel
Add data that is to be included in the output. The Demographics panel contains an internal worksheet 
that can be used to manually enter concentration data, or a concentration worksheet can be mapped 
to it.

None: Data types mapped to this context are not included in any analysis or output.
Subject Identifier: The unique identifier of the subjects in a dataset.
Demographic: Data to include in the output datasets.

Exposure panel
Specify how the exposure columns are treated when producing the Dose result dataset. The panel 
can also be used to identify the columns to use in joining the sample domain and the columns to 
include in the Sample dataset.

Dose context definitions:

None: Data types mapped to this context are not included in any analysis or output.
Pivot: Identifiers of the unique dose tests.
Dose: Actual dose amount.
Unit: Unit of the actual dose amount.
Carry to Dose Dataset: Data to include in the Dose result dataset.

Sample context definitions:

None: No action should be taken for the exposure field related to the Sample dataset.
Join: Set of columns to use to join the PK Findings domain. Typically, the EXSTDTC field (Start 
Date/Time of Treatment) from the EX domain is referenced in the PC domain PCRFTDTC field 
(Date/Time of Reference Point), and this field alone can be configured as the Join column; how-
ever, a combination of fields can be used to join the EX and PC domains.
Carry to Sample Dataset: Data to include in the Sample result dataset. It is often necessary to 
carry some fields from the EX domain to the Sample result dataset so that sort keys can be spec-
ified between the Dose and Sample datasets during analysis.

PK Findings panel
Specify the data from PK Findings tests.

None: Data types mapped to this context are not included in any analysis or output.
Test Identifier: Identifiers for unique PK Findings test. The unique tests are displayed in the PK 
Findings properties tab.
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Row: Data to include, and that represent the unique set of rows. All unique combinations of Row 
and Join columns determine the number of sample rows in the result dataset.
Carry: Data to carry over unchanged in the output worksheets.

Each column selected as a Join column in the EX domain will appear as a column mapping context 
for the PC domain. This allows the user to specify what column in the PC domain corresponds to what 
column in the EX domain. In most cases, the EXSTDTC (Start Date/Time of Treatment) context will be 
mapped to the PCRFTDTC (Date/Time of Reference Point) field in the PC domain.

PCELTM column requirement
Although PCTPT (Planned Time Point Name), PCTPTNUM (Planned Time Point Number), and 
PCELTM (Planned Elapsed Time from Time Point Ref) tabulate the same information, they each have 
a different format and only PCELTM has a defined standard format. Therefore, PCELTM is the vari-
able that CDISC Data Preparer uses to calculate Relative Nominal Times for the Sample result data-
set. If your datasets usually have PCTPT or PCTPTNUM instead of PCELTM, you will need to create 
a PCELTM column from the other column. If PCELTM is not in the dataset, or not carried along, or not 
in the proper format, CDISC Data Preparer generates a warning. 

The PCELTM column values need to be in hours and have units of “hr” specified in the header. The 
column type must be text. 

To create the PCELTM column from a PCTPTNUM or PCTPT column:

1. Use the Data Wizard object’s Transformation action to copy the contents of the column to a new 
PCELTM column. You can use the arithmetic formula “x-n” and set “n” to 0.

2. Create a Properties step to specify the column units as “hr” and, if the data is from a PCTPTNUM 
column, set the column’s data type to Text.

3. If the data is from a PCTPT column, create a Filter step involving multiple filters to replace “PRE-
DOSE” with “0”, “15MIN” with “0.25”, “30MIN” with “0.5”, “45MIN” with “0.75”, “1H” with “1”, etc.

Other Findings panel
Specify additional tests to include in the data preparation.

None: Columns mapped to this context are not used to identify the tests performed.
Pivot: The fields identified as Pivot fields are used to identify the tests to be included in the Sam-
ple results. For example, in the VS domain, the tests might be identified by the combination of the 
VSTEST (Vital Signs Test Name) and the VSPOS (Vital Signs Position of Subject) fields.

Options tab
Add or remove the Other Findings items listed in the Setup. 

Add Other Findings: Add another Other Findings item (displays as Other Findings1) in the 
Setup panel list.
Remove Other: Remove an Other Findings item from the Setup panel list. This button only 
removes Other Findings item that were added using the Add Other Findings button.
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Exposure tab
The Exposure tab allows users to view the list of unique exposure data combinations based on the 
Exposure context mappings.

EXTRT = Name of Actual Treatment, EXDOSFRM = Dose Form, EXDOSFRQ = Dose Frequency 
per Interval, EXROUTE = Route of Administration

The image above shows a study where, based on the Exposure context mappings, only one expo-
sure specification was identified.

PK Findings tab
The PK Findings tab allows users to view the unique tests that were identified using the PK Findings 
context mappings and select the ones to include.

PCTESTCD = Pharmacokinetic Test Short Name, PCSCAT = Test Subcategory, PCSPEC = 
Specimen Material Type 

Usage: whether to Include or Exclude the test in (from) the output.
Layout: control the display of the test data. See the “Layout Columns” section below for more 
information. Choices are:
– Stacked: create a PCORRES (Result or Finding in Original Units) and PCSTRESN (Numeric 
Result/Finding in Standard Units) result column for each unique unit found in the source dataset 
for the stacked test, 
– Pivoted: for each pivoted test a set of result columns is added in the output.
Result Column: the result column to include for each test (select All to include all of the results 
columns). Result columns are those that match the CDISC specification for results columns in 
original, numeric, or text format.

Layout Columns
The table below shows the sets of columns that will be included in the output depending on the set-
tings for Layout and Result Column.

For example, it would be common to stack urine concentration results for different analytes and pivot 
the urine volume such that the volume and concentration are shown on the same row.
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With the set up shown above, note that the SYDN and SYND_OH concentration results are stacked, 
and the VOLUME data are pivoted to align with the concentrations.

PCTESTCD = Pharmacokinetic Test Short Name, PCORRES = Result or Finding in Original 
Units, PCSTRESC = Character Result/Finding in Std Format, PCSTRESN = Numeric Result/
Finding in Standard Units, PCSTRESU (Standard Units)

Other Findings tab
Select data from multiple other findings domains that were identified using the Other Findings context 
mappings to include in the Sample output. Data is extracted from these datasets by finding the tests 
corresponding to subjects and occurring within a specified time-window relative to the concentration 
sample collection time.

Usage: whether to Include or Exclude the covariate value in (from) the output.
Selection Rule: rule to use to extract data from the dataset. Choices are: 

– Dynamically Pick Closest: Pick test value closest to the PC sample collection time* 
– Dynamically Pick Next: Pick test value that occurred after the sample collection time* 
– Dynamically Pick Previous: Pick test value that occurred prior to the sample collection time* 
– Fixed Baseline: Use the first value marked as a baseline value 
– Fixed Pick First: Pick first value for the test, based on the collection time 
– Fixed Pick Last: Pick last value for the test, based on the collection time 
– Fixed Pick Mean: Calculate the Mean of all numeric test results, regardless of time collected 
– Fixed Pick Median: Calculate the Median of all numeric test results, regardless of time col-
lected.
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Tolerance Interval: The allowed tolerance in the covariate value.
Result: The result column to include for each covariate (select All to include all of the results col-
umns). 

*Value must be within Tolerance Interval, if specified, or no value is returned.

Results
Dose: Worksheet containing: 

• USUBJID
• Selected Demographics, Pivot, Dose, Dose Unit, Carry to Dose Dataset, and Join col-

umns
• Calculated Relative_Actual_Time and Relative_Nominal_Time

Sample: Worksheet containing: 
• USUBJID (Unique Subject Identifier)
• Columns marked as Include in the PK Findings tab 
• Columns selected for joining to the EX domain
• Result column and result unit column for each pivoted test (column name is the concatena-

tion of the Test Identifier and the Result column name)
• LLOQ value for each pivoted test 
• PCSEQ (Sequence Number) value for each pivoted test in the PK Findings domain
• Result column for PCORRES (Result or Finding in Original Units) and PCSTRESN (Numeric 

Result/Finding in Standard Units) for each unique unit found in the source dataset for stacked 
tests

• Result columns for attributes associated with the stacked values: PCORRESU (Original 
Units), PCSTRESU (Standard Units), PCLLOQ (Lower Limit of Quantitation), and PCSEQ for 
stacked results

• Columns from the EX domain marked as Include in Sample Dataset 
• Demographics marked as Demographic in the DM domain
• Calculated time values for Relative_Actual_Time, Relative_Actual_End_Time, and Rela-

tive_Nominal_Time

If a single unit is found for all occurrences in a column, it is displayed in the column header.

Log: Text file containing a list of step performed during processing.

Settings: Text file containing the mapping selections and test selections made by the user and 
applied when processing the data.
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CDISC Data Preparer Example
This example demonstrates the general steps to prepare a CDISC dataset so that it can be used 
within Phoenix. The CDISC Data Preparer object produces analysis-ready datasets (SAMPLE and 
DOSE worksheets) in Phoenix, using CDISC formatted datasets as input. This example will also walk 
through submitting the output of the CDISC Data Preparer as input to an NCA object, which will be 
successfully executed.

There are steps common to many Phoenix objects (e.g., inserting an object, importing and mapping 
data to an object, and executing an object) and can be completed in multiple ways (e.g., main menu 
selection, right-click menu selection, drag and drop operation, etc.). For simplicity, only one mecha-
nism is listed. Please refer to the Phoenix Functions chapter of the Phoenix Framework User’s Guide 
to familiarize yourself with the basic operations used in Phoenix and any alternative mechanisms 
available.

The sections in this example include:

Setting up the project and data
Setting up the CDISC Data Preparer object
Exploring the results
Mapping the results to an NCA model

Setting up the project and data
1. Create a new project named CDISC Prep Example.


The CDISC Data Preparer object is dependent on CDISC Navigator. The CDISC Navigator con-
verts CDISC files, in SAS transport file format (.xpt), into Phoenix worksheets and verifies that the 
data conforms to the standards for the specified domain. Elapsed times are also converted from 
ISO format to numeric times in hours.

2. Select File > CDISC > SDTM > Import.

3. Import the DM.xpt, EX.xpt, and PC.xpt files from …\Examples\CDISC\Single Day.

4. Click Open.

The CDISC SDTM Import dialog is displayed listing any problems that were encountered during 
the import and data validation processes. 
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For this example, there were no errors.

5. Click Close.

Setting up the CDISC Data Preparer object
1. Select Workflow in the Object Browser and then select Insert > Data Management > CDISC 

Data Preparer.

2. Drag the DM worksheet from the Data folder to the Demographics Mappings panel to map it as the 
input source.
The columns are automatically mapped to the appropriate contexts:
– USUBJID to the Subject Identifier context.
– AGE, SEX, and RACE to the Demographic context.These are the columns to include in the out-
put datasets.

3. Select Exposure in the Setup panel list

4. Drag the EX worksheet from the Data folder to the Exposure Mappings panel.

There are two mapping section in the Exposure Mappings. The first section specifies how expo-
sure columns are treated when producing the Dose result dataset. The second section specifies 
which data columns from the Exposure domain are used to join to the Sample domain and which 
exposure columns to include in the Sample result dataset.

The columns are automatically mapped to the appropriate contexts:

• EXTRT (Name of Actual Treatment), 
EXDOSFRM (Dose Form), 
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EXDOSFRQ (Dosing Frequency per Interval), 
EXROUTE (Route of Administration) 
to the Pivot context. 
These columns identify unique dose tests as defined in the Exposure tab. 

• EXDOSE to the Dose context. This column contains the actual dose amount.
• EXDOSU to the Unit context. This column contains the actual unit of the dose amount.
• EXSTDY (Study Day of Start of Treatment), 

EXENDY (Study Day of End of Treatment), 
EXTPT (Planned Time Point Name), 
EXTPTREF (Time Point Reference) 
to the Carry to Dose Dataset context. 

• EXSTDTC (Start Date/Time of Treatment) to the Join context. This column will be used to 
match up data in the PK Findings domain.

• EXTRT, EXDOSFRM, EXDOSFRQ, EXROUTE, EXSTDY, EXENDY, EXTPT, EXTPTREF to 
the Carry to Sample Dataset context. 
This context enables sort keys to be specified between the dose and sample datasets during 
analysis.

5. Select PK Findings in the Setup panel list

6. Drag the PC worksheet from the Data folder to the PK Findings Mappings panel.

Most of the columns are automatically mapped to the appropriate contexts.
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PCTESTCD (Pharmacokinetic Test Short Name) to the Test Identifier context. 
These columns are used to identify unique PK Findings tests. The unique tests are displayed in 
the PK Findings (Tests (PC)) tab in the properties.

STUDYID (Study Identifier), 
USUBJID (Unique Subject Identifier), 
PCSCAT (Test Subcategory), 
PCSPEC (Specimen Material Type), 
PCSPCCND (Specimen Condition), 
VISITNUM (Visit Number), 
VISIT (Visit Name), 
VISITDY (Planned Study Day of Visit), 
PCDTC (Date/Time of Specimen Collection), 
PCDY (Actual Study Day of Specimen Collection), 
PCTPT (Planned Time Point Name), 
PCTPTNUM (Planned Time Point Number), 
PCELTM (Planned Elapsed Time from Time Point Ref), 
PCTPTREF (Time Point Reference) 
to the Row context. 
These are columns to include and represent the unique set of rows. All unique combinations of 
the Row and Join columns determine the number of sample rows in the result dataset. 

Each column selected as a Join column in the EX domain will appear as a column mapping con-
text for the PC domain. This allows specification of the columns in the PC domain that correspond 
to columns in the EX domain. 

PCRFTDTC to the EXSTDTC context.
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Select PK Findings Tests
The PK Findings Tests(PC) tab on the Properties panel is used to select the tests to include, the lay-
out, and the result columns to include in the result sample dataset.

In this example, the dataset only involves one test.

Do not change the default settings for the SYDN PK Findings test, which are.

Usage set to Include to include the test in the output. 
Layout set to Stacked to have the results presented in a stacked format.
Result Column set to All to have all results columns included in the output that match the CDISC 
specification for results columns in original, numeric, or text format.

Continue to the next section.

Exploring the results

Click  (Execute icon) to execute the object.

The Results are displayed on the Results tab. The CDISC Data Preparer object produces a Dose and 
Sample worksheet in the Output Data folder. A Log and Settings file are also produced. A Warnings 
and Errors file is generated if issues are encountered during execution.
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Dose 

The Dose results worksheet contains the following columns in the order listed:

Subject identifier columns
Selected demographic columns
Selected pivot columns
Selected dose and dose unit columns
Selected Carry to Dose Dataset columns
Selected join columns
Calculated relative actual time and relative nominal time columns

The following images show a portion of the Dose worksheet generated as part of this example.

Sample 

The Sample results worksheet contains the following columns in the order listed:

Subject identifier columns
Columns selected as Row in the PK Findings context mapping 
Selected join columns
Selected test identifier columns
Selected demographics
Selected Carry to Sample Dataset columns
PCORRES and PCRSTRESN columns for each unique unit in the source dataset for stacked 
tests
Result column and result unit column for each pivoted test
LLOQ column for each pivoted test
If any results are stacked, PCORRESU, PCRSTRESU, and PCLLOQ columns containing the 
attributes associated with the stacked values
Calculated relative actual time, relative actual end time, and relative nominal time columns
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The following images show a portion of the Sample worksheet generated as part of this example.
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Mapping the results to an NCA model
1. Select Workflow in the Object Browser and then select Insert > NonCompartmental Analysis > 

NCA.

2. Map the CDISC Data Preparer Sample worksheet to the Main input of the NCA object.

– In the NCA Mappings panel click  (Select Source icon). 
– Select the Sample worksheet under CDISC Data Preparer and click OK.

3. Use the option buttons in the NCA Mappings panel to map the following:
– Map USUBJID to the Sort context.
– Map Relative_Actual_Time to the Time context.
– Map PCORRES to the Concentration context.

4. Map the CDISC Data Preparer Dose worksheet to the Dosing input of the NCA object.
– Select Dosing in the Setup list.
– In the Dosing Mappings panel click the Select Source icon. 
– Select the Dose worksheet under CDISC Data Preparer and click OK.

5. Use the option buttons in the NCA Mappings panel to map the following:
– Map USUBJID to the Sort context. 
– Map Relative_Actual_Time to the Time context.
– Map EXDOSE (Dose per Administration) to the Dose context.
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6. Execute the object. 

The results are displayed on the Results tab. The NCA object will produce worksheets and plots in the 
Output Data folder. It also produces a Core Output and Settings file. If any issues are encountered 
during execution, a Warnings and Errors file will be generated.

This example has shown how to use the CDISC Data Preparer object to convert CDISC data into a 
format that can be used by Phoenix. The object was set up and executed. The results of the CDISC 
Data Preparer were then mapped to another Phoenix object, NCA, as input. The execution of that 
NCA object was successfully completed without error.
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CDISC Navigator
CDISC Navigator supports the importing and exporting of CDISC data in either the SDTM (Study Data 
Tabulation Model) or the SEND (Standard for Exchange of Nonclinical Data) format. 

• CDISC SDTM is a unified way of transmitting information in drug studies with precise column 
names and a common file format. The CDISC STDM implementation in CDISC Navigator is 
compliant with the standards in the SDTM Implementation Guide 3.1.1. 

• CDISC SEND is an implementation of SDTM for nonclinical studies and specifies a consistent 
format for presenting and exchanging nonclinical data. The CDISC SEND implementation in 
CDISC Navigator is compliant with the standards in the SEND Implementation Guide 3.0. 

For further information, please visit the Clinical Data Interchange Standards Consortium Web site at 
www.cdisc.org.

A typical workflow using CDISC Navigator tools begins by obtaining the SEND files from the labs, 
then using CDISC Preparer to generate the data and format needed for the NCA analysis. The NCA 
analysis will generate the necessary PK parameters and SEND columns, which in turn can be 
exported to a PP SEND file.

CDISC domains supported by CDISC Navigator include:

DM (Demographics): Essential standard variables that describe each subject in a clinical study.
SC (Subject Characteristics): Subject-related data not collected in other domains.
EX (Exposure): A subject’s exposure to protocol-specified study treatment.
PC (PK Concentration): Concentrations of drugs/metabolites in fluids or tissues as a function of 
time. 
PP (PK Parameters): Pharmacokinetic parameters derived from pharmacokinetic concentration-
time (PC) data.

CDISC datasets are saved as SAS Transport Format (XPORT) Version 5 files (.xpt). Datasets 
exported from CDISC Navigator are automatically saved as SAS transport files. 

This section contains the following topics:

CDISC Export
CDISC Import
CDISC time formats

CDISC Export

Note: The images in this section show the SDTM Export Wizard. The options are identical to those in the 
SEND Export Wizard.

Select File > CDISC > SDTM > Export for SDTM formatted datasets.
Or select File > CDISC > SEND > Export for SEND formatted datasets.

http://www.cdisc.org/
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Clear the Select checkbox beside a domain to exclude it from the export.

To specify a file outside of Phoenix as the source

Click in the Datasource cell beside the domain. 

Select File System and click OK.

In the file browser, locate and select the .xpt file and click Select.

Click Finish to export the data.

Upon export, the original .xpt file from the file system is overwritten. Because of this, there is no 
need to do any mapping for the domain.

To specify a Phoenix object as the source

Select Phoenix Project and click OK. 

Select a worksheet in the Select Object dialog and click Select. 

Each domain has its own set of study variables that must be mapped. Users can map columns in 
a dataset to domain variables. 

If a map file exists of the selected domains and data sources, click Load Map to load the file. Other-
wise, click >> to proceed with the mapping.

The Variable column contains the CDISC variable names. The column headers in the data source 
are not required to match the variable names.
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Note: When exporting a PP domain, an additional checkbox is shown above the table, Include REL-
REC. Turn on to include related records. See “Exporting related records” for more information.

In the Filter field, type a column name followed by a condition to filter the input for the current domain.

For example, if a user retrieves data from Certara Integral that contains dosing and sample data, 
entering Type=‘Dose’ in the Filter field only exports the dosing data. Note that the Filter field is 
case sensitive.

Use the Map Column menus to select a column in the data source to map to each CDISC variable.

Select the Use Column Unit checkbox to remove the units from a column header and place them in 
their own column during export.

In the Static Value field, enter a static value for a CDISC variable.
Note that the Map Column selection supersedes any static value.

Select the Sequence checkbox if a column contains the order of the output, or the treatment 
sequence in a crossover study.

Click >> to continue mapping for each selected domain.

Optionally save the mappings for future use once the mapping is complete by clicking Save Map to 
save the mappings to an XML file.

Every selection in the export wizard, including domains, static values, etc., is saved in the map 
file.

To export the data, click Finish and, in the Browse for Folder dialog, select an export directory. 

The exported data is placed in a directory with date and time stamps included in the name. A 
message is displayed telling users when the export is complete. If a required field is missing, the 
export continues, but an alert is presented to the user.
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Exporting related records
Exporting related records provides a link between parameter calculations and the data in the original 
data source that went into the calculation.This is accomplished by creating a RELREC worksheet in 
the output that stores the connection information.

There are some limitations/considerations when exporting related records: 

The original dataset must have a PCSEQ (Sequence Number) column. 

The datasource for the PP domain must be an NCA result.

Some of the Final Parameters are calculated based on the points from which the regression line 
was fitted. For these parameters, the RELREC information should only contain the PC data that 
was used for Lambda Z calculations. 

The CdiscRelRecLZParams.xml configuration file (located in <Phoenix_in-
stall_dir>\application\Plugins\CDISC) lists these Lambda Z-based parameters. 
Parameters specified in this file will have records in the RELREC table that link to a RELID 
defined as the profile number plus the suffix “LZ”.

Assume that CDISC DM, EX, and PC domains are imported into Phoenix using the CDISC Data Pre-
parer object. 

1. Using the imported CDISC data as input, set up and execute an NCA object. 

2. Map PCSEQ as a Carry column so that it appears in the Summary Table. The PCSEQ column 
enables referencing to the original sequence number in the source data. 

The Summary Table and Final Parameters table can be used to determine which entries from orig-
inal PC dataset were used to calculate the profiles in the NCA analysis. 

3. In the Final Parameters table (stacked), identify the sort key for the parameter of interest.

4. Go back to the Summary Table and find that sort key. Each associated sequence number that 
went into this calculation is listed as a separate row with the same sort key.

5. To export the Final Parameter Results back to CDISC, select File > CDISC > SDTM > Export. 

6. Click in the Datasource cell for one of the domains to export.

The user is able to pick datasources for the domains being exported that are either located in the 
file system or are part of the Phoenix project. For exporting related records, the datasource for the 
PC domain must be the original dataset.

Note: Selecting the dataset that was imported into the Phoenix project instead of the original dataset is 
not recommended. During import, modifications to the data have occurred (e.g., different date and 
time formations, relative time calculations, etc.) and the purpose of exporting related records is to 
be able to track the data that went into a calculation back to the original CDISC dataset.

7. Select File System, click OK.

8. Locate and select the original dataset. 

9. Repeat for each of the domains to export.

10. For the PP domain, click in the Datasource cell.
The PP domain datasource must be the Final Parameters worksheet from the NCA analysis.

11. Select Phoenix Project, click OK.

12. Locate and select the Final Parameters worksheet for the NCA analysis. 
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13. When finished mapping the domains to data sources, click the >> button at the bottom of the dia-
log.

14. For each domain being exported, make adjustments as needed to the column mappings in the cor-
responding page and click the >> button.

15. For the PP domain, turn on the Include RELREC checkbox above the table to create the REL-
REC.xpt file of related records.

16. Continue through the Export Wizard and click Finish.

17. Select the folder in which to export the domains.

The image below shows a portion of an exported RELREC.xpt file. For the rows where 
IDVAR=PCSEQ, each sequence has an identifier listed in the IDVARVAL column. The RELID column 
lists the NCA profile identifier. Thus, PCSEQs 11, 13, 17, 19, 23, 25, 30, and 32 all were included in 
calculating profile P1. 

Looking further down in the RELREC.xpt file, where IDVAR=PPSEQ, each row reflects a different 
parameter. Each sequence number (IDVARVAL) can be tracked back to a parameter that was calcu-
lated.



CDISC Navigator
User’s Guide

134

CDISC Import
Select File > CDISC > SDTM > Import for SDTM formatted datasets.
Or select File > CDISC > SEND > Import for SEND formatted datasets. 

In the Open dialog, choose the file format from the pull-down menu next to the File name field (.xpt 
domain file or define.xml file).

The define.xml file specifies all of the domains that are part of the CDISC dataset. Selecting 
this file will result in all of the specified domains being imported.

Locate and select the CDISC domain file(s) or define.xml file and click Open.

A message is displayed that lists any validation errors encountered during import. Users are 
alerted if a required field is missing but the import is not stopped.

Click Save to save the error messages to a file for later review or Close to close the dialog.

The imported dataset is added to the Data folder in the Object Browser.

CDISC time formats
Below are some important notes regarding the time formats used in CDISC.

All the date, time, and collection time fields are in ISO 8601 format as defined by the CDISC stan-
dards.

The format of CDISC data after import may differ depending upon the default local/regional ISO 
format for the environment in which Phoenix is running. The mm/dd/yyyy ISO date format may not 
be the default and may not even be an option in some regions.

CDISC Navigator selects the highest time unit when importing datasets.

When relative time values are exported, CDISC Navigator creates the 8601 format based on the 
values in the relative time column.
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Data Link
Data Link is an operational object that allows adding/removing/renaming of required columns so the 
user can use datasets with different column names, without having to do a specific column rename. 
This facilitates reuse of workflows by standardizing the column names of input. 

What happens if data links are not used? If a workflow template is saved without using data links, 
when it is applied to another workflow, all of the links from the external sources will be missing. The 
more complex the workflow, the harder it is to establish new links to replace those that were lost. If 
data links are included in the template being applied, simply connect the source data to the data links 
themselves. Each data link distributes the data to where it is needed in the workflow.

To add a Data Link object to a workflow

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > System > Data Link. 
Or Main menu: Insert > System > Data Link.
Or right-click menu for a worksheet: Send To > System > Data Link.

Map an input dataset to Data in the Setup tab list.

To modify the required columns and their names

When creating a Data Link, by default all the columns in the original dataset are shown as a require-
ment. The user must map a column to each of the listed columns. If a new dataset does not have one 
of the columns listed in the Data Link, the user must remove that column from the Data Link or add the 
data to the dataset and map it before the Data Link can be executed. 

In the Options tab of a Data Link object, click Initialize From Input to list only columns in the input 
dataset. Any columns that have been added by the user are removed from the list.

To add a column, click Add and the enter the name in the Column Name field., 

To remove a column(s), select the column name(s) from the list and click Remove.

To rename a column, select the column name from the list and enter a new name in the Column 
Name field.

Use the up and down arrows to reorder the columns.

Click Remove unmapped columns to delete all columns that are not mapped to the input data.

To connect and disconnect external sources to data links

Before saving a workflow template, the Connect External Source to Data Links feature should be 
used. This feature allows you to create a data link object for every worksheet coming into the work-
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flow. It is a way of making place holders in the workflow so someone using the template can see 
where external data are needed. Therefore, it is recommended that you first finalize your workflow, 
then connect the external sources using data links and then save the workflow as a template.

In a Diagram window that has external sources mapped directly to operational objects, right-click and 
select Connect External Source to Data Links.

• If there is an existing Data Link object and all columns in the input match the columns in the 
object, then the connections will be redirected through the Data Link object. 

• If, on the other hand, columns in an existing Data Link do not match all the columns of the 
input, then the existing Data Link will not be used. Phoenix will create a new Data Link object 
to match all of the columns exactly.

To disconnect external sources from a Data Link object, right-click in the Diagram and select Discon-
nect External Data Links. The External Sources and operational objects will be directly connected.

Use of the Connect External Source Data Links feature is demonstrated in the “Workflows and 
Templates example”.
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Data Wizard
The Data Wizard is designed to facilitate repeated data operations on the same dataset. It also allows 
changes in the sequence of the operations. It replaces the following standalone tools: Column Proper-
ties, Filter Worksheet, and Column Transformation. (If a project created in an earlier version of Phoe-
nix has those options, these objects are loaded and visible.) The Data Wizard provides the property 
computing, filtering, and transformation operations as well as generating an easy summary worksheet 
to keep the workflow organized. 

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Data Management > Data Wizard. 
Or Main menu: Insert > Data Management > Data Wizard.
Or right-click menu for a worksheet: Send To > Data Management > Data Wizard.

The manipulation of data is defined in the Data Wizard as Steps. When the Data Wizard object is 
added, Step 1 is automatically listed in the Summary list of the Setup tab and is ready to be defined. 
From the Action menu in the Options tab, select Properties, Filter or Transformation and press 
Add to define the step.

Once that selection is made, the action is appended to the Step name in the Summary list and other 
controls on the Options tab are enabled appropriately.

A series of steps can easily be created (specifying column properties via Properties, filtering the data 
using Filter, and then doing a data transformation using Transformation). Each step in the Data Wiz-
ard identifies its action in the Summary. Delete steps, rearrange steps, insert new steps, and specify 
when to execute steps in a sequence using the buttons in the Options tab.

The first step in the Data Wizard allows the user to map the dataset, whether it is for filtering, transfor-
mation, or modifying column properties. After the dataset has been mapped in that first step, all sub-
sequent steps use that source dataset in combination with the steps created in the Data Wizard.

The Retain Intermediate Results checkbox preserves all results for each step set up in the Data 
Wizard. It will add significantly to the amount of output (and requires more memory). This options is 
only recommended when the intermediate output is truly necessary. 

This section contains information about the following:

Properties operation
Transformation operation
Filter operation
Results

See also “Ratios and baseline adjustments example”.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.
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Properties operation
The Properties operation in the Data Wizard allows users to set column header names, units, and 
data types (text or numeric) for worksheets. 

The interface consists of three main parts:

Main Mappings panel
Options tab
Defaults tab

Main Mappings panel
Users must map a dataset to the Main Mappings panel when the first step is set up. All subsequent 
steps will automatically be mapped to the same dataset. 

None: Columns mapped to this context are simply included in the output.
Sort: Sort variables used to define individual profiles. 

Options tab
The Options tab lists all the column headers in a worksheet and any associated units. The column 
headers and units are displayed in the columns list in the Options tab.

To change column header properties:

Select a column header in the columns list to change its properties.

In the New Column Name field, type a new column header name.

Phoenix does not allow spaces in column headers and will substitute an underscore (_) for a 
space.

A column name can only consist of alphanumeric characters and underscores, and cannot start 
with a number. 

The constraints on column names exist because spaces and other characters in column names 
can cause filter and sort functions to not work correctly.

In the New Unit field, type a new unit for the new column. 

Alternatively, click Units Builder to use the Units Builder dialog to change column units. The 
Units Builder can be used to specify new units or convert existing units.
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In the Unit Action list, select the action desired: Specifying the unit or Converting units.
See “Using the Units Builder” for more details on this tool.

Each column in a worksheet can use different units. The units are displayed in parentheses in the 
column header, and can be used in calculations. If the units are not standard or recognizable, 
Phoenix displays them in braces: {mmHg}. Nonstandard units are carried throughout any opera-
tions but are not used in any calculations. For a list of valid units and prefixes, see “Valid units and 
prefixes in Phoenix”.

Caution: If it is possible, units are automatically converted when the new column unit does not match the old 
column unit. Make sure the old and new column units match if unit conversion is not necessary or 
wanted.

In the New Data Type menu, select Text or Numeric to change the data type of the selected column.

Changing a column from text to numeric deletes any non-numeric values in the column. Changing 
a column from numeric to text does not delete any values. 

Data type refers to column data types. There are two kinds, numeric and text. Numeric columns 
contain only numeric values, and Phoenix treats the values in a numeric column as numeric 
data.Text, or string-type, columns can contain mixed numeric and text values, but Phoenix treats 
values in a text column as non-numeric values that cannot have certain operations performed on 
them, such as an arithmetic transformation. 

Select another column header in the columns list to change its properties.

For a list of valid units and prefixes, see “Valid units and prefixes in Phoenix”.

Defaults tab
The Defaults tab is used to automatically change column properties. Users can specify new column 
names and units for common columns like Time or Concentration. 

Caution: Defaults must be specified before a worksheet is mapped in the Properties operation.

When a worksheet is mapped to a Properties operation that has defaults set, any matching column 
headers and units are automatically changed or converted.

Defaults are listed on the default columns box.

To add new defaults

Type the column header name to be automatically converted in the Old Column Name field.

Select a unit, if applicable, in the Old Column Unit menu.
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Type a new column name in the New Column Name field.

Select a new unit, if applicable, in the New Column Unit menu.

Caution: If it is possible, units are automatically converted if the new column unit does not match the old 
column unit. Make sure the old and new column units match if unit conversion is not necessary or 
wanted.

Click Add to add the new column header default to the default columns box.

The default column name can be edited after it is added. 

Make any changes in the column name field and column units menus, and click the Apply button to 
apply the changes.

In the Match on menu, select whether or not to match the default column to input worksheet columns 
based on column name or column name and unit.

Select a default in the default columns box and click Remove to remove the column default.

Add another default by typing another column header name in the Old Column Name field and 
repeating the previous instructions.

Transformation operation
The Transformation operation creates a new column in a worksheet that is the result of a transfor-
mation. Phoenix supports arithmetic, baseline, custom, and function transformations. All data in the 
source column are transformed regardless of exclusions, which are carried over to the new column. 

The Transformation user interface consists of two main parts, the Setup tab and the Options tab.

Main Mappings panel
Options tab

Main Mappings panel
Users must map a dataset to the Main Mappings panel when the first step is set up. All subsequent 
steps will automatically be mapped to the same dataset. Required input will be highlighted orange in 
the interface.

Users can select to assign the units of an input (mapped) column to a new column created via a trans-
formation. If the Output Column Unit selection is mapped, the column mapped to that context will 
have its unit used in the new output column.

Context associations for a Transformation object change depending on which transformation type is 
selected in the Options tab.

Arithmetic transformation mappings 

None: Columns mapped to this context are simply included in the output.
x Column and y Column: Columns in a worksheet used in an arithmetic transformation.

Output Columns:
None: Units of columns mapped to this context are not used in the new output column.
Unit: The column whose units are to be used in the new output column.

Baseline transformation mappings 

None: Columns mapped to this context are simply included in the output.
x Column: The independent variable that is used to compute the baseline values.
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Sort: Sort variable(s) used to define individual profiles.
Time: Time values that are used to compute the baseline values.

Output Column:
None: Units of columns mapped to this context are not used in the new output column.
Unit: The column whose units are to be used in the new output column

Custom transformation mappings 

Output Column:
None: Units of columns mapped to this context are not used in the new output column.
Unit: The column whose units are to be used in the new output column.

Other mapping contexts are defined in the Formula field.

Function transformation mappings 

None: Columns mapped to this context are simply included in the output.
x Column: The independent variable that is used to provide the values for the function transfor-
mations.

Output Column:
None: Units of columns mapped to this context are not used in the new output column.
Unit: The column whose units are to be used in the new output column.

Options tab

The Options tab is used to select the transformation type and specify options for each transformation 
type. The Options tab also allows users to specify the sequence of the operations in the Data Wizard. 

Phoenix supports the following types of transformations:

Arithmetic: (x – y)/y, (x + y)/y*100, x – n, x – y, x*n, x*y, x/n, x/y, x^n, x^y, x + n, x + y

Baseline: % Change from Baseline, Change from Baseline, Ratio from Baseline

Custom: Custom Function, see “Example custom functions”.

Functions: 1/x, Absolute value(x), e^x, LN(x), Log10(x), Square root(x)

In the Arithmetic and Functions options, x and y are columns in a worksheet, in the Arithmetic options, 
n is a number, and in the Functions options e is the base of the natural logarithm (2.718281828).

Note: Blank cells are treated as zero when operated on with cells that contain numbers.
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In the Transformation Type menu, select one of four transformations: Arithmetic, Baseline, Cus-
tom, Functions.

Arithmetic options
In the Transformation Type menu, select Arithmetic.

In the Transformation menu, select the arithmetic transformation type.

If one of the x and y transformations are selected, the x Column and y Column mapping con-
texts are made available in the Main Mappings panel.

Use the option buttons to map data types in the worksheet to the x Column and y Column contexts. 
If one of the x and n transformations are selected, then a value for n must be specified.

In the Arithmetic Options field, type a value for n.

In the New Column Name field, type a name for the column used to contain the transformed values.

In the Destination Area, select one of the option buttons.

Append places the new column after the last column in the dataset.

Adjacent places the new column to the right of the data type mapped to the x Column context. 

Baseline options
Users can choose whether to specify sort variables for baseline transformations. Sort variables define 
unique profiles that are used to compute change from baseline separately for each profile. Typically, a 
single variable representing subject IDs is sufficient. Other data may require more than one variable, 
such as Subject and Period. The baseline transformation sorts the output worksheet in alphabetical or 
numerical order, based on the sort variables.

Rules for using datasets in a baseline transformation:

By default, Phoenix uses the value corresponding to time=0 as the baseline for each unique pro-
file. If a profile has more than one value at time zero, Phoenix uses the first value as the baseline.

If a zero time value is not in the dataset, the time value to use for the baseline value (normally the 
lowest time) must be specified, or the user must choose to use the minimum time for each group, 
in order to generate the baseline transformations.
Enter the lowest (or other) time value in the Fixed Value field or
Select MinimumPerGroup in the Starting Point dropdown menu.

If the columns mapped to x Column has a zero or missing value at the time specified for the 
baseline, then the % Change from Baseline and Ratio from Baseline options will produce 
empty results. An alternate baseline time value or the MinimumPerGroup option may be used.

To create a baseline transformation

In the Transformation Type menu, select Baseline.

In the Transformation menu, select the baseline transformation type.

If % Change from Baseline is selected, Phoenix performs a transformation on a column by cal-
culating the percent change between each value and either a fixed baseline value or the mini-
mum value for each distinct profile.
result=(x – baseline)/baseline*100

If Change from Baseline is selected, Phoenix performs a transformation on a column by calcu-
lating the change between each value and either a fixed baseline value or the minimum value for 
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each distinct profile.
result=x – baseline

If Ratio from Baseline is selected, Phoenix performs a transformation on a column by determin-
ing the ratio to either a fixed baseline value or the minimum value from each distinct profile.
result=x/baseline

In the Main Mappings panel, click the option buttons to specify the x Column, the Sort column(s), and 
the Time column.

Users can map multiple or no columns in a worksheet to the Sort context. Each column mapped 
to the Sort context creates a unique profile. Baselines are calculated on a per profile basis.

In the New Column Name field, type a name for the column that will contain the transformed values.

In the Starting Point menu, select Fixed Point or Minimum per Group.

If Minimum per Group is selected, the lowest time point in each profile is used to generate the 
baseline transformation. Selecting this option means that the baseline transformation uses a dif-
ferent starting point for each profile defined by the sort key(s).

If Fixed Point is selected, users can enter custom starting time value in the Fixed Value field.

In the Fixed Value field, type a time value for a time column in Numeric format or in Text format.

If a time column is in Text format, users must type fixed time value in the same format used to 
enter the time values in the worksheet. For example, if the first time point used as the baseline is 
1:00, then 1:00 must be typed in the Fixed Value column. For acceptable dates and times in Text 
format, see “Date and time formats”.

The default is zero, because Phoenix, by default, evaluates the change from baseline at time=0. If 
a value is entered that is higher than the highest time value, then no output values are produced 
in the new column.

In the Treat Time Values as menu, select the format used by the time column.

Numeric Format means the Time column is in Numeric format. 
Date\Time Format means the Time column is in Text format. If selected, the Time Units menu is 
made available. The selected units are applied to the transformed time column, and are con-
verted if they do not match the source time column units.

In the Time Units menu, select the units to use in the transformed time column.

If Date\Time Format is selected, the Create Transformed Time Column checkbox is made 
available.

Check the Create Transformed Time Column box to create a Numeric time column in the output 
that is based on the values in a Text time column or clear the checkbox to not create a transformed 
time column.

In the Destination Area, select one of the option buttons.

Append places the new column after the last column in the dataset.
Adjacent places the new column to the right of the data type mapped to the x Column context. 
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Custom options
Users can create a custom transformation that transforms one or more columns in a worksheet using 
the functions provided by Phoenix. 

To create a custom transformation

In the Transformation Type menu, select Custom.

Custom Function is selected by default in the Transformation menu. There are no other 
options in the menu for custom functions.

In the New Column Name field, type a name for the column that will contain the transformed values.

In the Formula field, type a custom function or use the pointer to select a function name in the Func-
tion List and drag the function name to the Formula field.

Custom functions can be defined, edited, and combined in the Formula field. The if custom func-
tion allows users to create a compound function using the logical operators & (and) and | (or). For 
example, if((col1=1) & (col2=2), 1, 0). Each condition in the if statement must be 
placed in parentheses. The function name must be followed immediately by the left parenthesis, 
there cannot be a space.

See “Example custom functions” for a list of all possible functions and examples of how to use 
them. The same information is also listed in the Function List in the Options tab.

In the Main Mappings panel, click the option buttons to specify the mapping contexts created by the 
custom function.

Functions options

To find the absolute value, logarithmic values, or square root 

In the Transformation Type menu, select Functions.

In the Transformation menu, select the function transformation type.

Use the option buttons to map a column in the worksheet to the x Column context.

In the New Column Name field, type a name for the column used to contain the transformed values.

In the Destination Area, select one of the option buttons.

Append places the new column after the last column in the dataset.
Adjacent places the new column to the right of the data type mapped to the x Column context. 

Note: Using the Data Wizard, it is easy to create a sequence of operations, whether transformations or 
combinations of the other Wizard operations.

Example custom functions
Below are some common functions that may be helpful.

substitute(conc,”BQL”,0.1,0)
In the mapped column “conc”, replace each cell value found to be equal to BQL with 0.1 in the 
new column. 
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substitute(CobsPop, 0.1,"BQL",0)
In the mapped column “CobsPop”, replace each cell value found to be 0.1 with “”BQL” in the new 
column. 

if(CobsPop==0.01, 1, 0) or;
Note: There are 2 equal signs. 
If any cell in the mapped column “CobsPop” is equal to 0.1, then enter a 1 in the new column; oth-
erwise enter a 0.

if(CobsPop = 0.01, 1, 0)
Note: When using a single equal sign, spaces are needed before and after the equal sign.
If any cell in the mapped column “CobsPop” is equal to 0.1, then enter a 1 in the new column; oth-
erwise enter a 0. (Same as previous function.)

if(CobsPop = 0.1, 1, if(CobsPop < 1, 2, 0))
Note: You need spaces before and after the < sign or use two << signs without spaces.
Embedded ifs. If any cell in the mapped column “CobsPop” is equal to 0.1, then enter a 1 in the 
new column; if it is less than 1, enter a 2; otherwise enter a 0.

if(CobsPop = 0.1, 1, if(id==1, 2, 0))
Embedded ifs with different vars. If any cell in the mapped column “CobsPop” is equal to 0.1, then 
enter a 1 in the new column; if the mapped column “id” is equal to 1, enter a 2; if none of these 
conditions are met, enter a 0.

replace(conc,2,2,"LQ")
Starting at number 2 position in the mapped column “conc”, replace the string with 2 letters “LQ”. 
This is useful for converting BQL to BLQ, but notice that it does not discriminate, so a number 
1.537753 ends up being 1LQ37753 (position 2 and 3 replaced). Use with caution!

Ln(conc)
Write the natural log of the value in the mapped column conc in the new column.

Custom functions list
abs: Return the absolute value of the supplied parameter.

abs(–12)=12; 
abs(ColumnA) 

acos: Return the inverse cosine of parameter1.

acos(–0.5)=2.094395 

acosh: Calculate the inverse hyperbolic cosine of parameter1.

acosh(10)=2.99322 

asin: Calculate the inverse sine of parameter1.

asin(–0.5)= –0.5236 

asinh: Calculate the inverse hyperbolic sine of parameter1.

asinh(–2.5)= –1.6472311 

atan: Calculate the inverse tangent of parameter1.

atan(1)=0.785398 

atan2: Calculate the arc tangent of two coordinates.

atan2(x coord, y coord); 
atan2(–1,1)= –2.3561945 
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atanh: Calculate the inverse hyperbolic tangent of a value.

atanh(0.76159416)=1 

average: Return the average of the supplied parameters.

average(A1:A10); 
average(12, 5, 7, 8, 11.4) 

ceiling: Return the smallest integer value greater than, but not equal to, the value supplied.

ceiling(12.5) 

chiinv: Calculate the inverse chi-square distribution

chiinv(p, df) 

clean: Clean text of non-printable characters.

clean(“string with non-printable chars”); 
clean(A1) 

concatenate: Combine two or more strings into one string.

concatenate(A1:A5); 
concatenate(ColumnA, “& “, ColumnB) 

cos: Calculate the cosine of parameter1.

cos(1.047)=0.50017107 

cosh: Calculate the hyperbolic cosine of parameter1.

cosh(4)=27.30823 

count: Return the number of values in a list, including empty cells.

count(A1:A5) 

counta: Return the number of non-empty cells in a given range.

counta(A1:A5) 

date: Return the sequential serial number that represents a particular date.

date(2007, 11, 27)=39411 

datevalue: Use datetime to return the serial number of the date represented by date_text. Use this 
function to convert a date represented by text to a serial number. If time is associated with the date, 
then the serial date will be a decimal and not a whole number.

datevalue(“11/27/2017”)=39411 

day: Return the day of a date, represented by a serial number. The day is given as an integer ranging 
from 1 to 31.

day(serial_time); 
day(39411)=27 

even: Return the smallest even integer greater than the argument.

even(12.1) 

exp: Return e raised to the power of the supplied parameter.

exp(3); 
exp(ColumnA) 
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fact: Return the factorial of the supplied parameter.

fact(3) 

Finv: Calculates the quantile of F-distribution and returns the absolute value.

Finv(p,df1,df2); 
Finv(0.7, 1, 10) = 1.194776 

floor: Return the largest integer less than the supplied parameter. 

floor(12.9) 

format: Format a string using .NET string formatting commands.

format(ColumnA, “G8”); 
format(“.12345”, “G8”) 

geomean: Return the geometric mean of a range of positive data.

geomean(A1:A15) 

geovar: Return the geometric variance of a range of positive data.

geovar(A1:A15) 

harmean: Return the harmonic mean of a range of data.

harmean(A1:B32) 

harmvar: Return the harmonic variance of a range of data.

harvar(A1:C33) 

hour: Return the hour of a time value. The hour is given as an integer, ranging from zero (12:00 
A.M.) to 23 (11:00 P.M.).

hour(serial_time);
hour(38711.06302)=1;
hour(37811.27135)=6 

if: Return true if conditional argument is true; false otherwise.The if function also supports using & 
(and) and | (or) in statements, and supports nested if statements.

Note: parameter 1 (logical test) must return true or false; place a space between cell reference 
and '=' 
if((Time=1) & (Conc>2),…);
if((Time=1) | (Conc>2),…);
if(trt=”Reference”, “R”, “T”);
if(CVWR<=30, ‘125.00’,
if(CVWR<=50, 100*exp(+0.76*sqrt(Estimate)), 143.19)) 

if((A1=0.25), 1, 0) 

IsNull: Return true if value of cell is NULL (empty).

IsNull(ColumnA) 

left: Return the specified number of characters (from left to right) of a string.

left(“This is a test”, 1)=T; 
left(“This is a test”, 3)=Thi; left(A1, 3) 
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length: Return the length of a string.

length(“this is a test”)=14; 
length(A1) 

ln: Return the natural log of the supplied parameter.

ln(2.3); 
ln(ColumnA) 

log: Return the log of the first parameter to the base of the second parameter.

log(number, base); 
log(5,3) 

log10: Return the log base 10 of the parameter.

log10(5); 
log10(ColumnA) 

lower: Return the supplied string as lower case.

lower(“This Is A Test”)=“this is a test”; 
lower(A1) 

mid: Return a specific number of characters from a string from a given position and length parame-
ters.

mid(text, start pos, distance); 
mid(“This is a test”, 2, 3)=his 

minute: Return the minutes of a time value. The minute is given as an integer, ranging from zero to 
59.

minute(serial_time); 
minute(38711.06302)=30 

mod: Return the remainder after parameter1 is divided by parameter2.

mod(number, divisor); 
mod(12,2) 

month: Return the month of a date represented by a serial number. 
The month is given as an integer, ranging from 1 (January) to 12 (December).

month(serial_time); 
month(39411)=11 

now: Return the current date and time as a double (serial date/time).

now()=current date 

odd: Return the smallest odd integer greater than the supplied parameter.

odd(13.1) 

pi: Return the value of pi.

pi() 

product: Return the product of a list of real numbers.

product(A1:Z88) 
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rand: Return a random number based on a lower limit, an upper limit, and a seed.

rand(,);
rand(0,1,92756) 

replace: Replace a sub-string with another string.

replace(text, start pos, distance, replace with); 
replace(“T_%_025”, 2, 3, “–”)=T–025; 
replace(ColumnA,1,4,””) 

right: Return a specific number of characters from a string starting from the right and moving left.

right(“This is a test”, 3)=“est” 

root: Return the root of a parameter1, using parameter2/parameter3.

x^(a/b); 
root(x, a, b); 
root(2, 3, 4) 

round: Round parameter1 to the number of decimal places defined by parameter2.

round(12.345, 2)=12.35; 
round(ColumnA,1) 

roundsig: Round parameter1 to the number of significant digits defined by parameter2. Note that 
Phoenix worksheets do not support displaying trailing zeros in decimals, so not all significant digits 
will be displayed in this case.

roundsig(12.234, 3)=12.3 

search: Return the one-based starting position of a substring within a larger string. The third argu-
ment is the one-based starting position for the search. The function returns –1 if there is no match. 

search(“Phoenix”, “oe”, 1)=3 

second: Return the seconds of a time value. The second is given as an integer in the range zero to 
59.

second(38711.06302)=44 

sign: Determine the sign of a number. Returns 1 if the number is positive, 0 if the number is zero, or 
–1 if the number is negative.

sign(–12); 
sign(0); 
sign(200) 

sin: Calculate the sine of parameter1.

sin(1)=0.84147098 

sinh: Calculate the hyperbolic sine of parameter1.

sinh(1)=1.175201194 

sqrt: Return the square root of parameter1.

sqrt(9) 

stdev: Estimate standard deviation based on a range of data.

stdev(A1:C1) 
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strcmp: An integer indicating the case sensitive lexical relationship between the two comparands. 

Value condition < zero, stringA is < stringB
Value condition = zero, stringA = stringB
Value condition > zero, stringA is > stringB 

strcmp(stringA, stringB) 

substitute: Substitute new text for old text in a text string and optionally [for a given instance]. [] 
is optional but the preceding comma is required; substitute(ColumnA,”_%_”,””,) 

substitute(text, target text, replacement text, [instance]) 

sum: Return the sum of the specified values.

sum(A1:A12); 
sum(1,2,3,4,5) 

sumsq: Return the sum of the squares of the arguments.

sumsq(C1:C33) 

tan: Calculate the tangent of parameter1.

tan(0.785)=0.99920399 

tanh: Calculate the hyperbolic tangent of parameter1.

tanh(–2)= –0.96403 

time: Return the decimal number for a particular time.

time(hour, min, sec); 
time(12,2,3)=0.50142361 

timevalue: Use datetimes to return the decimal number of the time represented by a text string, 
with precision up to the second. 

timevalue(“2:24 AM”)=0.1 

tinv: Calculate the inverse t distribution and returns absolute value. 

tinv(p, df);
tinv(0.7, 10)=tinv(0.3, 10)=0.541528 

today: Return the serial number of the current date.

today()=current date as serial time 

trim: Remove all spaces from text except for single spaces between words.

trim(“      this is     a test”)=“this is a test” 

trunc: Truncate a real number to an integer by removing the decimal places.

trunc(number); 
trunc(12.1234) 

upper: Return parameter1 in upper case.

upper(“this is a test”)=“THIS IS A TEST” 

var: Return the variance of a set of real numbers.

var(A1:A5) 
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weekday: Return the day of the week corresponding to a date. The day is given as an integer, rang-
ing from 1 (Sunday) to 7 (Saturday).

weekday(serial_time); 
weekday(39411)=Monday (Sunday is the first day) 

year: Return the year corresponding to a date. The year is returned as an integer in the range 1900–
9999.

year(39411)=2007 

Filter operation
The Filter operation allows users to search for values in a dataset, specify if only matching data are 
returned (include), if the matches are filtered out (exclude), or replaced with another value. Additional 
options allow users to choose if the entire dataset is to be searched or just a particular column and if 
the entire row containing a matching cell is filtered or just the matching cell.

Main Mappings panel
Options tab

Main Mappings panel
Users must map a dataset to the Main Mappings panel when the first step is set up. All subsequent 
steps will automatically be mapped to the same dataset. 

Use the Main Mappings panel to specify which input variables are filtered. Main Mapping input vari-
ables to context associations is optional.

None: Columns mapped to this context are simply included in the output.
Exclude: Columns mapped to this context are excluded in the result worksheet.

Options tab

To specify the type of filter

Select one of the option buttons to choose the filter type.

Built In – Use the Filter Specification dialog to add a filter.
Selection (Exclude) – Use the Filter Selection dialog to exclude part of a dataset. 
Custom (Include) – Use the Custom Filter Entry dialog to specify a custom filter.

Click Add to add a filter.
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The Specify Filter field lists all added filters. Select a filter to remove, edit, or move it.

Filters are executed in the order they are listed.

Click Undo to remove the last filter created from the list.

Click Edit to edit a filter.

Click Move Up to move a filter to top of the list.

Click Move Down to move a filter to the bottom of the list.

Note: If a User Selection filter is defined and listed in the Specify Filter field, the Move Up/Move Down 
buttons in the Data Wizard are disabled. 

Filter Specification dialog
When the Built In option is selected in the Options tab, clicking Add displays the Filter Specification 
dialog.

In the Action menu, select a filter action.

Exclude: Filter out cells/rows that match the filter criteria.
Include: Keep only the cells/rows that match the filter criteria.
Replace: For each cell that matches the filter criteria, replace it with a specified value.

From the Column menu, select the column to which the filter criteria is to be applied.

From the Operator menu, select an operator.

=: equal to the search string
<: less than the search string
>: greater than the search string
≤: less than or equal to the search string
≥: greater than or equal to the search string
≠: not equal to the search string

Note: To exclude (include) “not equal” values, instead include (exclude) equal values.
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Select the name of an existing column from the Select Column or Enter Value pull-down menu to 
compare its cell values with those in the column chosen in the Column pull-down menu. 
Or
Type a value directly into the field to search for that value in the column selected in the Column pull-
down menu. 

If Exclude or Include is the action, check the Apply to entire row box to exclude/include the entire 
row when the filter criteria is matched. or clear the checkbox (the default) to exclude or include a cell 
that matches the criteria.

If Replace is the action:

In the Replace with field, type the value to place in a cell that matches the filter criteria. 

Check the Replace All box to replace all instances where the criteria is matched in the specified 
column (or in all columns if Any is specified). Clear the checkbox to only replace the first match in 
the specified column (or first match in each column if Any is specified).

Type a value in the Tolerance field to search for values within a range of a numeric search value.

The Tolerance field is only available when a numerical value is entered in the Value field and is 
used to find values not different from the numeric search value by more than the tolerance value. 
This function is optional.

Numeric values that are +/- the tolerance of the search value are considered to match the search 
value. If a non-numerical value is entered in the Find field, then the Case Sensitive checkbox is 
made available.

Select the Case Sensitive checkbox to search for strings that match the capitalization used in the 
search string.

Built-in filter rules: 

Blank cells can be filtered by using the term ‘NULL’ in the filter expression to represent the blank 
cells.

Users can filter cells that contain values with leading single quotes by typing an additional single 
quote before the value in the Filter Specification dialog. For example, to filter a value like 
‘000123’, users need to type “000123” in the Custom Filter Entry dialog.
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Filter Selection dialog
When the Selection (Exclude) option is selected in the Options tab, clicking Add displays the Filter 
Selection dialog.

Note: If this table is blank, click Cancel, check the Retain Intermediate Results checkbox in the 
Options tab, and then click Add. The table will be populated.

Use the pointer to select part or all of a worksheet.

Click OK to exit the Filter Selection dialog, or click Cancel to exit the dialog without excluding the 
selected cells.

Note: Adding a User Selection filter to the list in the Specify Filter field results in the Move Up/Move 
Down buttons in the Data Wizard becoming disabled. 

Custom Filter Entry dialog
This section contains the syntax and some of the codes that can be used to create custom inclusion 
filters for a worksheet. Any standard SQL syntax can be used. Custom filters are defined in the Cus-
tom Filter Entry dialog. 

In the Custom Filter Entry dialog, type the custom filter.

Click OK to add the filter or click Cancel to exit the dialog without adding the filter.

Only one filter can be added at a time in the Custom Filter Entry dialog.
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Custom filter syntax: 

[Column name] [Expression] [Value] [Logical operator][Column name] 
[Expression] [Value] 

Example: Subject='GW' AND Time <= 12 

Logic operators: 

Statement grouping is done using the Boolean AND, OR, and NOT operators. Use parentheses to 
group clauses and force precedence. The AND operator has precedence over other operators. 

Example: (Subject='JDW' OR Subject='LEJ') AND Conc > 1 

When creating comparison expressions, the following operators are allowed:

=: Equals
<>: Not equals
<: Less than
<=: Less than or equal
>: Greater than

Custom filter rules: 

• User-defined values can be used in expressions to compare against column values. 
Example: Effect <= 75.00

• String values must be enclosed in single quotes.
Example: Subject='JDW'

• String values and column names are not case sensitive.

• Date values should be enclosed with pound signs (#).
Example: Date > #12/01/2008#

• Decimals and scientific notation are permitted for numerical values.

• Blank cells can be filtered by using the term ‘NULL’ in the filter expression to represent the blank
cells.

• A wildcard can be specified by a percent sign with the operator ‘like’.
Example: Analyte like ‘Metabolite%’

Results

Note: Any step in the Data Wizard can be revisited, revised, and re-executed. All of the steps performed 
are described carefully in the Summary part of the Output. 

All of the steps in the Data Wizard generate output. The output forms specific to a particular kind of 
operation are specified below. In general, each step in the Data Wizard will create the following out-
put:

Result: The final result of all operations in the step.
Summary: Listing of all steps in the Data Wizard.
Settings: The settings used in all steps.

Additional output when intermediate results are retained.

Final Results: The Results, Summary, and Settings that represent all steps.
Secondary: Non-empty intermediate results that are not used in the final results above.
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Additional output when intermediate results are retained

Final Results: The Results, Summary, and Settings that represent all steps.
Intermediate Results: All non-empty intermediate results generated by the steps.
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Ratios and baseline adjustments example
This example demonstrates some frequently used calculations, including:

Computing ratios
Creating a baseline-adjusted variable

Most Phoenix objects require the same basic steps for their use. However, there may be multiple 
paths to accomplishing a step (e.g., main menu, right-click menu, drag-and-drop, etc.). For simplicity, 
only one is listed here.

Note: Any object added to a project can be viewed in its own window by selecting the object in the Object 
Browser and double-clicking it or pressing ENTER. All instructions for setting up and executing an 
object are the same whether the object is viewed in its own window or in Phoenix’s viewing.

The completed project (Transformations.phxproj) is available for reference in …\Exam-
ples\Data and Plots.

Computing ratios
Phoenix can compute derived parameters as ratios of modeling output parameters. This functionality 
has been designed specifically for the computation of F (fraction of oral dose absorbed) and for the 
calculation of metabolite to parent drug ratios.

This example will demonstrate the computation of F. Metabolite to parent drug ratios would be calcu-
lated in the same manner.

Two datasets are needed for this example: one with AUC from IV data for 24 subjects, and another 
with AUC from oral data from the same 24 subjects. These datasets are provided in the Phoenix 
example subdirectory as IV.csv and Oral.csv. During the following steps, these datasets will be 
merged into one dataset, F will be computed for each subject, followed by calculations of the sum-
mary statistics for F.

1. Create a new project named Transformations.

2. Import …\Examples\WinNonlin\Supporting files\IV.csv and Oral.csv.

3. Click the Next Arrow button and then click Finish in the File Import Wizard dialog.

4. Right-click the IV in the Data folder and select Send To > Data Management > Join Worksheets.

5. In the Mappings panel, map the data types as follows:
Subject to the Sort context.
Form to the Source Column context.
AUC to the Source Column context.

6. Select Worksheet 2 in the Setup list.

7. Drag the Oral worksheet from the Data folder to the Worksheet 2 Mappings panel.

8. Map the data types as follows:
Subject to the Sort context.
Form to the Source Column context.
AUC to the Source Column context.

9. Click  (Execute icon) to execute the object. 
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Figure 26-1. Portion of Join Worksheets Result worksheet

Calculate F (fraction of oral dose absorbed).

1. Right-click Workflow in the Object Browser and select New > Data Management > Data Wizard.

2. In the Options tab, select Transformation from the Action menu.

3. Click the Add button.

4. In the Mappings panel for the Data Wizard (Step 1: Transformation), click  (Select Source 
icon).

5. In the dialog, select the Join Worksheets object’s Result worksheet and click OK.

6. Arithmetic is automatically selected in the Transformation Type menu. Do not change this set-
ting.

7. Select x/y in the Transformation menu.

8. In the New Column Name field type Fraction.

9. Map the data types as follows:
AUC_1 to the y Column context.
AUC_2 to the x Column context.

10. Execute the object.

Calculate descriptive statistics

1. Right-click Workflow in the Object Browser and select New > Computation Tools > Descriptive
Statistics.

2. Click the Select Source icon.

3. Select the Data Wizard object’s Result worksheet and click OK.

4. Map the data types as follows:
Fraction to the Summary context.
Leave all other data types mapped to None.

5. In the Options tab, check the Confidence Intervals and Number of SD Statistics checkboxes,
but do not change the default values for these two items.

6. Check the Other Statistics checkbox.

7. Execute the object.

The Statistics worksheet results are shown below:
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Creating a baseline-adjusted variable
In many cases it is useful to fit a model to a variable with some endogenous or baseline level, for 
example, blood pressure or estrogen levels. The calculation of these PK parameters would generally 
be done on the baseline-adjusted observation values. This example will compute the change from 
baseline in a response variable, creating an analysis-ready new column of data.

Compute the change from baseline using a column transform.

1. Import …\Examples\WinNonlin\Supporting files\endogenous.dat.
Click Finish in the File Import Wizard dialog.

2. Right-click Workflow in the Object Browser and select New > Data Management > Data Wizard.

3. In the Options tab, select Transformation as the Action and click Add.

4. Drag the endogenous worksheet from the Data folder to the Data Wizard 1 object Main Mappings
panel.

5. Select Baseline in the Transformation Type menu on the Options tab.

6. Select Change from Baseline in the Transformation menu.

7. In the New Column Name field type Change.

8. In the Main Mappings panel, map the data types as follows:
Time to the Time context.
Conc to the x Column context.

9. Execute the object.

Figure 26-2. Part of Column Transformation Result worksheet

The Change column is added to the dataset and is ready for use in modeling.

10. Right-click the project and select Close Project.

This includes the Transformations — Ratios and Baseline Adjustments example.
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Descriptive Statistics
Phoenix can compute summary statistics for variables in any worksheet. This feature is frequently 
used to create data to plot means and standard errors, for preclinical summaries, to summarize mod-
eling results, or to test for normal distribution of data. Separate statistics for subgroups are obtained 
through the use of one or more sort variables. 

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Computation Tools > Descriptive Statistics. 
Or Main menu: Insert > Computation Tools > Descriptive Statistics.
Or right-click menu for a worksheet: Send To > Computation Tools > Descriptive Statistics.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

This section includes information on the following:

User interface description
Statistical results and computational formulas
Weighted summary statistics

User interface description
Main Mappings panel
Options tab

Main Mappings panel
Use the Main Mappings panel to identify which variables are used to compute statistics or weight the 
data. Required input is highlighted orange in the interface.

None: Data types mapped to this context are not included in any computation or output.
Summary: The variable(s) for which statistics are computed.
Sort: Categorical variable(s) identifying individual data profiles, such as subject ID or gender. 
Separate statistics are computed for each unique combination of sort variables.
Weight: If a weight variable is present in the dataset, it can be used to weight the summary statis-
tics. If a weight is non-numeric or missing, the observation is excluded from the analysis. If a 
weight is negative, it is changed to zero (0) upon execution.
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Options tab
See “Statistical results and computational formulas” for a full list of the available statistics.

Use the tree on the right to select the statistics to compute and include in the report by checking the 
corresponding checkboxes. 

The available statistics are grouped into categories and checking/unchecking a category check-
box controls all of the checkboxes for statistics within that category. For example, unchecking the 
Spread Statistics checkbox unchecks the Min, Median, Max, and Range checkboxes.

Click the Select All or Clear All buttons to quickly check/uncheck all checkboxes in the list, 
respectively, with a single click.

Click the  button to expand all categories in the tree. Click the  button to collapse all cat-
egories in the tree. 

There are a number of preset percentiles available in the Percentiles category (1, 2.5, 5, 10, 25, 50, 
75, 90, 95, 97.5, 99). However, if you wish to include other percentiles, enter them as a comma-sepa-
rated list in the User-specified percentiles field.

To generate confidence interval statistics, type the desired confidence interval in the Confidence 
Interval field.

Check the Confidence Intervals checkbox to compute all statistics in that category or expand 
the category to select a subset of the statistics

To generate standard deviation statistics, type the desired number of standard deviations in the Num-
ber of SD Statistics field. The value must be greater than 0 and less than or equal to 10.

Check the Number of SD Statistics checkbox to compute all statistics in that category or expand 
the category to select a subset of the statistics.

Statistical results and computational formulas
The Descriptive Statistics object creates a Statistics worksheet and a Settings text file in the Results 
tab. The Statistics worksheet includes summaries of all statistical computations. The Settings file con-
tains user-specified settings.

CI GEO X% Lower: Lower limit of an X% confidence interval for the logs of the data, back-trans-
formed to original scale:

exp(Mean_Log – t x SD_Log)
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CI GEO X% Upper: Upper limit of an X% confidence interval for the logs of the data, back-trans-
formed to original scale:

exp(Mean_Log + t x SD_Log) 

where (1 – )*100 is the percentage given for the confidence interval
and t is from the t-distribution with N–1 degrees of freedom.

CI X% Lower: Lower limit of an X% confidence interval for the data (i.e., confidence interval that tells 
the range that is expected to have X% of the data)

Mean – (t x SD) 

CI X% Lower GEO Mean: Lower limit of an X% confidence interval for the Geometric Mean:

(equivalently, exp of the lower CI for Mean_Log).

CI X% Lower Mean: Lower limit of an X% confidence interval for the mean (i.e., the confidence inter-
val in which the mean exists with X% certainty)

CI X% Lower Var: Lower limit of an X% confidence interval for the variance (i.e., the confidence inter-
val in which the variance exists with X% certainty):

where u
2 is from the  2-distribution with N–1 degrees of freedom.

u
2 cuts off an upper tail of area /2 where (1–)*100 is the percentage for the confidence inter-

val.

CI X% Upper: Upper limit of an X% confidence interval for the data:

where (1–)*100 is the percentage given for the confidence interval, 
and t/2 is from the t-distribution with N–1 degrees of freedom.

CI X% Upper GEO Mean: Upper limit of an X% confidence interval for the Geometric Mean:

where (1 – )*100 is the percentage given for the confidence interval, 
and t/2 is from the t-distribution with N – 1 degrees of freedom.

CI X% Upper Mean: Upper limit of an X% confidence interval for the mean:

Mean_Log t 2
SD_Log
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where (1–)*100 is the percentage given for the confidence interval, 
and t/2 is from the t-distribution with N–1 degrees of freedom. 

Thus, a 95% confidence level indicates that =0.05. Note that for N>30, the t-distribution is close 
to the normal distribution.

CI X% Upper Var: Upper limit of an X% confidence interval for the variance:

where L
2is from the 2-distribution with N – 1 degrees of freedom.

L
2 cuts off a lower tail of area /2 where (1 – )*100 is the percentage for the confidence inter-

val.

CV%: Coefficient of variation: (SD/Mean)*100

GEO Lower XSD and GEO Upper XSD: Range determined by adding or subtracting “X” log stan-
dard deviations from the log-mean, back-transformed to original scale:

When X=1, this range is equivalent to: (Geometric_Mean/exp(SD_Log) and Geomet-
ric_Mean*exp(SD_Log))

Geometric CV%: Geometric coefficient of variation: 

Geometric Mean: Nth root of the product of the N observations. Equivalently, the exponential of the 
Mean_Log. Each value must be > zero:

Geometric SD: Geometric standard deviation of the natural logs of the observations exp (SD_Log)

Harmonic Mean: Reciprocal of the arithmetic mean of the reciprocals of the observations:

IQR: Interquartile range is the difference between the first and third quartiles (i.e., the middle 50% of 
the data). IQR is only included in the output when the Include Percentiles checkbox is checked. 

KS PValue: Kolmogorov-Smirnov normality test  value. This quantifies the distance between the 
empirical distribution function of the data and the cumulative distribution function of the Normal distri-
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bution. The empirical distribution function Fn for n independent and identically distributed observa-
tions Xi is defined as:

where  is the indicator function and = 1 if , otherwise 0.

The Kolmogorov-Smirnov statistic for a given cumulative distribution function F(x) is:

where sup x is the supremum of the set of distances. A -value is then computed to determine 
the significance of Dn.

Kurtosis: Sample coefficient of excess (sample excess kurtosis):

Sample Excess Kurtosis=[Population Excess Kurtosis*(N+1)+6]*(N–1)/[(N–2) x (N–3)]

Kurtosis Pop: Population coefficient of excess (population excess kurtosis):

Population Excess Kurtosis=((Sample Excess Kurtosis x (N–2) x (N–3)/(N–1)) –6)/(N+1)

Lower XSD and Upper XSD: Range determined by adding or subtracting X standard deviations from 
the mean Mean +/– X*SD

Max: Maximum value

Mean: Arithmetic average 

Mean log: Arithmetic average of the natural logs of the observations 

Median: Median value — from the percentiles computations, 50th percentile.

Min: Minimum value.
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N: Number of observations with non-missing data (i.e., numeric observations).

NMiss: Number of observations with missing data (i.e., non-numeric observations such as text or 
blanks).

NObs: Number of observations (i.e., N+NMiss)

P(ercentiles): The Pth percentile divides the distribution at a point such that P percent of the distribu-
tion are below this point. For a sample size of n, the quantile corresponding to the proportion p 
(0<p<1) is defined as:

Q(p)=(1 – f)*x(j)+f*x(j+1)

where:
  j = int(p*(n+1)), (integer part)
  f = p*(n+1) – j, (fractional part)
  x(j) = the j-th order statistic

The above is used if 1 j < n. Otherwise, the empirical quantile is the smallest order statistic for 
j=0 or the largest order statistic for j=n.

Pseudo SD: Jackknife estimate of the standard deviation of the harmonic mean. For n points, x1, … 
xn, the pseudo standard deviation is:

where: 

and: 

Range: Range of values (maximum value minus minimum value). 

SD: Standard Deviation: 

SD Log: Standard deviation of the natural logs of the observations:
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(Definition 6 in Hyndman and Fan, “Sample Quantiles in Statistical Packages”, American 
Statistician, Nov 1996. Equivalent to SAS PCTLDEF 4, Excel PERCENTILE.EXC, and NIST 
Engineering Statistics Handbook, Section 7.2.6.2, Percentiles.)
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SE: Standard Error:

Skewness: Sample coefficient of skewness (sample skewness):

Sample Skewness=Population Skewness*sqrt(N*(N–1))/(N–2)

Skewness Pop: Population coefficient of skewness (population skewness):

Population Skewness=Sample Skewness*(N–2)/sqrt(N*(N–1))

Sum: Sum of the values in the column mapped to Summary:

Variance: Unbiased sample variance:

Units
When summary statistics are calculated for a variable with units, some of the output will have units. 
Assuming that the variable summarized is x and has x-units specified, the units for the summary sta-
tistics are:

N, NMiss, NObs: No units
CV%, Geometric CV%: No units
Skewness, Skewness Pop, Kurtosis, Kurtosis Pop, KSP Value: No units
Mean Log, SD Log: No units
Variance: x-unit2 
Cl Lower Var, Cl Upper Var: x-unit2 
Everything else: x-unit

If more than one Summary variable is mapped, with at least two of those variables having units in the 
input dataset, and the units differ, a stacked Units column is displayed in the Statistics output work-
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sheet that reports the units of the Summary variables. In cases where the input data does not have 
units, or the units are all the same, then the units of the statistics are displayed in the column headers.

Weighted summary statistics
Summary statistics can be weighted by selecting a column in the dataset in the Main Mappings panel 
to provide weights. If a weight is non-numeric or missing, the observation is excluded from the analy-
sis. Weighted descriptive statistics output also includes a text file called Settings that contains user-
specified settings. Some summary statistics and all percentiles are excluded in weighted output. 

Results and computational formulas for weighted calculations
The output for weighted summary statistics contains a column indicating the summary variable(s), 
one for each sort variable, and the statistics listed below.

CI X% Lower: Lower limit of an X% confidence interval for the weighted data:
     Weighted Mean – t/2 x Weighted SD 

CI X% Lower Mean: Lower limit of an X% confidence interval for the weighted mean.

CI X% Lower Var: Lower limit of an X% confidence interval for the weighted variance.

CI X% Upper: Upper limit of an X% confidence interval for the weighted data: 
     Weighted Mean + t/2 x Weighted SD 

CI X% Upper Mean: Upper limit of an X% confidence interval for the weighted mean.

CI X% Upper Var: Upper limit of an X% confidence interval for the weighted variance.

CV%: Weighted coefficient of variation: 
     (Weighted SD/Weighted Mean)*100

Kurtosis Pop: Weighted coefficient of excess (population excess kurtosis):

Lower XSD and Upper XSD: Range determined by adding or subtracting X weighted standard devi-
ations from the weighted mean: 
      Weighted Mean +/– X*Weighted SD

Max: Maximum value

Mean: Weighted arithmetic average:

Min: Minimum value

N: Number of non-missing observations (including those with weights=zero)
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NMiss: Number of observations with missing data

NObs: Number of observations (including observations with weights=zero)

Range: Range of values (maximum value minus minimum value)

SD: Weighted standard deviation: 

SE: Weighted standard error:

Skewness Pop: Weighted coefficient of skewness (population skewness):

Sum: Weighted Sum: 

Variance: Weighted variance:

where  is the weighted mean.

Weighted Variance

Weighted SD
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ggquickeda
The ggquickeda object provides access to the ggquickeda R shiny application, which is an interface to 
ggplot2/table1. The application enables quick exploration of data to detect trends on the fly. You can 
do scatter plots, dot plots, box plots, bar plots, histograms, densities, and summary statistics tables.

The ggquickeda object requires:
• Installation of R: It is recommended that the version of R required to run the ggquickeda pack-

age be verified by looking at the ggquickeda documentation on the cranr-project.org website. 
• Configuration of the Phoenix R plugin: Use the Phoenix Preferences dialog (Edit > Prefer-

ences) to set the location of the R executable.
• Installation of the R package ggquickeda: Use R package installation process (e.g., 

install.packages(“ggquickeda”)). All other R packages required to run ggq-
uickeda will also be installed. For a list of these additional packages, see the ggquickeda doc-
umentation on the cranr-project.org website. 

Information on using the ggquickeda package can be found at 
https://cran.r-project.org/web/packages/ggquickeda/vignettes/ggquickeda.html
and
https://cran.r-project.org/web/packages/ggquickeda/vignettes/AdditionalPlotsStats.html

Use one of the following to add the object to a Workflow:

Right-click menu for a worksheet: Send To > External Software > ggquickeda.
Right-click menu for a Workflow object: New > External Software > ggquickeda. 
Main menu: Insert > Open External Software > ggquickeda.

Note: A dataset must be mapped to the object before the ggquickeda interface is displayed. To do this, 
use the Select Source button in the area to the right of the Object Browser. If you use drag and 
drop instead, be sure to drag to the top area near the View Source button on the right until the 
mouse cursor changes from unavailable to available and then release the mouse button (other-
wise, the dataset will not be mapped and the interface will not open). 

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Once you have executed the ggquickeda object, import the results into Phoenix to continue your anal-
ysis. 

https://cran.r-project.org/web/packages/ggquickeda/vignettes/ggquickeda.html
https://cran.r-project.org
https://cran.r-project.org/web/packages/ggquickeda/vignettes/AdditionalPlotsStats.html
https://cran.r-project.org
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Integral
Integral is a database system for secure storage of study data and analyses. Integral provides a 
secure data management system with complete auditing capabilities. The combination of Integral and 
Phoenix provides an effective means to share source data, models, scripts and results among the 
members of a drug development team. The combination also supports compliance with the U.S. Food 
and Drug Administration’s 21 CFR Part 11 regulation.

Phoenix can work in conjunction with Integral for secure storage and change tracking for data and 
analyses. This section covers the use of Phoenix as an Integral client: loading Integral data to Phoe-
nix and saving data from Phoenix as Integral projects and experiments. Integral can also be accessed 
by way of a Web interface, which provides additional operations. The Integral functions and opera-
tions are covered in the Certara Integral documentation.

This section contains the following topics:

Accessing the Integral browser
Adding a project to Integral
Defining the settings for a project
Confirming changes
Saving updated projects to Integral
Adding items to Integral
Loading Items in Phoenix
Adding an Experiment
Detaching an item in Phoenix from Integral
Setting up a connection
Configuring default save options
Using PKS scenarios and Integral

Accessing the Integral browser

Note: Connection to Integral from Phoenix requires the setting of some preference options. Refer to 
“Setting up a connection” for more information.

Selecting Integral > Browser from the main Phoenix menu displays the login page of Integral. Once 
credentials are verified, the Integral interface is presented. For details on using this interface, go to 
Certara Integral documentation. 

Use the red X button to close the Integral browser dialog when finished.

https://onlinehelp.certara.com/integral/1.0/index.html
https://onlinehelp.certara.com/integral/1.0/index.html
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Adding a project to Integral

Note: Connection to Integral from Phoenix requires the setting of some preference options. Refer to 
“Setting up a connection” for more information.

An Integral project can be created from a project loaded in Phoenix. With the project selected in the 
Object Browser, select Integral > Save to New Project (or right-click a project in the Object Browser 
and select Save to New Project in Integral). If a connection to Integral has not been established, 
you will be asked to enter your log in credentials first. 

1. All of the repositories to which you have been permitted access are listed in the Repository pull-
down menu. Select the one to which the project is to be saved.

2. Enter the name (Project Name) and a description (Description) of the project. 

3. Use the remaining fields and pull-downs to enter additional information. 

The options available in the dialog are controlled by the administrator.

4. When finished, click Next Arrow button to continue to the Settings page (see “Defining the set-
tings for a project”).
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Defining the settings for a project
The settings for a project are divided into three separate tabs:

Experiment tab
Save Options tab
Dependencies tab

Experiment tab

In the Experiment tab, define an experiment in the project using the available fields and menus. The 
options available are set up by the administrator.
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Save Options tab
Click the Save Options tab to set up what and how the project items will be saved to Integral.

In the Save Options Settings tab, each item available for export listed. 

1. Search through the list by entering the query in the field above the list and using the following but-
tons to find the next or previous instance of the query.

2. If a name other than the one assigned by Phoenix (shown in the Full Name field) is to be used 
when exporting an item, select the item and enter the new name in the Name field.

3. Select the format(s) in which to export the item by checking the box(es) in the Available Formats 
list.

4. If the Include Workflow Summary box is checked, a Workflow Summary.zip file is saved 
in the project. 

5. Use the Clear Save Options button to remove any user-entered names or format settings. Use 
the Apply Default Save Options button to use the default settings for the data type of the 
selected item. See “Configuring default save options” for details on setting up default save options.
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Dependencies tab
Click the Dependencies tab to set dependency tracking options.

Objects loaded from Integral into the current project are listed in the Dependencies tab, along with 
their current status.

Checking the Invalidate Scenario On box for a dependency causes experiments that reference 
the object to be marked as out-of-date (i.e., invalidated) when a different version of the object is 
saved to Integral. Clearing the checkbox will result in an experiment not being marked out-of-date 
when a new version is saved to Integral.

Check the Notify box to send the user a message when the experiment is invalidated. 

After setting the experiment properties, save options, and dependency customizations, click Next 
Arrow button to continue to the Confirmation page (see “Confirming changes”).

Objects loaded from the Integral into Phoenix projects have their dependencies maintained.
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Confirming changes

1. In the Confirmation page, enter a statement regarding the new project being added to Integral in 
the Audit Reason field.

2. Check the Approve Change box to authorize submission to Integral.

3. Click Finish.

The saving process begins and a progress dialog is displayed. Once the Phoenix project has been 
saved to Integral, the progress dialog goes away. 

Note: When a Phoenix project is loaded into Integral for the first time, a SavePoint (i.e., a snapshot of 
the experiment) will not be registered. Only after it is loaded into Phoenix from Integral and saved 
back will SavePoints and versions be registered.

Saving updated projects to Integral
The Integral Save and Save As options are enabled when a project that has already been saved in 
Integral is loaded into the Object Browser. These options are located in the Integral menu or on the 
right-click menu for a project in the Object Browser as Save to Integral and Save As to Integral. 

Using the Save option creates a SavePoint for the experiment in Integral. A SavePoint is essentially a 
snapshot of the experiment as it currently exists. At any point in the future, you are able to take the 
experiment back to a prior state by loading the corresponding SavePoint. 

Once you load an experiment from Integral into Phoenix, create a SavePoint before making any 
changes. You can then easily return to the starting point as needed. If you try to create a SavePoint 
after making changes to the experiment, you are warned about the changes and asked to choose to 
either save the changes as a new experiment (Save As) or discard the changes and load the latest 
saved version from Integral (Get Latest). 

Using the Save As option, as mentioned in the previous paragraph, creates a new experiment.

Selecting either Save or Save As takes you to the Settings dialog, where you can make the neces-
sary modifications before saving to Integral. See “Defining the settings for a project”.
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Adding items to Integral
With the item to save selected in the Object Browser, select Integral > Add Selected Item (or right-
click the item in the Object Browser and select Add Selected Item to Integral).

1. All of the repositories to which you have been permitted access are listed in the Repository pull-
down menu. Select the one to which the item is to be saved.

2. Enter a name (Name) for the item or use the default name.

3. Select the type of the item being added from the Type pull-down.

4. Enter a description (Description) of the item. 

5. Select the Integral folder in which to save the item from the list. 
To search through the list:

-Enter the query in the field above the list.

-Use  to find the next or previous instance of the query. 

- Load a list of favorite locations in Integral by clicking . 

- To refresh the list, click .

6. Click OK to add the item to Integral.

7. Use the Integral browser to view the newly added item.
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Setting up a connection
The Integral connection information must be provided before Phoenix can connect to Integral.

1. Select Edit > Preferences.

2. In the Preferences dialog, click the (+) sign beside Integral and select Instances.

3. Click Add to display the Integral Configuration dialog and enter the configuration properties.

To connect directly, enter the address to the web site in the Host Url field.

To connect via proxy, check the Use Proxy Server box and then choose whether to Use Default
Proxy or Specify Proxy Settings by entering the Host and Port information to access a different
proxy. (Check the Use Https box if this is an HTTPS proxy server.)

4. Click OK to save the new Integral instance.

To edit an existing Integral instance definition, select it in the Preferences dialog and click Edit. Then 
make the modifications in the displayed dialog.

To delete the instance definition, select it in the Preferences dialog and click Remove. 

Note: Users cannot edit or remove instances to which they are currently connected.
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Configuring default save options
The default save options can be configured in the Integral section in the Preferences dialog. The 
default save options determine how operational object output is displayed in Integral. An operational 
object’s output should be displayed when it is useful for data mining or reports, or if the output is 
loaded individually into another project to be re-used or shared.

1. Select Edit > Preferences.

2. In the Preferences dialog, select Integral > Default Save Options.

3. To add a default save option, click Add.
To edit an option, select it and click Edit.

In the Default Save Option dialog, use the pull-down menus and field to define a save option. For 
example, the previous image shows a new default save option being defined involving NCA. When 
the program encounters an NCA generated worksheet with a name that starts with “Final Parame-
ter”, it is to be exported to Integral as an Integral Dataset.

4. To remove a save option, select the option and click Remove.

5. To save the defined options to an XML file, click Save to File, then select a location and enter a 
filename in the dialog. To load options from a file, click Load from File.

Saving the default save options to a file is a useful way of synchronizing settings across an organiza-
tion.
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Using PKS scenarios and Integral
If you have the legacy PKS plugin, you can continue to use it to update data and scenarios. Any 
changes made through the PKS plugin will be synced with the information in Integral. However, the 
reverse situation is not true. Change made through Integral will not be synced to PKS. 

PKS scenarios can be opened in Phoenix through the Integral plugin by going to the corresponding 
project and loading the desired scenario. Phoenix will open the scenario as a project. Note that a new 
version of the scenario cannot be saved, but it can be saved as a new project in Integral. (Right-click 
the scenario in the Object Browser and select Save to New Project in Integral.)
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NONMEM Shell
The NONMEM object runs NONMEM models by using NONMEM control files and datasets. The 
results are returned to Phoenix.

Note: Phoenix program plugins, such as the NONMEM object, assume that the corresponding third party 
software is installed and running properly.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > External Software > NONMEM Shell. 
Or Main menu: Insert > External Software > NONMEM Shell.
Or right-click menu for a worksheet: Send To > External Software > NONMEM Shell.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

This sections contains information on the following topics:

Setting up preferences
User interface description
Importing/Writing the code to access the external program
Executing the NONMEM object
Results

Setting up preferences
Global preferences are available to the user. Some third party tool objects require certain global set-
tings to be specified prior to use. There are optional settings to enable editing of scripts in external 
programs from within Phoenix. Some optional preferences can streamline the workflow by automati-
cally filling in or setting options in the object’s UI with information entered by the user in the Prefer-
ences dialog. 

To set up access to the external program

Select Edit > Preferences.

In the Preferences dialog, select the NONMEM in the menu tree.

Enter the path to the batch file in the first field or click Browse to locate and select the file/directory.

Click Test to make sure the correct file is selected. 

To specify a development environment

There is a Development Environment section available on the preference pages. When the develop-
ment environment is defined in this section, users can access that environment from the NONMEM 
object’s Options tab with the Start button. This allows users to edit scripts in other specified environ-
ments, and then pull the updated scripts back into Phoenix, at which time, the script can be executed 
from Phoenix and the output processed through the normal Phoenix workflow.
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In the Command field, enter the directory path to the executable or click Browse to locate and select 
the file.

In the Arguments field, enter any arguments/keywords to use when starting up the environment.

To define a default output location

Setting the output folder in the Preferences dialog eliminates the need to enter the information in the 
Options tab for each run. The fields will automatically be filled with the paths entered here.

Enter the directory path in the Default Output Folder field or use the Browse button.

Note: If the user specifies a default output location, the user must ensure that they have write access.

Turn on the Create a unique subfolder for each run checkbox to generate and then store the output 
from each run in a new subfolder of the output folder. 

User interface description
Setup tab
Options tab
Result Filters tab

Setup tab
The Setup tab allows mapping of datasets and control files to the object. The Mappings panel(s) of 
the Setup tab displays the column headers specified in the control file. The Text panel allows users to 
map a control file to the object and view the contents.

Context associations for NONMEM objects change depending on the column headers, or input, 
defined in the control file. Some common mapping contexts associated with NONMEM are listed in 
“Common NONMEM context definitions”.

Common NONMEM context definitions
The following context definitions are common NONMEM variable names. They are not representative 
of all NONMEM variable names. Required context mappings are colored orange in the Mappings 
panel.

None: Exclude data type from analysis and output.
ID: Subject identification number.
AMT: Dose given at dosing time or time zero for observation records.
DOSE: Dose given to each subject.
TIME: Blood sampling times. 
When using the Dose-Effect model, TIME is required as an input field in data, even though it is 
not used in analysis. You can create a dummy TIME column and map it work around this restric-
tion.
CONC_DV: Typically drug concentration in plasma, but can be any dependent variable.
MDV: Missing dependent variable.
AGE: Age in years.
WT: Weight in kilograms.
ISM: Is male or is not male. In the column, 1=male, and 0=female.
CLCR: Creatinine clearance in mL per minute.
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Options tab
The Options tab is used to define a location for the output, access development environment, and 
start a remove execution.

Entering an output location is optional. If a directory is not specified then Phoenix places output in a 
temporary folder that is deleted after Phoenix is closed. This may be preferred when sharing third 
party tool projects with other users, as the output folder is machine specific and may not exist on other 
machines. If users want to save the results from a third party tool object run to a disk, then they must 
either specify an output folder or manually export each result to disk. 

Enter the output folder path in the field or click Browse to specify the output folder location.

Turn on the Create a subfolder for each run checkbox to add a new results folder in the specified 
output location each time the object is executed.

This option prevents the output from being overwritten with each run, especially if the default out-
put folder option, under Edit > Preferences, is being used. 

Click Select Sources to include additional files along with the mapped input.

As an example, if a NONMEM object creates an MSF file that contains the estimates to full preci-
sion, then a second NONMEM object can use the MSF file as an Input File source. 

Note: The Select Sources button in a NONMEM object’s Options tab can only access workflow objects. 
To access items in the Data or Code folders, use the Select Source icon in the Setup tab toolbar.

Click the Clear Empty Results to remove any results published by the object that are empty.

Turn on the Clear DV when WRES=0 for NONMEM table output checkbox to clear the cell in the DV 
column for rows where the WRES column value equals 0.

To start the development environment, click Start in the Development Environment section of the 
Options tab.

The development environment as configured in the Preferences dialog is started. (See “To specify 
a development environment”.)
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Note: NONMEM requires that a dataset be mapped to the object before the development environment 
will start.

When script work is completed, click Reload Script to bring the modified script into Phoenix for use in 
the next execution of the object.

The following are available only for a NONMEM object:

Select the version of NONMEM to use when the object is executed. The versions are defined in 
the Preferences dialog, see “To set up access to the external program”.

Use the Generate Time/Residual Plots checkbox to control which plots are generated. These 
plots are required for some types of comparisons. In other cases, the type of model and data are 
not appropriate for the automatically generated plots, and can cause errors during the execution, 
in which case the user can uncheck this option.

Result Filters tab
See the “Result Filters tab” description for the PsN object.

Importing/Writing the code to access the external program
The NONMEM object must have code that will allow it to initiate the external program and submit 
jobs. The code can be stored as a control file, imported into the project, and mapped to the object, or 
the code can be directly entered into the object. 

Import and map file containing code
Write code in the Text panel
Adding shortcuts in scripts
Filtering results by size

Import and map file containing code
The process is the same as for many other Phoenix objects. Refer to “Importing datasets” common 
task description.

Write code in the Text panel
Instead of importing and mapping a control file, users can write their own code or copy and paste 
code from another source. (For more information, see the “Write code in the Text panel” section for 
the PsN object.

Below are additional notes for NONMEM.

• Changes made to the $INPUT record are reflected in the Dataset Mappings panel. Changes 
made to a mapped control file do not change the control file in the Code folder. 

• Any blanks or tabs before statements should be removed prior to executing in Phoenix. Other-
wise, the statement will be ignored.

• Use only upper case when the specifying PHXTBL in the control file. Otherwise, duplicate NON-
MEM output files will result since Phoenix generates a file named “PHXTBL” by default for use 
with the NONMEM Comparer object.
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• Input statements should not contain equal strings. For example, $INPUT ID TIME DV=DROP 
LNDV=DV MDV AMT RATE EVID DOSE should be changed to $INPUT ID TIME DV MDV AMT 
RATE EVID DOSE and the column LNDV mapped to DV.

• If a NONMEM control statement calls to perform more than one fit, the control statement should 
be split and the models run in sequence. For example, it should not be used with multiple $PROB 
input files, superproblems, or $PRIOR routines. 

In order for NONMEM to call Ifort variables within Phoenix the setup of nmfe7.bat needs to be 
modified to support specific compilers. The modifications needed are:

        set F77HOME=C:\Program Files\Intel\Compiler\Fortran\10.1.011 
        if '%F77VERHOME%==' set F77VERHOME=%F77HOME% 
        call “%F77VERHOME%\Ia32\bin\ifortvars.bat” 

• If NONMEM is installed on the same server as Phoenix, edit the path in the system environment 
so that gfortran comes ahead of the Certara software (i.e., edit the path so that C:\Program 
Files\gfortran\libexec\… comes first in the path, before C:\Program File 
s(X86)\Certara\Phoenix\MinGW…) to avoid issues where NONMEM errors out.

Adding shortcuts in scripts
The input can be defined within the script as a shortcut by adding ;PHX_SHORTCUT to the end of the 
$DATA statement.

     $DATA FILE [OPTIONS];PHX_SHORTCUT 

FILE will be replaced with the path to the file. 

Filtering results by size
See the “Filtering results by size” section for the PsN object.

Executing the NONMEM object

Click  (Execute icon) or click Execute Remotely in the Options tab to run the job remotely.

Executing a third party tool object remotely sends the job to the server that is defined in the Prefer-
ences dialog (Edit > Preferences > Remote Execution). See “Phoenix Configuration” for instruc-
tions. The project is saved automatically. 

The project must have been saved at least once prior to executing on RPS, otherwise execution will 
not pass validation and a validation message will be generated.

At this point, the step being executed on RPS, along with any dependent objects, has been locked. It 
is now safe to close the project or to continue working in Phoenix.

Results
The results are displayed on the Results tab. The output falls into the following categories:

Output Data: Datasets in tabular form
Text Output: Settings files, log files, and other text output
Other: Other kinds of files, for example: documents, export files, binary files, etc. 
Images: Graphs or other images in recognized image formats (jpg, tiff, emf, etc.)
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The NONMEM object generates the following output:

PHXTBL: Summary of ID, TIME, CWRES, DV, PRED, RES, and WRES. The table is generated 
by default even if there is no TABLE statement in the control file. (Do not use the name PHXTBL 
(lowercase, uppercase, or mixed case) for any other table, since the name is in use.)

Summary: Contains the total number of observations, total number of subjects, lengths of theta, 
minimum objective function value, total number of parameters, AIC, BIC, and the conditions for 
estimation.

GFCOMPILE: List of Digital FORTRAN compiler messages created during NONMEM execution.

FCON: NONMEM control stream file.

FDATA: Dataset used with NONMEM.

FREPORT: List of subroutines that generate commands used to create the NONMEM model.

FSTREAM: NONMEM file control stream.

FSUBS: List of generated FORTRAN subroutines.

PRDERR: List of errors encountered during execution of the PRED subroutine.

Raw_Output: Unparsed output from NONMEM.

Settings: Input worksheet used and the options selected.

stdout: Warnings and errors (if any) for problems.

If a NONMEM control file has a $COV statement then the total number of parameters in the model are 
calculated in the Summary table. If there is no $COV statement, then users can specify the number of 
parameters in the control file by adding this comment prior to the $EST statement:

   ;  #parameters= X 

where X is an integer.

If the control file contains several $EST statements the number of parameters comment preceding the 
estimate statement(s) would be used. 

If the number of parameters is available then AIC and BIC are calculated:

   AIC=Min. Val. Of Obj. Func+2*(Tot. #Params) 
   BIC=Min. Val. Of Obj. Func+(Tot. #Params*Loge(Tot.#obs)) 

Note: To correctly read in TABLE files generated by NONMEM, the ONEHEADER command must be 
present in the control file as part of the TABLE statements.

Additional NONMEM parameter data tables 

Sigma SE: Standard error(s) of the observation error variance estimates if the $COV statement is in 
the control file.

Theta: Fixed effect estimates.

Omega: Estimates of the elements of the random effect(s) covariance matrix.

Sigma: Estimates of the observation error variance(s).

Table 1: NONMEM generated table files.

COVARIANCE MATRIX OF ESTIMATE: Covariance matrix for the model parameter estimates if the 
$COV statement is in the control file.
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CORRELATION MATRIX OF ESTIMATE: Correlation matrix for the model parameter estimates if the 
$COV statement is in the control file.

Theta SE: Standard errors of the fixed effect estimates (thetas) if the $COV statement is in the control 
file.

Omega SE: Standard errors of the random effect covariance matrix element estimates (omegas), if 
the $COV statement is in the control file.

(Optional) File name of the TABLE statement: NONMEM generated table files.

Users can double-click any plot in the Results tab to edit it. (See the “Options tab” description for plots 
for more details.) Plot edits are maintained during consecutive NONMEM modeling runs.

Plots 

DV VS PRED: Dependent variable in the X-axis and predicted variable in the Y-axis. Generated by 
default.

PRED VS CWRES: Predicted variable in the X-axis and conditional weighted residuals in the Y-axis. 

PRED VS RES: Predicted variable in the X-axis and residual variable in the Y-axis. Generated by 
default.

PRED VS WRES: Predicted variable in the X-axis and weighted residuals in the Y-axis. Generated by 
default.

TIME VS DV: Time in the X-axis and dependent variable in the Y-axis. Generated by default.

TIME VS CWRES: Time in the X-axis and conditional weighted residuals in the Y-axis. 

TIME VS PRED: Time in the X-axis and predicted variable in the Y-axis. Generated by default.

TIME VS RES: Time in the X-axis and residual variable in the Y-axis. Generated by default.

TIME VS WRES: Time in the X-axis and weighted residuals in the Y-axis. Generated by default.

(Optional) Plot names in the $SCAT statement: NONMEM generated plots. SCAT statements in NON-
MEM code will only automatically generate a plot in Phoenix if there is a TABLE statement in NON-
MEM that contains the variable being plotted. Third party tool objects generate a TABLE statement 
automatically for ID, TIME, DV, PRED, RES, and WRES and thus, SCAT statements involving these 
variables will be created. If other variables are required by the SCAT statement, the user must specify 
them in an appropriate TABLE statement.

The Settings text file is generated and contains the updated concentration column.
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NONMEM Comparer
The NONMEM Comparer object allows users to compare the output of NONMEM models.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > External Software > NONMEM Comparer. 
Or Main menu: Insert > External Software > NONMEM Comparer.
Or right-click menu for a worksheet: Send To > External Software > NONMEM Comparer.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

This section contains information on the following:

User interface description
Results

User interface description
Setup tab
Options tab

Setup tab

Note: Although there are no icons in the Setup tab for importing/saving/loading object settings, these 
operations are still available using the File > Import menu, and right-clicking the object in the 
Object Browser or in the workflow diagram.

Models in the Setup tab are listed using the object name as seen in the object browser. If a NONMEM 
model was created by making a copy of a previous NONMEM model, then the copy is nested under-
neath the first model in the Comparison. The original model is the root model, and the copied model is 
the child.

Model copies that are nested underneath the original model will typically have additional parameters 
that are compared against the original model, which has fewer parameters. 

To change the hierarchical relationship between root and sub-models

Use the pointer to select a model in the Setup tab and drag the model on top of another model. 

Click Yes in the Move confirmation dialog.
The selected model is nested underneath the selected root model.

To move a child model back to the root level, right-click the child model and select Orphan Model.

Click Yes in the Move confirmation dialog.
The model is moved back to the root level in the Setup tab. 
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To exclude/include a model in the comparison

In the Comparison tab, users can select or clear the Hide or Compare checkboxes to exclude or 
include a model in the comparison.

If the Hide checkbox is checked, then the model is considered “hidden” and is removed from any 
comparisons.

If the Compare checkbox is checked, then the selected model is included in comparisons.

Options tab
The Options tab can be used to add or remove columns, worksheets, and plots used for comparisons. 

In the Columns list, clear checkbox to remove that column from the comparison. Removed columns 
are not included in the output worksheets.

In the Worksheets and Plots lists, clear the checkbox to exclude that worksheet or plot from the 
results.

In the Plot Options area, select the height, width, and graphic format for the output plot.

If a NONMEM model is marked as hidden, then check the Hide Selected checkbox to remove the 
model from the Setup tab and the comparison. (The hidden model is not used in any comparisons.)

Check the Full Names checkbox to display the full name of a model. The full name includes the 
name of the workflow containing the model.

Use the buttons in the Selections area to select or hide several models at once. Multiple rows in the 
Comparison panel must be selected to use these buttons.

Select multiple rows in the Comparison panel to use the buttons in the Selections area.

Click Check Hide to hide the selected models.
Click Check Compare to include the selected models in the comparison.
Click Un-Check Hide to not hide the models.
Click Un-Check Compare to remove the models from the comparison.

Results
Worksheets 

Correlation Matrix of Estimate: Estimates of the correlation of model parameter estimates listed for 
all the models being compared.

Covariance Matrix of Estimate: Variance-covariance matrix for model parameter estimates listed for 
all the models being compared.

Omega: Estimates of the random effect variance-covariance matrix (Omega) and standard errors of 
omega elements listed for all the models being compared.

Overall: Stacks the table 'Summary' result for each individual run but doesn't present any comparison 
calculation. Columns include:

NAME: The name of the NONMEM object being compared
Tot. # Obs: total number of observations
Tot. # Individuals: Total number of individuals
Length of Theta: Total number of fixed effects variables 
Min. Val Of. Obj. Func: Is the minimum value of the objective function for each NONMEM run
AIC: Akaike Information Criterion for each model run
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BIC: Bayesian Information Criterion for each model run
Conditions of Estimation: is the $EST statement of each control file 

Residuals: Stacked results from PHXTBL created for each individual NONMEM run with the addition 
of Model name. It contains columns for NAME (Model names being compared), ID, TIME, CWRES, 
DV, PRED, RES, and WRES.

Sigma: Estimates and standard errors of the observation error variance-covariance matrix (Sigma) 
for all models being compared.

Theta: Estimates and standard errors of the observation error variance-covariance matrix (Sigma) for 
all models being compared.

Summary: Estimates and standard errors of the fixed effect parameters (Theta) for all models being 
compared. Models are shown across the top. Columns include:

NAME: The name of the NONMEM object being compared
Method: The $EST statement of each control file
Lineage: List the 'parent' (i.e. reduced model) if the current model is a 'child' (derived from but 
with additional parameters) of another model 
Min. Val Of. Obj. Func: The minimum value of the objective function for each NONMEM run
AIC: Akaike Information Criterion for each model run
BIC: Bayesian Information Criterion for each model run
–2(LL)Delta: Difference in Min. Val Of Obj. Func. for nested models only (Lineage-Child model)
AICDelta: Difference in AIC values. for nested models only (Lineage-Child model)
BICDelta: Difference in BIC values for nested models only (Lineage-Child model)
#params: Number of model parameters
#obs: Number of observations
#Subj: Number of subjects
p-value: Chi-Square p-value based on the Likelihood Ratio Test for nested models only

The Plot Table is generated and illustrates all the selected plots in rows for each model being com-
pared (columns). This plot table is not editable and it places side by side the plots from the individual 
runs for easy visualization. Any changes done to the individual run plots will be reflected in this Plot 
table. This table can be exported or printed using the right-click menu options.

The Settings text file is generated and contains the list of current columns, plots, and models being 
compared. 
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ODBC

Note: The ODBC user interface is only available when using the 32-bit version of Phoenix.

Phoenix can exchange data with Open Database Connectivity (ODBC) compliant databases such as 
Oracle and SAS. For example, Phoenix can read rows of PK data from an ODBC-compliant database, 
and save analysis output back to a table in that database. This is done using the ODBC import and 
export functionality in Phoenix.

This section contains the following topics:

Establishing a connection
ODBC import
ODBC export

Establishing a connection
The first step in an ODBC import or ODBC export is to establish a connection to a specific database.

Creating a new connection string creates a new connection string, defining the database type 
and location. This connection string may be saved as part of an import or export settings file for 
re-use. 

Loading a saved connection extracts the connection string from a previously-saved import or 
export file. This establishes a link to the database, to be used with a new or saved query or 
export.

Creating a new connection string
To define the database type and location for ODBC import or export

Select File > ODBC > Import (or Export) > Legacy Wnl.

Select the Create a new Import (or Export) option button in the ODBC Import (or Export) dialog.

Click Next.

Select the Create a new connection option button and click Next.

Click New to set up new File or Machine data sources or select a data source from one of the two tabs 
in the Select Data Source dialog. (See Microsoft Windows documentation for details on creating new 
data sources.)
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The File Data Source tab lists all file Data Source Names (DSNs) and subdirectories on the system. 
These are file-based data sources that can be shared among all users who have the same ODBC 
drivers installed. The data sources do not need to be dedicated to a single user or local to a specific 
computer.

The Machine Data Source tab uses information stored in Window’s registry, which provides the major-
ity of the connection string information.

Click OK.

If a log in dialog appears, enter the appropriate login ID and password for the data source and click 
OK.

ID and password are set up by the Database Administrator or Information Technology personnel.

A connection string may be saved along with a import query or export definition in an import (*.imp) or 
export (*.exp) settings file for re-use. This is done at the conclusion of building the import query or 
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export definition. A connection string can also be saved by itself and loaded separately during the 
import/export setup process.

The next step is to set up a query (see “Specifying the Query”) to pull the desired data from the data-
base, or create an export definition (see “Creating a new export”) to map Phoenix data columns to 
database fields.

Loading a saved connection
Once a connection string is saved in an import (*.imp) or export (*.exp) file, it can be loaded for use 
with different import queries or export definitions.

Select File > ODBC > Import > Legacy Wnl or File > ODBC > Export > Legacy Wnl.

Select the Create a new Import (or Export) option button in the ODBC Import (or Export) dialog and 
click Next.

Select the Load an existing connection option button and click Next.

In the Open dialog, select the import file (*.imp) or export definition file (*.exp) containing the connec-
tion string for the desired database and click Open.

Proceed with the import or export, as detailed under “Specifying the Query” for imports or “Creating a 
new export” for export.

ODBC import
Use ODBC Import to load data from an ODBC-compliant database directly to a worksheet. An import 
involves establishing a connection to the database, then defining a query to draw specific fields and 
records from it.

Database connection: Both ODBC import and export use a connection string that defines the 
database type and location. This string can be created by pointing to the database type and file, 
or loaded from a previously-saved import or export as detailed under “Establishing a connection”. 

Query: Once the database connection is established, an import requires a query to set which 
data table, field(s) and records to import. The query can be created in the or loaded from a previ-
ously-saved import as described under “Specifying the Query”. Phoenix translates the query into 
Structured Query Language (SQL), which can be edited before executing the import.

The query settings can be saved with a connection string to an import specifications file (*.imp), for 
later re-use. The query settings can also be saved without the connection string and loaded for use 
with other databases via different connection strings.

Phoenix also provides a Custom Query Builder for creation of dynamic link library (DLL) files that can 
access additional data source types, including Watson version 7.x DMLIMS. See “Using the custom 
query builder”.

Note: If an error is encountered when using ODBC Import, try setting the permissions of the C:\Win-
dows\SysWOW64\comdlg32.ocx file (C:\Windows\SysWOW64\comdlg32.ocx for 
32-bit systems) to Read-Execute and Read for Everyone user.”
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Specifying the Query
Once a database connection string is established (see “Establishing a connection”), ODBC import 
requires a query specifying the data table, field(s) and records to be imported. There are two ways to 
specify a query:

Building a query
Loading a saved query

Building a query
Select File > ODBC > Import > Legacy Wnl.

Select the Create a new Import option button in the ODBC Import dialog and click Next.

Create a new or load a saved connection string, as detailed under “Establishing a connection”.

Select the Build a Query option button and click Next.

The Phoenix Query Builder accesses the database, and loads a list of the available tables. If the 
appropriate ODBC drivers are available, the Schema Filter dialog is displayed. It provides a 
means to filter the available database tables by schema, a metadata organizational tool. The 
schema are created by the database administrators.

If the Schema Filter dialog is displayed, select the schema to use in filtering the list of data tables, 
then click OK.

In the Source Table list, select a table from which to import data.

Click Next to continue with selecting the fields to import or click Done to load all fields in the table.

To select a field(s) to import: 

Click a field in the list to select it for import. (Clicking a field a second time, deselects it.)

Click Select all to select all fields. (Click De-Select all to clear all field selections.)

Click Next to continue with filtering the records or click Done to import all records in the selected 
fields.

To create the record filter:

In the Field Name menu, select a field name used to filter queries.

In the Operator menu, select a comparison or logical operator. 
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Note: The logical operator like means true if the operand matches a pattern.

Enter a value in the Field Value field or click List Distinct Values to select from all existing val-
ues for the selected field.

Click Add to set the filter.

To apply more than one filter, select the And or Or option buttons and return to create another fil-
ter. Filters are applied in the order they are created.

Click Done when all filters are entered.

In the ODBC Import: Final Settings dialog, confirm/edit the connection string and query SQL.

Check the Set Column Widths checkbox to adjust the destination worksheet's columns to match the 
widths of the fields in the database.

Check the Set Column Names checkbox to adjust the destination worksheet to have the same col-
umn names as the source fields.

Check the Set Column Formats checkbox to apply the appropriate number formats to columns con-
taining times, currency, and dates.

Check the Check Number of records? checkbox to provide a count of filtered records prior to the 
import, and the option to return and edit the query if needed.

Click Finish to import the selected data to a Phoenix worksheet.

If Check Number of Records? is checked, a message is displayed that states the number of 
records returned by the query. Click Yes to continue. 



Phoenix Framework
User’s Guide

200

In the Save Import query? dialog, check the Save Password checkbox to save the database user-
name, password, and connection string in the import file.
Saving all three pieces of information in the import file allows users to connect to a database.

Caution: The import file is not encrypted, so the saved password is not secure. 

Click Yes to save the import file.

In the Save As dialog, select a directory in the Save in field, type a file name in the File name field, 
and click Save.

If a user clicks Cancel in the Save As dialog the worksheet is still imported into Phoenix, but the 
import file is not saved.

The size of the worksheet Phoenix can import depends on the amount of memory in the computer 
running Phoenix. The list below shows memory requirements and cell limitations. ODBC drivers might 
impose additional limits.

For 1 gigabyte of RAM, there is a limit of 2 million worksheet cells
For 2 gigabytes of RAM, there is a limit of 4 million worksheet cells
For 3 gigabytes of RAM, there is a limit of 6 million worksheet cells

Loading a saved query
A saved import specifications file (*.imp) may or may not contain the connection string, depending on 
what options were specified during saving.

Select File > ODBC > Import > Legacy Wnl.

In the ODBC Import dialog, select the Load an existing Import option button and click Next.

In the Open dialog, select the import (*.imp) file and click Open. The ODBC Import: Final Settings 
dialog appears with all settings for that import loaded.

Makes changes as needed in the Import: Final Settings dialog or by using the Back button.

When the settings are correct, click Finish. The data from the database are then loaded into a Phoe-
nix worksheet.

Be aware that, once a connection string (new or existing) is established, any saved query can be 
loaded so long as it uses the tables, fields, and record types in the database to which Phoenix is con-
nected.

Using the custom query builder
The Custom Query Builder provides a means to build custom dynamic link library (DLL) files that 
access additional data source types, including Watson version 7.x DMLIMS. Further, Phoenix pro-
vides templates for creating the DLL files to access custom data sources.

Select File > ODBC > Import > Legacy Wnl.

Select Use Custom Query Builder and click Next.

The Select a Builder dialog is used to set the data resources to access. If the Custom Query 
Builder has not been used before, this dialog may be empty. 

To add resources to the Query Builder, click Add, then double-click the appropriate DLL file such as 
WatsonLIMS.dll.
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To configure the Watson DMLIMS custom resource to make sure that data are imported correctly:

Select that item and click Edit. 

In the Configuration dialog, enter the name of the Watson LIMS tables’ owner.

Enter the full directory path for the Watson templates or click Browse to locate the directory on 
your local machine or on a network server.

Click OK to close the Configuration dialog.

Highlight Watson DMLIMS (or another custom query builder) in the Select a Builder dialog and click 
OK. 

The dialog asks whether to load a query. 

To load a saved query, click Yes. In the Open File dialog, select an existing query (file type 
*.wts for Watson LIMS) and click Open. 

If no query has been saved for this builder, click No and proceed with the following steps. 

In the log in dialog, enter user name, password, and database alias, and click OK.

Note: The user name, password, and alias for any custom database system (such as the Watson 
DMLINS) are set by the database administrator or IT personnel. Request this information from that 
person or department.

In the Study Selection dialog, select a study by clicking on the row and then click Next.

Use the Order Study By field to sort any category, such as study number or ID, study director, 
etc., in order to find a listing more quickly.

Note: If no projects are listed in this dialog, contact your IT department. 

In the Import Data Variables dialog, select the desired variables. 

If all available variables are desired, click Select All. 

For a subset, drag each variable to the Selected Variables field. 

A particular combination of variables can be saved as a template. To create a new template drag the 
variables for the template to the Selected Variables field and click New. Then enter a name for the 
template. 

The fields will be imported in the order shown in the Selected Variables list.

Click Next to continue with data filtering or click Done to import all data in the selected fields.

Define a filter in the Filter dialog: 

Select the field to filter on from the Field box.

Choose an operator.

Either enter a value in the Field Value field or click List Distinct Values to select from all existing 
value for the selected field.

Click Add to set the filter. 

Use the And/Or operators to create compound filters such as Age>12 and Gender=Male. 

Click Done to load the data into a Phoenix worksheet. If Check # of rows returned checkbox was 
selected, Phoenix reports a count of records returned.
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ODBC export
Phoenix can export selected worksheet columns to specific fields within a table in any ODBC-compli-
ant database. Like ODBC import, the export requires a connection string defining the database type 
and location. It also requires an export definition to map columns in the source worksheet to fields in 
the target database table. 

Database connection: Both ODBC import and export can use the same connection string to 
define the database type and location. This string is created in the ODBC Export wizard or loaded 
from a previously-saved import or export as detailed under “Establishing a connection”.

Export definition: Once the database connection is established, an export requires a mapping of 
columns from the Phoenix worksheet to fields in the target database table. This export definition 
may be created in the ODBC Export wizard or loaded from a previously-saved export as shown 
under “Creating a new export”.

The export definition can be saved with a connection string to an export definition file (*.exp), for later 
re-use. The export definition can also be saved without the connection string and loaded for use with 
other databases via different connection strings.

See the following topics for more information:

Creating a new export
Loading a saved export

Creating a new export
In the Data folder, select a worksheet to export.

Select File > ODBC > Export > Legacy Wnl.

In the ODBC Export dialog, select the Create a new Export option button and click Next.

Create a new or load a connection string as detailed in “Establishing a connection”.

In the ODBC Export Definition dialog, select the Build a Definition option button and click Next.

As with the ODBC import, the schemas used to select the data variables can be specified. The 
Schema Filter dialog displays available schemas, if any were created by the database administrators.

If the Schema Filter dialog is displayed, select a schema and click OK. 

Using schema filters can speed up export operations by using saved export files.

In the Table Name menu of the Field Selection dialog, select the database table to receive the 
exported data.
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Drag the variables from the Variables list to the appropriate database fields under Field Definitions.

To export one constant value for all records in a given field, check the Fixed checkbox for a variable 
and enter a value in the field name.

This method can be used to differentiate one export from another. The data type and field size are 
set by the database administrator.

Click OK.

In the Save Export? dialog, check the Save Password checkbox to save the database username, 
password, and connection string in the export file.

Saving all three pieces of information in the import file allows users to connect to a database. The 
export definition file contains all information needed to reproduce the same export, excluding any 
constants in fixed fields.

Note: The import file is not encrypted, so the saved password is not secure. 

Click Yes to display the Save As dialog for specifying the location and file name.

If you click Cancel in the Save As dialog, the worksheet is still exported into the database, but the 
export file (*.exp) is not saved.

Loading a saved export
A saved export file (*.exp) may or may not contain the connection string, depending on what options 
were specified during saving. The field mappings in any ODBC export definition can be re-used with 
any database connection, assuming the field and table names in the export file exactly match a table 
in the selected database.

Select the dataset to export in the Data folder.

Select File > ODBC > Export > Legacy Wnl. 

In the ODBC Export dialog, select the Load an Export option button and click Next. 

In the Open dialog, select the export file (*.exp) and click Open. (Log on to the data source, if nec-
essary.)
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If the Schema Filter dialog is displayed, use the Schema Filter option to narrow the set of available 
data tables (optional) and click OK.

Users can select All schemas in the Schema Filter dialog.

Make any adjustments needed in the Field selection dialog and click OK to complete the export. 
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Pharsight Knowledgebase Server
The Pharsight Knowledgebase Server (PKS) is a database system for secure storage of study data 
and analyses. The PKS provides a secure data management system with complete auditing capabili-
ties. The combination of the PKS and Phoenix provides an effective means to share source data, 
models, scripts and results among the members of a drug development team. The combination also 
supports compliance with the U.S. Food and Drug Administration’s 21 CFR Part 11 regulation.

Phoenix can work in conjunction with the Pharsight Knowledgebase Server (PKS) for secure storage 
and change tracking for data and analyses. This chapter covers the use of Phoenix as a PKS client: 
loading PKS data to Phoenix and saving data from Phoenix as PKS studies and scenarios. The PKS 
can also be accessed by way of a Web interface, which provides additional operations, and an XML 
API. The PKS functions and operations are covered in the Pharsight Knowledgebase Server User’s 
Guide.

This section contains the following topics:

The PKS information structure
Dosing
Setting up a PKS connection
PKS Browser
Creating a PKS study
PKS study properties
PKS study data
Detaching PKS objects from source
PKS Save and Save As options
Configuring default save options
Loading and exporting multiple PKS objects
Global Library objects
PKS Job Viewer

The PKS information structure
Phoenix is an object (text, chart, model, data) based application. Those objects fit into specific niches 
in the PKS data structure. PKS saves observations and related data as a PKS study. Analysis settings 
and output are added to the study as scenarios. Non-Phoenix documents, such as analysis output, 
reports, and graphics that are related to the study, can be loaded into the PKS and associated with a 
scenario.

Studies
The basic unit of information in the PKS is a study. A study starts with a collection of raw data that 
must include longitudinal observations, observation times and subject identifiers, and may include 
dosing and subject demographics. A study must have all of these data characteristics if data is 
mapped to PKS internal structures, but the study can contain any type of data if stored in the study 
library. Studies can be created with data mapped to the PKS data structures, or they can contain file-
based data, maintained in the study library. As analyses are performed on these data, the analyses, 
including model settings and results, can be added as scenario(s) within the study. 

A PKS study requires specific fields. First, a study must include at least one column containing sub-
ject identifiers. A collection of fields taken together can be used for subject identification. For example, 
first name, last name. 
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A study can include, but is not required to have, multiple columns of subject data: time-invariant, 
subject-specific information such as body weight or gender, that is, baseline covariates. 

A study can include time-dependent observation and dosing data. Observation data can include 
records of concentration, measurements of blood pressure, heart rate, etc. Each data collection point 
can have multiple observations. In this case, a sampling variable is used to differentiate the samples.

If the observation data includes multiple, concurrent measurements for any subject, for example, mul-
tiple assays performed on a given sample or multiple samples during a given visit, the dataset must 
include a variable that differentiates the measurements, that is, values 1, 2, 3 for the 1st, 2nd and 3rd 
samples.

Time fields
Because a study generally includes time-dependent observation data, a study must include relative 
nominal time, indicating the times at which observations and doses if included, were scheduled in the 
protocol. This is in contrast to relative actual time, representing the times that observations or doses 
really happened. Relative time is time elapsed since the start of the study, period or phase. If the 
data uses infusion dosing, the relative nominal end time must be identified as well. If only the Relative 
Nominal Time is defined in the dataset, a duplicate column is created for the actual times. 

Note: To create a study that does include longitudinal observation data, include a dummy time column, 
with values for each row as placeholders, in the study.

Valid relative time units in PKS are: sec, min, hr, day, weeks, years. This restriction only applies to the 
nominal time, nominal end time, relative time, and relative end time. Other data elements can have 
any units (times, concentrations or other measurements).

Study metadata
When a study is created, information about the study can be entered in the Create Study dialog. This 
dialog includes information about the study: Study Name, Portfolio, Project, Indication, Study Type, 
Study Design, Compound, etc. The metadata provides ways to search and filter the data within the 
database. The metadata are saved with the study. See “Creating a PKS study” for more information 
about study metadata.

Scenario
When an analysis is performed on a PKS study, the combination of source data, model, and results 
data can then be saved in the PKS as a scenario of the original study. A scenario can include a 
structural model, initial parameters, and/or statistical tests to be applied to a particular dataset for fit-
ting or analysis, as well as any derived output from those tests or analysis. Scenarios are roughly 
comparable to the Phoenix concept of a project in that it is possible to save, in one place and under 
one name, related work: the data source, a model with model parameters, dosing, other model set-
tings, and the analytical output. There is also a file created when the scenario is saved that contains 
all of the History entries for the scenario at the time of the save. Scenarios are associated with, that is, 
they are the children of a particular study data source, although it is possible to create further scenar-
ios from a study or from an existing scenarios. See “Creating a Scenario” for more information.

Note: Loading a PKS scenario and submitting the workflow to the JMS for processing can prevent the 
scenario from being saved if the PKS middle-tier URL has changed since the scenario was last 
saved. If this occurs, run the scenario locally and save it to the PKS again.
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Global Library objects
The PKS can store documents, or library objects, such as study reports, SAS or NONMEM code files, 
or a graphic created by saving a Phoenix chart to an image file. Sets of documents can be associated 
with scenarios. See “Global Library objects” for more information.

Dosing
Dosing information is a special case of study data. Dosing is generally saved as part of a PKS study 
and it is preferable to have the dosing data in the same worksheet as the observations, though it is not 
required. 

If dose data is in a separate worksheet, it can be added to a study by loading it during study creation 
and its variables assigned as part of mapping the study variables. See “Creating a PKS study” for 
more information. 

The dosing worksheet must contain, at a minimum, subject identifiers, dose amounts, and relative 
nominal dose times. It must contain the sort variables required to distinguish profiles. The worksheet 
can contain columns for more than one analysis scenario. Users can select which dose columns to 
use for a given scenario. See “Creating a Scenario” for more information.

To append dosing data to an existing PKS study, import a worksheet containing the dose information. 
Use the PKS Append/Update feature to map the new data columns to PKS study fields. See “Editing 
study data” for more information.

Setting up a PKS connection
The PKS connection information must be provided before Phoenix can connect to PKS installations.

• Select Edit > Preferences.

• Click the (+) sign beside PKS and select Instances.

‘+

• Click Add. The PKS Configuration dialog is displayed.
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• Enter the requested configuration properties.

• Leave the Compress Subjects checkbox selected to improve performance by compressing 
study data per subject as it is transmitted to the PKS.
• Clearing the Compress Subjects checkbox is only recommended for diagnostic purposes.
• Selecting the Log XML checkbox is only recommended for diagnostic purposes.

• To use your Integral login information, check Use Integral Credentials and enter the web loca-
tion for the repository in the field.

• To connect via proxy from the Phoenix PKS Plugin, configure the proxy information with the spe-
cific instance.

• Check the Use Proxy Server checkbox.
If this checkbox is not checked, the controls inside the proxy configuration settings are disabled, 
and no proxy will be used.

• Select Default Proxy or click Specify Proxy to enter the Host and Port information to access a 
different proxy.

• Three Credentials or authentication methods are available for passing credentials to the proxy 
server. Select one of the credential methods:
Use Network Credentials: The system passes the credentials used to access the network.
Use PKS Credentials: The user name and password specified for the PKS connection are 
passed to the proxy by the system. (Users who have also configured PKS with LDAP authentica-
tion may want to select this option.)
Prompt (username and password): The system prompts for the proxy user name and pass-
word.

• Click OK to save the new PKS instance.

• Click OK to close the Preferences dialog.
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Users can edit PKS instances after they are created. In the Instances page in the Preferences dialog, 
select a PKS instances and click Edit to edit it and Remove to remove it.

Users cannot edit or remove instances to which they are currently connected.
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PKS Browser
Most interactions with PKS occur through the PKS Browser. The PKS Browser displays a list of stud-
ies in the system and their contents on the left. The table in the right panel allows sorting and search-
ing of the studies. All of the study information on the left is available in the table on the right. 

A study contains libraries, scenarios, and views. Selecting one of these “collection” nodes in the left 
panel will list the items in that collection in the right panel. Selecting one of the items in the list will dis-
play the properties for that item in the right panel. Selecting the study itself provides an opportunity to 
edit some of the study properties and post them to the system. The Custom Attributes tab lists any 
custom attributes that are defined for a study through the PKS Web Interface. Selecting a particular 
scenario displays several tabs of information: properties, custom attributes, dependencies (such as a 
study view, other scenario object, or global library), list of objects that are saved within the scenario. 

The contents displayed in the PKS Browser are limited by the logged in user's security permissions 
and by any applied filters. 

The PKS Browser also has a toolbar that allows users to perform several common PKS functions, 
including: switching between library and study views, refreshing the browser contents, setting display 
options, filtering PKS contents, toggling study and object property displays, creating new scenarios, 
study views, and new study object, and editing, appending, and updating study data.

The PKS Browser includes the following capabilities:

Viewing the Global Library
Refreshing the browser view
Displaying options
Filtering based on properties
Viewing Study and Study Object properties
Creating a Scenario
Creating a Study View
Loading existing scenarios/creating new scenario versions
Creating a new Study Library object
Editing study data
Appending data

Viewing the Global Library
The PKS Global Library can be used to store documents, models, scripts, images, and other binary 
files that can be re-used across many projects or analyses. The PKS Browser can be toggled back 
and forth between viewing the Global Library contents and viewing the Study menu tree. 

• Click  (Library icon) in the PKS Browser toolbar to toggle between the Global Library and 
Study views.
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Refreshing the browser view
PKS contents can change as a result of actions from other users. The changes might not be immedi-
ately reflected in the PKS Browser.

• Click Refresh to load the current contents of the PKS.

Displaying options
In the PKS Browser, the studies are listed in alphabetical order by default. They can also be grouped 
by indication, project, portfolio, compound and type.

• Click  (Display Options icon) to set the browser display options.

• Use the pointer to select one or more of the properties in the Available Properties list and click 
Add to move properties to the Selected Properties list. (Use the Remove button to move proper-
ties back to Available Properties list.
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• Change the display order of selected properties by selecting a property and doing any of the fol-
lowing:
• Click the Move Up and Move Down buttons.
• Select the Display latest scenarios first checkbox (displays the scenarios in reverse order 

of derivation).
• Select the Display all uniquely named scenarios first checkbox (displays all uniquely 

named scenarios at the root level). 
This option can be useful when multiple branches of a scenario, such as a new version with a 
different name, exist.

• To use the current settings in the dialog as the default display options, turn on the Set as default 
display options checkbox.

• Click OK to change the view of the studies and/or scenarios.

 

Filtering based on properties
Filter criteria can be created based on the properties of a study, scenario, or Global Library objects. 
Filter specifications can be saved and reused, and a filter specification can be set as the default filter.

• Click  (Filter icon), which displays the Filter PKS Contents dialog.

• In the Category menu select Study or Scenario.

• Select a study or scenario property in the Property List.

• For some properties, text values must be specified in the Criteria field.

An asterisk can be added to act as a wildcard for the filter criteria.

• For some properties users must select criteria based on existing values in the PKS database.

• Click Add Criteria, which adds the filter criteria to the filter in the Current Criteria list.
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• Click Add Criteria to continue adding other criteria.

• Click OK to apply the filter criteria. The Clear Filter icon  (Clear Filter icon) is added to the 
PKS Browser toolbar.

– Click Clear to clear all criteria from the Current Criteria field.
– Select a criteria and click Remove to remove the criteria from Current Criteria field.
– Click Save to save the filter criteria as an .xml file.
– Click Load to load a saved filter criteria file.
– Select the Set as default filter checkbox before saving the filter to set it as the default filter.
– The default filter can be loaded by clicking Load Default Filter.
– To clear the default filter, click Clear, select the Set as default filter checkbox and click OK.
– To remove a filter applied to the PKS Browser, click the Clear Filter icon in the PKS Browser 
toolbar.

Viewing Study and Study Object properties
The PKS Browser allows users to view and modify the current study and scenario properties.

– Click  (Show Properties icon) to toggle the study properties view on and off.
– Select a study to view its Study Properties tab.
– Edit the study properties using the property menus that define the study.
– Edit the study description.
– Click Apply to save the changes to the PKS.
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Creating a Scenario
Each PKS Scenario is treated as a Phoenix project. Scenarios can be created containing dependen-
cies on multiple PKS objects stored in the parent study, or in other studies or scenarios, or in the 
Global Library.

If a study only contains study library objects, those objects can be loaded directly into a project. How-
ever, if data is mapped to PKS data structures, then a study view must be generated before creating a 
scenario. When the new scenario is created, the data can be analyzed, modified and then saved to 
the PKS as a scenario for the selected study.

• Select a study and then click  (New Scenario icon) in the toolbar or Action > New Scenario 
from the menu.
Or right-click a library or view object and select New Scenario.

• Type a scenario name in the Scenario Name field.

• Clear the Show Latest Versions Only checkbox to display all objects that can be loaded. If the 
scenario being created is the first version, then no additional objects are displayed.
• Check the checkbox beside an object to include the object in the new scenario.
• Select as many objects as needed to create the new scenario.

• Click OK to create the scenario. A message is displayed when the scenario project is created. 

If any errors were encountered during scenario creation they are displayed in a separate mes-
sage.

New scenarios typically contain the contents of one or more study views.

After a scenario is created, additional objects can be loaded into the scenario by opening the PKS 
Browser, selecting an object, and clicking  (Load Object icon).

• Click Close to close the PKS Browser.

• Use Phoenix to edit data, add or update models, or make any other changes before saving the 
new scenario to the PKS.

See “PKS Save and Save As options” for instructions on saving the scenario to the PKS.
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Creating a Study View
Study views define how to extract data from the PKS. Most commonly, views are specified to extract a 
subset of data (columns or rows) from the currently selected study. More complex views can be cre-
ated to extract subsets of data from multiple studies.

Study views provide critical information necessary to reproduce datasets as they exist over time, and 
they provide for more granular status tracking of dependent analyses.

• Select a study and click  (New Study View icon).

• Type the study view name in the Study View Name field.

• Specify the columns to include in the view and their order.
• Select a column in the Available list and click Add to move the column to the Selected list for 

inclusion in the study view. 
(Click Remove to move the column back to the Available list).

• Select a column in the Selected list and click Move Up and Move Down.

• Use the Advanced Study View dialog to add studies to the new view and adjust the column asso-
ciations and settings.
• Click Advanced/Add Studies, which displays the Advanced Study View dialog.
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• Click Add Study to open the PKS Browser.
• Select a checkbox beside one or more studies and click Select to add them to the study view.

The new study information in displayed in the Advanced Study View dialog.

Depending on how the data source associated with a study is mapped, users can make changes 
to columns mapped to four areas: Subject Identifiers, Subject Demographics, Data Collection 
Point, and Observations.
• Use the menus in the Subject Identifiers, Subject Demographics, and Observations sections 

to change column mappings.
• Enter a new result name in the Result Name field or accept the default name.
• If a column has an associated unit, convert it by entering a conversion unit in the Convert to 

Unit field.
• Enter a new significant digit value in the Significant Digits field or accept the default value.
• In the Data Collection Point section, users can modify the nominal and relative time units, or 

leave the default settings.
• Click OK to close the Advanced Study View dialog.

• Click Specify Filter, which displays the Filter PKS Contents dialog.
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• Select a field in the Fields list.
• In the Operator menu, select boolean operator to specify the criteria.
• In the Criteria field, enter a filter criteria for the selected field.

OR
• Click Distinct Values to display all distinct values in the selected field. 
• Select a value and click Select to add the value to the Criteria field.
• Click Add Criteria to add the filter criteria to the Current Criteria list.
• Select a field and click Describe to open the Data Description window.
• Click OK to close the Data Description window.
• Click Clear to remove ALL of the filter criteria in the Current Criteria list.
• Select a filter criteria and click Remove to remove only that criteria from the Current Criteria 

list.

• Click OK in the Filter PKS Contents dialog to save the filter criteria. The filter criteria are displayed 
in the Filter list in the New Study View dialog.

• Click OK in the New Study View dialog to display the PKS Save dialog.

• Enter an Audit Reason in the Audit Reason field and enter your password in the Password field.

• Click OK to have the PKS process the new study view.
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Loading existing scenarios/creating new scenario versions
• Select an existing scenario in the PKS Browser.

• Open the scenario in one of three ways:
Double-click the scenario
Or right-click the scenario and select Load Scenario to Project.
Or click  (Load Object icon) in the toolbar.

If the scenario has out of date dependencies, users are prompted to load current objects. If the 
latest versions are not loaded, use the Refresh from Source button to get the latest version of 
the dependent objects.

Users can choose to load the scenario in its existing state or to get the most recent versions of 
dependent objects.

Updated versions of individual PKS objects can be retrieved from the PKS.

• Select a scenario in the Object Browser. Right-click the scenario and select Refresh from 
Source to update the scenario from the PKS.

When work is complete on the loaded scenario, it can be saved as a new version to the PKS.

• Select PKS > Save to save the scenario.

• Select PKS > Save As to save the scenario as a new branch.

Work can continue on scenarios between Phoenix and PKS sessions. Changes can be saved 
back to the PKS at any time.

Creating a new Study Library object
PKS supports storage and version history of objects, such as files or binary objects, at the study level. 
These objects can include documents, scripts, rule sets, or other files useful for the reporting or anal-
ysis of study data.

• Select a study to which to add a library object and then click the New Study Object icon  
(New Study Object icon).
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To load a file from a disk:

• In the Add Library Object dialog, click Browse Files. 

• In the Open dialog, search for and select a file and click Open.
The directory path is displayed in the Data Source field. The file name is listed in the Name field.

Change the file name by typing a new file name in the Name field.
Or select a name by clicking […] to open the PKS Global Library browser.

• Select a library object and click Select.

• The object name is displayed in the Name field.

To load an object from an opened project or projects:

• Click Browse Projects to open the Select Object dialog.

• Select an object in an open project and click Select.

• In the Add Library Object dialog, use the PKS Type menu to assign a different type to the object.

Some objects have only one PKS type. The PKS type default and options are based on the object 
file type.

• Enter a description for the object in the Description field.

• Click OK, which displays the PKS Save dialog.

• Enter an Audit Reason in the Audit Reason field.

• Enter your password in the Password field. 

• Click OK to create a Global Library object in the PKS.

To create a new version of an existing study library object:

• Select the object in the PKS Browser.

• Click the New Study Object icon. The Add Library Object dialog is displayed.
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• Make any necessary changes in the Add Library Object dialog.

• Update the library object by selecting a newer version from a saved file or an open project.

• Click OK to update the object.

In the PKS Browser, the updated version is listed beneath the previous version.

Editing study data
• Select a study to edit in the PKS Browser.

• Click  (Edit Study Data icon) (or right-click the study and select Edit Study Data).

• In the Load Study Data dialog, accept the default study data columns in the Selected field.

OR
• Select a column in the Available list and click Add to move the column to the Selected list.
• Remove a column from the selected list by selecting it and clicking Remove.
• Change the column order in the Selected list by selecting a column and clicking the Move Up 

and Move Down buttons.
• To specify a filter to return desired subset of data, click Specify Filter to add a filter.

• Click OK to retrieve the data and display it in the Edit Study dialog.
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• Edit or insert values as needed.

• Click Apply, which displays the PKS Save dialog.

• Enter an Audit Reason in the Audit Reason field.

• Enter your password in the Password field. 

• Click OK, which displays the PKS Process Manager.

• Click Close in the Process Manager dialog. 

• Close the Edit Study Data dialog.

Appending data
Data can only be appended to a study that already has been added to the PKS.

• Select a study to append data to in the PKS Browser.

• Click  (Edit Study Data icon) (or right-click the study and select Append/Update Study 
Data).
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• In the Append to Study dialog, select a data source by selecting a file or by selecting a dataset in 
a currently opened project.
To learn more about Study Data, see “Selecting a data source”.
• If the there are multiple worksheets, select the one to use as the source for creating the study.

If the selected data source is a workbook/worksheet, the File Import Wizard is displayed.
If a data source from a project is selected, the Select Object dialog is displayed.

• Select a worksheet in the Select Object dialog and click Select to add the worksheet as a 
data source.

• Click Map Study Data.

• In the Study Mapping dialog, assign the source columns to the appropriate tab.

See “Mapping study data” for instructions on using the Study Mapping dialog.

Users can load study mappings from a file. See “Loading a study map from a file” for instructions 
on loading a .map file.

Users can also load study mappings from the PKS. See “Loading a study map from PKS” for 
instructions on loading mappings from the PKS.

• Click OK to close the Study Mapping dialog.

• Click OK in the Append Study dialog, which displays the PKS Save dialog.

• Enter an Audit Reason in the Audit Reason field.

• Enter your password in the Password field. 

• Click OK, which displays the PKS Process Manager.

• Click Close to close the PKS Process Manager window. 

The additional study data is incorporated into the first project.
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Creating a PKS study
Studies are the fundamental unit of PKS organization. A PKS study stores raw data to be modeled 
and analyzed in one or more scenarios. 

• A study can be created from a project loaded in Phoenix (PKS > Save Project as PKS Scenario) 
or from scratch (PKS > Create Study). In either case, the Create Study dialog is used to define 
the study components.

If a connection to an instance of PKS is not established, the fields and menus are unavailable in 
the Create Study dialog.

• To establish a PKS connection, select a PKS instance in the instance menu in the Create Study 
dialog. The selected PKS instance is used to create a new study. 
If no instance is available, configure the PKS connection settings as described in “Setting up a 
PKS connection”.

• Click Connect and enter your user name and password in the Connect to PKS dialog and click 
OK. 

If the Prompt option for credentials is selected in the PKS Configuration dialog, the Connect to PKS 
dialog will display prompting for the PKS user name and password and a user name and password for 
the proxy connection.

The metadata fields in the Create Study dialog are made available:

Study Name: Used to identify and locate a study in PKS; must be unique within the PKS data-
base; typed entry; 50 character max. (Required field)
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Description: Text describing the study; press Ctrl+Enter for line breaks; typed entry; 2000 char-
acter max.

Blinding Type: Blinding level for the study; typed or selected from list of prior values; 30 charac-
ter max. (Required field)

Design: Experimental structure, e.g., parallel or crossover; typed or selected from list of prior val-
ues; 30 character max. (Required field)

Type: Type of study; typed or selected from list of prior values; 30 character max. (Required field)

Portfolio: Development portfolio to which the study belongs; typed or selected from list of prior 
values; 50 character max.

Project: Development project to which the study belongs; typed or selected from list of prior val-
ues; 100 character max.

Indication: Primary indication(s) for the study; typed or selected from list of prior values; 50 char-
acter max.

Compound: Main drug compound(s) under development; typed or selected from list of prior val-
ues; 50 character max.

State: Whether the study will be locked against changes or not; selected entry: normal or locked.

Study Start Date: Date on which the study began; typed or selected from the calendar popup; 
YYYY.MM.DD format.

Study End Date: Date on which the study concluded; typed or selected from the calendar popup; 
YYYY.MM.DD format.

• In the Properties tab, enter the study name and a description of the study.

• Use the menus in the Create Study dialog to select blinding type, design type, study type, portfo-
lio, etc.

• To save the study properties, click Save Properties.

• Type a name in the File name field and click Save. 

The study properties are saved as a .map file.

Load study properties from a file
• Click Load Properties. The Open dialog is displayed.

• In the Open dialog, select the directory that contains the study properties file.

• In the Files of type menu, select one of three study property file types:
Map (*.map)
XML (*.xml)
WNL Map (*.pks)

• Select the file and click Open to load saved study properties.

To learn more about creating and loading properties, see “PKS study properties”.
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• Select the Study Data tab. 

• Click Browse Files to select a data source from a file.

Column names in the data source cannot include an apostrophe as it can lead to errors when the 
data is added to the mapped columns. 

• Click Browse Projects to select a data source from an open Phoenix project.

• Use the Select Source dialog to navigate to a data source in Phoenix.
For more on Study Data, see “Selecting a data source”.
• If the selected data source contains multiple worksheets, the File Import Wizard is displayed.
• In the File Import Wizard, select the worksheet to use as the source for creating the study.
• Additional worksheets can be appended to the study using the Append/Update feature.

• Click Map Study Data and then:
• Create a new study mapping as detailed in “Creating and saving a .map file”.
• Load a map from file as detailed in “Loading a study map from a file”.
• Load map from PKS as detailed in “Loading a study map from PKS”.

• Click OK, which saves the map settings to the study.
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• Select the Custom Attributes tab and check the boxes of the custom study attributes to include in 
the study. 

• Check OK in the Create Study dialog to display the PKS Save dialog.

• Enter an Audit Reason in the Audit Reason field.
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• Enter your password in the Password field. 

• Click OK, which displays the PKS Process Manager.

• Click Close, which saves the study to the PKS. 

The study can also be submitted as a job after which the Phoenix session can be terminated and the 
processing will continue on the server processed later.

• Select the Submit as Job checkbox to process. 
• When the PKS has received the job information the PKS Process Manager can be closed.
• Use the PKS Job Viewer to monitor the processing status.

PKS study properties
Properties can be entered once or saved for future use. Once a properties file has been saved, the file 
can be loaded during any study creation. Saving the properties file is helpful if multiple projects have 
the same properties or if you create a study in PKS from this project multiple times. The saved proper-
ties can be modified once they have been loaded.

This section covers the following topics:

Creating and Saving Properties to a file
Loading properties files

Creating and Saving Properties to a file
• Load a Phoenix project file (*.phxproj) or create a new project.

• Select PKS > Create Study. 

• If Phoenix is not already connected to PKS, click Connect and enter your login credentials in the 
Connect to PKS dialog.

• In the Study Name field, type a study name. 

• Enter a description in the Description field.

• Use the menus in the Create Study dialog to specify Blinding Type, Design, Type, Portfolio, etc.
A red asterisk (*) denotes a required study property.

• Click Save Properties to save the study properties.

• In the Save As dialog, enter a file name and select a location in which to save the .map file.
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• Click Save to save the .map file. 

Loading properties files
• Load a Phoenix project file (*.phxproj) or create a new project.

• Select PKS > Create Study. 

• If Phoenix is not already connected to PKS, click Connect and enter your login credentials in the 
Connect to PKS dialog.

• Click Load Properties to load a file with saved study properties.

• In the Open dialog, select a .map file or a .pks file.

Phoenix WinNonlin study properties are saved as a .map file.
WinNonlin 5.3 study properties are saved as a .pks file.

• Click Open, which loads the study properties.

• If necessary, users can further modify study properties after the properties are loaded.
• Enter a new name or description in the Study Name and Description fields, or use the menus 

to modify study properties such as Blinding Type, Design, Type, etc.
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PKS study data
If study files are saved to the study library, no mapping is necessary. However, if a study is going to be 
saved to the PKS from Phoenix, the data source and its columns must to be mapped before creating 
the study in the PKS. Only one data source needs to be selected. The data source can be imported 
from a disk or selected from an open project.

Once a data source is selected the observation data, demographic data, and other data must be 
mapped to the appropriate columns. A .map file can be created and saved or properties can be 
loaded from a previously created .map file.

Selecting a data source
Mapping study data

Creating and saving a .map file
Loading a study map from a file
Loading a study map from PKS

Note: If a sample, dose, or demographic source field contains multiple values, use one of the following 
options to prevent leading zeros or commas from being stripped:
– include a space between the values (e.g., “01, 2, 3”)
– include quotes in the value, so in a CSV file, it would be “”01,2,3””
– include any non-numeric characters in the value

Selecting a data source
• Load a Phoenix project file (*.phxproj) or create a new project.

• Select PKS > Create Study. 

• If Phoenix is not already connected to PKS, click Connect and enter your login credentials in the 
Connect to PKS dialog.

• In the Properties tab, make sure the study property fields contain the appropriate selections.

• Select the Study Data tab.

There are two ways to add a data source: selecting a file from a disk or selecting a worksheet in a 
Phoenix project.

• To select a file from a disk:
• Click Browse Files.
• In the Open dialog, select a worksheet or workbook then click Open.
• In the Options area of the File Import Wizard, specify any additional import options.
• Click Finish to add the worksheet or workbook.

• To select a file from a Phoenix project:
• Click Browse Projects.
• In the Select Source dialog, click the (+) signs beside workbooks and operational object 

results to locate a data source.
• Use the pointer to select the data source.
• Click Select.

The Select Object dialog closes and the selected data source is listed in the Data Source field.
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Mapping study data
Study data can be mapped to PKS structures and saved as a .map file, loaded from an existing map 
file on a disk, or loaded from an existing .map file in the PKS.

Creating and saving a .map file
Loading a study map from a file
Loading a study map from PKS

Creating and saving a .map file
• Load a Phoenix project file (*.phxproj) or create a new project.

• Select PKS > Create Study.

• In the Create Study dialog, select the Study Data tab.

• In the Study Data tab, select a data source and click Map Study Data.

In the Study Mapping dialog, all the source columns in the worksheet are listed on the left. All of 
the different contexts for mapping are shown as tabs on the right. 

• To map a column to a Subject Identifier, Demographic, Samples, or Doses context, click and drag 
the source column from the list on the left to the list in the context tab. For example, drag the col-
umn that uniquely identifies subjects from the Source Column list to the list in the Subject Identi-
fiers tab.

• Use the Remove button to unmap a selected column.
• Enter an alternative name for the selected column by typing it in the Target Name field.
• Select the mapped column in the list to display attributes that can be modified.

• Specify column attributes and defaults for data collection points or treatments.
• If the attribute values are in a separate column, click and drag that column to the attribute 

field. 
(For example, if units are recorded as a separate column in the data source, click and drag 
that column name from the Source Column list to the Units attribute text field.) 
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• If the attribute value is always the same (i.e., static), enter that value and select the Static 
checkbox.

The Demographics tab maps subject data such as demographics and covariates.The selected demo-
graphic columns must contain values that exist once per subject. That is, the values are not time or 
visit dependent.

The Samples tab is for mapping time-dependent sample results and contains the following column 
attributes. 

Unit: Units of measurement.

Status: Indicates data status, for example, below a limit of quantification (BQL), or missing due to 
dropout or non-adherence. Valid data are finite. The list of statuses is defined by a PKS adminis-
trator.

Sample_Number: Sample identifier.

Sample_Matrix: Identifier for the sample matrix.

Sample_Description: Further information about the sample.

Analytical Method: Assay or technique used to obtain the sample data.

LLOQ: Lower limit of quantification for the assay. A numerical value.

ULOQ: Upper limit of quantification for the assay. A numerical value.

The Doses tabs contain the following column attributes. 

Unit: Units of measurement.

Status: Indicate data status, for example, below a limit of quantification (BQL), or missing due to 
dropout or non-adherence. Valid data are finite. The list of statuses is defined by a PKS adminis-
trator.

Sample_Number: Sample identifier.

Sample Description: Text information about the sample.

Route: Variable identifying route, oral, IV, IM, etc., for each dose.

The Data Collection Point tab (and Default Data Collection Point tab) is used to specify columns that 
contain data used to uniquely identify events where samples were collected or doses were adminis-
tered. The mappings can be overridden per dose or sample. The following column attributes are avail-
able on the Data Collection Point tab:

Period: Identifier for the period of the study.

Phase: Identifier for phase of the study.

Matrix: Matrix value, if study involves a matrix of analyte and concentration combinations.

Day: Number of days after the study, phase, period started.

Visit: Identifier for the visit during which observation was made/sample was taken.

Analyte: ID of the analyte used.

DCP Description: (Data Collection Point description) use this field for variables that distinguish 
different measurements stored a single observation column, for example, an indicator variable 
noting whether a given record contains a measurement of plasma concentration or pain score.

Relative_Nominal_Time: Scheduled time of observation or sampling since last dose.

Nominal_Time_Unit: Sample identifier.

Relative_Nominal_End_Time: Identifier for the sample matrix.
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Relative_Actual_Time: Further information about the sample.

Relative_Actual_End_Time: Assay or technique used to obtain the sample data.

Actual_Clock_Time: Lower limit of quantification for the assay. A numerical value.

The Treatment tab (and Default Treatment tab) is used to specify columns that uniquely identify 
administered treatments. Treatment information is combined with data collection point information to 
uniquely identify events where samples were collected or doses were administered. The following col-
umn attributes are available on the Treatment tab:

Treatment: Variable identifying the treatment.

Treatment_Description: Additional descriptive field.

Route: Variable identifying route, oral, IV, IM, etc., for each dose.

Regimen: Variable identifying dose regimen.

Fasted_Fed: Variable identifying whether subject ate before dosing.

Formulation: Variable identifying drug formulation for each dose.

State: Additional descriptive field.

The Default Treatment mappings can be overridden per dose or sample.

• Click OK. The Save As dialog is displayed.

• Select a directory in which to save the .map file and type a name in the File name field. Click
Save.

• Click the OK in the Study Mapping dialog.

The map file is used to create the study.

Loading a study map from a file
• In the Study Data tab of the Create Study dialog, select a data source and click Map Study Data.

• Click Load Map from File. which displays the Open dialog.

• In the Open dialog, search for and select the .map file.

• Click Open to load the .map file.

• Click OK to close the Study Mapping dialog.

The loaded mappings are applied and attached to the study.

The mappings are applied to the selected data source as closely as possible. Phoenix displays warn-
ing messages if there are any problems with the mappings.

Loading a study map from PKS
• In the Study Data tab of the Create Study dialog, select a data source and click Map Study Data.

• Click Load Map from PKS.
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• In the PKS Browser, click the (+) sign beside the study that contains the mappings and select the 
map file.

• Click Select to load the map file.
The loaded mappings are applied and attached to the study.

The mappings are applied to the selected data source as closely as possible. Phoenix displays 
warning messages if there are any problems with the mappings.

• (Optional) Click through the study mapping tabs to make any changes.

• Click OK to close the Study Mapping dialog.

• In the Save As dialog, save the mapping file.

Detaching PKS objects from source
Objects loaded from PKS can be detached from their PKS source. Detaching an object from its 
source allows the objects to be edited without a link to a specific PKS source.

To detach a project, select the project in the Object Browser and then select PKS > Detach PKS Set-
tings from Project or right-click the project object in the Object Browser and select PKS > Detach 
Object. 

The PKS source information is removed from all items in the project and are editable.

To detach an individual item within a project, right-click the item in the Object Browser and select PKS 
> Detach Object. 

The PKS source information is removed from the selected item in the project and is editable.
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PKS Save and Save As options
The PKS Save option is enabled when a scenario is created or loaded into the Object Browser. The 
PKS Save As option is used to save a scenario with a new name in order to create a new branch.

Note: Windows has a maximum file path limit of 255. PKS operations involve creating projects/objects 
based on names generated from the study and scenario names. These object/projects will be 
saved to disk using the temp paths. This combination can result in file names (path+filename) that 
exceeds the Windows limit of 255 characters. To avoid potential issues with Phoenix operations 
due to exceeding this limit, maintain smaller study and scenario names, and/or change the tmp/
temp environment variables to a shorter path (i.e. C:\tmp).

Load a scenario as a project from PKS into Phoenix and make any changes to the project using the 
instructions in “Creating a Scenario”. 

• Select the scenario in the Object Browser. 

• Select PKS > Save or Save As.

• In the Scenario Properties tab of the Save Scenario dialog, the Study Name and Scenario Name 
are already entered, based on the project information.

• Accept the default scenario name or type a new name in the Scenario Name field.

• Enter a description in the Description field, or leave the default description.

• Clearing the Derived checkbox allows the users to enter a new name for the scenario and save it 
as version one of a new scenario. Checking this box saves the scenario as a subsequent version 
of an existing scenario.

• Select the Save Options tab.

In existing scenarios, users can modify save options in the Save Options tab, or apply default 
save options.
• Click Re-apply Default Save Options to apply the default settings as set in the PKS Prefer-

ences.
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The Save Options tab displays objects in the current scenario that can be exported or saved to 
additional formats in the PKS.

Exporting objects using the Save and Save As functions allows objects to be viewed in the PKS 
Web interface, shared in other PKS Scenarios, and referenced by reports or queries.

Default save options are applied to new scenarios. See “Configuring default save options” for 
instructions on setting default save options.

• Select an object in the Save Options tab.
• In the Export Name field, type a new name.
• In the Available Formats field, check the format to be assigned to the selected object.

• Check the Include Workflow Summary box to save the Workflow Summary.zip file in the 
scenario. 

• Select the Dependencies tab. The Dependencies tab allows users to set dependency tracking 
options.

n
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Objects loaded from the PKS into the current scenario are listed in the Dependencies tab.

The default setting for each dependency is Invalidate Scenario On Change, which causes the 
scenario to be marked as out-of-date if or when a different version of the object is saved to the 
PKS. Clear the Invalidate Scenario on Change checkbox to not mark scenarios as Out-of-Date 
if or when a new version of the object is saved to the PKS.

• After setting the scenario properties, save options, and dependency customizations, click OK.

• In the PKS Save dialog, enter an Audit Reason in the Audit Reason field.

• Enter your password in the Password field. 
• Check the Submit as Job checkbox to submit the job. 

(You can continue working in Phoenix or close it and the job will continue to run until comple-
tion.)

• Use the PKS Job Viewer to monitor the status of submitted jobs.

• Click OK to save the scenario.

The PKS Process Manager is displayed and shows the save progress.

• When the processing is complete or the job is submitted, click Close to close the PKS Progress 
manager.

Note: Loading a PKS scenario and submitting the workflow to the JMS for processing can prevent the 
scenario from being saved if the PKS middle-tier URL has changed since the scenario was last 
saved. If this occurs, run the scenario locally and save it to the PKS again.
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Configuring default save options
The default save options can be configured in the PKS section in the Preferences dialog. The default 
save options determine how operational object output is displayed in the PKS. An operational object’s 
output should be displayed when it is useful for data mining or reports, or if the output is loaded indi-
vidually into another project to be re-used or shared.

1. Select Edit > Preferences.

2. In the Preferences dialog, select PKS > Default Save Options.

3. To add a default save option, click Add.
To edit an option, select it and click Edit.

In the Default Save Option dialog, use the pull-down menus and field to define a save option. For 
example, the previous image shows a new default save option being defined involving NCA. When 
the program encounters an NCA generated worksheet with a name that starts with “Final Parame-
ter”, it is to be exported to PKS as a PKS Dataset.

4. To remove a save option, select the option and click Remove.

5. To save the defined options to an XML file, click Save to File, then select a location and enter a 
filename in the dialog. To load options from a file, click Load from File.

Saving the default save options to a file is a useful way of synchronizing settings across an organiza-
tion.
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Loading and exporting multiple PKS objects
Multiple PKS objects can be loaded from Scenarios, Study Libraries, and from the Global Library 

• In the PKS Browser, select the scenario or library to load.

• Click Load Selected Objects.

The Load Selected Objects button is available on the Scenario Objects tab, Study Library tab, and 
Library Objects tab.

The Custom Load button allows the user to load system objects, scenario objects, and study objects 
without using the default import handler for the object type. For example, .xml files can be loaded 
without Phoenix assuming it is a settings file. Pressing the Custom Load button displays a dialog 
showing the same options when the File > Custom Import menu option is used.

To export multiple PKS objects from Scenarios, Study Libraries, Global Libraries, and Study Views 
directly to disk as a zip file:

• In the PKS Browser, select the objects to export.

• Click Export Selected Objects.

The Export Select Objects button is available on the Scenario Objects tab, Study Library tab, Library 
Objects tab, and Views tab.

Ctrl+click to select the objects to export or use Ctrl+A to select all objects.

PKS datasets and study views are saved as .csv files with the units row included. If a selected file 
does not have an extension or it is not recognized, then the file is saved with a .unknown extension.
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Global Library objects
The PKS Global Library can be used to centralize storage of objects that can be re-used across many 
projects. Objects loaded from the Global Library into Phoenix projects have their dependencies main-
tained.

• Select PKS > Add to Library. The Add Library Object dialog is displayed.

To select a file from disk:

• Click Browse Files.

• Use the Open dialog to search for, select, and open a file.

• The directory path is displayed in the Data Source field. The file name is listed in the Name field. 
Change the file name by typing a new file name in the Name field. Or select a name by clicking 
[…] to open the PKS Global Library browser.

• Select a Global Library object and click Select. The object name is displayed in the Name field.
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To select a file from a Phoenix project:
• Click Browse Projects.

• In the Select Object dialog, use the pointer to select a data source and click Select.

In the Export dialog, the type of file to export the object in the Save as type menu. Most non-data-
set objects have no export options other than the file name and where to save the file. 

A few of the file types lead to additional dialogs of export options. For example, if a plot is speci-
fied, the Image Settings dialog is displayed; for an Excel file the Excel Export Options dialog is 
displayed; for an SAS Transport file, the Rename Columns dialog is displayed; for plain data files 
(CSV, DAT, or TXT formats), the Data Export Options dialog is displayed.
• Make any changes in the dataset export dialogs and click OK.

The file is saved and the Add Library Object dialog displays the new file information.

• Use the PKS Type menu to assign a different type to the object. 

Some objects have only one PKS type. The PKS type default and options are based on the object 
file type.

• Enter a description for the object in the Description field. 

• Use the attribute menus (Model Type, Population Type, etc.) to select different attributes for an 
object, or leave the default selections.

• Click OK, which displays the PKS Save dialog.

• Enter an Audit Reason in the Audit Reason field.

• Enter your password in the Password field. 

• Click OK to create a Global Library object in the PKS.

• Use the PKS Browser to view the newly added Global Library object.
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PKS Job Viewer
The PKS Job Viewer displays all jobs submitted by the current user within a specified time frame.

• Select PKS > Job Viewer. The Job Viewer dialog is displayed.

• In the Time Frame menu select a time range to use to display submitted job history.

• Click Refresh to refresh the Job Viewer and get the current status of submitted jobs.

• Check/uncheck the Auto-refresh checkbox to toggle automatic refreshing of the Job Viewer 
using the selected Interval. 

• If the Auto-refresh checkbox is checked, use the Interval pull-down to adjust the time between 
refreshes: 5, 10, 30, or 60 seconds.

• Select a job that is not completed and click Terminate to cancel the job.

Note: When terminating a job or reviewing the job list, it is recommended that the user turn off the Auto-
refresh checkbox.
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Plotting
Phoenix includes several plot objects. These can be used to create plots using imported datasets, or 
output data from an analysis. Users can choose from:

Bar Plot object: To display the numeric values of categorical data. The data values of each 
series are represented as horizontal bars, which are plotted along the vertical axis at equally 
spaced intervals.

Column Plot object: To display the numeric values of categorical data. The data values of each 
series are represented as vertical columns, which are plotted along the horizontal axis at equally 
spaced intervals. Error bars can be added when no Groups are used.

Box Plot object: To graphically represent groups of numerical data through their five-number 
summaries, which include the smallest observation, the lower quartile (Q1), the median (Q2), the 
upper quartile (Q3), and the largest observation.

Histogram object: To create a graphical display of a frequency distribution. Bars are used to 
show a count of the data points that fall into various ranges.

XY Plot object: To create scatter or line plots. It can also be used to create overlaid plots. 
Regression lines and error bars can be added to XY plots.

QQ (quantile-quantile) Plot object: To display the quantiles of numeric data along with a com-
parison distribution which is the Standard Normal, to determine how closely the data fits the nor-
mal distribution. A quantile is the percent of data points below a given value.

Scatter Plot Matrix object: To shows a correlation between two or more variables. The Scatter 
Plot Matrix object contains all the pair-wise scatter plots of the variables on a single page in a 
matrix format.

X-Categorical XY Plot object: To create scatter plots when X is discrete data. It can also be 
used to create overlaid plots. Profile data, the independent variable, and the dependent variables 
can also be mapped to the Grouping context. For example, if time data is mapped to the X con-
text, it can also be mapped to the Group context. If the time data is also mapped to the Group 
context, and concentration data is mapped to the Y context, then the plot displays the time and 
concentration data points using different markers for the data points. 

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Plotting > [plot object name]. 
Or Main menu: Insert > Plotting > [plot object name].
Or right-click menu for a worksheet: Send To > Plotting > [plot object name].

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Additional information is available on the following topics:

Terminology of a plot display
Plots user interface
Plotting results
Error bars and overlaying plots example
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Terminology of a plot display
Before describing the individual controls, it will be helpful to understand the terminology used when 
discussing the areas of a plot displayed in the Phoenix user interface. 

Figure 46-1. Anatomy of a Phoenix plot

• The center of the display is the actual plot or graph, itself. This includes the plotted data points, 
any regression lines or error bars, and the axes lines. Adjusting the panel height and width 
options will change the size of this area.

• The area that encompasses the tick marks, tick labels, and labels for the axes is called the axis 
and tick label space. 

• The outer margin area extends beyond the axis and tick label space area and provides white 
space around the plot.

• The legend area is where the plot’s legend is displayed, if specified. 

• The space between the area where the plot’s title is displayed and the outer margin area is 
referred to as the title area size. 

• The area between the individual plots that make up a lattice is called chart spacing. For non-lat-
ticed plots, it is the area around the plot. 



245

Figure 46-2. Chart Spacing is the white space between plots in a lattice

Adjusting the sizes of these areas is available in the Options tab below the display area, select the 
Layout under the Plot node. There are also controls for setting the appearance of different labels 
used in a plot. If you find a particular set of values that you would like to use as the default settings, 
they can be entered in the Plotting Defaults page of the Preferences dialog (Edit > Preferences). See 
“Plotting defaults” for more details.
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Plots user interface
Data Mappings panel
Plot Options tab
Plot Layout Options tab
Plot Lattice Options tab
Axes Options tab
Graphs Options tab
Legend Options tab
Reference Lines Options tab
Annotations Options tab

Plot objects in Phoenix share a set of common controls that allow users to configure the plot display. 
Plot options are located in the Options tab, which is located underneath the Setup tab. Users can 
select one of five main categories in the navigation tree to display the corresponding group of display 
options. The categories are the same for all plots except Scatter Plot Matrix (which does not have 
Legend or Reference Lines options).

Most menu options in the Options tab can be used to format the plot display before or after the plot 
object is executed. Options that do not automatically update the plot display are noted.

Data Mappings panel
Use the Data Mappings panel to identify how input variables are used in a Plot object. Separate plots 
can be created for each profile. Required input is highlighted orange in the interface.

None: Data types mapped to this context are not included in the output.

X: The independent variable axis. Note that, for Bar plots, this axis is the vertical axis. A single X 
mapping is required for Column, Bar, XY, and X-Categorical XY plots.

Y: The dependent variable axis. A single Y mapping is required for Box and QQ plots. Mapping of 
either Y or Y2 is also required for XY, X-Categorical XY, Bar, and Column plots. 

Y2: The secondary dependent variable axis. This axis is displayed on the top of each plot.

Included: Variables used to create a Scatter Plot. At least two variables must be mapped to this 
context.

Data Label: Labels for data points on the X axis.

Distribution: Variable used to create the Histogram plot quartiles. A single Distribution mapping 
is required.

Group: Only for Bar, Column, Box, and XY plots. Groups the X axis based on the selected vari-
able.

Grouping: Only for X-Categorical XY plots. None: Data types mapped to this context are not 
grouped. Grouping Group: Displays the data points using different data point markers based on 
the variable mapped to this context. Any data type in a dataset can be mapped to Group even if it 
is also mapped to the independent and dependent variables contexts.

Lattice Conditions: Row: Separates the plots into multiple rows based on the selected variable 
or variables. (See “More on latticed plots in Phoenix”.) Not available for Scatter Plots. Column: 
Separates the plots into multiple columns based on the selected variable or variables. Not avail-
able for Scatter Plots. Page (Sort): Separates the plot by page based on the selected variable. 
Allows users to sort a plot by a variable or variables.

Error Bars: Error bars represent the overall distribution of the data and are used to indicate how 
closely the means of the data reflect the true values. Error bars are only available for XY, and X-
Categorical XY plots, and for Column plots that have no Group mapping. (See “Set up error 
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bars”.) Lower Error Bar: Error bar lengths or coordinates down the Y-axis. Upper Error Bar: 
Error bar lengths or coordinates up the Y-axis. Different variables in a dataset can be mapped 
separately to the Lower and Upper Error Bar contexts.

More on latticed plots in Phoenix
Latticing data is a way of arranging a plot display based on a sort key. For example, if a dataset con-
tains columns for subjects, time of dose, and concentration, it is possible to create a graph that dis-
plays time versus concentration for each subject if subject is selected as a sort key.

There are two ways to arrange a latticed graph: by row and by column. If a graph is latticed by sub-
ject, and there are three subjects in the dataset, Phoenix can create three graphs on one page that 
are displayed as either three rows or three columns.

The Lattice Titles window allows users to map a title to the columns in the source dataset that are 
used as lattice values. Users can map a separate worksheet to Lattice Titles, or use the source data-
set if it contains titles for the latticed variables. The lattice titles worksheet must contain the data that 
are used as the sort key or keys for the latticing, as well as one column that contains the title for the 
latticing sort keys.

For example, if a user wanted to create a graph that was latticed by subject, he or she would need a 
second worksheet that contains the subject IDs in one column, and the title for the subject IDs in 
another column. That worksheet would then be mapped to the Lattice Titles window. 

Lattice conditions

• Variables mapped to Lattice Conditions Row create a single column of plots in the Results tab.
For example, if a dataset contains 10 subjects and the subject variable is mapped to Lattice Con-
ditions Row, then a column of 10 rows (one row per subject) with a separate plot in each row is 
created in the Results tab.

• Variables mapped to Lattice Conditions Column create a single row of plots in the Results tab.
For example, if a dataset contains 10 subjects and the subject variable is mapped to Lattice Con-
ditions Column, then a row of 10 columns (one column per subject) with a separate plot in each 
column is created in the Results tab.

• Variables mapped to Lattice Conditions Page (Sort) create a separate plot per page in the 
Results tab. Each page is located on its own tab in the Results tab.
For example, if a dataset contains 10 subjects and the subject variable is mapped to Lattice Con-
ditions Page (Sort), then 10 separate plots are created on 10 separate page tabs in the Results 
tab.

Lattice Titles panel usage

If a variable in a dataset is mapped to any of the Lattice Conditions, then the Lattice Titles panel is dis-
played in the Setup tab list. Users can map a worksheet to the Lattice Titles page to add titles to the 
variable mapped to a Lattice Condition. Scatter Plot Matrix objects do not have a Lattice Titles panel.

• Import a worksheet that contains the titles associated with the variable or variables mapped to a 
lattice condition.

• Use the pointer to drag the worksheet from the Data folder to the Lattice Titles panel.
If the worksheet mapped to the plot Data Mappings panel contains the title column, drag the 
same worksheet to the Lattice Titles panel.

• Select the Title option button to map the title column to the Title context.
The Lattice Condition selected in the plot Data Mappings panel must also be selected in the Lat-
tice Titles panel. The column in the dataset that contains the title for the variable mapped to a Lat-
tice Condition must be mapped to the Title context.
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Plot Options tab
Select Plot in the menu tree to access the following tabs: 

Content tab, see “Define display sets”

Appearance tab, see “Set plot background and border”

Title tab, see “Define plot title”

Graphs tab, see “Add or remove plots”

Define display sets
Select Plot > Layout in the tree, then click the Content tab.

Phoenix has a maximum limit of 100 page tabs per plot display panel. This is only a limit on the num-
ber displayed, all plots are created, and, if an export is requested, all plots are exported. If a dataset 
contains more than 100 profiles mapped to a lattice condition, then plots 101 to 200 are contained in 
the second display set, etc. The Plot Content tab provides controls for switching between display pan-
els (i.e., display sets) and for adjusting the number of tabs available at one time in a display panel.

In the Display Set box, single-click the up and down arrows to view switch to a different set of page 
tabs (i.e., a different display set).

In the Pages per Set box, select or type the number of plot page tabs per display set.

The default and maximum number of page tabs per display set is 100.

Change the Pages per Set value to display less page tabs in the plot display panel.

Click the Force Redraw button to apply any changes made to the settings on this tab. (Clicking in 
another field or pressing the Enter key after changing the value in a field also triggers a redraw.)

The example below uses the default settings for the Content tab. The first 100 pages of the latticed 
results are available in Display Set 1. 

The figure below shows that the third display set has been selected for display and that the number of 
pages per set has been lowered to 10. Pages 21 through 30 are available when Display Set 3 is 
selected.
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Set plot background and border
Select Plot > Layout in the tree, then click the Appearance tab.

Figure 47-1. Plot Options — Appearance tab

In the Background Color menu, select the background color used in the plot display panel by select-
ing a color scheme tab: Palette, Named, or System and clicking the color.

In the Chart Areas Background Color menu, select the background color used as the background 
for each plot by selecting a color scheme tab: Palette, Named, or System and clicking the color

In the Border Color menu, select the background color used in the plot display panel by selecting a 
color scheme tab: Palette, Named, or System and clicking the color.

In the Border Style menu, select the border style to display around each graph. 

In the Border Width field, select or type the width for the plot borders. Users can select up to a 20 
point border width.

In the AntiAliasing Mode menu, select the part of the plot to be smoothed through anti-aliasing.
Anti-aliasing options include:

None (default)

Text: smooth the lines in text only 

Graphics: smooth the lines in the graphs only 

Text and Graphics: smooth all lines (text and graphs)

Note that anti-aliasing can slow down performance.
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Define plot title
Select Plot > Layout in the tree, then click the Title tab.

The Title menu item displays the title text field to enter a title for the plot. The tab also contains tradi-
tional Windows text formatting tools for defining the appearance of the title.

In the Text field, type a title.

Use the formatting controls above the Text field to modify the title’s appearance.

Add or remove plots
Select Plot > Layout in the tree, then click Graphs tab.

Figure 47-2. Plot Options — Graphs tab

Not all plot objects support adding multiple graphs to one plot object. If a plot object supports this fea-
ture, the Graphs tab instructions are included in that plot’s section.

Note: Users cannot add additional plots to Box, Histogram, or QQ plot objects, so the Graphs tab con-
trols are unavailable for those plots.

Click Add to add another plot to the Plot object. An additional plot is added to the plot list in the 
Graphs tab and an additional plot input is added to the Setup tab list.

Map a dataset to the additional plot object using the same steps listed under “Data Mappings panel”.

Remove a plot by selecting a plot in the plot list in the Graphs tab and clicking Remove.

Change the order of the plots by selecting a plot in the plot list in the Graphs tab and clicking the up or 
down arrow buttons.

Note: Plots are given a default name based on the variables mapped to the X, Y, and Y2 contexts.
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Plot Layout Options tab
Select Plot > Layout in the tree.

Refer to “Terminology of a plot display” for a review of the various areas that make up a plot.

Select the Fit image to screen checkbox to force the plot image to fit the current size of the right 
viewing panel. 

Note: Selecting Fit image to screen disables all other options in the Layout tab. 

In the Panel Height field, select or type the number of pixels used to specify the plot height.

In the Panel Width field, select or type the number of pixels used to specify the plot width. 

If a value is entered that is larger than what can be used in the plot display panel, then Phoenix 
automatically changes the value to maximum possible. Selecting more pixels than can be used to 
create the plot automatically changes the title, legend, axis and tick label space, chart spacing, 
and margin values.

In the Title Area Size field select or type the number of pixels used for the title area of the plots. Set-
ting the value too low can cause the title to get cropped.

In the Legend Area Size field select or type the number of pixels used for the legend area. The Scat-
ter Plot Matrix object does not use the Legend Area Size control.

In the Tick Label Area Size field select or type the number of pixels used for the tick labels.

In the Chart Spacing field select or type the number of pixels used to specify the distances between 
plots.

In the Outer Margin field select or type the number of pixels used to specify the margin around the 
plots.

In the Lattice Title Offset field select or type the number of pixels used to offset the lattice title from 
the plots.
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Plot Lattice Options tab
Select Plot > Lattice in the tree.

The default lattice setting for a plot with a study variable mapped to one of the lattice conditions is 
Bind Lattice to Data. This setting automatically displays multiple plots per page (maximum is 15 by 
15 plots per page). If a variable with more than 225 values is mapped to any lattice condition, Phoenix 
cannot automatically create the graph and lattice options must be set manually.

Clear the Bind Lattice to Data checkbox to specify lattice display options.

In the Lattice Rows box, select or type the number of rows used to lattice the plot.

In the Lattice Columns box, select or type the number of columns used to lattice the plot.

Select the Collapse Sparse Latticing checkbox to remove empty plots. 

If multiple variables are mapped to lattice conditions and one variable does not contain as many 
data points as the others, some empty plots are created. Complete plots are only created when all 
variables mapped to lattice conditions contain the same number of values. Selecting the Col-
lapse Sparse Latticing checkbox removes the empty plots.

The Text menu controls the part of the plot title that comes from the data on which the lattice depends 
(e.g., the variable mapped to the Lattice Condition). Select the format for displaying this information in 
the title of each latticed plot. Options include:

Name: displays the name of the mapped variable.

Value: displays the value of the mapped variable.

Name - Value: displays the name and value of the mapped variable.

None: no information about the mapped variable is included in the title.

Figure 47-3. Controlling the content of latticed plot titles



Phoenix Framework
User’s Guide

254

Click the Change Font button to open the Font dialog and change the lattice title font.

Select the font type, style, size, effect, and script. Click OK to accept the changes or Cancel to 
leave the font the same.

In the Color menu, select the lattice title color by selecting a color scheme tab: Palette, Named, or 
System and clicking the color.

Check the Ignore Mapped Lattice Titles box to hide the portion of the latticed plot titles derived from 
the worksheet being plotted. 
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Axes Options tab
The X, Y, and Y2 menu items set the appearance of the plot axes. The Box Plot and Histogram 
objects only have a Y context, but they do have X and Y axes. Select the X or Y menu items to set the 
appearance of the plot axes. The Scatter Plot object will list an axis item for each variable mapped to 
the Included context. 

Select one of the axis menu items to access the following tabs: 

• Content tab, see:
“Set the axis range”
“Set the axis scale”

• Appearance tab, see “Define axis and tick mark appearance”

• Axis Label tab, see “Format the axis label”

• Order tab, see “Order categorical axes”

Set the axis range
Select Axes > X, Y, or Y2 in the tree, then click the Content tab.

Options for setting the range are fairly consistent across plot objects.

Figure 48-1. Axis Options — Content tab 

There are two autoscaling methods available for determining the axis range. 

AutoScale Uniform creates a uniform axis scale across all plots when multiple pages, rows, or 
columns are used to show the plots. This is the default setting. Note that, in some plots, this 
option can cause the axis to extend past the highest data point or below the lowest point, since 
the largest range needed is used. (This option does not apply to Scatter Plot Matrix.)

AutoScale Best allows Phoenix to determine the best axis scale based on the number of data 
points and the values used to create each individual plot. This is the default setting for the X-axis 
when the X-axis is categorical (X-Categorical XY, Box, Bar, and Column plot objects).

Note: Both Auto-scale options use the highest and lowest data points mapped to the axis to create the 
scale, where the first option uses the highest and lowest points from all plots in the lattice, and the 
second option uses the highest and lowest points for each individual plot.

For axes that are continuous, if either auto-scale option is selected and Linear scaling is specified, 
the Start Axis At 0 checkbox becomes available. When checked, this option forces the axis number-
ing to start at 0, regardless of the data being plotted. 

A Custom option allows manual entering the range for the axis. This option is available for the Y- and 
Y2-axes for all plot objects and the X-axis for QQ, Scatter Plot Matrix, and XY Plots. 

• Enter the starting point (i.e., the lowest value on the axis) in the Minimum field. 

• In the Maximum field, type the end point (i.e., highest value on the axis). 
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• Use the Divisions options to specify the number of tick marks that appear on the axis.

In the Major field, enter the number of numerically-labeled tick marks to display on the axis. 
In the Minor field, enter the number of unlabeled tick marks to appear the axis.

Set the axis scale
Select Axes > X, Y, or Y2 in the tree, then click the Content tab.

Scaling is available for the X-. Y- and Y2-axes for all plot objects and the X-axis for QQ, Scatter Plot 
Matrix, and XY Plots. 

Select whether to perform Linear (default) or Logarithmic scaling of the axis.

If Logarithmic is specified, select the logarithmic base. Options include: 2, 10, e (base of the natural 
logarithm).

Define axis and tick mark appearance
Select Axes > X, Y, or Y2 in the tree, then click the Appearance tab.

Figure 48-2. Scatter Plot Axis Options — Appearance tab

Clear the Visible checkbox to remove the corresponding item from the plot. 

Clearing this checkbox for Axis disables all other axis and tick mark formatting controls in the 
Appearance tab.

Use the Color menu to set the color. Choose one of the color scheme tabs: Palette, Named, or Sys-
tem and click the color. 

Select the line style for the axis, ticks, and grids from the Style menu

Enter the format for the tick label in the Tick Label Style field. 

The default is G4. G is the Microsoft .NET general format used for displaying real numbers in dec-
imal form. Using the G format converts a number to either fixed-point or scientific notation, 
depending on the length of the number and the specified precision. The 4 indicates that four num-
bers can be displayed on axis tick marks. 

Users can enter their own custom format using the following characters:
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G4: The default format. Can be changed to display numbers longer than four digits. (Usage: G5, 
G6, etc.)

0: Displays the whole number. (Usage: 0)

0.00: Displays the whole number plus two decimal places. (Usage: 0.00)

#: The pound sign is used as a digit placeholder. The digit is displayed if it exists, and is blank oth-
erwise. 0 and # can be combined, 0 for required digits and # for optional digits. (Usage: #.##, 
0.0####)

.: Decimal point. (Usage: #.##)

,: Thousand separator. (Usage: #,###.##; #,##0; #,##0.00)

%: Percentage sign. (Usage: #.##%; 0%; 0.0%)

E0; E+0; E–0: Entering any of these characters will cause the scale ticks to be formatted using 
scientific notation. (Usage: #.##E0; #.##E+0; #.##E–0)

ABC: Plain text characters are displayed literally. (Usage: Hello world)

Note: Standard and custom .NET numeric formats are supported for labels. Full specifications can be 
found at: 
– Standard numeric format strings: https://docs.microsoft.com/en-us/dotnet/standard/base-types/
standard-numeric-format-strings 
– Custom numeric format strings: https://docs.microsoft.com/en-us/dotnet/standard/base-types/
custom-numeric-format-strings 

Select or type the thickness of the axis or grid lines in the Line Weight field.

For tick labels, use the Font Angle field to specify how far to rotate the tick labels (in degrees). The 
range of valid angle values is from –90 to 90.

For axis and tick labels, click the Change Font button to open the Font dialog. Select the font type, 
style, size, effect, and script for the label and click OK.

Format the axis label
Select Axes > X, Y, or Y2 in the tree, then click the Axis Label tab.

Clear the Visible checkbox to remove the axis label from the plot.

Type a title for the axis in the text field. Axis titles are automatically assigned based on the column 
header and units of the variable mapped to the axis.

Use the tools to customize the format of the text.

In the Insert Symbol menu, select Greek letters to insert in the axis title. Users can select any lower-
case or uppercase Greek letters except zeta, eta, kappa, xi, rho, and upsilon.

Click the Insert label tags button to enter place holder text into the label which Phoenix will replace 
with the mapped value. The place holder labels are:

https://docs.microsoft.com/en-us/dotnet/standard/base-types/standard-numeric-format-strings
https://docs.microsoft.com/en-us/dotnet/standard/base-types/standard-numeric-format-strings
https://docs.microsoft.com/en-us/dotnet/standard/base-types/custom-numeric-format-strings
https://docs.microsoft.com/en-us/dotnet/standard/base-types/custom-numeric-format-strings
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<x:#> for the x column names
<xunit:#> for the x column units
<y:#> for the y column names
<yunit:#> for the y column units

The # is replaced by the number corresponding to the graph (generally one unless the user has 
overlaid multiple graphs).

Order categorical axes
Select Axes > X in the tree, then click the Order tab.

Note: The Order tab is available only for the X axis of X-Categorical XY, Bar, Column, and Box plots.

The available X axis values are displayed in the list. The order in which the values appear along the X 
axis of the plot is specified by selecting one of the following:

Source Data: Order the values as they appear in the source data.
Ascending: Order the values from least to greatest.
Descending: Order the values from greatest to least.
Custom: Select a value and use the arrows to arrange the values to the desired order.
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Graphs Options tab
All plot object except Scatter Plot, have a Graphs menu that lists all plots in the object. Many objects 
have plots with names based on the variables that are mapped to the X, Y, or Y2 contexts. For exam-
ple, if Time is mapped to the X axis and Concentration is mapped to the Y axis, the plot is named 
Concentration vs Time.

Graphs menu options also change depending on whether or not a variable is mapped to the Y2 axis, 
multiple variables are mapped to the Y axis, Data Label, Group, or one of the Lattice Conditions 
contexts.

Y2: If a variable is mapped to the Y2 axis, then two plots are listed under Graphs. For example, if 
Time is mapped to the X axis and Effect is mapped to the Y2 axis, the second plot is named Effect 
vs Time.

Multiple Y: If more than one variable is mapped to the Y axis, then a separate plot for each 
mapped variable is listed under Graphs. 

Data Label: If a variable is mapped the Data Label context and no variables are mapped to the 
Y2 axis or the Group contexts, then only one plot is listed under Graphs.

Group: If a variable is mapped to the Group context, then all variable values are listed under the 
plot name in the Graphs menu. For example, if Subject is mapped to the Group context, then all 
Subject identifiers are listed under the plot name. If multiple variables are mapped to the Group 
context to create unique profiles, then each profile is listed under the plot name.

Lattice Conditions: If a variable is mapped to one of the Lattice Conditions contexts and no vari-
ables are mapped to the Y2 axis or the Group contexts, then only one plot is listed under Graphs.

For Scatter Plots, there is no list of graphs, only a single Graph item that, when clicked, provides 
access to the Appearance tab for the plot.

Selecting a particular plot under the Graphs menu provides access to the following tabs of controls 
(tab and option availability depend on the plot type). 

• Content tab
Define data display and how quartiles and whiskers are generated
Set up histogram bins
Sort X values and specify offsets for multiple XY plots
Set up regression lines for XY plots
Set up error bars

• Appearance tab
Specify appearance of data labels
Specify appearance of bars
Specify appearance of borders
Specify appearance of markers
Specify appearance of data labels
Specify appearance of scatter plot diagonal labels
Specify appearance of lines
Specify appearance of error bars
Specify appearance for Group variables

• Quick Styles tab: quickly switch the XY plot between a line and a scatter plot and set Group 
options
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Define data display and how quartiles and whiskers are generated
Select Graphs > <box graph name> in the tree, then click the Content tab.

Use the Show Average checkbox to toggle display of the line indicating the average value of the data 
in the box plot.

Use the Show Median checkbox to toggle display of the line indicating the median value of the data 
in the box plot.

Use the Show Outliers checkbox to toggle display of the outliers in the plot display panel.

Use the Show All Data Points checkbox to toggle display of all data points in the plot display panel.

Check the Custom Whisker IQR Factor box to enter a custom value used to calculate the IQR (inter-
quartile range).

In the Custom Whisker IQR Factor field, type the value to use as a multiplier used to determine how 
far to extend both the top and bottom whiskers.

Set up histogram bins 
Select Graphs > <histogram graph name> in the tree, then click the Content tab.

In the Lower Bin Boundary area, select Minimum value to use the lowest value of the variable 
mapped to the Distribution context as the minimum value, or select the option button beside the field 
and enter a value.

In the Upper Bin Boundary area, select Maximum value to use the highest value of the variable 
mapped to the Distribution context as the maximum value, or select the option button beside the 
field and enter a value.

 In the Number of Bins area, select Default to use the default number of bins, or select the option 
button beside the field and enter the number of bins.

In the Maximum Number of Axis Labels area, select Show all to display all axis labels, or select the 
option button beside the field and type the maximum number of axis labels to display.

Check the Show Relative Frequency box to display the relative frequency on the Y axis. The default 
frequency display is a simple frequency.
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Sort X values and specify offsets for multiple XY plots
Select Graphs > <graph name> in the tree, then click the Content tab.

These options are available for the output plots for the XY and X-Categorical XY Plot objects.

Figure 49-1. Graphs Options — Content tab for XY plots

Figure 49-2. Offset option available for second and subsequent plots in a multi-plot graph

To control sorting of plots

Clear the Sort X Values checkbox to disable automatic sorting. When checked, the Sort X Values 
option sorts data in ascending X axis order before creating the plots. Clear this option when creating 
plots with a hysteresis curve. 

To shift the first plot

For XY and X-Categorical XY Plot objects, when multiple columns are plotted on a single graph (e.g., 
predicted and observed results), each plot can be shifted to the left or right.

Shifting the first plot requires adjusting the X-axis range. Note that changing the range also affects the 
other plots, so it is recommended that you position the first plot, if desired, before setting the offsets 
for the other plots.

Select Axes > X in the tree, then click the Content tab.

Select the Custom option and adjust the values in the Minimum and Maximum fields.

To offset subsequent plots

Select the name of the plot to offset under the Graphs menu item. 

On the Content tab check the Offset box and enter the number of units (for the XY Plot object) or pix-
els (for the X-Categorical XY Plot object) that the plot should be shifted. Entering a positive value 
moves the plot to the right, a negative value moves it to the left.
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Set up regression lines for XY plots 
Select Graphs > <XY graph name> > Regression in the tree, then click the Content tab.

Check the Generate Regression box to display a regression line on the plot.

Select the type of regression line to display. 

Ln (log base e)

Linear 

LOESS (LOcally wEighted Scatter plot Smoothing)

If selected, the Loess Options group is made available

Note: If a regression line is selected, the values used to create the line are displayed across the top of 
the plot. 
Ln: the log of the Y slope and the values of a and b.
Linear: The R-squared, intercept estimate, and slope estimate values are displayed.
LOESS: Nothing is displayed.

Select the Compute Abs Regressions checkbox to fit a LOESS regression to the absolute values of 
the dependent variable, in addition to the normal LOESS regression that does not take absolute val-
ues. The reflection of the absolute value fit through the X-axis is also included. This is useful when the 
magnitudes of the dependent variable are more important than the signed values, for example, 
weighted residuals.

Select the Fix Intercept at Origin checkbox to fix the intercept of a linear regression line at the plot’s 
origin. This option is only available when Linear regression is specified, as Ln and LOESS do not use 
intercept values.

Clear the Show Associated Title checkbox to not include the regression line equation in the title of 
the plot.

Check the Bring to Front checkbox to display the regression line in front of the data points.

In the Legend field, type a name for the regression line so it is displayed in the plot legend.

The Number of Points in Regression field controls the display of the regression line plot, by setting 
the number of points at which to evaluate and plot the regression line. 
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Set up error bars 
Special note for X-Categorical plots: For X-Categorical XY Plot objects, use the Descriptive Statis-
tics object to compute data for the error bars. The Descriptive Statistics results worksheet will be used 
as input for a second plot, with the Mean column being mapped to the Y axis and the SD column 
mapped to the Error Bars context. Use the Offset option in the Content tab for the second plot to shift 
the error bars as desired. See the example “Multiple profile analysis using NCA”.

Select Graphs > <graph name> > Error Bars in the tree, then click the Content tab.

Error bars are available for an XY Plot, X-Categorical XY Plot, or a Column object that has no Group 
mapping.

Clear the Enable checkbox to disable error bars. Check to enable, but additional mappings or settings 
are required before error bars will display.

In the Error Calculation Type menu, select the calculation type used to create the error bars.

FixedValue: Use the value entered in the Value field as the length of the lower and upper bars. 
Phoenix ignores the variable or variables mapped to the error bar contexts.

User: Apply the method selected in the User Calculation Type menu to the error bar mapped 
columns in the Data Mappings panel. Choose from:

Absolute: The mapped columns are Y-axis coordinates. Values mapped as Lower are the Y-axis 
coordinates for the ends of the lower error bars, and values mapped as Upper are the Y-axis 
coordinates for the ends of the upper error bars. The error bars display only when the mapped 
data values for Lower are below the corresponding plotted points or when the mapped data val-
ues for Upper are above the corresponding plotted points.

Relative: The mapped columns are error bar lengths. Values mapped as Lower are the lengths 
from the plotted points to the lower ends of the error bars, and values mapped as Upper are the 
lengths from the data points to the upper ends of the error bars.

Click Apply Value to use the typed value in the display of the error bars.
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Specify appearance of data labels
For all plots except box plots, the display of labels for the data can be controlled. The background 
color for data labels can be set for scatter plots and grouped XY plots. Grouped XY plots also have a 
setting for the label color. 

Select Graphs > <graph name> in the tree, then click the Appearance tab.

Check the Display Data Labels box to display variable values beside the bars/points.

In the Data Label Color menu, select the color for the data label by selecting a color scheme tab: 
Palette, Named, or System and clicking the color.

In the Data Label Back Color menu, select the background color for the data label by selecting a 
color scheme tab: Palette, Named, or System and clicking the color.

Specify appearance of bars
Bar appearance options are only available for Bar, Column, Box, and Histogram objects.

Select Graphs > <graph name> in the tree, then click the Appearance tab.

In the Bar Width box, select or type the width of the bars. (This option is only available for Bar and 
Column objects.)

In the Fill Color menu, select the color for the bar by selecting a color scheme tab: Palette, Named, 
or System and clicking the color.

Specify appearance of borders
Border appearance options are only available for Bar, Column, Box, and Histogram objects.

Select Graphs > <graph name> in the tree, then click the Appearance tab.

Select the color for the border by selecting a color scheme tab: Palette, Named, or System n the 
Border Color menu and clicking the color.

In the Border Style menu, select the style for the border. 

In the Border Width box, select or type the width of the borders.

Specify appearance of markers
Marker appearance options are only available for Box, XY, QQ, Scatter Plot and X-Categorical XY 
Plot objects.

Select Graphs > <graph name> in the tree, then click the Appearance tab.

Check the Markers Visible box to display plot markers.

Select the shape to use as a data point marker from the Marker Shape menu.
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In the Marker Color menu, select the color for the marker by selecting a color scheme tab: Palette, 
Named, or System and clicking the color.

In the Marker Size box, select or type the size of the data point markers.

In the Marker Border Color menu, select the color for the marker border by selecting a color scheme 
tab: Palette, Named, or System and clicking the color.

Specify appearance of data labels
Data label options are available for all plot objects except Box Plot objects.

Select Graphs > <graph name> in the tree, then click the Appearance tab.

Use the Display Data Labels checkbox to toggle the display of data point labels.

Turning on the checkbox adds the following two controls: 

In the Data Label Color menu, select the color for the label by selecting a color scheme tab: Palette, 
Named, or System and clicking the color.

In the Data Label Back Color menu, select the background color for the label by selecting a color 
scheme tab: Palette, Named, or System and clicking the color.

Specify appearance of scatter plot diagonal labels
Diagonal labels are only applicable to Scatter Plot objects.

Select Graph in the tree.

In the Appearance tab, use the Display Diagonal Labels checkbox to toggle the display of labels 
along the diagonal.

Turning on the checkbox adds the Change Font button to the tab. Click to access tools for adjusting 
the label font, size, style, and effects.

Specify appearance of lines
The options described below can be used to change the appearance of lines in all groups by selecting 
the XY Plot or X-Categorical XY Plot in the tree. To only change the line appearance in an individual 
group, select that group in the tree.

To change the line display, click the plot node in the navigation tree. For regression lines, expand the 
plot node in the navigation tree and click Regression. If Compute Abs regressions is selected in 
the Regression Content tab, users can also format the LOESS absolute regression line display using 
the controls in the Abs Loess Lines area.

Select Graphs > <graph name> in the tree, then click the Appearance tab.

Check the Line Visible box to display a line connecting the points (this option is not available for 
regression lines).

In the Line Color menu, select the color for the line by selecting a color scheme tab: Palette, Named, 
or System and clicking the color.

In the Line Style menu, select the style for the line. 

In the Line Weight box, select or type the weight of the line.
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Specify appearance of error bars
Select Graphs > <graph name> in the tree, then click the Appearance tab.

Expand the plot node in the navigation tree and click Error Bars.

Click the Appearance tab.

In the Color menu, choose the color used to display the error bars center point marker by selecting a 
color scheme tab: Palette, Named, or System and clicking the color.

Check the Use Group Color checkbox to use the Line Color specification in the plot’s Appearance 
tab to color the error bars. 

In the Center Marker Shape menu, select the shape of the marker used to indicate the center point 
of the error bars. The default marker shape is None.

In the Center Marker Size field, type or use the arrows to change the size of the marker.

In the Cap Width field, type or use the arrows to change the width of the top and bottom bars.

In the Line Weight field, type or use the arrows to change the thickness of the error bar lines.

Specify appearance for Group variables
Several Plot objects contain a Group context. If one or more variables are mapped to the Group con-
text, then the variable values are listed under Graphs > <graph name> in the tree.

Note: The plot object must be run before users can view Group variables in the Graphs menu.

Select a Group value to access its Appearance tab. The Group variables Appearance tab controls are 
the same as those in the XY plot Appearance tab (see “Specify appearance of data labels” and sub-
sequent sections) with one extra field, Legend Text. 

In the Legend Text field, type a label for the Group value in the legend. 

Quick Styles tab
The Quick Styles tab allows users to quickly switch the XY plot between a line and a scatter plot. 
Users can also use the tab to quickly update the plot display. The Quick Styles tab is only available in 
the XY Plot object. 

Select Graphs > <graph name> in the tree, then click the Quick Styles tab.
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Options include:

Show Markers toggles display of markers. If at least one sort variable is mapped to the Group 
context, each profile is assigned its own unique marker shape and color combination, otherwise, 
all markers are the same by default. Clearing this option automatically clears the Group by 
Marker checkbox and all profiles are assigned the same marker shape.

Show Lines toggles displaying the plot as a line plot or as a scatter plot.

Group by Marker toggles displaying all markers as the same shape or by group. This option is 
only available when at least one variable is mapped to the Group context.

Group by Color toggles coloring all lines and markers the same (black by default) or by group. 
This option is only available when at least one variable is mapped to the Group context.

Group by Line toggles using the same style (solid by default) for all lines or style by group. This 
option is only available when at least one variable is mapped to the Group context.

Show Groups in Legend toggles the display of profiles in the plot legend. This option is only 
available when at least one variable is mapped to the Group context. Clearing this checkbox also 
clears and makes unavailable the Group by Marker, Group by Color, and the Group by Line 
checkboxes.

Each Group by Color toggles using the same color for each level (i.e., value) of the Group vari-
able selected from the pull-down menu, when two or more variables are mapped to the Group 
context. Only the line color and the marker color will change, styles remain unchanged. If the user 
changes either a marker color or a line color for an individual member of the group (individual 
members are listed below Error Bars in the tree on the left), then that color change is applied to all 
the individuals members in the same group.
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Legend Options tab
The Legend menu allows users to change the formatting and display properties. A legend is created 
in the plot display panel for each plot page tab.

Selecting the Legend menu provides access to the following tabs of controls. 

Appearance tab
Order tab

Appearance tab
Select Legend in the tree to access the legend Appearance tab.

The Legend Appearance tab allows users to specify how the legend is displayed for each plot or 
group of plots. All plot objects share a common set of legend formatting controls.

Click the Change Font button to open the Font dialog and change the legend font.

Use the Visible checkbox to toggle display of the legend in the plot.

In the menus for Font Color, Background Color, and Border Color, use one of the three tabs (Pal-
ette, Named, or System) to select the color.

Use the Display Graph Names checkbox to toggle display of plot names in the Legend.

If no variable is mapped to the Group context, then the only information in the Legend is the plot 
name. In this case, clearing the Display Graph Names checkbox has the same effect as clearing the 
Visible checkbox because the legend is removed from the plot display panel.

In the Border Style menu, select the legend border line style.

In the Text Format menu, select the legend label format:

Value: Only values of variable(s) mapped to the Group context are displayed in the legend.

Name: Value: The name of variable(s) mapped to the Group context is displayed with the corre-
sponding value in the legend.

In the Layout menu, select the how the legend items are to be listed:

Column: List all legend items as a single column.

Row: List all legend items as a single row.

Table: List legend items as a table (multiple rows and columns).

In the Docking area, select whether to use relative or absolute positioning to place the legend with 
respect to the plots.
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Relative Position: Use the menu to specify the relative position (Top, Right, Bottom, Left). 
Check the Inside Chart Area checkbox to move the legend inside the area defined by the two 
axes.

Absolute Position: Enter the percentage from the left edge of the display (X Offset) and from the 
top edge of the display (Y Offset) to position the legend. Use the Width and Height fields to 
adjust the size of the legend area as a percentage of the display area.

Note: The Inside Chart Area checkbox and Absolute Position options are not available for latticed 
plots, unless latticed only by page (one plot per page).

Order tab
The Order tab is available only when at least one Group is mapped for an XY, X-Categorical XY, Bar, 
Column, or Box plot.

Select Legend in the tree to access the legend Order tab.

The available Group values are displayed in the list. The order in which the values appear in the leg-
end is specified by selecting one of the following:

Source Data: Order the values as they appear in the source data.

Ascending: Order the values from least to greatest.

Descending: Order the values from greatest to least.

Custom: Select a value and use the arrows to arrange the values to the desired order.
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Reference Lines Options tab
The Reference Lines menu allows users to add reference lines to the X, Y, or Y2 axes of a plot. Ref-
erence lines are useful for highlighting base lines or therapeutic ranges in a plot. Added reference 
lines are listed in the table.

Select Reference Lines in the tree and then click the Reference Lines tab.

Click Add to add a row in the table.

Use the Axis column drop-down menu to select the axis to use for the reference line.

In the Value column, type the axis value on which to place the reference line. 

In the Title column, type a title for the reference line (optional).

Click […] in the Font column to display the Font dialog for changing the format of the text (font, font 
size, font style, and effects).

In the Title Position column, select the location where the title is to be displayed relative to the axis.

In the Color menu, select the reference line color by selecting a color scheme tab: Palette, Named, 
or System and clicking the color.

In the Style menu, select the reference line style.

In the Line Weight box, select or type the reference line weight. 

To remove a reference line, click the red X in the corresponding row in the table.

Line of unity
For XY and QQ Plot objects and the Levy plot generated by the IVIVC object, options are available on 
the Unity Line tab for the line of unity, where Y=X. The two axes must use the same scaling (i.e., both 
are linear or both are logarithmic) for the options to be active.

Select Reference Lines in the tree and then click the Unity Line tab.

Check the Line Visible box to add a unity line in the plots and enable the Line of Unity settings. 
Uncheck the box to hide the unity line.
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In the Line Color menu, select the unity line color by selecting a color scheme tab: Palette, Named, 
or System and clicking the color.

In the Line Style menu, select the unity line style.

In the Line Weight box, select or type the weight of the unity line.

Select the Show in Legend checkbox to include the unity line in the legend.
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Annotations Options tab
The Annotations tab allows users to annotate the graph. Annotations can be dragged and dropped 
anywhere within the graph area.

Select Annotations in the tree to access the Annotations tab.

Click Add to add a row in the table.

In the Title column, type the annotation text.

Click […] in the Font column to display the Font dialog for changing the format of the text (font, font 
size, font style, and effects).

In the Title Color menu, select the annotation color by selecting a color scheme tab: Palette, Named, 
or System and clicking the color.

In the Shape column, select shape to use for the annotation text area.

In the Background Color column, select the color behind the annotation text by selecting a color 
scheme tab: Palette, Named, or System and clicking the color.

In the Border Style menu, select the style of border for the annotation area.

In the Border Color column, select the color for the annotation border.

In the Border Width column, select or enter the width of the annotation border.

To remove an annotation, click the red X in the corresponding row in the table.
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Plotting results
The results are displayed on the Results tab. The option buttons selected in the Data Mappings panel 
and the options selected in the Options tab determine the number of plots that are created in the 
Results tab. A Settings file is also generated containing all selections made in the object interface.

A plot can be viewed and modified in its own window by selecting it in the Results list and double-
clicking it or pressing ENTER. Once a result is displayed in its own window, the object can be re-exe-

cuted by clicking  (Re-execute Plot icon) in the toolbar.

Double-clicking a point in an XY plot, bar plot, or scatter plot matrix plot opens the worksheet for that 
plot in a separate window, with the row corresponding to the double-clicked point highlighted.

For all plot types except scatter plot matrix, click various parts of the plot image to go to the options 
associated with that part of the plot output. (See “Plot Options tab” for more details on the options 
available.)

Click an axis to display the corresponding axis menu
Click the title to display the Title text field.
Click the legend to display the Legend menu
Click a bar, column, or marker to display the Graphs > Appearance tab.
Click a box, bin, or XY line to display the Graphs > Content tab.

Hover the cursor over part of a plot, such as a bar, marker, line, or part of a box or histogram, to view 
a popup showing the associated data. 

Copy or export results
To copy a plot, select the Plots > Output item in the list on the Results tab. Then right-click the dis-
played plot and select either Copy High Resolution Image (vector) or Copy Image (bitmap). 

To export a plot, select the Plots > Output item in the list on the Results tab and then do one of the 
following:

Right-click the displayed plot.

Or right-click the Plots > Output item in the list.

Or click  (Export icon) above the Results list 

Use the dialog tools to specify a location, file name, and format for exporting the plot. Use the Image 
Settings options in the dialog to control the size of the exported plot.

If a plot has more than one page, each page will be exported to a separate file. Phoenix supports 
exporting plots in EMF, BMP, GIF, JPG, PNG, and TIFF formats. 

Additional information on Box Plot results
In the Box plot, the dashed line is the median; the solid line is the arithmetic mean. The ends of the 
“box” are the 25th and 75th percentiles, which are computed by the same method as in Descriptive 
Statistics. These are also referred to as the first and third quartiles. The whiskers show the lowest 
data value still within 1.5 IQR of the lower quartile, and the highest value still within 1.5 IQR of the 
upper quartile, where IQR is the interquartile range (the difference between the third and first quar-
tiles, the middle 50%). Custom Whisker IQR factor option in the Content tab allows the user to 
change the multiplier of IQR to a value other than 1.5. 

Data values that do not fall between the whiskers are plotted as outliers (markers outside of the whis-
kers). Profiles with fewer than five data points plot the data points directly with no box.
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Figure 53-1. Interpreting a box plot with whiskers
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Error bars and overlaying plots example
The first part of this example uses summary statistics and error bars to create two XY plots, one using 
relative error bars and the other using absolute error bars. Next, plot overlays are created to help with 
data comparison.

Most Phoenix objects require the same basic steps for their use. However, there may be multiple 
paths to accomplishing a step (e.g., main menu, right-click menu, drag-and-drop, etc.). For simplicity, 
only one is listed here. 

Note: Any object added to a project can be viewed in its own window by selecting the object in the Object 
Browser and double-clicking it or pressing ENTER. All instructions for setting up and executing an 
object are the same whether the object is viewed in its own window or in Phoenix’s viewing.

The completed project (Plots.phxproj) is available for reference in …\Examples\Data and 
Plots.

Set up the project

1. Create a new project called Plots.

2. Import the file …\Examples\WinNonlin\Supporting files\Bguide2.dat.
Click Finish in the Import File Wizard. 

Units must be added to the time and concentration columns before the dataset can be used to cre-
ate plots.

3. In the Columns tab, below the displayed Bguide2 worksheet, select the Time column header in the 
Columns box.

4. Clear the Unit field and type hr.

5. Select the Conc column header in the Columns box.

6. Clear the Unit field and type ng/mL.
Or click the Units Builder button and use the Units Builder dialog tools.

Note: Units added to ASCII datasets can be preserved when the datasets are exported to disk or a data-
base. Phoenix adds the units to a row beneath the column headers. When importing a .dat or 
.csv file with units, select the Has units row option in the Options area in the File Import Wizard 
dialog.

Set up the Descriptive Statistics object

To create error data for the error bars, this example computes means and standard deviations for the 
concentration data at each time point.

1. Right-click Bguide2 in the Data folder and select Send To > Computation Tools > Descriptive 
Statistics.

2. Map the data types as follows:
Sex mapped to None.
Subject mapped to None.
Time to the Sort context.
Conc to the Summary context.
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3. In the Options tab, check the Confidence Intervals and Number of SD Statistics checkboxes, 
but do not change the default values for these two items.

4. Click  (Execute icon) to execute the object. 

Plot the mean +/- standard deviation using relative error bars

1. Right-click the Statistics worksheet in the Results tab and select Send To > Plotting > XY Plot.

2. Map the data types to the following contexts:
Time to the X context.
Mean to the Y context. 
SD to the Lower and Upper Error Bars. 
Leave all other data types mapped to None.

3. In the Options tab, click the Title sub-tab and type: Mean +/- Standard Deviation in the 
Title field.

4. Select Graphs > Mean vs Time > Error Bars in the Options tab list.

User is the default Error Calculation Type and Relative is the default User Calculation Type. Do 
not change these settings. Using the Relative User Calculation Type causes Phoenix to add and 
subtract the errors from the mean.

5. Execute the object. 

Plot the median, minimum, and maximum using absolute error bars

1. Right-click Workflow in the Object Browser and select the New > Plotting > XY Plot menu item.

2. In the XY Plot 1 XY Data Mappings panel click the Select Source icon to open the Select Source 
dialog.

3. Select the Descriptive Statistics object’s Statistics worksheet and click OK.
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4. Map the data types as follows:
Time to the X context.
Median to the Y context. 
Min to the Lower Error Bar. 
Max to the Upper Error Bar.
Leave all other data types mapped to None.

5. In the Options tab, click the Title sub-tab and type: Minimum, Median, and Maximum 
Concentrations.

6. Select Graphs > Median vs Time > Error Bars.

7. In the User Calculation Type menu select Absolute.

Using the Absolute User Calculation Type instructs Phoenix to plot the Min and Max values on the 
Y axis, rather than to add and subtract them from the Median.

8. Execute the object. 

Overlay multiple plots using variables from the same dataset

This example overlays data from separate columns in the same workbook. 

1. Right-click Workflow in the Object Browser and select New > Plotting > XY Plot.

2. In the XY Plot 2 XY Data Mappings panel click the Select Source icon.

3. Select the Descriptive Statistic’s Statistics worksheet and click OK.

4. Map the data types as follows:
Map Time to the X context.
CI 95% Lower Mean to the Y context. 
CI 95% Upper Mean to the Y2 context. 
Leave all other data types mapped to None.

5. In the Options tab, click the Title sub-tab and type: Overlay Charts. Press ENTER to move to 
the next line and type: Example 1.
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6. Select Plot > Layout. 

7. Set the Legend Area Size field to 200.

8. Select Axes > Y and then the Axis Label sub-tab. 

9. In the field type Confidence Interval and click  to center the text.

10. Execute the object. 

Figure 54-1. Overlaid charts

Note: If the data are stored in one column, it is also possible to create similar plots, without using the 
overlay feature, by assigning a variable or parameter to the Group context.

Overlay variables from multiple datasets

This part of the example plots the Observed and Predicted concentrations from a model fitting by 
using the exported output files from a PK Model object in a different project. 

1. Import …\Examples\Data and Plots\Supporting files\bg1 Sheet1.dat and 
Summary Table.dat.
Click the Next Arrow button and then click Finish in the File Import Wizard dialog. 

2. Right-click bg1 Sheet1 in the Data folder and select Send To > Plotting > XY Plot.

3. Map the data types as follows:
Subject mapped to None.
Time to the X context.
Conc to the Y context.

4. Select the Graphs tab.

5. Click Add. 
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A second XY Plot input named XY 1 Data is added to the Setup list.

6. Select XY 1 Data in the Setup list.

7. In the Data Mappings panel click  (Select Source icon).

8. In the dialog, select Summary Table worksheet and click OK.

9. Use the option buttons in the XY 1 Data Mappings panel to map the data types to the following 
contexts:
Map Time to the X context.
Map Predicted to the Y context.
Leave all other data types mapped to None.

10. In the Options tab, click the Title sub-tab and type: Overlay Charts 2. 
Press ENTER to move to the next line and type: Example using two datasets.

11. Select Graphs > Conc vs Time. 

12. Select the Appearance tab.

13. Use the Marker Color menu to change the marker color to Red.

14. Execute the object. 



Phoenix Framework
User’s Guide

280

Figure 54-2. Chart of overlaid datasets.

15. Right-click the project and select Close Project.

This concludes the Error Bars and Overlaying Plots example.
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PsN Shell
The PsN Shell object builds commands against Perl Speaks NONMEM and executes against multiple 
model files and datasets. The results are then returned to Phoenix.

Users build a list of command-line strings against these interfaces in the Phoenix UI and submit the 
strings of commands as a batch process to PsN on execution. 

Note: Phoenix program plugins, such as the PsN Shell object, assume that the corresponding third party 
software is installed and running properly.

For PsN installation, consult the PsN installation documentation (https://uupharmacometrics.github.io/
PsN/install.html). Guides on managing multiple versions of PsN, submitting to computer cluster envi-
ronments, and general configuration of PsN can be found in the Documentation link on the PsN 
homepage (https://uupharmacometrics.github.io/PsN).

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > External Software > PsN Shell. 
Or Main menu: Insert > External Software > PsN Shell.
Or right-click menu for a worksheet: Send To > External Software > PsN Shell.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Additional information is available on the following topics:

Setting up preferences
User interface description
Importing/Writing the code to access the external program
Executing a third party tool object
Results
PsN examples

Setting up preferences
Global preferences are available to the user. Some third party tool objects require certain global set-
tings to be specified prior to use. There are optional settings to enable editing of scripts in external 
programs from within Phoenix. Some optional preferences can streamline the workflow by automati-
cally filling in or setting options in the object’s UI with information entered by the user in the Prefer-
ences dialog. 

Setup access to the external program
Define a default working directory and output location

https://uupharmacometrics.github.io/PsN/install.html
https://uupharmacometrics.github.io/PsN/install.html
https://uupharmacometrics.github.io/PsN
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Setup access to the external program
Select Edit > Preferences.

In the Preferences dialog, select PSN in the menu tree.

Enter the directory path to the PsN configuration file in the first field or click Browse to locate and 
select the directory.

Upon selection, the file is parsed and the other fields are automatically populated if the informa-
tion is present in the file. Otherwise, the user needs to specify the location of the Perl executable, 
PsN Utilities directory, and (optionally) the R executable.

To view and/or edit the PsN configuration file in a text editor, click Open/Edit.

For more information on the text editor, see http://www.syncfusion.com/products/user-interface-edi-
tion/windows-forms/edit/overview.

Click Test to make sure the correct file is selected. 

In the PsN preference page, turn on the Use Log Viewer checkbox to display log information in a 
separate window during execution.

The NONMEM Configuration(s) list in the PsN page shows all of the configurations of NONMEM 
available for use as defined in the PsN configuration file. 

Define a default working directory and output location
Setting the working directory or output folder in the Preferences dialog eliminates the need to enter 
the information in the Options tab for each run. The fields will automatically be filled with the paths 
entered here.

For PsN, enter the directory path in the Default Working Directory field.
Or click Browse to locate and select the directory.

Enter the directory path in the Default Output Folder field or use the Browse button.

Note: If the user specifies a default output location, the user must ensure that they have write access.

Turn on the Create a unique subfolder for each run checkbox to generate and then store the output 
from each run in a new subfolder of the output folder. 

http://www.syncfusion.com/products/user-interface-edition/windows-forms/edit/overview
http://www.syncfusion.com/products/user-interface-edition/windows-forms/edit/overview
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User interface description
Setup tab
Options and other tabs
Result Filters tab

Setup tab
The Setup tab allows mapping of model files to the object. The Mappings panel simply lists the col-
umns found in the dataset. The Text panel allows users to map a model file to the object and view the 
contents.

Options and other tabs
The Options tab for the PsN Shell object is distinct in its functionality, relative to the other third party 
tool objects. The PsN Shell object also has a number of additional tabs related to specific commands 
that can be submitted to the PsN program.

To identify the model files

Access the model files using one of the following methods:

• To load model files from the file system, click Browse to Directory Containing Model Files to 
locate and select the folder containing the model file(s). The path to the model file cannot have 
spaces.

Files with an extension of .ctl and .mod are recognized as model files. All models are brought 
into the Code folder of the Phoenix project and mapped to the PsN shell.

• If you want to create shortcuts to the model files in the file system instead of loading them into 
Phoenix, check the Bring Model files In as Shortcuts checkbox. (Turn off the checkbox to 
import the full model file as mentioned above.)

• If model files are already available in the project’s Code folder, click Select Sources from Phoe-
nix Project to select the desired model file.

The $DATA record for each model is parsed for the dataset name. The input specified for each unique 
dataset is published in the object. The names of the model files are added to the Model Files list on 
the rights side of the Options tab.
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Caution: Clicking Clear All below the list of model files clears all of the entries in the Setup tab. All map-
pings to datasets, commands, and models are removed.

After the model file is parsed, the Setup tab will show a list of items that need to be mapped. Once the 
model files and dataset are specified and mapped, you can start building the command lines.

To start building the command lines

• Enter the path to the working directory in the Root Working Directory field or click Browse to 
locate and select the directory. (Click Open to display the contents of the directory in a separate 
window.)

• Enter the path to the folder where results are to be stored in the Results Folder field or click 
Browse to locate and select the folder. (Click Open to display the contents of the folder in a sep-
arate window.)

• Set the Number of output subdirectories to traverse field to identify the level of output subdi-
rectories from which to retrieve results. The higher the number, the deeper into the output directo-
ries Phoenix will go to retrieve output.

Note: Setting the working directory and/or output folder in the Preferences dialog eliminates the need to 
enter the information in the Options tab for each run. The fields will automatically be filled with the 
paths entered as preferences. See “Define a default working directory and output location”.

• Click Select Sources (under the Additional Inputs heading) to include additional files along with 
the mapped input. As an example, if a user wanted PsN to use a different configuration file than 
the default, they would:

Import their configuration file into the project (it will be placed in the Code folder).

Edit the commands so the -config_file option points to the name of their configuration file.

Use the Select Source button in the Options tab to add their configuration file to the list in the 
Setup tab.

When the object is executed, the user’s configuration file will get copied to the working directory 
and the command that references that file will execute using that specified configuration file.

• Click the Clear Empty Results to remove any results published by the object that are empty.
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Build the PsN command line
Use the Execute tab and the CDD, LLP, Bootstrap, SCM, SSE, VPC, and MCMP tabs to build the 
commands that will be submitted to PsN. 

Figure 55-1. Execute tab for a PsN Shell object

Note: Spaces may be entered in the text entry fields, however, they must be enclosed in single or double 
quotes. If the space is not enclosed in quotes, the text is colored red and is not added to the com-
mand.

All of the tabs contain the following elements:

List of Available Models: Use the checkboxes to indicate which models to run the commands 
against. (Use the Toggle Select All button to quickly turn on or off all model checkboxes.)

Command Line Options: Turn on or off the checkboxes for the various tags to add/remove them 
from the command line. For options with fields, enter an appropriate value to add that option and 
its value to the command line. Clear the field to remove it. Invalid values will be colored red and 
not passed to command line.

Tooltip Viewer: Displays information regarding the item the cursor is hovering over. 

Command Field: Displays the command line, with all of the options that have been checked or 
entered on that tab. The field itself is not editable. 

Add to Commands List: Click this button to accept the command line as shown in the field and 
add it to the list of commands shown in the Setup tab. (Click the Commands node in the Setup tab 
to show list of commands as they will be submitted to PsN when the Execute button is clicked.) 

If the Series option below the model list on the Execute tab is selected, then the command is 
added once for each model selected in the list. 

If the Parallel option is selected, then the command is added once and contains all of the 
selected models explicitly listed in the command. NONMEM executes all the model files in parallel 
with this type of command.

Launch Command Window: Click this button to open a separate command line window for exe-
cuting commands interactively. 

• Turn on the checkboxes for the models to include in the execution.
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• Make the desired selections and value entries for the options on each command tab.

• When finished building a command, click Add to Commands List. 

The list of commands as they will be submitted to PsN when the Execute button is clicked can be 
viewed in the Commands List panel (click the Commands node in the Setup tab). The com-
mands listed in this panel are directly editable. 

•  Type the commands directly in the panel or modify existing commands.

Changes made directly in the panel are not automatically included in the execution. They must be 
applied first. A yellow bar at the beginning of a line indicates that a change has been made, but 
has not yet been applied. 

•  Click Apply to accept the changes made to the commands.

Result Filters tab
Allows specification of how different results files from the external program should be imported. Phoe-
nix first looks for the first rule to match a file and uses that rule to import the object. The order of the 
rule matching is: Always Import (using normal import methods), Max File Size (will create a short-
cut), Shortcut Files, Binary Files (using normal import methods). The user creates filter criteria 
based on filename patterns. If a maximum file size is specified, any file larger than the entered value 
will always be imported as a shortcut (unless the file matches filter criteria in the Always Import list). 

Importing/Writing the code to access the external program
The PsN Shell object must have code that will allow it to initiate the external program and submit jobs. 
The code can be stored as a model file, imported into the project, and mapped to the object, or the 
code can be directly entered into the object. 

Import and map file containing code
Write code in the Text panel
Filtering results by size

Import and map file containing code
• Select a project or workflow in the Object Browser and then select a third party tool object from 

the Insert menu.

• In the Options tab, click Browse to Directory Containing Model Files.

• In the Browse for Folder dialog, locate and select the directory containing the model file(s).
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Imported PsN model files are added to the Code folder in the Object Browser and mapped to the PsN 
Shell. The $DATA record in each file is parsed for the name of the dataset and is added to Inputs in 
the PsN Shell. 

Write code in the Text panel
Instead of importing and mapping a file, users can write their own code or copy and paste code from 
another source. (For more information on the text editor, see http://www.syncfusion.com/products/
user-interface-edition/windows-forms/edit/overview.

• To enter the code manually, check the Use internal Text Object checkbox. If a script/control file 
is already mapped, a message is displayed that asks if the mapped file should be copied to the 
internal text editor. 

Click Yes to allow editing of the currently imported file.
Click No to remove the imported control file.

• Type the code directly in the field.

• When entry or modifications are complete, click Apply.

Some important things to consider when entering code in the Text panel versus importing and map-
ping a script/control file are: 

Apply must be clicked for the code entered or modified to be accepted.

Changes made in the Text panel are not applied to the file on the disk.

The script can be modified either in the Code folder or in the object itself and these are kept in 
sync.

Once the user switches to Use Internal Text, any subsequent changes are not kept in sync with 
the script in the Code folder. 

Filtering results by size
The Result Filters tab allows users to define filters that determine whether files of a certain name or 
size are returned to Phoenix as a shortcut, a binary file, a complete copy, or returned at all.

• Type the file pattern to serve as a filter into the field near the bottom of the tab and click Add. 
(Enter full file names or use the wildcard “*”, e.g., *.txt.)

• To remove a pattern from the list, select it and click Remove.

• For each pattern, select how files matching the pattern are to be handled:

Import: Default file handling for imported data of that file type is used to import the file
Import as Shortcut: The file itself is not imported, however, a shortcut is created that points to 

http://www.syncfusion.com/products/user-interface-edition/windows-forms/edit/overview
http://www.syncfusion.com/products/user-interface-edition/windows-forms/edit/overview
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the complete file 
Import as Binary: The file is imported as a binary object, with no conversion to any specific 
Phoenix type
Exclude: The file is not imported

Should a file match several specified patterns, the precedence of processing is: Exclude, Import, 
Shortcuts, Binary. 

For .csv and .dat output files, check the Has Header Row box to indicate that files matching 
the file pattern have a header row.

• For .csv and .dat output files, select the Has Units Row option to indicate that files matching 
the file pattern have a units row.

• Enter maximum size that an imported complete file can be in the Max File Size in KB field. 

Any file that exceeds this size is imported as a shortcut (unless the file matches a File Pattern 
whose Import Format is set to Import).

Executing a third party tool object

Click  (Execute icon). 

Or, to run the job remotely, click Execute Remotely in the Options tab.

Executing a third party tool object remotely sends the job to the server that is defined in the Prefer-
ences dialog (Edit > Preferences > Remote Execution). See “Phoenix Configuration” for instruc-
tions. The project is saved automatically.

The project must have been saved at least once prior to executing on RPS, otherwise execution will 
not pass validation and a validation message will be generated.

At this point, the step being executed on RPS, along with any dependent objects, has been locked. It 
is now safe to close the project or to continue working in Phoenix.

In Phoenix, some objects in a workflow allow the user to click and execute the last object in a chain 
and it will re-run any necessary objects earlier in the workflow. This is true for the PsN Shell object.

Note: When executing PsN on JMS, the working folder must exist both on the client and on the JPS 
server or PsN will fail validation. Use a standard working folder location on all clients and make 
sure that the standard path also exists on all JPS servers.

Recovering from a failed PsN run
If a PsN run fails, do the following to attempt a restart of the job. 

• In the Command List panel, type ::RECOVER at the end of the command line whose execution 
failed. For example:

    1 bootstrap “psn3” -verbose -sample=1000 ::RECOVER 

Note: Do not change anything else in the command, just add the keyword.

• Click Apply and then execute the object .
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PsN will go into the working directory and locate the latest output folder whose name matches the 
command signature (e.g., bootstrap_psn3_-verbose_sample_1000_…) and attempt to continue the 
processing that was done before.

Results
The results are displayed on the Results tab. The output falls into the following categories:

Output Data: Datasets in tabular form

Text Output: Settings files, log files, and other text output

Other: Other kinds of files, for example: documents, export files, binary files, etc. 

Images: Graphs or other images in recognized image formats (jpg, tiff, emf, etc.)

During execution, the Log Viewer is displayed (if the Use Log Viewer checkbox in the PsN Prefer-
ence page was turned on) and shows the standard output and standard errors from PsN. Click the 
Pause button to pause refreshing of the log so it can be reviewed at a particular point. The Pause but-
ton is renamed to Resume and clicking the button continues refreshing of the log. Click the checkbox 
to toggle showing and hiding the line numbers.

In the working directory, every command executed by PsN from Phoenix has a separate folder. The 
folder is named according to the signature of the command line followed by the date/time stamp (e.g., 
bootstrap_psn3_-verbose_sample_1000_20120210103030).

Output Data: Datasets in tabular form

Text Output: Settings files, log files, and other text output

Other: Other kinds of files, for example: documents, export files, binary files, etc. 

Images: Graphs or other images in recognized image formats (jpg, tiff, emf, etc.)

Some results are duplicated in the Output Data and Text Output categories to allow users to view out-
put in Phoenix Worksheet format as well as pass raw files to downstream objects.
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PsN examples
This section contains step-by-step instructions for creating and executing a variety of third party tool 
projects. 

Completed projects for these examples are available for reference in …\Examples\PsN. You can 
save a copy of the Examples directory (installed with Phoenix) to your Phoenix project directory via 
the Project Settings in the Phoenix Preferences dialog.

Note: All of these examples assume that the path to the psn.conf file has already been specified in 
Phoenix. (Select Edit > Preferences > PsN and enter/browse to the psn.conf file.) 

Note: If all of the appropriate paths are set in this file (perl.exe, PsN utilities, R), Phoenix will populate 
the appropriate paths in this dialog. The available NONMEM configurations from psn.conf will be 
displayed for selection in the Options tab in the -nm_version pull-down.

PsN Shell object setup and execution example
Using shortcuts with the PsN Shell object
Using PsN Shell and R Shell objects to generate GOF and individual plots
Using PsN Shell and R Shell objects to generate VPC plots

PsN Shell object setup and execution example
The completed project (Ex01_PsN_Execute.phxproj) is available for reference in …\Exam-
ples\PsN.

Set up the project and data

1. Create a new project named Ex01_PsN_Execute.

2. Import THEOPP.dat and the PsN control file psn.ctl from …\Examples\PsN\Example1.

3. In the File Import Wizard dialog, click Finish. 

The THEOPP file is added to the project’s Data folder and the psn.ctl control file is added to the 
Code folder.

Set up the PsN Shell object

1. Select Workflow in the Object Browser and then select Insert > External Software > PSN Shell. 

2. In the Options tab, click the Select Sources from Phoenix Project button.

3. In the Select Sources dialog, expand the Code folder, check the box for psn, and then click OK to 
specify the input model. 

4. Click THEOPP in the Setup list, then drag the dataset THEOPP from the Data folder to the Map-
pings panel.

5. Specify the root working directory by typing the path to the desired folder in the Root Working 
Directory field or use the Browse button.
This is where PsN will create run directories for each command executed (i.e., execute, bootstrap, 
etc.), so you must have write permission for the selected folder.
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Execute the PsN Shell object

1. Click the Execute tab and build a command with the available command line options. 
Make sure the psn checkbox is checked in the model list.
Check the -verbose checkbox.

2. Click Add to Commands List when finished building the command.

3. Click  (Execute icon) to execute the object.

This concludes the PsN Shell object setup and execution example. You may save the project, if you 
wish, or simply close it.

Using shortcuts with the PsN Shell object
The completed project (Ex02_PsN_ExecuteWithShortcut.phxproj) is available for refer-
ence in …\Examples\PsN.

The example control file is set up to look for the dataset source in C:\temp, so do either of the fol-
lowing:

Copy the THEOPP file from the …\Examples\PsN\ExampleWithShortcut folder to 
C:\temp.
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Or

Edit the model_file_with_shortcut.ctl file if another location is desired.

Set up the project and data

1. Create a new project named Ex02_PsN_ExecuteWithShortcut.

2. Select Workflow in the Object Browser and then select Insert > External Software > PsN Shell. 

3. In the Options tab, check the Bring Model Files in as Shortcuts box.

4. Click the Browse to Directory Containing Model Files button and navigate to and select 
…\Examples\PsN\ExampleWithShortcut, then click OK.

A link to the model_file_with_shortcut.ctl control file is added to the Shortcuts folder 
in the Phoenix project. A new item also appears in the Object list: model_file_with_shortcut.

5. Specify the root working directory, if one has not been specified already via the Preferences dialog, 
by typing in the path to the desired folder in the Root Working Directory field or use the Browse 
button. You must have write permission for the selected folder.

Execute the PsN Shell object

1. Click the Execute tab and build a command with the available command line options. 
Make sure the model_file_with_shortcut checkbox is checked in the model list.
Check the -verbose checkbox.

2. Click Add to Commands List when finished building the command.



Phoenix Framework
User’s Guide

294

3. Execute the object.

This concludes the “Using shortcuts with the PsN Shell object” example. You may save the project, if 
you wish, or simply close it.

Using PsN Shell and R Shell objects to generate GOF and individual plots
This example involves the Xpose package for R. Make sure that this package is installed for R (http://
xpose.sourceforge.net/docs_install.php).

The Xpose package uses the following tables (* is the run number): 

sdtab* file (i.e., standard table file): This file contains columns such as ID, DV, PRED, IPRED, 
WRES, IWRES, RES, IRES, etc.

patab* file: This is a parameter table containing model parameters: THETAs, ETAs and EPSes. 
The correspondences between ETA and THETA can be defined within Xpose. EPS is optional in 
this table, it is mainly used to generate the parameter vs parameter plots and parameters vs 
covariates plots.

catab* Categorical covariates, e.g. SEX, RACE

cotab* Continuous covariates, e.g. WT, AGE 

extra*, mutab*, mytab*, xptab*: Other variables that might be needed by Xpose (Xpose 4 
and above can postulate all the other values from one table (mytab1), but it is always safer to 
have these plots).

cwtab*: The cwtab file is generated by Xpose. In NONMEM 7, the calculation of CWRES is 
built in.

run*.mod: Model specification file 

run*.lst: NONMEM output 

The completed project (Ex03_PsN_Xpose_GOF.phxproj) is available for reference in 
…\Examples\PsN.

http://xpose.sourceforge.net/docs_install.php
http://xpose.sourceforge.net/docs_install.php
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Set up the project and data

1. Create a new project named Ex03_PsN_Xpose_GOF.

2. Import the PsN control file nm_final.ctl and the dataset file example.csv from …\Exam-
ples\PsN\Xpose_GOF_IND.

3. In the File Import Wizard dialog, click Finish. 

Set up the PsN Shell object

1. Select Workflow in the Object Browser and then select Insert > External Software > PsN Shell. 

2. In the Options tab, click the Select Sources from Phoenix Project button.

3. In the Select Sources dialog, expand the Code folder, check the box for nm_final, and then click 
OK.
A new item appears in the Object list, nm_final, and a dataset input is now available to the PsN 
shell, based on the dataset name in the control file (“example.csv”). 

4. In the Setup tab list, click EXAMPLE.CSV.

5. Drag the example worksheet from the Data folder to the Mappings panel. 

6. Specify the root working directory by typing the path to the desired folder in the Root Working 
Directory field or use the Browse button. You must have write permission to the selected folder.

7. Go to the Execute tab and build a command with the available command line options. 
Make sure the nm_final checkbox is checked in the model list.
Check the -verbose checkbox.

8. Click Add to Commands List when finished building the command.
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9. Execute the object.

Setting up the R Shell object

1. Import the R command file Xpose_GOF_IND.R from …\Examples\PsN\Xpose_GOF_IND.

2. Right-click Xpose_GOF_IND in the Code folder and select Send To > External Software > R 
Shell.
An R Shell object is now in the workflow and has focus. 

3. Specify the location to store results by typing the path to the desired folder in the R Results Folder 
field or use the Browse button. You must have write permission for the selected folder. 

4. Click the Select Sources button on the Options tab and navigate to Workflow > PsN Shell > Text 
Output. 

5. Check the boxes for catab1, cotab1, patab1, and sdtab1, then click OK.

6. Execute the R Shell and observe the goodness-of-fit and individual plots generated by Xpose.

This concludes the “Using PsN Shell and R Shell objects to generate GOF and individual plots” exam-
ple. You may save the project, if you wish, or simply close it.

Using PsN Shell and R Shell objects to generate VPC plots
This example involves the Xpose package for R. Make sure that this package is installed for R (http://
xpose.sourceforge.net/docs_install.php).

The completed project (EX04_PsN_Xpose_VPC.phxproj) is available for reference in 
…\Examples\PsN.

Set up the project and data

1. Create a new project named Ex04_PsN_Xpose_VPC.

2. Import the PsN control file nm_final.ctl and the dataset file nonmem.csv from …\Exam-
ples\PsN\Xpose_VPC.
In the File Import Wizard dialog, click Finish. 

http://xpose.sourceforge.net/docs_install.php
http://xpose.sourceforge.net/docs_install.php
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Set up the PsN Shell object

1. Select the workflow in the Object Browser and then select Insert > External Software > PsN 
Shell. 

2. In the Options tab, click Select Sources from Phoenix Project.

3. In the Select Sources dialog, expand the Code folder, check the box for nm_final, and then click 
OK.

4. In the Object list in the Setup tab, click NONMEM.CSV.

5. Use the mouse pointer to drag the nonmem worksheet from the Data folder to the Main Mappings. 

6. Specify the root working directory by typing the path to the desired folder in the Root Working 
Directory field or use the Browse button. You must have write permission for the selected folder. 

7. Go to the VPC tab and build a command with the available command line options. 
Make sure the nm_final checkbox is checked in the model list.
Keep the -samples option set to 20.

8. Click Add to Commands List when finished building the command.

9. Go to the Result Filters tab.

10. Type vpc_results.csv in the field and click Add.

11. Set the Import Format pull-down to Import as Binary.
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12. Execute the object.

Set up the R Shell object

1. Import the R command file Xpose_VPC.R from …\Examples\PsN\Xpose_VPC.

2. Right-click Xpose_VPC in the Code folder and select Send To > External Software > R Shell.

3. Click the Select Sources button on the Options and navigate to Workflow > PsN Shell. 

4. In the Text Output folder, check the box for vpctab.

5. In the Other folder, check the box for vpc_results, then click OK.

6. Execute the R Shell object and observe the VPC plots generated by Xpose.

This concludes the “Using PsN Shell and R Shell objects to generate VPC plots” example. You may 
save the project, if you wish, or simply close it.
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Ratios and Differences
The Ratios and Differences tool in Phoenix is a data manipulation tool that is used to compare data 
from either one or two worksheets by computing ratios or differences. The computations are based on 
sort variables and on a variable that defines how data values are to be used as the X values and Y 
values of the ratios or differences. In Pharmacokinetics, ratios are often computed for observation 
data collected under two different scenarios and for resulting final parameters from two NCA or Mod-
eling executions. For discrete final parameters or log-transformed observation data, differences may 
be applicable instead of ratios.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Computation Tools > Ratios and Differences. 
Main menu: Insert > Computation Tools > Ratios and Differences.
Right-click menu for a worksheet: Send To > Computation Tools > Ratios and Differences.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Additional information is available on the following topics:

User interface description
Results

See “Analysis of three profiles using NCA” for an example of using the Ratios and Differences object.

User interface description
Worksheet 1 and 2 Mappings panel
Sort Map Mappings panel
Options tab

Worksheet 1 and 2 Mappings panel
Use the Worksheet Mappings panels to identify how input variables are used in the object. 

Sort: (Optional) Categorical variable(s) identifying individual data profiles, such as subject ID or 
gender. Separate computations are computed for each unique combination of sort variables. 
When no Sorts are identified for a worksheet, the input is assumed to be from one profile.

Filter: (Optional) Column containing the X/Y filter value. This column is a special case of a sort 
variable that is used to split or filter the data into subsets, and the subsets are used to define 
which data (in another column) is to be used for X (the numerator in the case of ratios) and which 
data (in another column) is for Y (the denominator in the case of ratios). For example, a column 
named Day, which contains the values Day 1 and Day 14, is mapped as the Filter, and Day 14 will 
be used to filter for the rows where data in other columns will be used as numerator values, and 
similarly Day 1 will be used to filter for the rows where data in other columns will be used as 
denominator values. If Filter is not mapped, then only the Sort(s) are used to split the data.

Carry: (Optional) Columns from the source worksheet will be copied to the result worksheet.
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Note: If no Sort or Filter is mapped, then this defines a special case where the X and Y columns will be 
required to be different columns (either on one worksheet or from two worksheets), and the Ratios 
and Differences object will compute the X/Y ratios (or differences) row-by-row. 

Sort Map Mappings panel
If a second worksheet is used, then the Sort Map worksheet may be needed to map the column 
names of Worksheet 1 and Worksheet 2, if they differ. This will allow rows in both worksheets to be 
merged based on their sort keys. The Worksheet 1 Sort Keys and Worksheet 2 Sort Keys pull-
down menus are populated with the names of the columns defined as Sort keys on each worksheet’s 
mapping panel. Required input is highlighted orange in the interface.

The Sort Map will automatically map columns of the same name. If there is not a matching name for a 
Worksheet 1 column, the Worksheet 2 column name will be blank.

Options tab
The Options tab is used to define the ratio and/or difference calculations that will be executed at run-
time. Additional rows may be added by pressing the Add button, which becomes active once the 
input for Worksheet 1 is specified. 

Comparison: The type of operation to be performed on X and Y, either X/Y or X – Y.

X or Y Worksheet: The worksheet to be used as the source for X or Y, respectively. Choose from 
either Worksheet 1 or Worksheet 2. Only displayed if more than one worksheet is specified as input 
for the object.

X or Y Column: Name of the column in the X or Y Worksheet that contains the values to be used as 
X or Y, respectively.

X or Y Filter Value: If a column is mapped to the optional Filter context, select the value to use to fil-
ter for data values in other columns in order to find the X or Y values to use in the ratios. For example, 
a column named Day is mapped to the Filter context, which contains the values Day 1 and Day 14. 
The user selects Day 14 for the X option and Day 1 for the Y option in order to compute ratios of data 
on Day 14 over data on Day 1, for each Sort level.

The list of values to define X also includes All, which will create multiple sets of ratios or differ-
ences using all values in the X Filter column that are different from the specified Y Filter Value, 
to define the X’s. Continuing the example, suppose the column Day contains Day 1, Day 14, and 
Day 28. The user selects All for the X option and Day 1 for the Y option. Ratios would be com-
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puted for each Sort level for Day 14 over Day 1 and for Day 28 over Day 1. Another example is 
comparing all metabolites to the parent drug.

New Column Name: Displays the name of the column that will contain the results of the specified 
operation on X and Y. The default name is created using the format:
[Ratio or Diff]_[X column name][X filter value]_[Y column name][Y filter value]

Units: The user-specified units of the comparison. Note: These units are NOT used during the calcu-
lation execution; they are only labels. 

Description: A read-only textual representation of the calculation. The format is:
[Worksheet 1].[X column][ where Filter=X filter value] [“/” | ”–”] [Worksheet 2].[Y column] ][ where Fil-
ter=y filter value]

Defined calculations can be deleted by pressing the red “X” on the row to be deleted. 

If the Sort(s) and Filters do not split the X and Y data into unique values for X and Y, check the Use 
means for X and Y when non-unique box to calculate the mean of the X values and the mean of the 
Y values, and use the calculated means in the specified ratio or difference. If unchecked, and the val-
ues for a profile are not unique, an error message will be given.

Results

Worksheet output
In the stacked results worksheet(s), mapped columns are listed first, followed by parameter data col-
umns used in the comparison computation, then the ratio/difference columns, and then the Carry vari-
ables.

Cells in the comparison columns will be empty for the X input worksheet data or if the Filter column is 
used and its value is the same as the X value. 

The unstacked results worksheet(s), the X values, Y values, and ratios (or differences) are listed side-
by-side, for each defined comparison, followed by the Carry variables.

Text output
Settings: The input worksheet used and the options selected.
Warnings and Errors: If any runtime errors are encountered, they are written to this file.
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Reporter
The Reporter object generates and maintains clinical and pre-clinical study reports based on data and 
analyses resulting from the execution of Phoenix Workflow objects. It is designed to work with tables, 
graphs, text objects, and worksheets. For example, the Reporter object can take output from the 
AutoPilot Toolkit, PK tables and graphs and place them into final or interim reports.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Reporting > Reporter. 
Main menu: Insert > Reporting > Reporter.
Right-click menu for a worksheet: Send To > Reporting > Reporter.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Additional information is available on the following topics:

Define the report content
Table options
Figure options
Pagination in the report
Captions
Footnotes
Report document setup
Handling lost connections
Object output
Setting up preferences

Define the report content 
In the Setup tab, check item(s) in the hierarchical list to include them in the report. Selecting the top 
level node selects all child content below the node.

Uncheck item(s) in the hierarchical list to exclude them from the report. You can also click the red X 
next to the item in the lower list to delete it (the item is automatically unchecked in the top list). 

Reporter is designed to recognize certain objects in a project as tables, figures, or lists and will add 
the appropriate form of content to the lower list. 

 Table: Added to the content list when any of the following are selected:

HTML (results of a Table object or from Tables folder of project)
Worksheets (from Data folder or results of object) 
AutoPilot Toolkit spreadsheets 
Comparer Plot table (from NONMEM Comparer or Maximum Likelihood Model Comparer)

 Figure: Added to the content list when any of the following are selected:

Plots (from results of Plot objects or from plot results of objects)
AutoPilot Toolkit image (WMF, EMF, JPG) 
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Documents folder images (WMF, EMF, BMP, PNG, JPG)
Figures can be displayed in a grid or lattice, see “Report document setup” for instructions.

 Listing: Added to the content list when any of the following are selected:

Text file (results of an object)
Code folder items 

The lower list displays the selected content using the following naming convention: 
ProjectName.Workflow.Object.Source.Name. The items in this list can be reordered by 
dragging and dropping. Selecting an item in the list displays a preview in the panel on the right. (Note 
that any links displayed in the preview area, such as in the list of tables or figures, will not function 
until the document is exported.)

Figure 58-1. Setup tab showing preview of a mapped table

Add text to the report

Click  (Free Form icon) in the toolbar of the lower list for direct entry of text to include in the 
report. 

Any formatting, such as bold, italic, underline, superscript, subscript, use of symbols is preserved in 
the Reporter object’s output document.

Order content
Items will appear in the output in the order they are shown in the lower list. To change the order, do 
either of the following:

Click an item and drag it to the new position in the list.
Ctrl or Shift+click to select multiple items and drag them to the new position. 

Note that the order of the multi-selected items is maintained in the new location.
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Table options

Choose the type of table
In the Options tab, specify the type of table to generate in the output: 

Word table (Create Word tables): This is the default type. These tables can be modified using 
the tools in Word.

Image (Create Images): To prevent table contents from being modified, select this option and 
tables will be inserted as images in the output document.

Optimize table splitting
There are some tables generated by Phoenix and its modules that are too wide to fit on a single page 
of a report. Several options are available in the Options tab for setting how and when to allow splitting 
of such tables.

Split tables that are too wide to fit on a page controls splitting of tables. When unchecked, 
there is no table splitting, regardless of the table size.

The Start each split table on new page option becomes available when the Split tables… 
option is checked and, when selected, forces each split table to begin on a new page.

The Do not split statistics columns or rows option becomes available when the Split tables… 
option is checked and, when selected, prevents table splitting from occurring between statistics 
columns and/or rows. 

Figure options

Set scale
• Click  (Options icon) next to the figure’s name in the lower list.

• Click the Figure tab in the dialog.

• Check the Set Y-axis scale in report box.

• Select Linear to output the figure with a linear scale.

• Select Logarithmic to output the figure with a log scale. Use the menu to select the type of loga-
rithmic scale to use. 



Phoenix Framework
User’s Guide

306

• Select Linear and Logarithmic to output the figure twice, with linear scale and log scale, stack-
ing the figures vertically. Use the menu to select the type of logarithmic scale to use.

If the Arrange figures in a lattice option is selected, then each log plot will be immediately after
the corresponding linear plot, following the specified number of Columns per row.

Create a lattice of figures
A lattice provides the opportunity to organize the display of multiple graphs in a grid layout. 

• Click the Reporter Options icon next to a figure item in the lower list.

• Click the Figure tab in the dialog.

• Check the Arrange figures in a lattice box.

• Specify the number of columns in the lattice using the Columns per row option.

• Specify the number of rows in the lattice using the Rows per page option. (Select To fit to have
as many rows in the lattice as will fit on the page.)

• To display borders for the rows and columns in the report, check the Show grid lines box.

• If the Show figure numbers in lattice cells box is unchecked, the individual figures in the lattice
cells will not be numbered in the report (but the figure number will still be above the lattice).

Pagination in the report
Indicating new pages in the report generated by the Reporter object can be accomplished in several 
ways. 

• To place each Reporter item on a separate page, check the Start each Item on New Page
checkbox in the Options tab.

• To insert a page break in between two particular Reporter items, click  in the lower list toolbar
item. A Section Page Break is placed after the selected item in the lower list. (To specify the orien-
tation of the page(s) in the section, select the Section Page Break item in the list and click Por-
trait or Landscape in the panel to the right of the list.)
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• To avoid tables starting on a page with the previous item and then continuing on the next page, 
turn on the Start each Split Table on New Page checkbox in the Options tab. 

Captions

Number items
All tables, figures, and listings are automatically numbered sequentially (e.g.,Table 1:, Table 2:, etc.). 
The same is true for figures and listings. 

• To turn off the automatic numbering, check the Disable all automatic numbering of Tables, Fig-
ures, and Listings box. 

• To use a specific primary number (e.g., Table 1.1, Table 1.2, etc.), in the Options tab, with the Use 
Major Index checkbox checked, enter the desired primary number in the field. Up to four num-
bers and three periods can be entered in the field, which would generate level five headings.

Latticed figures are automatically numbered sequentially within the lattice cells, using the figure num-
ber as the primary number (e.g., Figure 3.1, Figure 3.2, etc.), but this can be turned off by unchecking 
the Show figure numbers in lattice cells checkbox. 

(Click the Reporter Options icon next to a figure item and select the Figure tab).

Add caption text
A caption can be defined for a table, figure, or listing item. Once defined, the caption can be saved, 
which adds it to the Caption tab’s dropdown menu. Select the caption from the dropdown and reuse it 
within the same project or even across projects. See “Save and reuse captions” for more information.

• To create a caption, click the Reporter Options icon next to the item in the lower list.

• In the Caption tab, enter the text in the Caption Text field, or paste content from the Windows 
clipboard. 

The text can be emboldened, italicized and superscripted/subscripted by selecting the text and click-
ing on the desired font style. To add a symbol, select it from the Insert Symbols pull-down. 
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If the entry mapped to the Reporter object is based on a worksheet, the Source – Data Worksheet / 
Object Source option will be active on the Caption tab, allowing data from the worksheet itself to be 
placed into the caption. The column names (and column units, if applicable) from the relevant work-
sheets are displayed on the right.

In the following figure, the text Table results for Subject has been typed into the Caption 
Text field and then the entry Subject has been added by dragging it from the list on the right.

Figure 58-2. Caption tab with text entered

After execution of the Reporter object, the caption, as defined in the Caption tab, appears in the out-
put above the associated table, figure, lattice, or list.

Optional text in captions
Optional text can be included in a caption. This text will appear in the caption in the generated tables 
or figures if at least one of the specified column(s) are present. When entering the caption in the Cap-
tion Text field, use double angle brackets before (<<) and after (>>) the text that is optional. For 
example: 

PK Parameter table for subjects #1:Subject# <<having matrices 
#2:Matrix#>> 

When the Report object is executed, the appropriate worksheet will be checked to see if it includes a 
Matrix column. If the column is present, the portion of the caption within the double angle brackets will 
be included. If the worksheet does not contain a Matrix column, then the optional text will not be 
included.

Save and reuse captions
Commonly used captions can be saved and reused. 

To add a new caption to the saved list

• Enter the caption text and adjust formatting as desired.

• If the Caption Text pull-down is blank, click on either  (Save) or  (Save As). A Save As 
dialog is displayed that lists any saved captions. Click Save to add the new caption to the saved 
list. 

• If the Caption Text pull-down is not blank, click the Save As icon to display the Save As dialog 
and then click Save.

Captions are saved to the settings file specified in the Preferences dialog. 
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To edit a saved caption

• Select the saved caption from the Caption Text pull-down. 

• Modify the text as desired and formatting as desired.

• Click the Save icon (this overwrites the saved caption).
Or
Click the Save As icon and select the saved caption to overwrite, then click Save.

The saved captions are accessible from the Caption tab for any item selected in the Setup panel.

Upon retrieval of the caption, the validity of the column pattern is checked. If the column name no lon-
ger exists, double angle brackets (<< >>) are inserted to surround the column pattern in the caption. If 
<< >> already exists, the column name is not checked until the Reporter object is executed. 

Deleting a saved caption must be done manually by editing the setting file.

Footnotes

Add footnotes 
Footnotes can be defined as global or individual item footnotes. In addition, a contextual footnote may 
be created, see “Manage contextual footnotes” for more information.

A global footnote adds source information, object name, and/or a date-time stamp as a footnote to 
every individual table, figure, listing, and group member (time-concentration graphs only). This is 
accomplished by checking the Global Footnotes checkbox(es) on the Options tab. 

For a Worksheet, Table, Figure, or Listing result in the report, selecting the Date and Time global 
footnote option adds the date and time of execution for the object that generated that result. For items 
in the report that are not the result of an execution (e.g., data in the Data folder), the date and time of 
the last save of the project is used.

An individual item footnote can be defined for a table, figure, or listing. Once defined, the footnote 
can be saved, which adds it to the Footer tab’s dropdown menu. Select the footnote from the pull-
down and reuse it within the same project or even across projects. See “Save and reuse footnotes” for 
more information.

• To create a footnote, click the Reporter Options icon next to the item in the lower list.

• In the Footer tab, enter the text in the Footnote Text field, or paste content from the Windows 
clipboard. 
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The text can be emboldened, italicized and superscripted/subscripted by selecting the text and click-
ing on the desired font style. To add a symbol, select it from the Insert Symbols pull-down. 

After execution of the Reporter object, the footnote, as defined in the Footer tab, appears in the output 
below the associated table or figure.

Save and reuse footnotes
Commonly used footnotes can be saved and reused. 

To add a new footnote to the saved list

• Enter the footnote text and adjust formatting as desired.

• If the Footnote Text pull-down is blank, click on either the Save icon or the Save As icon. A Save 
As dialog is displayed that lists any saved footnotes. Click Save to add the new footnote to the 
saved list. 

• If the Footnote Text pull-down is not blank, click the Save As icon to display the Save As dialog 
and then click Save.

Footnotes are saved to the settings file specified in the Preferences dialog and will be added to the list 
in the Footnote panel pull-down. 

To edit a saved footnote

• Select the saved footnote from the Footnote Text pull-down. 

• Modify the text as desired and formatting as desired.

• Click the Save icon (this overwrites the saved footnote).
Or
Click the Save As icon and select the saved footnote to overwrite, then click Save.

The saved footnotes are accessible from the Footnote tab for any item selected in the Setup panel.

Deleting a saved individual item footnote must be done manually by editing the actual settings file.
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Manage contextual footnotes
Contextual footnotes may be added to Table items to clarify abbreviations that appear as cell values 
in the table. The footnote will be added only if the specified abbreviation is found within the generated 
table.

To add a contextual footnote

• Click  (Add Footnote icon).

• In the Contextual Footnote dialog, enter the text to search for in the Abbreviation field.

• Use the Match entire cell contents checkbox to toggle between performing an exact match or 
partial match search for the abbreviation.

• In the Footnote Text field, type the text to display as a footnote below the table if the abbreviation 
is found.

• Click Save to add the contextual footnote information to the Footnote panel.

• Use the checkboxes in the Contextual Footnote list to indicate the abbreviations to search for 
within the selected Table item.

When the Reporter object is executed, the tables will be checked for the presence of the identified 
abbreviations. If present, the footnote text will be added below the table. If the abbreviation is not 
present, the footnote will not be added.

To edit a contextual footnote

• In the Contextual Footnotes list, select the footnote to edit.

• Click  (Edit Footnote icon).

• Make the desired changes in the Contextual Footnotes dialog and click Save.
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To delete a contextual footnote

• In the Contextual Footnotes list, select the footnote to delete.

• Click X.

Report document setup

Select the document format
Reporter generates Word and PDF files as output. 

To specify which format to generate, in the Options tab, check the boxes for the desired format: 
Word Document, PDF, or both.

Use a Word template
To select a predefined Word template file (.dotx or .dotm) to apply when generating the report:

• Select the Report Setup tab.

• Enter the path to the template file or click Browse to navigate and select the file from file system
or click Project Documents to select the template from the Documents folder for an open project.

Specify page settings

Note: Page settings are not available if a template is specified.

To define size, margins, and orientation of the report pages:

• Select the Report Setup tab.

• Select a size from the Page Size dropdown menu.

• Enter or use the arrows to set each of the margins for the report pages.

• Click the desired orientation of the pages (Portrait or Landscape). This can be changed with
Section Page Break.

Include captions in document contents lists
The table and figure captions can be added to either the Table of Contents or in separate lists of 
tables and/or figures.

• Select the Report Setup tab.

• Check the Table and Figure Captions Listings box to include captions in the report.

• Click the desired radio button to indicate where to add the captions.

• If the option to Include Table and Figure Captions in Separate List(s) is selected, use the
checkboxes to select the lists to create: Include List of Tables, Include List of Figures, or both.
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Handling lost connections
Connection between an input source and the Reporter object can occasionally be lost. 

• The result that is mapped as the input source is no longer available. 
For example, a Reporter object has an AutoPilot Toolkit table as its input source. The AutoPilot 
Toolkit settings are then modified to not include that particular table in the output and the AutoPilot 
Toolkit object is re-executed.

• The object generating the input source is no longer available.
For example, a Reporter object has an AutoPilot Toolkit table as its input source. The AutoPilot 
Toolkit object is then removed from the Workflow.

• The connector to the input is deleted in the Workflow Diagram.

When a lost connection occurs, an icon will appear next to the associated Input item in the Reporter 
object.

Figure 58-3. Setup tab showing a lost connection of a Reporter item

To re-establish the connection, recheck the Input Object or remove it and then add a new Input 
Object.
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Object output
The Reporter object shown in the following image was executed to produce the example output for 
this section.

Figure 58-4. Reporter object setup used to generate example output 

To open the Reporter output document

• Click the Results tab.

• Click Report under Results.

The following are pictures of the Word document containing the Reporter output. 

The Description is an example of the Free Form Text item. This is followed by a results table from a 
Table object. The table has a caption and a footnote shows the table’s source. 
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Figure 58-5. Example output showing free form text and tables with captions and/or footnotes
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The next image shows one of the NCA results plot for which a footnote has been defined.

Figure 58-6. Example output showing a graph, caption, and footnotes

Several pages follow, each with an additional NCA results plot. Then several pages of text show the 
contents of the Core Output file for the NCA analysis. 



Report document setup

317

The following image shows a two-column lattice of graphs. The latticed figure has it’s own number 
and each cell within the lattice is numbered as well. Note that the footnote that was added appears 
below each latticed figure.

Figure 58-7. Example output showing a lattice of graphs and footnote
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Setting up preferences
By default, saved captions and footnotes are added to the file. The Reporter panel of the Preferences 
dialog is where the XML file to use for populating the Caption and Footnote panels’ pulldown menus 
is specified. This file also contains contextual footnote information. The default file is: 
C:\Users\<user>\AppData\Roaming\Certara\Phoenix\Configura-
tion\Reporter\SavedResources.xml.

• Select Edit > Preferences.

• In the Preferences dialog, select the Reporter item in the menu tree.

Captions and footnotes can be shared between users. This can be done by users loading an XML file 
with a set of pre-defined captions and footnotes (click […]) or by merging captions and footnotes from 
a different file into the one currently in use (Import into Current).

To save the contents of the currently selected XML file to a file with a different name, click Save As 
and specify the new file’s name and location.
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R Shell
The R Shell object imports R scripts and datasets for use in Phoenix.

Note: Phoenix program plugins, such as the R Shell object, assume that the corresponding third party 
software is installed and running properly.

Note: S-PLUS code must be converted to R for use within Phoenix.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > External Software > R Shell. 
Main menu: Insert > External Software > R Shell.
Right-click menu for a worksheet: Send To > External Software > R Shell.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Additional information is available on the following topics:

Setting up preferences
User interface description
Importing/Writing the code to access the external program
Executing a third party tool object
Results

Setting up preferences
Global preferences are available to the user. Some third party tool objects require certain global set-
tings to be specified prior to use. There are optional settings to enable editing of scripts in external 
programs from within Phoenix. Some optional preferences can streamline the workflow by automati-
cally filling in or setting options in the object’s UI with information entered by the user in the Prefer-
ences dialog. 

Setup access to the external program
Specify a development environment
Define a default output location

Setup access to the external program
• Select Edit > Preferences.

• In the Preferences dialog, select the object in the menu tree.

• Enter the directory path to the executable in the first field or click Browse to locate and select the 
directory.
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Specify a development environment
There is a Development Environment section available on the preference pages. When the develop-
ment environment is defined in this section, users can access that environment from the third party 
tool object’s Options tab with the Start button. This allows users to edit scripts in other specified envi-
ronments, and then pull the updated scripts back into Phoenix, at which time, the script can be exe-
cuted from Phoenix and the output processed through the normal Phoenix workflow.

• In the Command field, enter the directory path to the executable or click Browse to locate and 
select the file.

• In the Arguments field, enter any arguments/keywords to use when starting up the environment.

Note: Proper development environment setup for Tinn-R requires that $WorkDir\$File be entered 
in the Arguments field. 

Define a default output location
Setting the output folder in the Preferences dialog eliminates the need to enter the information in the 
Options tab for each run. The fields will automatically be filled with the paths entered here.

• Enter the directory path in the Default Output Folder field or use the Browse button.

Note: If the user specifies a default output location, the user must ensure that they have write access.

• Turn on the Create a unique subfolder for each run checkbox to generate and then store the 
output from each run in a new subfolder of the output folder. 

User interface description
Setup tab
Options tab
Result Filters tab

Setup tab
The Setup tab allows mapping of scripts to the object. The Mappings panel(s) of the Setup tab dis-
plays the column headers specified in the script file. The Text panel allows users to map a script file to 
the object and view the contents.

Note: Any apostrophe marks in the input data (e.g., 5’-deoxy-) should be removed or substituted, as they 
can prevent Phoenix from reading the data. Apostrophes are interpreted as quotation marks, so 
data between two apostrophes is considered to be a single cell value. This can result in the num-
ber of columns not being the same for all rows, 

Context associations for R Shell objects change depending on the column headers, or input, defined 
in the script file. Not all R scripts define or use mapping contexts. If the #WNL_IN # statement does 
not define any mapping contexts, then there are no mapping options available in the Mappings panel. 
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How dataset Mappings panels are defined in R scripts
Before the script is mapped, there are no data inputs into the R Shell object. The data inputs are 
defined in the attach() statement in the script. When using an imported dataset or a results work-
sheet as input for an R script, one or more attach() statements must be in the script in order to 
map an input dataset or sets. 

The attach() statement in the script requires the following format:

   attach(dataname) #WNL_IN context1 context2 context3 etc# 

Each attach() statement creates a data mappings panel that allow users to map a dataset as 
input for the script, and users can map study data to the contexts defined in the attach() state-
ment. If the study variable names are the same as the context names, the study variables are auto-
matically mapped to the appropriate contexts. For example, 

   attach(Eta) #WNL_IN Id nV nCl# 

A data input called Eta is created in the object and is listed in the Setup and Diagram tabs. Also, the 
data mapping contexts Id, nV, and nCl are created in the Eta Mappings panel.

Note: Using the #WNL_IN # comment to create mapping contexts is optional. If it is used, the column 
names in the comment must be space-delimited.

If the attach() statement does not have #WNL_IN … #, then Phoenix treats the data as an exter-
nal source specified in the script and not as an imported dataset. Scripts written in this manner would 
be difficult to share as the sources might not be able to be located on a different computer.

The example R script (plotpredtable.r), available in …\Examples\R, has these lines:

   attach(Residuals) #WNL_IN ID IVAR TAD POPPRED INDPRED 
         OBS IRES WTIRES WRES CWRES PCWRES CdfPCWRES CdfDV# 

   attach(Eta) #WNL_IN Id nV nCl# 

When using the R object for accessing the Model Comparer results for NLME or NONMEM, the 
default csv file generated for importing into R will not work. The columns beginning with “#” prevent 
the file from loading into R. To avoid this problem, set up Model Comparer so it will not generate these 
particular output columns, or explicitly state the columns to import by using the commenting mecha-
nism for mapping in the R tool. For example, use a script similar to the following to list the columns to 
import and then map the columns:

   attach(compare.df) #WNL_IN Hide Compare Name Sort 
         Method Description Lineage LogLik -2(LL) AIC 
         BIC -2(LL)Delta AICDelta BICDelta NumParms 
         NumObs NumSubj pvalue 
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Options tab
The Options tab is used to define a location for the output, access development environment, and 
start a remove execution. 

Entering an output location is optional. If a directory is not specified then Phoenix places output in a 
temporary folder that is deleted after Phoenix is closed. This may be preferred when sharing third 
party tool projects with other users, as the output folder is machine specific and may not exist on other 
machines. If users want to save the results from a third party tool object run to a disk, then they must 
either specify an output folder or manually export each result to disk. 

The results folder set in the Options tab must match the export folder location set in the script. For 
example, if the export path in an R script is c:\\local\\, then the R Shell results folder must also 
be C:\Local. To make sharing projects involving R Shell objects easier, set the results folder in the 
Options tab to the getwd value and refer to getwd in the code. Files written to the path returned 
from getwd end up in the output folder and in the results. 

• Enter the output folder path in the field or click Browse to specify the output folder location.

• Turn on the Create a subfolder for each run checkbox to add a new results folder in the speci-
fied output location each time the object is executed.

This option prevents the output from being overwritten with each run, especially if the default out-
put folder option, under Edit > Preferences, is being used. 

• Click Select Sources to include additional files along with the mapped input.

• Click the Clear Empty Results to remove any results published by the object that are empty.

• Turn on the Include R Workspace checkbox to have Phoenix store the R Workspace with the 
results.

The R Workspace, called RData in the results, can then be re-used in other R objects by using 
the Select Sources button to select it as a source for that object.

• To start the development environment, click Start in the Development Environment section of the 
Options tab.

The development environment as configured in the Preferences dialog is started. (See “Specify a 
development environment”.)
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• When script work is completed, click Reload Script to bring the modified script into Phoenix for 
use in the next execution of the object.

Result Filters tab
See the “Result Filters tab” description for the PsN object.

Importing/Writing the code to access the external program
The R Shell object must have code that will allow it to initiate the external program and submit jobs. 
The code can be stored as a script file, imported into the project, and mapped to the object, or the 
code can be directly entered into the object. 

Import and map file containing code
Write code in the Text panel
Adding shortcuts in scripts
Filtering results by size

Import and map file containing code
The process is the same as for many other Phoenix objects. Refer to “Importing datasets” common 
task description.

Write code in the Text panel
Instead of importing and mapping a script file, users can write their own code or copy and paste code 
from another source. (For more information, see the “Write code in the Text panel” section for the PsN 
object.)

Adding shortcuts in scripts
The input can be defined within the script as a shortcut by adding the following at the beginning of the 
script.

#PHX_SHORTCUT(Data) 

The text entered between the parentheses is used as the variable’s name (e.g., Data).

Phoenix will parse the script and prepend the variable to the script, with the shortcut path being stored 
assigned as the value.

Data <-”C:\\Path\\To\\File” 

In the script, the user can use the variable assigned the path to read or manipulate the file.

To add a shortcut to a script

• With the object inserted in the project, click R Shell in the Setup list.

• Either type the script directly in the field or click  (Select Source icon) and select the script 
(which has already been imported into the Code folder).

• Type the following as the first line in the script:
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   #PHX_SHORTCUT(Data) 

• Click Apply.

The following image is the R Shell Setup panel showing the contents of the script. Notice the first 
line, indicating that a shortcut will be the source of the input data. 

• Select the new Data item in the list.

The Data panel shows the full path behind the shortcut.

The log file produced from executing the object contains the definition used for the shortcut. 
Below is an image of the R Log file.
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Filtering results by size
See the “Filtering results by size” section for the PsN object.

Executing a third party tool object

Click  (Execute icon) or to run the job remotely, click Execute Remotely in the Options tab.

Executing a third party tool object remotely sends the job to the server that is defined in the Prefer-
ences dialog (Edit > Preferences > Remote Execution). See “Phoenix Configuration” for instruc-
tions. The project is saved automatically. 

The project must have been saved at least once prior to executing on RPS, otherwise execution will 
not pass validation and a validation message will be generated.

At this point, the step being executed on RPS, along with any dependent objects, has been locked. It 
is now safe to close the project or to continue working in Phoenix.

In Phoenix, some objects in a workflow allow the user to click and execute the last object in a chain 
and it will re-run any necessary objects earlier in the workflow. This is not true for the R object. Either 
the workflow or the individual objects must be executed to obtain the current source data for the R 
object.

Results
The results are displayed on the Results tab. The output falls into the following categories:

Output Data: Datasets in tabular form

Text Output: Settings files, log files, and other text output

Other: Other kinds of files, for example: documents, export files, binary files, etc. 

Images: Graphs or other images in recognized image formats (jpg, tiff, emf, etc.)
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SAS Shell
The SAS Shell object imports SAS scripts and datasets for use in Phoenix. 

Note: Phoenix program plugins, such as the SAS Shell object, assume that the corresponding third party 
software is installed and running properly.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > External Software > SAS Shell. 
Main menu: Insert > External Software > SAS Shell.
Right-click menu for a worksheet: Send To > External Software > SAS Shell.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

For a SAS script to work in the SAS Shell object, a “/*WNL_IN*/” comment must be added. When 
the script is parsed, the SAS Shell object will recognize this line in the script as defining the data input. 
For example:

     libname indata XPORT “input.xpt”; /*WNL_IN Subject Time Concen*/
     proc copy in=indata out=work;
     run;

The indata library reference name is used by the SAS Shell object for mapping the input dataset.

Notice that this example code has column names listed in the comment: Subject, Time, and Concen. 
The SAS object will use these as context headings in the Mappings panel of the Setup tab. Not all 
SAS scripts define or use mapping contexts. If the /*WNL_IN*/ comment does not define any map-
ping contexts, then there are no mapping options available in the Mappings panel.

When the script containing the example lines of code shown above is submitted to SAS during execu-
tion of the object, the dataset mapped to indata will be converted to a SAS transport file named 
input.xpt and copied to the temporary work directory where SAS will perform any other process-
ing steps outlined in the script file. 

Additional information is available on the following topics:

Setting up preferences
User interface description
Importing/Writing the code to access the external program
Executing a third party tool object
Results

See also SAS example.
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Setting up preferences
Global preferences are available to the user. Some third party tool objects require certain global set-
tings to be specified prior to use. There are optional settings to enable editing of scripts in external 
programs from within Phoenix. Some optional preferences can streamline the workflow by automati-
cally filling in or setting options in the object’s UI with information entered by the user in the Prefer-
ences dialog. 

Set up access to the external program
Specify a development environment
Define a default working directory and output location

Set up access to the external program
• Select Edit > Preferences.

• In the Preferences dialog, select the object in the menu tree.

• Enter the directory path to the executable in the first field or click Browse to locate and select the 
directory.

• Click Test to make sure the correct file is selected. 

Note: If JPS is run as a Windows Service, installation of SAS must be local to the JPS.

Note: If JPS is run as a Console application, the path to the SAS executable may be a Networked loca-
tion not local to the JPS.

Specify a development environment
There is a Development Environment section available on the preference pages. When the develop-
ment environment is defined in this section, users can access that environment from the third party 
tool object’s Options tab with the Start button. This allows users to edit scripts in other specified envi-
ronments, and then pull the updated scripts back into Phoenix, at which time, the script can be exe-
cuted from Phoenix and the output processed through the normal Phoenix workflow.

• In the Command field, enter the directory path to the executable or click Browse to locate and 
select the file.

• In the Arguments field, enter any arguments/keywords to use when starting up the environment.

Note: Proper development environment setup for Tinn-R requires that $WorkDir\$File be entered 
in the Arguments field. 

Define a default working directory and output location
Setting the output folder in the Preferences dialog eliminates the need to enter the information in the 
Options tab for each run. The fields will automatically be filled with the paths entered here.

• Enter the directory path in the Default Output Folder field or use the Browse button.

• Turn on the Create a unique subfolder for each run checkbox to generate and then store the 
output from each run in a new subfolder of the output folder. 
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Note: If the user specifies a default output location, the user must ensure that they have write access.

User interface description
Setup tab
Options tab
Result Filters tab

Setup tab
The Setup tab allows mapping of datasets and script files to the object. The Mappings panel(s) of the 
Setup tab displays the column headers specified in the script file. The Text panel allows users to map 
a script or control/model file to the object and view the contents.

Options tab
The Options tab is used to define a location for the output, access development environment, and 
start a remove execution. 

Entering an output location is optional. If a directory is not specified then Phoenix places output in a 
temporary folder that is deleted after Phoenix is closed. This may be preferred when sharing third 
party tool projects with other users, as the output folder is machine specific and may not exist on other 
machines. If users want to save the results from a third party tool object run to a disk, then they must 
either specify an output folder or manually export each result to disk. 

The results folder set in the Options tab must match the export folder location set in the script. To 
make sharing projects involving SAS Shell objects easier, set the results folder in the Options tab to 
the getwd value and refer to getwd in the code. Files written to the path returned from getwd end 
up in the output folder and in the results. 

• Enter the output folder path in the field or click Browse to specify the output folder location.

• Turn on the Create a subfolder for each run checkbox to add a new results folder in the speci-
fied output location each time the object is executed.

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This option prevents the output from being overwritten with each run, especially if the default out-
put folder option, under Edit > Preferences, is being used. 

• Click Select Sources to include additional files along with the mapped input.

• Click the Clear Empty Results to remove any results published by the object that are empty.

• To start the development environment, click Start in the Development Environment section of the 
Options tab.

The development environment as configured in the Preferences dialog is started. (See “Specify a 
development environment”.)

• When script work is completed, click Reload Script to bring the modified script into Phoenix for 
use in the next execution of the object.

Result Filters tab
See the “Result Filters tab” description for the PsN object.

Importing/Writing the code to access the external program
The SAS Shell object must have code that will allow it to initiate the external program and submit jobs. 
The code can be stored as a script file, imported into the project, and mapped to the object, or the 
code can be directly entered into the object. 

Import and map file containing code
Write code in the Text panel
Adding shortcuts in scripts
Filtering results by size

Import and map file containing code
The process is the same as for many other Phoenix objects. Refer to “Importing datasets” common 
task description.

Write code in the Text panel
Instead of importing and mapping a script/control file to use the third party tool object, users can write 
their own code or copy and paste code from another source. (For more information, see “Write code 
in the Text panel” section for the PsN object.

Changes made to the special comment (/*WNL_IN */) statement are reflected in the data Map-
pings panel. Changes made to a mapped script do not change the script in the Code folder. 

Adding shortcuts in scripts
The input can be defined within the script as a shortcut by adding the following to the script.

     *PHX_SHORTCUT(Data); 

The text entered between the parentheses is used as the variable’s name (e.g., Data).

     &let Data=”C:\\Path\\To\\File”; 

In the script, the user can use the variable assigned the path to read or manipulate the file.
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To add a shortcut to a script

• With the object inserted in the project, click the SAS Script in the Setup list.

• Either type the script directly in the field or click  (Select Source icon) and select the script 
from the Code folder.

• Type the following as the first line in the script:

     *PHX_SHORTCUT(Data); 

• Click Apply.

• Select the new Data item in the list.

The Data panel shows the full path behind the shortcut.

     &let Data=”C:\\Path\\To\\File”;

The log file produced from executing the object contains the definition used for the shortcut.

Filtering results by size
See the “Filtering results by size” section for the PsN object.

Executing a third party tool object

Click  (Execute icon) or to run the job remotely, click Execute Remotely in the Options tab.

Executing a third party tool object remotely sends the job to the server that is defined in the Prefer-
ences dialog (Edit > Preferences > Remote Execution). See “Phoenix Configuration” for instruc-
tions. The project is saved automatically. 

The project must have been saved at least once prior to executing on RPS, otherwise execution will 
not pass validation and a validation message will be generated.

At this point, the step being executed on RPS, along with any dependent objects, has been locked. It 
is now safe to close the project or to continue working in Phoenix.

In Phoenix, some objects in a workflow allow the user to click and execute the last object in a chain 
and it will re-run any necessary objects earlier in the workflow. This is not true for the R object. Either 
the workflow or the individual objects must be executed to obtain the current source data for the R 
object.

Results
Phoenix only supports using SAS Transport Format (XPORT) Version 5 files (*.xpt) in order to 
export datasets from Phoenix to SAS. The SAS transport file names must be specified in the SAS 
script.

The output files are also defined in the SAS script, so only common output files that Phoenix always 
generates are listed here.

All output files defined in the script are placed in the output folder specified in the Options tab. If an 
output folder is not specified, the file are placed in a temporary directory in C:\Users\<user 
name>\AppData\Local\Temp, depending on the operating system. The directory is deleted 
when Phoenix is closed.
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Log File: Text file that contains a list of the functions SAS performs based on the script.

Settings: Text file that contains third party tool object settings internal to Phoenix.
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SAS example

Note: This example assumes that the path to the SAS executable has already been specified in Phoenix. 
(Select Edit > Preferences > SAS.) 

This example generates a PROC mean and a graph from NCA data. Let’s take a closer look at one of 
the lines in the SAS script file we will be using (proc_mean_plus_grf.sas). 

libname indata XPORT "Final_Pa.xpt"; /*WNL_IN auclast tmax cmax aucinfob 
lambda_z hl_lz*/ 

The WNL_IN comment has been added to the SAS script to tell the Phoenix SAS Shell object that this 
line specifies the input information. The indata library reference name is used by the SAS object for 
mapping the input dataset. The column names that follow WNL_IN (auclast, tmax, cmax, aucinfob, 
lambda_z, and hl_lz) will be used by the SAS object as the context headings in the Mappings panel. 

When the script is submitted to SAS during execution of the object, the dataset mapped to indata is 
converted to a SAS transport file named Final_PA.xpt and copied to the temporary work direc-
tory where SAS performs any other processing steps outlined in the script file. 

Let’s continue with the example steps:

1. Create a new project named SAS_Example.

2. Import the SAS script file proc_mean_plus_grf.sas from …\Examples\SAS\Exam-
ple2. 

The script is added to the project’s Code folder and is parsed for comments indicating the data 
input “/*WNL_IN*/” as well any column names listed in the comment. 

3. Import Final_Parameters.csv from …\Examples\SAS\Example2. (Be sure to check 
the Has units row option.) 

4. Select workflow in the Object Browser and then select Insert > External Software > SAS Shell. 

5. With SAS Script selected in the Setup list, expand the Code folder and drag 
proc_mean_plus_grf.sas to the Mappings panel. 

6. Select indata in the Setup list and drag Final Parameters from the Data folder to the Mappings 
panel. (Notice that the context headings are the same as the names specified in the script file.)

7. Map the study variable AUCINF_D_obs to the aucinfob context.

8. Map the study variable HL_Lambda_z to the hl_lz context. 

9. Specify an output location in the SAS object's Options tab by typing the path directly in the Output 
Folder field or by using the Browse button.

10. Click  (Execute icon) to execute the SAS object.

In addition to the aucdescrp.xpt output file, the example script also calls for some additional xpt 
files to be created (finpar2.xpt, which contains only datasets where Lz is defined, and fin-
par.xpt). The finpar2.xpt file is then used to generate a graph (cmax_log.gif). All output 
files defined in the script are placed in the output folder specified in the Options tab (step 9). 

This concludes the SAS example.
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SigmaPlot Shell
The SigmaPlot Shell object imports SigmaPlot scripts and datasets for use in Phoenix. 

Note: Phoenix program plugins, such as the SigmaPlot Shell object, assume that the corresponding third 
party software is installed and running properly.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > External Software > SigmaPlot Shell. 
Main menu: Insert > External Software > SigmaPlot Shell.
Right-click menu for a worksheet: Send To > External Software > SigmaPlot Shell.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Additional information is available on the following topics:

User interface description
Importing/Writing the code to access the external program
Executing a third party tool object
Results

User interface description
Setup tab
Options tab
Result Filters tab

Setup tab
The Setup tab allows mapping of datasets and script files to the object. The Mappings panel simply 
lists the columns found in the dataset. The Text panel allows users to map a script or control/model file 
to the object and view the contents.

Options tab
The Options tab is used to define a location for the output. 

The results folder set in the Options tab must match the export folder location set in the script. To 
make sharing projects involving SigmaPlot Shell objects easier, set the results folder in the Options 
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tab to the getwd value and refer to getwd in the code. Files written to the path returned from 
getwd end up in the output folder and in the results. 

Enter the output folder path in the field or click Browse to specify the output folder location.

Result Filters tab
See the “Result Filters tab” description for the PsN object.

Importing/Writing the code to access the external program
The SigmaPlot Shell object must have code that will allow it to initiate the external program and sub-
mit jobs. The code can be stored as a script or control/model file. These code sources can be 
imported into the project and mapped to the object, or the code can be directly entered into the object. 

Import and map file containing code
Write code in the Text panel
Filtering results by size

Import and map file containing code
The process is the same as for many other Phoenix objects. Refer to “Importing datasets” common 
task description.

Write code in the Text panel
Instead of importing and mapping a script/control file to use the third party tool object, users can write 
their own code or copy and paste code from another source. (For more information, see the “Write 
code in the Text panel” section for the PsN object.

Changes to column headers in the .NamedRanges.Add statement are reflected in the Dataset 
Mappings panel. Changes made to a mapped script do not change the script in the Code folder. 

Filtering results by size
See the “Filtering results by size” section for the PsN object.

Executing a third party tool object

Click  (Execute icon).

In Phoenix, some objects in a workflow allow the user to click and execute the last object in a chain 
and it will re-run any necessary objects earlier in the workflow. This is not true for the R object. Either 
the workflow or the individual objects must be executed to obtain the current source data for the R 
object.

Note: Executing a Sigma Plot script that attempts to write results to a non-existent folder can result in 
Sigma Plot getting 'stuck' in a state where the only way to close the application is to kill it with Win-
dow’s task manager. Check the output folder names in the export statements of the scripts to con-
firm you are writing to an existing directory. 
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Results
The results are displayed on the Results tab. The output for SigmaPlot Shell objects falls into the fol-
lowing categories:

Output Data: Datasets in tabular form

Text Output: Settings files, log files, and other text output

Other: Other kinds of files, for example: documents, export files, binary files, etc. 

Images: Graphs or other images in recognized image formats (jpg, tiff, emf, etc.)
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Table
The Table object generates a report- and analysis-ready HTML table containing worksheet data and 
optional summary statistics. Eight table types provide a choice of layouts and summary statistics, with 
flexible formatting options.

Note: The Table object does not use case-sensitive comparisons when sorting and grouping data.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Reporting > Table. 
Main menu: Insert > Reporting > Table.
Right-click menu for a worksheet: Send To > Reporting > Table.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Additional information is available for the following topics:

User interface description
Results
Table template for merged worksheet data
Create report-ready table from NCA results example
Using custom tables example

User interface description
Main Mappings panel
Table Preview panel
Options tab
Statistics tab
Style tab
Column/Sort Order tab
Custom Tables tab

Main Mappings panel
Use the Main Mappings panel to identify how input variables are used in a Table object. Required 
input is highlighted orange in the interface.

Click the option buttons in the Main Mappings panels to map the data types in the dataset to the 
appropriate context associations. Context associations for a Table object change depending on which 
table type is selected in the Options tab. Required input is highlighted orange in the interface.

None: Data types mapped to this context are not included in any analysis or output.

Row ID: Data types mapped to this context are used to create the rows in the output table. 

Data: The observation data used to create the table. Multiple variables in a dataset can be 
mapped to this context.
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Dependency: Dependent values require variables to be mapped to the Row ID and Row Stratifi-
cation contexts. Dependent values are matched to values mapped to Row ID and Row Stratifica-
tion and are displayed separately in the output table.

Row Stratification: Data types mapped to this context are used to create row breaks based on 
individual values in the data type.

Column Stratification: Data types mapped to this context are used to create column breaks 
based on individual values in the data type.

Table Preview panel
The Table Preview panel allows users to see a preview of the table output. The Preview Panel is 
updated any time a new table type is selected in the Table Type menu.

Options tab
The Options tab list contains several items that allow users to select and format a table.

Table options
Precision/Alignment options
Title options
Column Titles options
Table Body options
Statistics options
Footers options

Table options
The Table options are used to format the output table.

• Use the Include Units checkbox to toggle between including/excluding units in the input dataset
in the output table. (The default is checked, include units.)

• Use the Remove Empty Columns checkbox to toggle between removing/including empty col-
umns in the output table. (The default is checked, remove empty columns.)

•



Check  the  Page Break on Row Stratification checkbox to create a printing page break in 
the output table for every new value of the variable mapped to the Stratification Row 
context. Use this option to decrease the uploading time for extremely large tables. 
If Page Break on Row Stratification is checked, the Titles on First Page Only checkbox 
becomes available.

• Check the Titles on First Page Only checkbox to only display the table title on the first page. If
unchecked, the title will be repeated on all subsequent pages containing the table.

• In the Table Type menu, select the table type to use to create the output table:
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Default: Computes and displays summary statistics for each column included under Data. Statis-
tics are computed separately for each unique combination of values for the group variable(s), if 
any. Users can also map variables to the Dependency context. 

Table 1: Column Summary by Row Stratification. Computes summary statistics for each column 
included under Data. Statistics are computed separately for each unique combination of values 
for the group variable(s), if any. 

Table 2: Column Detail by Row Stratification. Raw data for each column selected under Data. It 
does not generate summary statistics. Data are sorted alphanumerically by group variable values, 
then by Row ID variable values, in the order listed.

Table 3: Column Detail and Summary by Row Stratification. Adds summary statistics to Table 2. It 
lists the raw data for each variable at each value of the Row ID variable(s), and summarizes it for 
each unique combination of group variable values, if any.

Table 4: Column Summary by Row and Column Stratification. Like Table 1, this type generates 
summary statistics and displays them without the raw data. Separate statistics are computed for 
each unique combination of Row and Column Stratification values. 

Table 5: Column Detail by Row and Column Stratification. Reports raw data for each column 
mapped to the Data context, for each variable mapped to Row ID. A separate listing is included 
for each unique combination of values for the Row and Column Stratification variables, with Col-
umn Stratification variable values in adjacent columns.

Table 6–7: Column Detail and Summary by Row and Column Stratification. Adds computation of 
summary statistics to the listing of raw data as presented in Table 5. Statistics are computed sep-
arately for each unique combination of Row and Column Stratification variable values. Columns 
ordered by cross variable within variable (all Column Stratification variable values are grouped 
together, with one set for each regular variable).

Table 8: Row Detail by Row and Column Stratification. Same as Table 6, with summary statistics 
in columns instead of rows. Statistics are calculated for each Row ID variable value, within Row 
and Column Stratification variable values.

Precision/Alignment options
Any study variables mapped to a context other than None and any statistics selected in the Statistics 
tab are listed under Precision/Alignment.

For each table type, the following contexts cause variables to be listed under Precision/Alignment.

Default: Row ID, Data, Dependency, Row Stratification, or Column Stratification contexts 
Table 1: Data, Stratification Row
Table 2: Row ID, Data, and Stratification Row
Table 3: Row ID, Data, and Stratification Row
Table 4: Data, Stratification Row, and Stratification Column
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Table 5: Row ID, Data, Stratification Row, and Stratification Column
Table 6 and 7: Row ID, Data, Stratification Row, and Stratification Column
Table 8: Row ID, Data, Stratification Row, and Stratification Column

Except for Table 2 and Table 5, the contexts listed above will display variables for each summary sta-
tistic.

• Select the Precision/Alignment node.
Setting the numeric precision and output value alignment here will affect all variable columns in
the table.

• Select a variable underneath Precision/Alignment.
The options are the same as those available when the Precision/Alignment node is selected.
However, setting the numeric precision and output value alignment here will only affect the
selected variable’s column.

• In the Precision Method menu, select Decimal Places or Significant Digits to set the number
of digits used to display the values.

• In the Value menu, select the number of significant digits or decimal places used to display the
values.

• In the Header Alignment menu, select the alignment of the header in the output table.

• In the Data Alignment menu, select the alignment of the values in the output table.

• Select a statistic underneath Precision/Alignment in the Options tab list.

Make the same precision and alignment selections for the statistics that were made for the vari-
ables.

As with the variables, when the Statistics node is selected, adjustments to the precision and align-
ment options will affect all of the statistics rows.

• Select a variable underneath a statistic to set the precision and the data alignment. The header
alignment option is not available at this level.

Title options 
The Title options are used to add titles to the output table. 



343

• In the Title field, type a title for the table. 

• Select Superscript or Subscript to change the positioning of the text being entered, then select 
Normal to return to the default positioning.

• In the Symbol menu, select one of supported symbols to add to the title. 

• Click the Add button to add the title.

• To remove a title, select the title with the pointer and click the Remove button.

Column Titles options 
The Column Titles options are used to replace column headers in the input dataset with new headers.

• In the Search For field, type the column header to be replaced.

• In the Replace With field, type the column title used to replace the column header in the dataset.

• Check the Match Entire Cell checkbox to match on the contents of the entire cell during a 
search/replace (e.g., Subject will match Subject but not Subject 1 or Subject 2). If 
unchecked, search and replace will match any part of the cell value (e.g., max will find a match in 
both Tmax and Cmax).

The rest of the options are the same as described in “Title options”.

Table Body options 
The Table Body options are used to replace text or numerical values in the input dataset with new val-
ues. The options are the same as described in “Column Titles options”.

Statistics options 
The Statistics options are used to replace statistic names in the output table. The options are the 
same as described in “Column Titles options”.

Footers options 
The Footer options are used to add footers to the output table. Simply type the footer in the Footer 
field. The rest of the options are the same as described in “Title options”. 
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Statistics tab
The Statistics tab is used to add summary statistics to a table. Table types 2 and 5 do not allow users 
to add summary statistics.

For a complete list of available summary statistics and descriptions of each one, see “Statistical 
results and computational formulas”.

• Check the Display checkbox beside each summary statistic to include it in the output table.

• Click the Select All button to select all summary statistics.

• Click the Clear All button to clear all selected summary statistics.

The Column Statistics and Row Statistics option buttons are automatically selected for table 
types 1, 3, 4, and 6-8.

The Summary Only checkbox is unavailable for table types 1, 3, 4, and 6-8.

If the Default table type is selected, then users can select the Column Statistics and Row Sta-
tistics option buttons and the Summary Only checkbox.

• In the Confidence Interval box, type or select the confidence interval to apply to the summary 
statistics.

• In the Number of SD box, type or select the number of standard deviations to apply to the sum-
mary statistics. 

Style tab
The Style tab list contains several items that allow users to format parts of a table.

• Select Titles in the Style tab list.

• Click the Select Font button to open the Font dialog and change the titles font.
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• Select the font type, style, size, effect, and script. 
• Click OK to accept the changes or Cancel to leave the font the same.

• Repeat for Column Titles, Table Body, Statistics, and Footers to make changes to their fonts.

• To reset all font changes, click the Reset All To Default button.

Column/Sort Order tab
The Column/Sort Order tab allows users to change the arrangement and sort order of data types used 
to create a table. 

• Select an item from the menu. The items available in the menu change depending on the selected 
table type and the variables mapped to each context.

Row ID, Row Stratification, or Column Stratification requires at least one variable be mapped 
to the corresponding context.

Data and Dependency requires two or more variables be mapped the corresponding context.

Statistics requires two or more statistics be selected for display in the Statistics tab. 

• To change the sort order of Row ID, Row Stratification, or Column Stratification variables from 
ascending to descending and back again, double-click the variable.

• To change the display order of variables or statistics listed, select an item in the list and click the 
up or down arrow buttons to reorder the list.
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• To sort rows based on a list of row IDs:
• Select the column in the Row ID list.
• Click the Add Custom Sort button to display a second list of all values in that column. 

(The word Custom is added to the column’s name in the first list.)

• Select an ID in the second list and use the arrow buttons to change the display order.
• To remove a custom sort order, select the column in the first list and click Remove Custom 

Sort.

Custom Tables tab
The Custom Tables tab is used to select custom tables. Each custom table has its own set of context 
mappings and are designed to use with specific datasets.

Custom tables are defined using XSLT files. Each XSLT file must be added to the Custom-
Tables.xml file. By default, all files needed to create custom tables are located in C:\Program 
Files (x86)\Certara\Phoenix\application\Plugins\Table\Custom.

See an example in “Using custom tables example”. 

• In the Select Custom Table menu, select a custom table.

Phoenix comes with two custom tables:

Bioavailability Statistical Summary: A statistical summary of the comparative bioavailability 
data.

Bioequivalence Demographics: A demographic profile of subjects completing a bioequivalence 
study. One table is created per study.

When a custom table is selected, only the Custom Tables tab remains available.

• In the Select Custom Table menu, select None to return to the normal Table object user inter-
face.

Results
Table: Worksheet containing the output HTML table.

Settings: Text file containing the input worksheet used and the options selected.

Note: Extra-wide tables can become truncated when printed directly from Phoenix. This is due to a print 
limitation in Internet Explorer. If this occurs, copy the table from the Results tab to the Tables folder 
and use the Edit in Excel functionality to format as desired.
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Table template for merged worksheet data
In WinNonlin 5.2.1, there was a table template 9 that used data from two merged worksheets. For 
example, merged PK data from an input worksheet and PK parameter estimates from a modeling out-
put worksheet. 

This table type presents raw data at different sample times and PK parameters in columns, with a row 
for each subject or ID variable. It generates summary statistics for each unique combination of group 
and ID variable values. The two datasets must be merged using these group and ID variable values.

Although no longer available in the Phoenix interface, template 9 can be recreated by selecting the 
Default table type and using the Merge Worksheets object.

• Import the source data into a project.

• Add a Merge Worksheets object to the workflow.

• Drag the dataset from the Data folder to the Merge Worksheets’ Mappings panel.

• Merge the worksheets using common sort keys. The variables mapped to the Sort context must 
match in both worksheets.

The variables do not need to have identical names, but they must be the same type of variable 
with overlapping sets of values. The variable values are used to merge values from both datasets. 

One set of summary statistics are computed for each unique combination of Sort variable values.

• Map other variables to be included in the table to the Included Column context.

• Check the Carry Along Data For Like Sort Levels checkbox.

• Execute the Merge Worksheets object.

• Add a Table object to the workflow.

• Map the Merge Worksheets object’s Result worksheet to the Table object.

• In the Table object’s Options tab, select Default in the Table Type menu.

• Map the variables in the merged dataset to the appropriate contexts. 

• Specify any other table options and execute the Table object.
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Create report-ready table from NCA results example
PK parameters for six subjects for both Tablet and Capsule formulations were computed.

The input data for this example are located in the Phoenix examples directory. This example will cre-
ate a table using the parameters Cmax, Tmax, AUCall, and AUClast.

Most Phoenix objects require the same basic steps for their use. However, there may be multiple 
paths to accomplishing a step (e.g., main menu, right-click menu, drag-and-drop, etc.). For simplicity, 
only one is listed here. 

Note: Any object added to a project can be viewed in its own window by selecting the object in the Object 
Browser and double-clicking it or pressing ENTER. All instructions for setting up and executing an 
object are the same whether the object is viewed in its own window or in Phoenix’s viewing.

The completed project (Tables.phxproj) is available for reference in …\Examples\Data 
and Plots.

Import the final parameter estimates data

1. Create a new project with the name Tables.

2. Import the file …\Examples\WinNonlin\Supporting files\Profiles Out-
put.xls.
In the File Import Wizard dialog, select the Has units row option for the Final Parameters Piv-
oted, Dosing Used, and Summary Table worksheets, using the Next Arrow button to move 
through the worksheets being imported.
Click Finish.

Set up the Table object

1. Right-click Final Parameters Pivoted in the Data folder and select Send To > Reporting > Table.

2. In the Options tab below the Setup panel, select Table 3 - Column Detail and Summary by Row 
Stratification from the Table Type menu.

3. Map Subject to the Row ID context.
Map Form to the Stratification Row context.
Map Tmax, Cmax, AUClast, and AUCall to the Data context.
Leave the rest mapped to None.

Table type 3 sorts by the row variable within values of the stratification row variable. It does not com-
pute summary statistics for each level of the row variable. Table type 3 also sorts the data by stratifica-
tion row variable value and computes summary statistics for each value. 

These variables provide data for the body of the table. (Select the Table Preview panel in the Setup 
list to view an example of the final table output.)

Select and format summary statistics

1. Select the Statistics tab below the Setup panel.

2. Check the checkboxes in the Display column to select the following summary statistics: N, Mean, 
SE, Min, Median, Max.

3. Go to the Options tab, expand the Precision/Alignment node in the menu tree, and select Sub-
ject.
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4. Select 0 in the Value menu.

5. Enter a title for the table by selecting Titles in the Options menu tree.
– In the Title field type Table 1 and click Add.
– Continue by typing Pharmacokinetic Parameters in the Title field and click Add.

6. Select the Column/Sort Order tab.

The columns in the final table are displayed in the order set here. Use the up arrow and down 
arrow buttons to change the order in which the Data columns are displayed.

The pull-down menu offers the following options:
Row Stratification to view study parameter(s) mapped to Row Stratification.
Row ID to view study parameter(s) mapped to Row ID.
Data to view study parameter(s) mapped to Data.
Statistics to view the items selected on the Statistics tab.

7. Select Data from the menu.

8. Select Cmax in the Column Order list and click the Up Arrow button.

9. Select AUCall in the Column Order list and click Up Arrow button.

The Table object’s Style tab can be used to change the table display options, such as font, font size, 
font color, and alignment. Style selections are not necessary for this example.

Execute and view the Table object results

1. Click  (Execute icon) to execute the object. 
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Figure 64-1. Table type 3 results

This concludes the Create Report-Ready Table example.

Using custom tables example
The custom table types are included to provide additional reporting options. In custom table types, all 
output formatting, statistics, styles, sorting, and other options are predefined through an XML file and 
style sheets.

Once a custom table is defined, users do not need to make any further option selections. The only 
possible selections users can make are mapping the input data types to the mapping contexts in the 
custom table.

Most Phoenix objects require the same basic steps for their use. However, there may be multiple 
paths to accomplishing a step (e.g., main menu, right-click menu, drag-and-drop, etc.). For simplicity, 
only one is listed here. 

Note: Any object added to a project can be viewed in its own window by selecting the object in the Object 
Browser and double-clicking it or pressing ENTER. All instructions for setting up and executing an 
object are the same whether the object is viewed in its own window or in Phoenix’s viewing.
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The completed project (Tables.phxproj) is available for reference in …\Examples\Data 
and Plots.

Add a table object using the Send To menu

This example uses a dataset that contains demographic data for a population used in a bioequiva-
lence study. 

1. From within an open project, import the file …\Examples\WinNonlin\Supporting 
files\Bioequivalence Demographics.dat.

2. Right-click Bioequivalence Demographics in the Data folder and select Send To > Reporting > 
Table.

3. Select the Custom Tables tab below the Setup panel.

4. In the Select Custom Table menu, select Bioequivalence Demographics.

All other tabs are removed from the Table object user interface when a custom table is selected. This 
is because the custom table type contains preconfigured table options.

The study data types are automatically mapped to the appropriate mapping contexts.

Execute and view the results

1. Execute the object.
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Figure 64-2. Bioequivalence Demographics table results

2. Close this project by right-clicking the project and selecting Close Project.

This concludes the Using Custom Tables example.
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Watson Import Object
The Watson Import object uses the Watson LIMS plug-in to access active studies in Watson LIMS. 
Data from Watson LIMS are imported into a Phoenix project as either a study Workbook or as a study 
in Integral. 

The Watson LIMS plug-in assumes that the Watson LIMS software is installed and running properly. 

This section includes the following topics:

Setting up preferences
Importing the Watson Study as a study worksheet
Importing the Watson Study in Integral

Setting up preferences
A number of preferences for the Watson Import object are available to the user via the Preferences 
dialog (Edit > Preferences).

Server configuration
Business rules configuration
Sample and Dosing worksheet configuration

Each tab of preferences has the following buttons available:

Save to File stores the configuration selections to a specified file. 
Load from File loads configuration selections from a specified file. 
Apply Changes saves the configuration settings as the active configuration.
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Server configuration
In the Preferences dialog, select Watson Import > Server Configuration.

Host: Enter the name or IP address of the Oracle Server where the Watson schema is located.

Port: Enter the port of the Oracle Server where the Watson database is located (Oracle’s default 
port number is 1521).

DB SID: Enter the name of the Oracle database where the Watson schema is located.

Service Account: Enter the name of the Oracle database account used to select data from the 
Watson schema. This account needs to be located in the same Oracle database as the Watson 
schema and must have select privileges on all tables in the Watson Account schema.

Service Account PW: Enter the password for the Service Account.

Watson Account: Enter the name of the Watson schema. The Watson LIMS plug-in uses this to 
select data from the Watson schema (e.g., select * from watson.study). This is usu-
ally set to watson.

Info field: Lists copyright and specific licensing information.
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Business rules configuration
In the Preferences dialog, select Watson Import > Business Rules.

Sample: Enter the name of the Sample Worksheet that is created in the Phoenix project.

Dosing: Enter the name of the Phoenix Dosing Worksheet that is created in the Phoenix project.

BQL: Enter the text used to represent values from Watson that are below the limit of quantifica-
tion.

AQL: Enter the text used to represent values from Watson that are above the limit of quantifica-
tion.

Missing Value: Enter the text to display in cells that are missing data.

Units: Specify the unit of the transferred columns (Days, Hours, Minutes). 

Precision: Specify the precision of the time columns transferred from Watson by selecting either 
Significant Digits or Decimal Places and entering the numeric value for the precision in the 
adjacent field. 
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Remove Subjects Without Sample Results: Only import subjects with at least one concentra-
tion value in Watson. Default is checked.

Remove Samples Without Sample Results: Only import designed samples that have a corre-
sponding sample result in Watson. Default is unchecked.

Remove Unlocked Sample Results: Only import samples from Watson where the sample result 
is locked. This option is grayed out by default.

Create Dose Rows For Unique Analytes: Create additional dosing rows for each unique ana-
lyte in the study. Default is checked.

Create Dose Rows For Unique Matrices: Create additional dosing rows for each unique matrix 
in the study. Default is checked.

Remove Empty Columns: Only import a column of data from Watson when at least one value 
exists in the column. This rule is applied before the Missing Text Value is applied. Default is 
checked.

Remove Rejected Samples: Remove samples that have been rejected from the sample dataset.

Remove Dosing Worksheet: Do not create a dosing worksheet on a transfer from Watson. 
Default is checked.

Include Prep. Sample Worksheet: Create a prepared sample worksheet 

Include Samples with ReAssay Tags: Include reassayed data in the worksheets returned to 
Phoenix. When checked, the Filter Criteria options become available: Reasons: Enter the rea-
son for the reassay (e.g., Mandatory Repeats or Incurred Sample Repeats). Reas-
sayed samples that match the reason will be included during import. If not, the sample is 
removed. Statuses: Enter the status of the reassay (e.g., acc). Reassayed samples that match 
the status will be included. If not, the sample is removed.
If there is no entry for Reasons and Statuses, but the Include Samples with ReAssay Tags 
option is checked, then all of the reassayed data is imported.

Sample and Dosing worksheet configuration
The layout and options available in the Sample Worksheet Configuration are identical to those avail-
able in the Dosing Worksheet Configuration are discussed in this single section.

In the Preferences dialog, select Watson Import > Sample Worksheet Configuration or Dosing 
Worksheet Configuration.
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Columns 

Transfer: Check the checkbox to transfer the column during the Watson import. 
Uncheck the checkbox for columns that are not to be transferred.

Default Column Name: Displays the Watson column name and is not editable. 
Cells in this table column that are in yellow are time independent (demographics) and are shared 
across the Dosing and Sample Worksheet configurations. 
Configurations applied to these columns will be replicated to both the Dosing and Sample Work-
sheets.

Transferred Column Name: Enter the name of the column as it will appear in the Phoenix Work-
sheet after the Watson import is completed.

Units: Define the unit for the transferred column.
Set the units of a column to a fixed value by entering a text entry surrounded by single quotes 
(e.g., ‘year’, ‘min’). Or set the units of a column to a transferred column from Watson (e.g., CON-
CENTRATIONUNITS or DOSEUNITS). Cells in this column that are highlighted in gray cannot be 
set because these fields are not applicable or are populated based on a business rule.

Other Settings 

Sync Non-Demo From Samples: Synchronize configuration settings from the columns that are 
shared across the Dosing and Sample Worksheet configurations (e.g., Treatment, Period).

Column Order: Click the Up or Down to move the selected row up or down the list, respectively. 
This will impact the order that the columns appear from left to right in the Phoenix Worksheet.

All/None: Click All to check all of the Transfer checkboxes. Click None to uncheck all of the 
Transfer checkboxes.
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Reset Defaults: Restore the Worksheet configuration options to the original default selections.

Importing the Watson Study as a study worksheet
Select Watson > Create Study Workbook.

Figure 65-1. Select Watson Study to Import dialog

In the dialog, click a row to select the study to import and then click Import Study.

Once the import is complete, the name of the study is add under the Data section of the Phoenix 
Object Browser.

Figure 65-2. Imported Watson study is added to the Data folder

Note that the Dosing and Samples Worksheets may or may not be created depending on the Busi-
ness Rules that were set up in the Preferences dialog. The Transfer Summary Worksheet provides 
information about the importing process.

Use the Watson > Refresh Study Workbook menu option to update the data with any changes that 
have been made to the study data.
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Importing the Watson Study in Integral 
Select Watson > Create Study Workbook.

Click Connect and log in to Integral.

Figure 65-3. Select Watson Study to Import dialog

In the dialog, click a row to select the study to import and then click Create Study.

Once the import is complete, select Integral > Browser.

The study will be displayed in the Integral browser tree.

A right-click menu is available for the Watson study item containing the same options as other Integral 
studies. There is an additional item on the menu called Update Watson Study, which updates the 
data with any changes that have been made to the study data.

See “Integral” for details on the functionality available.

The Watson Import object creates the study in two steps: 1) create the study with subjects and sam-
ples; 2) append dosing. 
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Worksheet-Related Objects
The following operational objects can be used to modify worksheet content:

Append Worksheets
Crossproduct Worksheets
Enumerate Worksheets
Join Worksheets
Merge Worksheets
Pivot Worksheet
Rank Worksheet
Split Worksheet
Stacker
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Append Worksheets
Append columns of two or more worksheets into one worksheet. The selected columns are appended 
side by side, unless they use the same column header name, in which case they are presented in a 
stacked format. 

Worksheet columns are appended based on whether or not column headers match, and the order in 
which input worksheets are mapped to the object. For example, if the Time column in the first work-
sheet is selected as the source column, and then Concentration in the second worksheet is selected 
as the source column, then the output worksheet places the Time column first and the Concentration 
col-umn second.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Data Management > Append Worksheets. 
Main menu: Insert > Data Management > Append Worksheets.
Right-click menu for a worksheet: Send To > Data Management > Append Worksheets.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Mappings panel
The Mappings panel allows users to specify which columns in a worksheet are included in the 
new worksheet. Required input is highlighted orange in the interface.

None: Data types mapped to this context are not included in the result.
Source Column: The column or columns that are appended together in a new worksheet.

Options tab

• In the Number of Worksheets box, select or type the number of worksheets to use in the append
operation.
Each worksheet that is added creates another Worksheet Mappings panel in the Setup tab.

• Select the Create column with source information in output checkbox to include the names of
the input worksheets used to create the output worksheet in a separate column.

• Select the Abbreviate source name checkbox to abbreviate the names of the input worksheets
listed in the source column in the output worksheet.
If this option is selected then only the name of the worksheet, and not the full name of the input
source, is displayed in the Source column.
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Results
The Append Worksheets object generates one worksheet and one text file.

Results: The appended worksheet.

Settings: Text file containing input worksheets used and the options selected.



Phoenix Framework
User’s Guide

366

Crossproduct Worksheets
Use common sort keys in two worksheets to create two new worksheets that are the result of a Carte-
sian cross product transformation. Users specify the common sort keys and the carry along parame-
ters or variables used to create the output worksheets.

For example, assume the following two datasets are mapped to a Crossproduct object:

Dataset 1:

   Period  Data
   A       1
   A       2
   B       3
   B       4

Dataset 2:

   Phase  Color
   X      R
   X      B
   Y      Y
   Y      V

If Period and Phase are mapped to Sort, and Data and Color are mapped to Carry Along, then the 
output worksheets look like this:

Worksheet AB:

   Period  Phase  Data
   A       X      1
   A       X      2
   A       Y      1
   A       Y      2
   B       X      3
   B       X      4
   B       Y      2
   B       Y      4

Worksheet BA:

   Period  Phase  Color
   A       X      R
   A       X      B
   A       Y      Y
   A       Y      V
   B       X      R
   B       X      B
   B       Y      Y
   B       Y      V

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Data Management > Crossproduct Work-
sheets.
Main menu: Insert > Data Management > Crossproduct Worksheets.
Right-click menu for a worksheet: Send To > Data Management > Crossproduct Worksheets.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.
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Mappings panel
The Mappings panel allows users to specify which columns in a worksheet are involved in the work-
sheet transformation. Required input is highlighted orange in the interface.

Sort: Categorical variable(s) identifying individual data profiles, such as subject ID.
Carry Along: Variables or parameters from each worksheet that are used to create the cross 
product output worksheets.

Users can specify multiple sort keys and carry along values. It is also possible to select a sort key 
from only one input worksheet. That sort key is then applied to both output worksheets. Users can 
also choose no sort keys, in which case Phoenix assumes that a single profile is the sort key for both 
input worksheets.

Results
The Crossproduct Worksheets object generates two worksheets and one text file.

Worksheet AB: Combination of worksheet 1 and 2 sort keys, and worksheet 2 carry along val-
ues.

Worksheet BA: Combination of worksheet 2 and 1 sort keys, and worksheet 1 carry along val-
ues.

Settings: Text file containing input worksheets used and the options selected.
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Enumerate Worksheets
Assign ordinal values to the unique values in specified columns of a Phoenix worksheet. If more than 
one column is selected, there is an option to enumerate all unique combinations of all selected col-
umns. The user can select to start the numeration at zero or one. One typical usage of this tool is to 
convert covariates to numerical values for modeling in Phoenix NLME.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Data Management > Enumerate Worksheets. 
Main menu: Insert > Data Management > Enumerate Worksheets.
Right-click menu for a worksheet: Send To > Data Management > Enumerate Worksheets.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Additional information is available for the following topics:

Mappings panel
Output Column Names panel
User Supplied Values panel
Options tab
Results

Mappings panel
The Mappings panel allows users to specify which columns in a worksheet are involved in the work-
sheet transformation. Required input is highlighted orange in the interface.

Enumerate: Column(s) to enumerate.

Output Column Names panel
Column names can be assigned manually using the Output Column Names panel in the Setup tab. 

Type the new name in the Output Column Name column of the table.

Figure 69-1. Enumerated worksheet with new column name
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User Supplied Values panel
Output values can be assigned manually using the User Supplied Values panel in the Setup tab. 

Because Female is alphabetically before Male, the values assigned by default will be 0 to Females 
and 1 to Males. To indicate other values to assign, use the Setup option User Supplied Values.

In this example, Female has been assigned 1 and 0 to Males.

The default is for the output to concatenate the word code to the selected Enumerate column’s origi-
nal name to create the output column. In this case, the output column will be named Sex_code. 

Options tab

• Check the Group Values to Generate a Single Output Column box group values in the output. 
This option can only be applied when more than one column is mapped to Enumerate. 

• Set the Start Value to begin the enumeration at 0 or 1. This option only works if there are no User 
Supplied Values worksheet defined.
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In the example below, the source data includes a column of sex and weights and both sex and wt are 
selected to enumerate. 

Figure 69-2. Mappings set for enumerating two columns available in the source 

If the Group Values to Generate a Single Output Column box is not checked, the output will show 
a column for each variable.

Figure 69-3. Output with Group Values option turned off

If the Group Values to Generate a Single Output Column box is checked, then the output gener-
ates a single column, by default called Code, that has levels for the mapped data. For this example, 
that will result in levels zero to six, all the combinations for the two variables are enumerated together.
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Figure 69-4. Output with Group Values option turned on

Results
The Enumerate Worksheet object generates one worksheet and one text file.

Results: The enumerated worksheet.
Settings: Text file containing input worksheets used and the options selected.
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Join Worksheets
Join two worksheets based on one or more sort keys. The object can perform two types of joins: inner 
and outer. Each one corresponds to inner and outer joins used in SQL (structured query language). 
The result of an SQL join will be sorted by the sort keys.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Data Management > Join Worksheets. 
Main menu: Insert > Data Management > Join Worksheets.
Right-click menu for a worksheet: Send To > Data Management > Join Worksheets.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Additional information is available for the following topics:

Mappings panel
Sort Map panel
Options tab
Results

Mappings panel
The Mappings panel allows users to specify which columns in a worksheet are involved in the work-
sheet transformation. Required input is highlighted orange in the interface.

Sort: The variable(s) to match by when joining the worksheets.
Source Column: The additional column(s) to include in a new worksheet.

Sort Map panel
By default, the Join Worksheets object requires that columns mapped to the Sort context have the 
same name. The Sort Map panel allows users to mix and match or override column names. For 
example, if the two columns being merged have different names, such as Subject and ID, the Sort 
Map panel can be used to specify matching columns in the two worksheets.

In this example, the Subject column in worksheet 1 is joined/merged to the ID column in worksheet 2, 
and the Conc column in worksheet 1 is joined/merged to the YObs column in worksheet 2.

Options tab

The default join for the Join Worksheets object is an outer join. Check the Inner Join box to use an 
inner join to combine the two worksheets. Both types of joins combine rows from the worksheets that 
have matching values for the sort keys, but an inner join does not retain any of the unmatched rows, 
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whereas an outer join also retains the rows from both worksheets that do not have a matching value in 
the other worksheet.

Note that the Join Worksheet object uses a Cartesian join (also called cross join) in the many-to-many 
case for matched values, i.e., the case where, for a specific set of values to match on, both work-
sheets have multiple rows with those values.

Results
The Join Worksheets object generates one worksheet and one text file. The output worksheet is 
sorted alphabetically or numerically based on the sort keys and the order they were mapped.

Result: The joined worksheets.
Settings: Text file containing input worksheets used and the options selected.

Joining raw data and modeling output in tables example
This example shows how to reproduce table template 9 that was used in WinNonlin 5.3 and earlier. 
Phoenix does not have a specific table type for this template. The main difference between table tem-
plate 9 and the other table templates in WinNonlin is that two datasets are joined to create the final 
output. The Phoenix Table object only works with one dataset at a time. To produce a table similar to 
table template 9 it is necessary to use Phoenix’s Join Worksheets object prior to creating the table.

In this example, two datasets are joined by the Sort variables in both datasets. The Default table type 
in Phoenix is used to recreate table template 9 in WinNonlin. These steps include:

Recreating WinNonlin’s table template 9 in Phoenix

This example uses two datasets, clayton.CSV and clayton_pk.dat. clayton.CSV con-
tains time and concentration data for two formulations. clayton_pk.dat contains the Final 
Parameters output from a noncompartmental analysis.

1. Create a new project named Join.

2. Import the files …\Examples\WinNonlin\Supporting files\clayton.CSV and 
clayton_pk.dat.
In the File Import Wizard dialog, select the Has units row option for clayton.CSV only.

3. Right-click clayton in the Data folder and select Send To > Data Management > Join Work-
sheets.

4. Map Subject to the Sort context.
Map Form to the Sort context.
Leave Period mapped to None.
Leave Seq mapped to None.
Map Hour to the Source Column context.
Map Conc to the Source Column context.

5. Select Worksheet 2 from the Setup list.

6. Drag the clayton_pk worksheet from the Data folder to the Join Worksheets object’s Worksheet 2 
Mappings panel and map the input columns to the contexts as follows:
Map Subject to the Sort context.
Map Form to the Sort context.
Map Tmax to the Source Column context.
Map Cmax to the Source Column context.
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Map AUClast to the Source Column context.
Leave the rest mapped to None.

7. Click  (Execute icon) to execute the object. 

8. Right-click Workflow in the Object Browser and select New > Reporting > Table.

9. In the Table 1 object’s Mappings panel click  (Select Source icon).

10. In the dialog, expand Join Worksheets, select Result, and click OK.

11. Map the input columns to the contexts as follows:
Map Subject to the Row ID context.
Map Form to the Stratification Row context.
Map Hour to the Stratification Column context.
Map Conc to the Data context.
Map Tmax, Cmax, and AUClast to the Dependency context.

Setting up the summary statistics
1. Select the Statistics tab below the Setup panel.

2. Check the checkboxes in the Display column to select the following summary statistics: N, Mean, 
SE.

3. Select the Options tab.

4. With Table selected in the Options menu tree, check the Page Break on Row Stratification 
checkbox.

5. Expand Precision/Alignment in the Options menu tree, click Hour and select 1 in the Value 
menu.

6. Under Precision/Alignment, click Subject in the Options menu tree and select 0 in the Value 
menu.

7. Enter a title for the table by selecting Titles in the Options menu tree.
– In the Title field type Table 2 and click Add.
– In the Title field type Raw Data and Pharmacokinetic Parameters and click Add.
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Executing and viewing the results of the joining
1. Execute the object.

Figure 70-1. Default table type Formulation c results
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Figure 70-2. Default table type Formulation t results

This concludes the Joining Raw Data and Model Output in Tables example.
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Merge Worksheets
Merges selected data from any two worksheets into a new worksheet, following the order of the data 
in the first worksheet and combining rows with matched values, followed by the data from the second 
worksheet that has not already been merged in. Note that, because Merge retains the unmatched 
data, Merge is similar to an Outer Join, with the main difference being the order of the output.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Data Management > Merge Worksheets. 
Main menu: Insert > Data Management > Merge Worksheets.
Right-click menu for a worksheet: Send To > Data Management > Merge Worksheets.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Mappings panel
The Mappings panel allows users to specify which columns in a worksheet are involved in the work-
sheet transformation. Required input is highlighted orange in the interface.

Sort: The variable(s) to match by when merging the worksheets.
Included Column: Variables mapped to this context are included in the output worksheet.

Sort Map panel
By default, the Merge Worksheets object requires that columns mapped to the Sort context have the 
same name. The Sort Map panel allows users to mix and match or override column names. For 
example, if the two columns being merged have different names, such as Subject and ID, the Sort 
Map panel can be used to specify matching columns in the two worksheets.

In this example, the Subject column in worksheet 1 is joined/merged to the ID column in worksheet 2, 
and the Conc column in worksheet 1 is joined/merged to the YObs column in worksheet 2.

Options tab

Check the Carry Along Data For Like Sort Levels box to replicate data when the number of 
matched rows are not equal in the two worksheets. The Merge tool will combine the rows sequentially 
until it runs out of matched data in one of the worksheets (unlike the Cartesian join in the Join work-
sheets object). Then it will either carry down the last available value from that worksheet, if the option 
is checked, or leave a blank cell for the worksheet that has run out of matched data, if the option is not 
checked. 
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Results
The Merge Worksheets object generates one worksheet and one text file. 

Result: The merged worksheets.
Settings: Text file containing input worksheets used and the options selected.
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Pivot Worksheet
Pivot worksheets based on switching the columns and rows in a worksheet. For example, if a work-
sheet had Subject, Parameter, and Parameter Value columns, and a user wanted to place each 
parameter in its own column, this object can transpose the worksheet based on selections made in 
the Worksheet Mappings panel.

The Pivot Worksheet object is primarily used to unstack, or pivot, stacked datasets like the Final 
Parameters output worksheet from a PK or NCA model.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Data Management > Pivot Worksheet. 
Main menu: Insert > Data Management > Pivot Worksheet.
Right-click menu for a worksheet: Send To > Data Management > Pivot Worksheet.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Mappings panel
The Mappings panel allows users to specify which columns in a worksheet are involved in the work-
sheet transformation. Required input is highlighted orange in the interface.

Column Header: Data type to use for creating the column headers in the output worksheet. Only 
one data type can be mapped to this context.

Values: Data type to fill the columns for each column header. Only one data type can be mapped 
to this context.

Row Header: Data types to use for defining the rows in the pivoted worksheet. Multiple data 
types can be mapped to this context. Each combination creates a unique set of profiles that are 
used to order the output worksheet rows.

Unit: Source data column containing unit information. When checked, the units become part of 
the column header upon pivoting. If incompatible units (including blank units) are found in the unit 
column, then the pivot will not be able to be performed until these inconsistencies are resolved or 
units are unmapped.

Carry: Data types to carry over unchanged in the output worksheet.

Attribute: Data types to combine with the data type mapped to Values to create additional col-
umn headers.

Results
The Pivot Worksheet object generates one worksheet.

Result: The pivoted output worksheet.
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Rank Worksheet
Create a new column in an output worksheet by ranking columns in the source worksheet in ascend-
ing or descending order and sorting them based on the Group By selections.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Data Management > Rank Worksheet. 
Main menu: Insert > Data Management > Rank Worksheet.
Right-click menu for a worksheet: Send To > Data Management > Rank Worksheet.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Mappings panel
The Mappings panel allows users to specify which columns in a worksheet are involved in the work-
sheet transformation. Required input is highlighted orange in the interface.

Group By: Phoenix generates a separate set of ranking values for each unique value or group of 
values in columns mapped to the Group By context. 

Rank: Parameters or variables mapped to Rank are ranked in ascending or descending order.

Any study variable or parameter mapped to the Group By context acts as a sort key in the output 
worksheet. If enough data types are mapped to Group By to create individual profiles for each rank, 
then the ranking column values never go above one.

Data types mapped to Rank are ranked either numerically or alphabetically, depending on the data 
contained in the column.

If there are no matching values in a column mapped to the Rank context, and one or no columns are 
mapped to Group By, then the ranking count is incremented by one.

For every matching value in any column mapped to the Rank context, the ranking count is incre-
mented by 0.5 for every N+1 matching values. For example, if the ranked column starts with two 
matching values, then the ranking for the first two values is 1.5 and 1.5. If the ranked column starts 
with three matching values the ranking is 2, 2, and 2. If there are four the ranking is 2.5, 2.5, 2.5, and 
2.5. 

When matching values are encountered, the normal incrementation by one is stopped, the matching 
values are given equal ranking numbers, and the incrementation resumes normally with the next non-
matching value.

Options tab

• In the New Column Name field, type a name for the ranking column.

The ranking column ranks the data types mapped to Rank in incremental order based on how 
many unique values are in the ranked data.
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• In the Sort Direction menu, select an ascending or descending sort direction for the rank column.

Results
The Rank Worksheet object generates one worksheet and one text file. The output worksheet is 
arranged alphabetically or numerically based on the first selected sort key.

Ranked: The ranked values, in ascending or descending order.

Settings: Text file containing input worksheet used and the options selected.
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Split Worksheet
Split a worksheet based on the data types that are mapped to the Sort context. The worksheet is 
divided into separate worksheets based on the sort key. For example, if a column named Subject ID 
is mapped to Sort, then a worksheet for each subject ID is created in the output. 

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Data Management > Split Worksheet. 
Main menu: Insert > Data Management > Split Worksheet.
Right-click menu for a worksheet: Send To > Data Management > Split Worksheet.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Mappings panel
The Mappings panel allows users to specify which columns in a worksheet are involved in the work-
sheet transformation. Required input is highlighted orange in the interface.

Sort: Data types to use for creating the separate output worksheets.
Ignore: Data types to exclude from any output worksheets.

Options tab

Check the Create Worksheets Split by Sort Values box (the default) to create a separate worksheet 
for each data type mapped to Sort, along with the Unique Values worksheet (which lists the number 
of occurrences of each Sort).

If this box is unchecked, then only the Unique Values worksheet is created in the output.

Results
The number of worksheets the Split Worksheet object creates is based on the number of unique val-
ues in the data types mapped to the Sort context. The worksheet names are derived from the values 
in the data types mapped to Sort.

The Unique Values worksheet is always created. The Unique Values worksheet lists the number of 
times a sort key or keys are present in the input worksheet. For example, if Time is mapped to Sort, 
and there are 10 time values per profile, then each time value is listed in one column, and the total 
instances of each time value is listed in the Count column.

The Split Worksheet object also creates one text file.

Separate worksheets: The values of each data type mapped to Sort, along with the associated 
values in the worksheet for each unique sort profile.

Unique Values: Lists the number of times a sort key(s) are present in the input worksheet.

Settings: Text file containing input worksheet used and the options selected.
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Stacker
Primarily used to convert unstacked datasets, like the Final Parameters Pivoted worksheet output 
from a PK or NCA model. The Stacker object moves values stored in column headings into rows. 
When data is stacked by parameter, the separate parameter columns are “stacked” in one column 
and the parameter values are arranged beside each parameter in the stacked column.

Use one of the following to add the object to a Workflow:

Right-click menu for a Workflow object: New > Data Management > Stacker. 
Main menu: Insert > Data Management > Stacker.
Right-click menu for a worksheet: Send To > Data Management > Stacker.

Note: To view the object in its own window, select it in the Object Browser and double-click it or press 
ENTER. All instructions for setting up and execution are the same whether the object is viewed in 
its own window or in Phoenix view.

Mappings panel
The Mappings panel allows users to specify which columns in a worksheet are involved in the work-
sheet transformation. Required input is highlighted orange in the interface.

Carry: Data types mapped to carry over into the stacked output worksheet. Note that the order in 
which the Carry columns are selected is the order they will appear in the output worksheet.
Stack: Data types to stack in a single column. The values in each stacked column are then placed 
beside each column header in a separate column.

Options tab

• In the Stacked Column Name field, type a name for the output column that contains the stacked 
data.

• In the Estimate Column Name field, type a name for the output column that contains the values 
that are matched with the stacked data.

• Check the Include Missing Values box to carry empty rows through to the results worksheet. 
This allows the user to keep track of records for which a parameter (e.g., a PK parameter) could 
not be calculated for some reason.

• In the Unit Column Name field, type a name for the output column that contains the units that are 
matched with the stacked data.

• Clear the Use Units checkbox if the input worksheet does not use units or units are not needed in 
the output.

Results
The Stacker object generates one worksheet and one text file.

Stacked: The stacked data types and their associated values and units, if any.
Settings: Text file containing input worksheet used and the options selected.
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Phoenix Configuration
Phoenix provides many configurable settings for the user to manage via the Preferences dialog. 
There is also a configuration file containing options that can be adjusted as necessary for local envi-
ronments (see “Phoenix Config file”).

Select Edit > Preferences to set Phoenix defaults using the Preferences dialog. 

General options

Set location of saved Phoenix projects and copy Examples directory.

Licensing options 

Activate and retrieve a license, and add a licensing server. See “Licensing of Phoenix software”.

Mapping contexts 

Set up Global Contexts and identify column names to associate with specific variables. Set up 
Context Associations to automatically map variable names with specific data inputs in Phoenix 
operational objects.

PKS

Default Save Options: See the PKS “Configuring default save options” section. 
Instances: See the PKS “Setting up a PKS connection” section.

Remote Execution 

JMS: Enable the Phoenix Job Management Service (JMS).
RPS: Enable many third party objects to be executed remotely.
Compute Grid: Add, modify settings, delete grids. The grids listed are the ones presented on the 
Execute on menu in the Run Options tab. 

Watson Import 

Configure the server, set up business rules for the import and specify the content for the resulting 
sample and dosing worksheets. See “Setting up preferences” for details.

AutoPilot 

Open the AutoPilot Toolkit Administrator Module to configure business rules, system settings, and 
output, including formatting. See the “Administration Module”.

LinMixBioequivalence 

Control the default model for a 2x2 average bioequivalence crossover design involving nonrepli-
cated data. When Default for 2x2 crossover set to all fixed effects is unchecked, the default 
fixed effects model is Sequence+Formulation+Period and random model is Subject(Sequence). 
When the option is checked, the fixed effect model becomes Sequence+Formula-
tion+Period+Subject(Sequence) and the random effects model becomes unspecified. See “Non-
replicated crossover designs”.

NONMEM, PsN, R, Reporter, SAS

Set the paths to access the external programs, define output directories, and set up development 
environments for modifying scripts for the third party programs from within Phoenix. See NON-
MEM’s “Setting up preferences”, PsN’s “Setting up preferences”, R’s “Setting up preferences”, 
Reporter’s “Setting up preferences”, and SAS’ “Setting up preferences” for more details.
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NLME

In the NLME root run folder field, type a path to the default temporary folder for NLME runs or 
click Browse to use the Browse For Folder dialog to select a new folder. The default is 
C:\Users\<username>\AppData\Local\Temp\Phoenix.

Object Settings

Manage saved object settings files. The list is grouped by operational object. Set the default file to 
use for object settings, delete saved files, import/export settings files to and from Phoenix. See 
“To set object settings preferences for operational objects” in the Operational Objects section.

Plotting defaults

Manage the default display settings for plots.

Plugins menu

Select the top-level Plug-ins item to view and control the status for installed Phoenix plug-in 
modules. Select a specific plug-in page to view the plug-in version and description.

General options
In the Preferences dialog, click the (+) sign beside General to expand the menu tree.

Select General > Projects to display the Project Settings page.

Figure 76-1. Project Settings preferences

Check the Auto Save on Execution box to have Phoenix save a back up copy of the project every 
time a workflow or operational object is executed.

In the Project Save Location field, type a path to the directory in which to save Phoenix project files 
(the use of environment variables when defining the path is supported) or click Browse to use the 
Browse For Folder dialog to select a new directory. The default is C:\Users\<username>\My 
Documents\Certara\Phoenix Projects.

Click Reset to Default to change the project save location back to its default location.

Click Copy Example Files to create a copy of the Examples directory installed with Phoenix in your 
project save location.

In the Backup Save Location field, type a path to the directory in which to place automatically saved 
projects or click Browse to use the Browse For Folder dialog to select a new directory. The default is 
C:\Users\<username>\My Documents\Certara\Phoenix Projects\Backups.
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In the Workflow Template Save Location field, type a path to the directory in which to place saved 
templates or click Browse to use the Browse For Folder dialog to select a new directory. The default 
is C:\Users\<username>\My Documents\Certara\Phoenix Templates.

Click Apply to apply the changes.

Note: For large projects, the autosave option can decrease performance as the benefits of saving auto-
matically after every object execution may be far outweighed by the time it takes. In those cases, 
this option is not recommended and users should manually save their projects.

Mapping contexts
Mapping contexts are used to associate inputs into operational objects with columns in a dataset. 
There are two mapping context pages: the Global Contexts page and the Context Associations page. 

The Global Contexts page is used to specify potential columns in a dataset that belong to a particular 
data input. Potential column names are columns in a worksheet that are typically associated with a 
mapping context. For example, ID is a potential column name for Subject, and Hour is a potential col-
umn name for Time.

The global contexts are then used to map the columns to operational object inputs in the Context 
Associations page.

Global contexts

To identify column names typically used for a particular data input

Click the (+) sign beside Mapping Contexts. 

Select Global Contexts in the menu tree.

Figure 76-2. Global Contexts preferences
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Check the Column order is important box to maintain order of columns. 

Select a context in the list.

To add/remove a global context

To add to the list of global contexts, click Add underneath the Global Contexts list and type the 
global context name in the list.

To remove a global context, select the context in the Global Contexts list and click Remove below 
the list.

To add/remove a column name

To add to the list of potential column names, click Add underneath the Potential Column Names 
field and type the name of the column in the Potential Column Names field.

To remove a potential column name, select the name in the Potential Column Name field and click 
Remove below the field.

Context Associations

To map columns to specific inputs in each operational object

Select Context Associations in the menu tree.

Figure 76-3. Context Associations preferences

Select a context in the Global Contexts list.

In the Plugin Contexts list, click the (+) sign beside an operational object to view a list of its data 
inputs.
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Check the box(es) to associate that operational object’s input with the dataset column(s) specified in 
the Global Contexts list.

When a dataset with a column that matches the global context is mapped to that operational object, 
the column is automatically mapped to that input.

Example usage
Suppose a user always wants the subject identifier column in a dataset to map to the Sort context in 
the NCA object. The user would do the following:

1. Select Global Contexts. 

2. Select Subject in the Global Contexts list.

3. In the Potential Column Names box, add any column names used to contain subject identifiers, 
such as ID or Subject.

4. Select Context Associations.

5. Select Subject in the Global Contexts list.

6. Click the (+) sign beside NCA to view all NCA data inputs.

7. Check the box beside Sort. 
The subject identifier column is now associated with the Sort context in the NCA object.

8. Click OK to close the Preferences dialog.

9. Import a dataset that contains subject identifiers. (The subject identifier column must have a name 
specified in the Global Contexts dialog.)

10. Insert an NCA object and map the dataset to the object.

The subject identifier column is automatically mapped to the Sort context in the NCA object’s Main 
Mappings panel.

JMS
The Job Management dialog allows users to specify the address and protocol used by the Phoenix 
Job Management System™ (JMS™), how often to send data packets to the JMS, and setting the 
address for viewing remote jobs via the RPS web UI.

To set preference options for JMS

In the Preferences dialog, expand Remote Execution and select JMS.

Check the Remote Submit Enabled box to use the JMS.

In the Job Queue Server (JQS) field, enter the JQS network address.

In the Port field, enter the JQS port number.

In the Protocol menu, select TCP or HTTP.

In the Polling Interval box, type or select the number of times per second that Phoenix sends data 
packets to the JMS.

In the RPS Queue Address field, enter the fully qualified address of the RPS queue (e.g., http://
myserver:8080/PhoenixServer).
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RPS
To use RPS from Phoenix, users must have an RPS license, and they must enable RPS in the Phoe-
nix configuration. (Refer to “Remote Processing Server”.)

To set preference options for RPS

In the Preferences dialog, expand Remote Execution and select RPS.

Check the Enable Remote Execution box. 

Click Define to specify the location of the RPS queue.

In the server definition dialog enter the server name, the root context, and the port. 

Figure 76-4. Server definition dialog

Click OK. 

At this point the information provided will be validated by attempting to communicate with the 
server.

Select the object types for which remote execution is to be enabled by checking the box in the Exe-
cute Remotely column next to the object type. 

Compute Grid
Phoenix is capable of implementing parallel computing in two distinct ways to optimize the use of 
computational grids and multicore computers. A description of these two methods and the advan-
tages and challenges will help the user select the optimal method for each project.

The first is called parallelizing by model (PBM), in which individual NLME models are sent to individ-
ual computation cores for execution. One example of PBM would be a 200 replicate bootstrap, which 
requires 200 independent NLME models to be run. Using PBM, each of the 200 models would be 
sent to 200 separate compute nodes, with each model running on a single compute node from initial 
estimates to final parameters. PBM is extremely useful to simultaneously execute many NLME mod-
els. 

The second method is called parallelizing within model (PWM), in which an individual NLME model is 
spread across multiple computation cores for execution. One example of PWM would be a simple 
estimation of a single PK/PD model. Using PWM, the one model would be spread across 50 compu-
tation cores, allowing successful minimization to be done more quickly than if the local computer was 
used. PWM is extremely useful with models that have long run times to achieve convergence. 

Phoenix supports both PBM and PWM and even supports a combination of the two. An example of 
combining PBM and PWM can be seen in a stepwise covariate search. During the first step, let’s 
assume there are 8 models to be run (base + 7 possible covariates). Phoenix will run all 8 models 
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simultaneously (PBM) with each model using 20 computation cores (PWM). Combining PBM and 
PWM can be extremely powerful to reduce overall run times with complex PK/PD model development 
activities.

The following outlines the parallelization method implemented for each run mode and each computa-
tion platform supported in Phoenix NLME 8.1:

Simple: Run None PBM PWM None PWM PBM PWM None PWM

Windows: MultiCore (PBM), MPI (PWM)
Linux: MultiCore (PBM), MPI (PWM), SGE_MPI/LSF_MPI/TORQUE_MPI (PWM)

Scenarios Run: 

Windows: MultiCore (PBM), MPI (PWM and PBM)
Linux: MultiCore (PBM), MPI (PWM and PBM), SGE_MPI/LSF_MPI/TORQUE_MPI (PWM and 
PBM)

Stepwise Cov Search Run: 

Windows: MultiCore (PBM), MPI (PWM and PBM)
Linux: MultiCore (PBM), MPI (PWM and PBM), SGE_MPI/LSF_MPI/TORQUE_MPI (PWM and 
PBM)

Shotgun Cov Search Run: 

Windows: MultiCore (PBM), MPI (PWM and PBM)
Linux: MultiCore (PBM), MPI (PWM and PBM), SGE_MPI/LSF_MPI/TORQUE_MPI (PWM and 
PBM)

Profile Run: 

Windows: MultiCore (PBM), MPI (PWM and PBM)
Linux: MultiCore (PBM), MPI (PWM and PBM), SGE_MPI/LSF_MPI/TORQUE_MPI (PWM and 
PBM)

Predictive Check Run: No parallelization method implemented.

Simulation Run: No parallelization method implemented.

Selection of the desired grid mode in the Phoenix Preferences dialog is critical to achieving the 
desired type of parallelization for the submitted run mode. For example, a user who submits an NLME 
model in Simple run mode to a compute grid set to Linux/SGE will result in the model running on a 
single core of the grid. However, that same model submitted to a compute grid set to Linux/SGE_MPI 
will be parallelized using PWM.

Setting up grids
There are two methods for setting up grids to run parallel executions in Phoenix. The Compute Grid 
page of the Preferences dialog, see “Compute Grid preferences” is one method. The other is editing 
the configuration files directly (either as an administrator or a user), see “Configuration files”.

Phoenix supports the following modes of parallelization:

• MultiCore (Windows, Linux): Parallelize (single models) across multiple cores on a single 
machine (i.e., 32-core Linux or Windows computer). 

• MPI (Windows, Linux): Parallelize (single models and/or single model parallelized by subject) 
across multiple cores on an MPI Cluster.

• LSF (Linux): Parallel execution of single model runs (e.g., bootstrap and shotgun covariate 
search) on an LSF grid. Individual models are not parallelized across multiple cores.
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• LSF_MPI (Linux): Parallel execution and parallelization across multiple cores of all model runs on 
a LSF grid. All models are run simultaneous and are parallelized across multiple cores. Phoenix 
determines the optimal parallelization strategy for each model run. Supports all Phoenix run 
modes.

• SGE (Linux): Parallel execution of single model runs (e.g., bootstrap and shotgun covariate 
search) on an SGE grid. Individual models are not parallelized across multiple cores.

• SGE_MPI (Linux): Parallel execution and parallelization across multiple cores of all model runs 
on a SGE grid. All models are run simultaneous and are parallelized across multiple cores. Phoe-
nix determines the optimal parallelization strategy for each model run. Supports all Phoenix run 
modes.

• TORQUE (Linux): Parallel execution of single model runs (e.g., bootstrap and shotgun covariate 
search) on a TORQUE grid. 

• TORQUE_MPI (Linux): Parallel execution and parallelization across multiple cores of all model 
runs on a TORQUE grid. All models are run simultaneous and are parallelized across multiple 
cores. Phoenix determines the optimal parallelization strategy for each model run. Supports all 
Phoenix run modes.

Example grid definitions for different parallel modes can be found in the PhoenixParallelExe-
cutionSettings.txt file and modified with company-specific settings. (See “Configuration files” 
for details on modifying this file.)

Note: When a grid is selected for executing an NLME object, loading the grid can take some time and it 
may seem that the application has stopped working. 

Make sure that there is adequate disk space on the grid for execution of all jobs. A job will fail on 
the grid if it runs out of disk space.
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Compute Grid preferences
In the Preferences dialog, expand Remote Execution and select Compute Grid.

The Compute Grid page allows users to add, modify, or delete the setup for a grid. The list of grids on 
the left of the page is the list you will see in the Execute on pull-down menu in the Run Options tab for 
an NLME object. 

To set up a new grid

Click Add and enter all of the following information for the new grid:

User machine name: Name to appear in the selection box on the Run Options tab of Phoenix 
models. 

Startup script: Script to execute on the remote host to setup the run environment. 

Machine name/IP address: Actual machine name or its IP address. 

Shared folder: Location where the application can write results/temporary files on the remote 
machine.

Machine type: Choose from Windows or Linux.

R folder: Path to R on the remote machine. 

Parallel mode: If the machine type is Windows, choose from None, MultiCore, MPI, LSF. If the 
machine type is Linux, choose from None, MultiCore, MPI, TORQUE, SGE, SGE_MPI, 
TORQUE_MPI, LSF, LSF_MPI. 

Number of cores: Number of computational cores available on this grid.

User: Username for logging into the host. This is required to use the grid, unless using a private 
key file.

Password: Password for logging into the host. This is required to use the grid unless using a pri-
vate key file.

Private Key Filename: As an alternative to entering a username and password, enter the name 
of the private key file to use for ssh private keyfile authentication or use the ellipsis button to dis-
play a file browser for selecting the file. See “Setting up an ssh private key file”. 
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To modify grid settings

Select the grid from the list.

Adjust the settings in the page as described.

Press the Enter key.

Changes are automatically updated in the user’s custom PhoenixParallelExecution-
Settings.txt file.

To delete a grid platform:

Select the grid from the list.

Click Delete. 

The grid is automatically removed from the user’s custom PhoenixParallelExecution-
Settings.txt file.

Configuration files
There are two system-wide files that are used in the configuration of grids: PhoenixParallelEx-
ecutionSettings.txt and PhoenixParallelExecutionSettings.xml, located in 
<Phoenix_install>/application. The list of grids shown in the “Compute Grid prefer-
ences” figure above comes from the PhoenixParallelExecutionSettings.txt file that is 
installed with Phoenix, after removing the comment syntax from all of the definitions in the file. (Ini-
tially, all but the first two platforms are commented out.) 

Administrators can modify the PhoenixParallelExecutionSettings.txt and Phoenix-
ParallelExecutionSettings.xml files to be site-specific. Each user can also customize the 
grids by placing copies of these files in: C:\Users\<username>\AppData\Roaming\Cer-
tara\Phoenix\ and customizing them. 

Setting up an ssh private key file
On the server Linux system, generate keys.

   mkdir ~/.ssh /* if you do not have this directory already */ 
   chmod 700 ~/.ssh 
   ssh-keygen -t rsa 

Take default location and press Return key for passphrase 

   Generating public/private rsa key pair.
   Enter file in which to save the key (~/.ssh/id_rsa):
   Enter passphrase (empty for no passphrase):
   Enter same passphrase again:
   Your identification has been saved in ~/.ssh/id_rsa.
   Your public key has been saved in ~/.ssh/id_rsa.pub.

Transfer key to remote system.

Simply copy ~/.ssh/id_rsa to a secure location on windows. You will specify this file in the Remote 
Execution > Compute Grid settings page in the Preferences dialog.
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Add public key to server list.

   cp ~/.ssh/authorized_keys ~/.ssh/authorized_keys_Backup
   cat ~/.ssh/id_rsa.pub >> ~/.ssh/authorized_keys

Make keys secure.

   chmod 600 ~/.ssh/authorized_keys

Test that you can connect to remote Linux system without a password.

– Open PuTTY.
– Enter the hostname in the PuTTY Configuration dialog.
– Go to the SSH > Auth category.
– Enter the keyfilename (that was transferred) in the Private key file for authentication field.
– Click Open.
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Plotting defaults
The Plotting Defaults page of the Preferences dialog allows users to adjust a number of display set-
tings that will be used as the defaults for plots. The settings in this dialog apply to the output of Plot-
ting objects, as well as to any plots created from other operational objects, such as NCA. They do not 
override any user-specified settings in projects. 

Figure 76-5. Plotting Defaults preferences

Panel Height and Panel Width: The size of the plot drawing area.

Tick Label Area Size: How wide the tick label area is from the axes.

Chart Spacing: The distance between multiple graphs.

Title Area Size: How wide the area is where the title is displayed.

Legend Area Size: How wide the area is for the legend.

Outer Margin: The size of the space between the graph title and the tick label area.

Lattice Title Offset: Distance to shift the Lattice Title from the graphs in the lattice.

Font: Select the item whose font is to be changed.

Change Font: Display the Font dialog for modifying the selected item’s font, size, style, etc.
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Reset System Defaults: Resets all of the values in the Plotting Defaults page to the Phoenix system 
defaults.

Apply: Click to save the settings as the plot defaults.

Note: When saving a project, only those plot settings that have been changed in the user interface will 
be saved with the project. Any settings that have not been modified in the interface will not be 
saved with project, as the default plot settings will be applied when the project is reopened.

Plugins menu
The Plugins menu is used to view the status of Phoenix plug-ins and add new plug-ins. Phoenix plug-
ins are listed in three groups: General, System, and Non-Loaded. Each group has its own tab in the 
Plugins menu. Plug-ins can be viewed individually by expanding the Plugins menu.

The Plugins menu provides the following information on Phoenix plug-ins: the name, version number, 
and state, either started or not started.

Figure 76-6. Plugins preferences

Plug-ins in the General tab are operational objects. These plug-ins are responsible for providing 
Phoenix functions such as drug modeling, charting, and dataset manipulation. The General tab dis-
plays the name, version number, and state of each operational object plug-in. 

Plug-ins in the System tab are used to provide Phoenix framework functions. The name, version, and 
state of each framework plug-in is listed.

The Non-Loaded tab displays information on why a plug-in failed to load. If a plug-in fails to load its 
state is listed as “FailedToStart.” If it has not yet been loaded, the state is listed as “Not Loaded.” 
Select the failed plug-in to display any details on the failure in the Reason field.

To add a new plug-in

Select Plugins in the Preferences dialog and click  (Load Plugin icon) . 

In the Load Plugin dialog, select a plug-in manifest or plug-in assembly.

A plug-in manifest is a file that describes the plug-in. 
A plug-in assembly is the plug-in DLL.

The plug-in is added to the General or System tab, depending on the type of plug-in selected.
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Phoenix Config file
In the file Phoenix.exe.config (or Phoenix32.exe.config) there are two path properties 
that can be configured, if necessary, for your local environment.

• tempDirectoryRoot: Users can use this property to specify where Phoenix writes temporary 
files. The path must be fully qualified, and it does not support the use of environment variables. 
For example, to have Phoenix use the Phoenix application data folder for the temporary storage, 
you might specify a path like this: 

tempDirectoryRoot="C:\Users\UserName\AppData\Roaming\Cer-
tara\Phoenix\Temp" 

The default value is <blank> which will cause Phoenix to use the default system temporary direc-
tory. 

• repositoryDirectory: This property is used to specify the location that Phoenix uses as a 
working folder for open projects. Use a fully qualified path name to enter an alternate path. This 
property supports the use of environment variables. For example, to use the system temporary 
file location, you could specify a path like this:

repositoryDirectory="%TEMP%\ScratchRepository" 

The default value is "%APPDATA%\Certara\Phoenix\ScratchRepository".
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Index

Symbols
.NET

E format, 256
F format, 256
G4 format, 256

A
Accuracy of numbers, 73
Annotations menu, 272
Append worksheets, 364
Axes menu

plots, 255
B
Bar plot, 243

Lattice Titles panel, 248
Below Quantifiable Limit, 107
Blinding type, 224
Box plot, 243

results, 273
BQL, 107

export rules set, 100
Rules folder, 108

Browser, 210
display options, 211
filters, 212
refreshing, 211
viewing, 210
viewing properties, 213

Browser in Integral, 173
C
CDISC Data Preparer, 113

results, 118
CDISC SDTM and SEND implementation, 129
Change from baseline, 159
Close project, 6
Column

order, 33
Column plot, 243
Compare datasets (ASCII only), 72
Compound, 224
Computation formulas, 162
Confidence intervals, 162, 300
Config file, 398
Connection string, 195
Copy

plot, 40
result worksheet, 40
table, 42
text file, 41
workflow object, 71
worksheet or workbook, 70

Create
project, 4
worksheet, 79

Creating
library object, 218
scenarios, 214
study view, 215

Crossproduct worksheet, 366
Custom imports, 76
Custom query builder, 200
D
Data link, 135
Date formats, 83
Default for 2x2 crossover preference, 385
Delete object

from Information tab, 64
from object browser, 71

Dependent objects, 69
Descriptive statistics, 161

KS PValue, 164
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output, 162
Descriptive stats

Main Mappings panel, 161
Options tab, 162, 300

Detach PKS object from source, 233
Diagram tab, 60
Differences, 299
Dosing in PKS, 207
E
Edit

worksheet data, 82
worksheet with Excel, 86

Enumerate worksheet, 368
Examples

PsN, 291
Execute

all objects, 66
objects, 105
workflows, 105

Export
BQL rules set, 100
file, 97
HTML table, 100
multiple PKS objects, 238
ODBC, 202
plot, 40, 100
related records, 132
text objects, 100
workbooks, 97
workflow, 71
worksheets, 97

F
Filter, 151

Custom Filter Entry dialog, 154
G
ggquickeda, 171
Graphs menu, 259
Grid examples, 390
H
Histogram, 243
History tab, 65
Hotkeys, 66
HTML table, export, 100
I
Import

datasets, 74

file, 73
Importing data, 73
Importing, ODBC, 197
Indication, 224
Information tab, 64
Insert

object, 27
Insert object using Send To, 40, 70
Integral, 173

add project from Phoenix, 174
connection setup, 180
default save options, 181
save items, 179
savepoints, 178

Integral browser, 173
Internal worksheet use, 31
J
Join worksheets, 372
K
Keyboard shortcuts, 66
Kolmogorov-Smirnov normality test, 164
KS PValue, 164
L
Lattice Titles panel, 248
Latticed plots, 248
Legend menu

plots, 268
Library object

creating, 218
LLOQ, 109
LOESS, 262
M
Main menu, 58
Manual data entry, 31
Mapping

context associations, 78
datasets to object, 77
results to object, 78

Mapping for plots, 247
Mapping variables, 230
Merge worksheets, 377
Microsoft Word export, 102
N
New page options, 306
NONMEM Comparer, 191
Normality test, 164
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O
Object

copy/paste, 71
delete multiple, 64
delete single, 71
execution, 105
insert, 27
move, 71

Object Browser, 59
print objects, 93
using, 68

Object settings, 34
ODBC, 195
ODBC export, 202

creating an export, 202
loading a saved connection, 197

ODBC import, 197
building a query, 198
connection string, 195
custom query builder, 200
loading a saved connection, 197

Open project, 4
Order output and columns, 33
Overlay plots example, 277
P
Pagination options, 306
Parallel modes, 390
Percentiles, 162, 300
Pharsight Knowledgebase Server, 205
Phoenix

toolbar, 59
user interface, 57

Pivot worksheet, 379
PKS, 205

browser, 210
connection setup, 207
detach object from source, 233
dosing, 207
job viewer, 241
save study, 234
scenarios, 206
studies, 205
study data, 229
study metadata, 206
study properties, 227
time, 206

Plot
annotations, 272
axes, 255
graphs, 259
legend, 268
mapping, 247
reference lines, 270
results, 273
title, 251

Plot export, 100
Plot menu, 249
Plotting, 243
Portfolio attribute in PKS studies, 224
Preferences, 385
Preferences for Reporter object, 318
Print, 93

plot, 40
result worksheet, 40
results, 93
table, 42
text file, 41

Private key file, 394
Project, 224

add to Integral, 174
Projects, 3
Properties, 138, 227

creating, 227
loading, 228
saving, 227

PsN examples, 291
PsN recovery from failed run, 288
Q
QQ plot, 243
Quantiles computation, 166
Queries

building ODBC queries, 198
ODBC import, 198

R
Rank worksheet, 380
Ratios, 299
Ratios and Differences

Worksheets Mappings panel, 299
Redo worksheet action, 82
Reference Lines menu, 270
Refresh dataset (ASCII only), 72
Related records, 132
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RELREC, 132
Rename result, 39
Reporter object, 303

preferences, 318
Result

print, 93
rename, 39

Results, 162
Results tab, 62

using, 39
S
Save

plot, 40
project, 7
result worksheet, 40
table, 42
text file, 41

Save options
Integral, 181

Savepoints in Integral, 178
Scatter plot matrix, 243
Scenarios, 206

creating, 214
Send to option, 40, 70
Settings file, 65
Setup tab, 62

toolbar, 30
using, 29

Shortcuts in scripts, 187, 323, 330
Show

dependents, 60, 69
source, 68
sources, 60

Sort
output, 33
worksheet, 85

Source worksheets, 68
Split worksheet, 382
ssh private key file, 394
Stacker, 383
Studies

creating views, 215
description, 224
design, 224
mapping variables, 230
name, 223

PKS, 205
properties, 227
saving, 234
type, 224
viewing properties, 213

Study data
appending, 221
data sources, 229
editing, 220
mapping, 230

Subject
identifier, 230

Synchronize dataset (ASCII only), 72
T
Table reports, 339
Tables, 339
Templates for workflows, 14
Text objects, export, 100
Time formats, 83
Timestamp, 65
Title menu, 251
Toolbar for Phoenix, 59
Transformation, 140
U
Undo worksheet action, 82
Units

summary statistics, 167
Units builder, 89
Unstacked to stacked datasets, 383
V
Verification tab, 63
Verify workflow, 60
W
Watson import object, 355
Weighted summary statistics, 168
Workflow

execution, 105
export, 71
templates, 14

Worksheet
sort, 85

Worksheets
edit data, 82

Worksheets, export, 97
X
X-Categorical XY plot, 243
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Xpose package, 294
supported files, 294

XY plot, 243
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